none
IE8 / Dot Matrix Printing Issues

    Question

  • Something in IE8 changed which now causes the print output on an Okidata 320 printer to be distorted. My guess is that any dot matrix printer will have this issue and I've asked Okidata if there are any updated drivers, and they've said no.

    In IE7, we could bring up a simple text HTML page, and print it to the printer without any issues. If we then update that PC (XP) with IE8 and attempt to
    print the exact same page, the text prints, but it's distorted. (see link below) If we then uninstall and reinstalled IE7, the output to the printer is perfect.

    IE8 Image Example: http://img149.imageshack.us/img149/7426/ie8printissue.jpg 


    We've tweaked just about every setting in IE8 with no resolution. Any thoughts or ideas here would be greatly appreciated.
    David
    Monday, May 04, 2009 4:28 PM

Answers

  • From what I can tell from other threads on the subject, the problem is in the Trident 4.0 web layout (“rendering”) engine that’s what Internet Explorer 8 and certain other programs use to render HTML & XHTML content styled with implicit or explicit CSS. IE7 uses Trident 3.1, and earlier versions of WinIE use earlier versions of Trident.

    Any program that uses Trident will use the version installed by the latest version of IE on the system. Other Trident programs include Outlook and Outlook Express (when displaying an HTML Email as opposed to a plain-text one), InfoPath, Word (when in Web View mode), Visual Studio 2002–2005 (when designing HTML or ASP or ASP.NET), Visual Studio InterDev, several web browsers which “wrap” their own user interface around the IE/Trident rendering engine (e.g. AOL Explorer, Avant, Bento [built into WinAmp], Enigma, Maxthon, NeoPlanet, Sleipnir, SlimBrowser, UltraBrowser, Netscape 8 in IE mode, Firefox with the IE Tab add-on/extension installed and activated, etc. ). As such, if WinIE8 is installed, then any of these programs will likely show the same problem when printing.

    The actual bug seems to be that Trident 4.0 doesn’t properly handle printers with non-square pixel aspect ratios. For instance, an old laser printer might have a 300×300dpi resolution and would work fine. So would newer ones with 600×600, 1200×1200, 2400×2400, etc.

    But dot matrix printers come in two basic types: 9-pin and 24-pin. 9-pin printers usually have no square resolutions available, but you can get close with the maximum which is something like 240×216. 24-pin printers do usually have one or two square resolutions available: typically 180×180 and 360×360, but usually default to something like 360×180 (to balance quality with print speed).

    Basically, what seems to be happening is that Trident 4.0 is calculating the spacing between letters based on the vertical resolution of the printer, not the horizontal. If they don’t match, the spacing will be wrong. If they’re wildly different, the spacing will be wildly off. In this case, you’re seeing overlapping letters because Trident sees the “180dpi” vertical resolution and is thinking that that’s also the horizontal resolution when calculating inter-letter spacing, and thus spacing only ½ as much as it should, thus the overlapping letters.

    • Workaround #1: Roll back to IE7 if practical, to return to Trident 3.1 which worked fine in this regard.

    • Workaround #2: Set your printer resolution as used by IE8 and other Trident 4.0-using apps to a square aspect (equal horizontal and vertical) if available. If not, pick a resolution where the difference isn’t so extreme, and preferably where the horizontal is greater than the vertical (so at least the letters won’t overlap — they’d be spaced too far apart instead). You can either do this on a per-job basis, or once by opening the Printers Control Panel, right-clicking the dot-matrix printer, and selecting “Printing Preferences…”. In either case, click the [Advanced] button, and under “Graphic” you should see the “Print Quality.” Clicking that will present a drop-down allowing you to select from resolutions available for your printer. Again: choose a square one if available, or the closest available to square to minimize the problem.

    • Workaround #3: Instead of printing from IE or other Trident app, save the web page to disk and open it in Word, then print from there in some view other than Web view (preferably Page View or Normal View) so that Trident 4 isn’t invoked and Word’s own native printing is used instead.

    Thursday, April 22, 2010 4:24 PM

All replies

  • Try this: In "Page Setup", uncheck "Enable Shrink-to-fit".
    Robin Walker
    Tuesday, May 05, 2009 10:26 AM
  • Hi Robin-
    thanks for the response.. The Enable Shrink to fit option resulted in the same text output...
    Thursday, May 07, 2009 4:25 PM
  • IE8 Image Example: http://img149.imageshack.us/img149/7426/ie8printissue.jpg 

    David,

    In the output it looks like some of the text is overprinting on the same line.  Perhaps missing line feeds (LF)? 

    I assume you've already checked matching emulations in the print driver and the printers.  See Note below.  I ask only because Okidata has some very similar sounding printer names that have different defaults.  They are very easy to cross up.

    I also vaguely recall an old setting common to dot matrixes that automatically added an LF to carriage returns (CR) that didn't include it.  Perhaps the change to IE8 exposed a configuration mismatch.

    Could you post an image of what the correct printout looks like?
    Also, try setting up a second instance of the printer using the same driver, connected to the  "FILE:" port and compare the output of IE7 vs IE8.  Use the programmer's reference at Okidata's support site to decode the output.
    --
    Tom S.

    Note:  The Okidata support site 320 manual lists ML320/321 E/I printers which default to IBM emulation and should use those drivers and also the ML320/321 Standard which should use Okidata Microline drivers.  Then there's the ML 320 Turbo variants as well.  See the Okidata support site for default emulations and recommended drivers.

    Friday, May 08, 2009 4:45 AM
  • David,

    Did you ever find a solution to this problem? I am having the same issue - distorted printing on dot matrix printers when printing from IE8.

    Charles
    Thursday, June 11, 2009 1:58 AM
  • This is an IE issue, not an XP SP3 issue.  You might get a better response from a forum which specialises in IE matters.
    Robin Walker
    Thursday, June 11, 2009 9:33 AM
  • No, although I wish we would have. As odd as it sounds,  It's crippling our business not being able to print and IE8 webpage to the dot matrix printer.

    Friday, June 12, 2009 3:10 AM
  • Monday, June 15, 2009 10:23 AM
  • David tried there first on 4/29/2009 and received a not very helpful answer from MS Support Engineer Jack redirecting him here. 

    Try setting up a second instance of the printer using the same driver, connected to the "FILE:" port and compare the output of IE7 vs IE8. Use the programmer's reference at Okidata's support site to decode the output.
    Did you try to capture the output from IE7 and 8 and compare them? 

    If this is "crippling our business" can you get Okidata involved on a pay per incident basis?

    David, did the "reset IE8" advice from your second IE8 forum post work?
    --
    Tom S.
    Monday, June 15, 2009 5:39 PM
  • Apologies for the follow up to my own post,

    Elsewhere, another MS engineer has posted the suggestion to view the page in IE8's Compatibility Mode before printing. 

    Who knows, maybe it will work?  If it does work, I'd be curious to know what errors, if any, the simple page encounters using an HTML validator.
    --
    Tom S.
    Tuesday, June 16, 2009 2:36 AM
  • I am glad to see that I am not alone with the IE8 printing problem. Since I have installed IE8 I can't print web pages. I get the same output as the one here:

    IE8 Image Example: http://img149.imageshack.us/img149/7426/ie8printissue.jpg 

    PRINTING OUTPUT:


    I have a Fujitsu DL 3400 and everything was working before updating IE7 so it has nothing to do with the Okidata 320 printer. I tried everything and nothing works. It is a general dot-matrix problem not a printer specific brand problem. If I paste the content of a web page to Microsoft Word or OneNote I will be able to print it no problem. All printing outside IE8 is ok.

    Pierre.

    Saturday, August 15, 2009 2:52 AM
  • To my knowledge, MS still doesn't have a hotfix for this issue. Hopefully, by staying ontop of MS and applying pressue, they will do something...
    Monday, August 17, 2009 1:07 PM
  • Hello,

    I have the same problem here.  I'm an MCSE and have done exhaustive testing, this is problem also with Outlook Express, not just IE!  It is fixed by rolling back to IE7.  Windows Test Pages print fine, MS Dos and other Windows Applications seem to be un-affected.  Compatibility mode does not fix the problem either.

    Please Advise, thank you.
    Lucas Forrest
    Global Corp.
    Tuesday, September 01, 2009 3:18 AM
  • Hello support folks,

    I also have the problem with an Epson Action Printer 5000+ (impact printer).  The print preview is fine but the hardcopy output looks like the sample from Rocket234 above.  I have this problem only with IE8.  I do not use Outlook Express.  MS Office Outlook 2007 prints fine.

    KC Garrett
    Select Systems

    Sunday, October 25, 2009 2:04 AM
  • The problem was solved on my computer by using a square matrix in my printing quality option.

    With my dot matrix I have the option of :

    - 180 x 180 dot per inch
    - 360 x 180 dot per inch
    120 x 180 dot per inch

    If I select 180 x 180 dot per inch my web pages and emails print perfectly !

    I hope this can be usefull, try it.

    Bye.
    Friday, March 05, 2010 3:43 PM
  • What we have our clients do is first ensure the website they are printing from is set as a trusted website both on the Security and Privacy pages of the Internet Options window.

     

    Then set the printer graphics to 240 x 216 from the Printer Preferences window - the only draw back is that the printing slows down because it actually prints each line 3 times making the printout darker and bolder - also because it prints 3 times the printer ribbon is used 3 times faster.

     

    Or as others have said - just uninstall IE8 - which is not an option for Windows 7 users.

     

    Mike D

    • Proposed as answer by FEX DMS Friday, March 26, 2010 5:49 PM
    Friday, March 26, 2010 5:49 PM
  • From what I can tell from other threads on the subject, the problem is in the Trident 4.0 web layout (“rendering”) engine that’s what Internet Explorer 8 and certain other programs use to render HTML & XHTML content styled with implicit or explicit CSS. IE7 uses Trident 3.1, and earlier versions of WinIE use earlier versions of Trident.

    Any program that uses Trident will use the version installed by the latest version of IE on the system. Other Trident programs include Outlook and Outlook Express (when displaying an HTML Email as opposed to a plain-text one), InfoPath, Word (when in Web View mode), Visual Studio 2002–2005 (when designing HTML or ASP or ASP.NET), Visual Studio InterDev, several web browsers which “wrap” their own user interface around the IE/Trident rendering engine (e.g. AOL Explorer, Avant, Bento [built into WinAmp], Enigma, Maxthon, NeoPlanet, Sleipnir, SlimBrowser, UltraBrowser, Netscape 8 in IE mode, Firefox with the IE Tab add-on/extension installed and activated, etc. ). As such, if WinIE8 is installed, then any of these programs will likely show the same problem when printing.

    The actual bug seems to be that Trident 4.0 doesn’t properly handle printers with non-square pixel aspect ratios. For instance, an old laser printer might have a 300×300dpi resolution and would work fine. So would newer ones with 600×600, 1200×1200, 2400×2400, etc.

    But dot matrix printers come in two basic types: 9-pin and 24-pin. 9-pin printers usually have no square resolutions available, but you can get close with the maximum which is something like 240×216. 24-pin printers do usually have one or two square resolutions available: typically 180×180 and 360×360, but usually default to something like 360×180 (to balance quality with print speed).

    Basically, what seems to be happening is that Trident 4.0 is calculating the spacing between letters based on the vertical resolution of the printer, not the horizontal. If they don’t match, the spacing will be wrong. If they’re wildly different, the spacing will be wildly off. In this case, you’re seeing overlapping letters because Trident sees the “180dpi” vertical resolution and is thinking that that’s also the horizontal resolution when calculating inter-letter spacing, and thus spacing only ½ as much as it should, thus the overlapping letters.

    • Workaround #1: Roll back to IE7 if practical, to return to Trident 3.1 which worked fine in this regard.

    • Workaround #2: Set your printer resolution as used by IE8 and other Trident 4.0-using apps to a square aspect (equal horizontal and vertical) if available. If not, pick a resolution where the difference isn’t so extreme, and preferably where the horizontal is greater than the vertical (so at least the letters won’t overlap — they’d be spaced too far apart instead). You can either do this on a per-job basis, or once by opening the Printers Control Panel, right-clicking the dot-matrix printer, and selecting “Printing Preferences…”. In either case, click the [Advanced] button, and under “Graphic” you should see the “Print Quality.” Clicking that will present a drop-down allowing you to select from resolutions available for your printer. Again: choose a square one if available, or the closest available to square to minimize the problem.

    • Workaround #3: Instead of printing from IE or other Trident app, save the web page to disk and open it in Word, then print from there in some view other than Web view (preferably Page View or Normal View) so that Trident 4 isn’t invoked and Word’s own native printing is used instead.

    Thursday, April 22, 2010 4:24 PM
  • Hi All,

     

    Just find the solution for this by choose some settings;

     

    1. From Printing Preferences>Advanced>Print Quality should be 120x144 or the next to the highest

    2. From the Printer Properties>Advanced it should be "Print directly to the Printer"

     

    We have tried those settings and we get the good result on the printing.

     

    I hope this will works on you as well.

     

    Dennis Tidon

    • Proposed as answer by AT1616 Wednesday, February 27, 2013 11:32 AM
    Tuesday, June 28, 2011 8:37 AM
  • This did it!! wuhoooo!!!

     

    Thanks dtidon!!!!

    Wednesday, October 12, 2011 3:02 AM
  • i've been having this exact same problem on some of my computers except that we are using firefox. of all the pages that i have found, your answer made the most sense. the only problem is that it seems like it did not matter which browser i used. on the machines that have the problem, i tried using ie8, the latest firefox, the latest google chrome. and the printing from all three looks exactly the same. on the other hand, i have other computers with the exact same installation that does not exhibit this problem. printing in 120x144 partially fixes the problem but it would make the font too wide. and since our printing needs to go inside a fixed form, this is not a solution for me. anymore ideas?
    Thursday, December 19, 2013 3:00 PM
  • Sir

    Thanks For the solution. ITs Working ....

    Friday, February 14, 2014 7:00 AM