none
Missing internet connection icon in taskbar

    Question

  •  

    The internet connection icon is missing in the taskbar.  It was there when I first got the computer a few days ago and no it's gone.  I'm not sure what I did to remove it or how to get it back.
    Friday, March 14, 2008 2:44 PM

Answers

All replies

  •  

    Rt click on Task Bar > Properties > Notification Area Tab > Check Network System Icon Box > Apply > OK.
    Saturday, March 15, 2008 1:19 PM
  • That was easy, lol.  Thanks!

    Saturday, March 15, 2008 1:28 PM
  • I've come across this thread and have a similar problem.

     

    This afternoon, I installed the Vista SP1 update and as a result I seem to have lost my network icon in the notification area.

     

    The problem is that, in "Task Bar > Properties > Notification Area" under "System Icons - Select which system icons to always show", the boxes for Volume and Network are both greyed-out and unticked, so I cannot select either to show.

     

    How now do I restore my network icon to the notification area ... ?

    • Proposed as answer by www. _ Wednesday, November 03, 2010 8:02 PM
    Wednesday, March 19, 2008 5:32 PM
  • I seem to have answered my own question (previous post).

     

    I had accessed the "Taskbar and Start Menu Properties" menu by right-clicking the taskbar; this showed the options for the volume and Network icons being greyed-out.

     

    I have been fiddling and, for some obscure reason, accessing this same menu via the Control Panel showed these two option boxes as available - I have ticked them and the two icons have re-appeared. This has also restored normal operation of the menu when accessed by right-clicking the taskbar.

     

    The remedy is strange in itself but why did the SP1 update result in these icons being deactivated in the first place?


    Happier now ...

     

    WT

    Wednesday, March 19, 2008 8:10 PM
  • same problem here, but when i tried accessing them from control panel, they are still grayed out...
    Wednesday, March 19, 2008 9:02 PM
  • look in the registry under:

     

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]

     

    In the right-hand pane, delete the values named:

     

    HideSCANetwork

    HideSCAVolume

     

    Keith

    Thursday, March 20, 2008 12:09 AM
  • I have the same problem as "whocares?", option is greyed out whether through the control panel or not. In the registry following the provided path

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]

     when i get to "Policies" It does not expand. There is no Explorer option. So im stuck. Any ideas?

    Friday, April 25, 2008 5:27 PM
  •  

    Ok upon expanding them out again this time there was a policies and explorer option but in Explorer there were no values

    HideSCANetwork

    HideSCAVolume

     

    There were these values only

    ForceActiveDesktopOn

    NoActiveDesktop

    NoActiveDesktopChanges

     

     

     

    Friday, April 25, 2008 5:33 PM
  •  

    I have the same problem and want an answer!
    Monday, June 23, 2008 12:03 PM
  •  

    I have the same problem with volume icon - help please
    Monday, June 23, 2008 12:15 PM
  • I also have the same problem since updating Vista.

     

    Please let me know,

    Thanks

    Maureen

    Tuesday, June 24, 2008 12:31 PM
  • Didn't Work For Me, Same problem in the Control panel

     

    Sunday, July 06, 2008 10:36 PM
  • I have the same problem.  Noticed it in the last week or two; probably caused by my xxGrade (I hesitate to use the term upgrade), to Vista SP1.  If I go through Control Panel, or right-click on taskbar, I find that Volume, Network, and Power are disabled and unchecked.  I cannot find any thre registry entries under the explorer subkey mentioned above.  Bummed. Sad

     

    Monday, July 07, 2008 12:41 PM
  • I'm having the same problem!!! its a bit annoying. Thankfully the gadgets can be used as a makeshift for the volume and power, but they're not direct controls. I really hope someone figures this out soon, because myself and a friend are having this problem.
    Sunday, August 03, 2008 5:27 AM
  • Wednesday, September 03, 2008 12:42 AM
  • How do you find the registry??  I've looked in control panel can't find a thing that isn't grayed out.  do not know how or where to put that link can't find registry and really really never wanted vista to begin with ... it was forced upon me by dell.  never again.    

     

    Friday, October 24, 2008 2:29 PM
  •  

    Click start, run...

    then type regedit and hit enter.

    The registry editor program is not usually on a menu anywhere.

    Friday, October 24, 2008 6:16 PM
  •  Guys, I always have this problem in vista.  Very annoying!  But here's a solution: 

    Step 1:  CTRL + SHIFT + ESC (brings up the task manager)
    Step 2:  On processes tab find "Explorer.exe"
    Step 3:  Click End Process
    Step 4:  Click File--> New Task
    Step 5:  Type Explorer.exe

    by restarting this executable corrects the settings
    • Proposed as answer by Notatechgeek Monday, December 29, 2008 4:18 PM
    Monday, December 29, 2008 4:17 PM
  •  Guys, I always have this problem in vista.  Very annoying!  But here's a solution: 

    Step 1:  CTRL + SHIFT + ESC (brings up the task manager)
    Step 2:  On processes tab find "Explorer.exe"
    Step 3:  Click End Process
    Step 4:  Click File--> New Task
    Step 5:  Type Explorer.exe

    by restarting this executable corrects the settings
    Thanks for the tip. That worked great.
    Friday, July 03, 2009 2:50 AM
  •  Guys, I always have this problem in vista.  Very annoying!  But here's a solution: 

    Step 1:  CTRL + SHIFT + ESC (brings up the task manager)
    Step 2:  On processes tab find "Explorer.exe"
    Step 3:  Click End Process
    Step 4:  Click File--> New Task
    Step 5:  Type Explorer.exe

    by restarting this executable corrects the settings
    Thanks for the tip. That worked great.
    It did, Thanks!
    Saturday, August 01, 2009 12:11 AM
  • Even quicker (no reboot or registry editing required):

    Obatin Process Explorer
    http://technet.microsoft.com/en-us/sysinternals/bb896653.aspx

    Right click on Explorer.exe, and click Restart
    (same as Process menu selection, then Restart)

    Saturday, August 01, 2009 4:01 PM
  • No good! I do not have the "check Network system" Icon box. If I right click taskbar/ properties Under the taskbar tab I get taskbar appearance and notification area/ that has show clock and hide inactive Icons.HELP!!!!!!!
    Sunday, January 17, 2010 5:09 PM
  • where do you go to access this from the control panel

    Monday, January 18, 2010 6:39 PM
  • thanks for the tip an .. u r a life saver
    Tuesday, January 26, 2010 3:57 AM
  • l Guys, I always have this problem in vista.  Very annoying!  But here's a solution: 

    Step 1:  CTRL + SHIFT + ESC (brings up the task manager)
    Step 2:  On processes tab find "Explorer.exe"
    Step 3:  Click End Process
    Step 4:  Click File--> New Task
    Step 5:  Type Explorer.exe

    by restarting this executable corrects the settings

    Thanks for the tip; so useful.
    Sunday, February 07, 2010 2:15 PM
  • Never mind, someone's already given that solution lol. Didn't see that.
    • Proposed as answer by Achal Dave Saturday, February 20, 2010 10:12 PM
    • Edited by Achal Dave Saturday, February 20, 2010 10:12 PM Unnecessary.
    Saturday, February 20, 2010 10:12 PM
  • GR8. U r the man!
    Friday, March 12, 2010 10:33 PM
  • Wow...it worked....thnks dude......
    Saturday, March 27, 2010 2:59 PM
  • Even i too had the same issue ...

    Great, your solution solved the issue.

    Must say easy way out without meddling in to the register keys

    Thanks

    Saturday, April 10, 2010 8:08 AM
  • Great. Much easier than trying to edit the registry. Thanks for this one!
    • Proposed as answer by Thoma Lile Sunday, May 16, 2010 12:13 AM
    Sunday, May 16, 2010 12:13 AM
  •  Guys, I always have this problem in vista.  Very annoying!  But here's a solution: 

    Step 1:  CTRL + SHIFT + ESC (brings up the task manager)
    Step 2:  On processes tab find "Explorer.exe"
    Step 3:  Click End Process
    Step 4:  Click File--> New Task
    Step 5:  Type Explorer.exe

    by restarting this executable corrects the settings

    Ahh, thank you so much. Worked like a charm :)
    Sunday, May 16, 2010 4:02 PM
  • Great worked first time after the others drew a blank.............well done, take a day off.......
    Friday, June 11, 2010 9:22 AM
  • Worked great, Thanks
    Wednesday, June 23, 2010 9:39 PM
  • ive had this icon missing for ages, thanks ,Karl
    Sunday, June 27, 2010 11:35 AM
  • Thank you, soooo sooo much! This was fast, easy and it worked!
    Wednesday, July 28, 2010 3:09 AM
  •  Guys, I always have this problem in vista.  Very annoying!  But here's a solution: 

    Step 1:  CTRL + SHIFT + ESC (brings up the task manager)
    Step 2:  On processes tab find "Explorer.exe"
    Step 3:  Click End Process
    Step 4:  Click File--> New Task
    Step 5:  Type Explorer.exe

    by restarting this executable corrects the settings

    worked perfectly - thank you loads
    Tuesday, September 14, 2010 8:27 PM
  • Hey thank u so much for ur help...that worked realy wel for me and i supose for everyone else as wel.thanks mate for that help........I RECOMMEND U TO EVERYONE ELSE 

     

     

    Thanks!!!!!!!!!!!!!!

    Tuesday, September 21, 2010 8:21 AM
  • excellent did the trick....thanks a bunch was annoying me....  
    Tuesday, October 19, 2010 2:34 AM
  •  Guys, I always have this problem in vista.  Very annoying!  But here's a solution: 

    Step 1:  CTRL + SHIFT + ESC (brings up the task manager)
    Step 2:  On processes tab find "Explorer.exe"
    Step 3:  Click End Process
    Step 4:  Click File--> New Task
    Step 5:  Type Explorer.exe

    by restarting this executable corrects the settings

    12/16/2010 Thanks, works fine. It just started happening after the latest update...
    • Proposed as answer by Jim Nickerson Thursday, December 16, 2010 4:47 PM
    Thursday, December 16, 2010 4:47 PM
  • thanks, have just followed above steps and it worked fine, nice and easy :)
    Wednesday, December 29, 2010 11:36 AM
  • Worked a treat! Thanks!
    Thursday, February 10, 2011 2:09 PM
  • It worked for me as well.

     

    Thanks a lot Notatechgeek!!!

    Monday, February 14, 2011 8:31 PM
  • Thanks, fixed my problem!
    Saturday, April 02, 2011 6:06 AM
  • Great tip. who knew?

    thanks

    Friday, April 08, 2011 12:45 PM
  • Thanks so much...I had this problem and was going to live without the Internet connection icon on my taskbar rather than enter the realm of the "REGISTRY".  Your solution worked along a path I was comfortable with...not being a geek and all.
    Friday, April 22, 2011 9:50 PM
  • Go to Control Panel, Network Connections, highlight your current network connection, in the left panel select "Change settings of this connection" and a window will open. Near the bottom put a check in the box next to "Show icon in notification area when connected".  Your icon will now be in the bottom right of the taskbar.

    • Proposed as answer by kdsres Saturday, May 21, 2011 4:23 PM
    Saturday, May 21, 2011 4:23 PM
  • The simpliest solution of all is here......

     

    Click start >> control panel >> network connections.


    Right click on the local Area Connection icon visible.

    Select properties.

    In the general tab >> Select the otpion show icon in notification area when connected.

    The icon will be back......

    That is the best soltuion I can say

    Cheeeeeeeeeeers !!!!!


     BrandenKaturi.

    Monday, May 30, 2011 3:23 AM
  • Thanks so much, It works!!!!
    Tuesday, September 13, 2011 3:08 PM
  • This does not work for Windows 7.
    Sunday, October 02, 2011 2:10 PM
  •  Guys, I always have this problem in vista.  Very annoying!  But here's a solution: 

    Step 1:  CTRL + SHIFT + ESC (brings up the task manager)
    Step 2:  On processes tab find "Explorer.exe"
    Step 3:  Click End Process
    Step 4:  Click File--> New Task
    Step 5:  Type Explorer.exe

    by restarting this executable corrects the settings
    Thanks man saved me works on windows 7 64. u are the man.
    Wednesday, November 02, 2011 1:23 AM
  • This does not work for Windows 7.
    it does i just did it know. it additionally installed some other messed up components
    Wednesday, November 02, 2011 1:28 AM
  • I WORSHIP YOU SIR! THANKS ALOT :) 
    Thursday, November 10, 2011 4:10 PM
  • dont know how to get in the registry

    • Proposed as answer by JWim Saturday, February 09, 2013 10:25 AM
    Sunday, March 11, 2012 6:24 PM
  • thank you

    Sunday, March 11, 2012 6:33 PM
  • Some of the other fixes might work but this was the quickest, easiest way to fix the problem. Thanks Notatechgeek!
    Monday, March 12, 2012 6:18 PM
  • That worked like a charm--thanks!!
    Tuesday, March 13, 2012 11:38 PM
  • Thank you this worked for me

    Judy Lott

    Friday, May 11, 2012 6:01 PM
  • This works for Windows 2008 as well.  Was missing a few icons like network and restarting Explorer fixed it.
    • Edited by Ack3r Thursday, July 12, 2012 2:46 PM
    Thursday, July 12, 2012 2:45 PM
  •  Guys, I always have this problem in vista.  Very annoying!  But here's a solution: 

    Step 1:  CTRL + SHIFT + ESC (brings up the task manager)
    Step 2:  On processes tab find "Explorer.exe"
    Step 3:  Click End Process
    Step 4:  Click File--> New Task
    Step 5:  Type Explorer.exe

    by restarting this executable corrects the settings
    Worked for me too... thanks!
    Friday, August 03, 2012 1:15 AM
  • Really works great Notatechgeek thank you.

    Wednesday, August 15, 2012 4:59 PM
  • This worked perfect. Came right back. Thank you.
    Sunday, October 07, 2012 7:32 PM
  • Thanks, that worked out good for me!  Cheers
    Thursday, December 20, 2012 9:57 PM
  • 1.go to Start, clik RUN and in dialogue bar type REGEDIT  to get you to the Regitry. Advice:  Be
    VE
    RY careful in Registry or you could screw up your computer
    Saturday, February 09, 2013 10:39 AM
  • thank you so much, this really worked.

    everything else I tried didn't work. (:

    Wednesday, June 19, 2013 4:30 AM
  • This worked, it worked, it worked, all this wasted time for an icon, but now I can tell if I'm online or not.  Thanks

    Wednesday, June 19, 2013 8:18 PM
  •  Guys, I always have this problem in vista.  Very annoying!  But here's a solution: 

    Step 1:  CTRL + SHIFT + ESC (brings up the task manager)
    Step 2:  On processes tab find "Explorer.exe"
    Step 3:  Click End Process
    Step 4:  Click File--> New Task
    Step 5:  Type Explorer.exe

    by restarting this executable corrects the settings

    Fixed.

    I had the same problem, connection was working fine but the icon was missing from the system tray.

    In the properties of the task bar the network was greyed out.

    By following the above steps resolved the problem thank you.

    Saturday, July 13, 2013 7:57 AM
  • hear is full explanation what to do to fix this
    http://support.microsoft.com/kb/945011

     Guys, I always have this problem in vista.  Very annoying!  But here's a solution: 

    Step 1:  CTRL + SHIFT + ESC (brings up the task manager)
    Step 2:  On processes tab find "Explorer.exe"
    Step 3:  Click End Process
    Step 4:  Click File--> New Task
    Step 5:  Type Explorer.exe

    by restarting this executable corrects the settings


    • Edited by ganja951 Monday, July 15, 2013 6:35 PM Xml error
    Monday, July 15, 2013 6:34 PM
  • http://support.microsoft.com/kb/945011










    The internet connection icon is missing in the taskbar.  It was there when I first got the computer a few days ago and no it's gone.  I'm not sure what I did to remove it or how to get it back.

    Monday, July 15, 2013 6:36 PM
  • There are instances when task bar Icons like anti virus, Volume or net work icon  any one disappearing when booted. The reasons are not known. But the remedy is every time you see one of the selected Icon is missed in task bar, log off the administrator page and log in again , you will get back them. You have to collect cookies by doing these several times to establish steady icons that you have selected to be shown.After this you go to  task bar properties and select the Icons  as always show and apply them.
    Tuesday, August 13, 2013 7:57 AM
  • Thank you so much. I did it. Great
    Friday, August 16, 2013 7:45 AM
  • This advice is not much use.  The only icon you can tick to show up is the network icon which should only show when you have two computers running on a network.  Sometimes it works with only one computer running.  This icon shows whether you are connected or not connected.  Sometimes it will show that you are not connected and browsers work showing you "are" connected.  This has always been a problem with "all" Microsoft operating system.  Their programmers are thick and stupid.  They are incapable of fixing it.  Some programs you install somehow affect whether the icon shows or not.  Windows' coders either don't care or just cannot solve the problem.  I think it is the latter with a bit of the former.  As I have said many times, professional coders have no common sense whatsoever.  They continue to create updates with useful functions removed and useless functions added.  THEY DO NOT LISTEN TO USERS!  You will not be able to take any action to fix the problem.  Perhaps you should try uninstalling the last downloaded software.  Once you have the problem you sometimes see the icon though often you do not.  There is something wrong with your operating system - it is rubbish!  Anyway, Microsoft will not be around in five years.

    Ty Buchanan

    Sunday, October 20, 2013 8:01 AM
  • Go to Control Panel, Network Connections, highlight your current network connection, in the left panel select "Change settings of this connection" and a window will open. Near the bottom put a check in the box next to "Show icon in notification area when connected".  Your icon will now be in the bottom right of the taskbar.


    This worked ok for me  thanks
    Thursday, April 03, 2014 9:10 AM