none
How to share folders with specific users?

    Question

  • Hello,

    I have two Win7 Pro PCs, both are in the homegroup. On both machines there is an account with the same name "Testuser" and the same password. Now if I try to share a folder, e.g. C:\blah, via Advanced settings to the user "Testuser", I cannot access this share on the other machine:
    "Windows cannot access \\PC_A\blah
    You do not have permission to access blah. Contact your Network Administrator to request access."

    So what I want is to share files and folders in the local network PER USER and not only per homegroup. In Vista I immediately gained access to "blah" because there was a local account with the same username and password which was used to log on to PC_A. From within another user session, say "Testuser2" Vista opened the username and password prompt and I was able to log in with "\\PC_A\Testuser" and the corresponding password. In Win7 I only get this "access denied" message.
    How is it possible to share files and folders only to specific users instead to the whole homegroup?

    I also tried to use the wizard which opens when you use "Share with --> specific people". There I chose "Testuser" and it did not work either... Generally, I do not understand what "Share with --> specific people" does. Because it obviously does not share files and folders with specific user across different machines!
    Sunday, November 15, 2009 12:37 PM

Answers

  • Yes, that's right.

    There is a solution, but it is not very nice...
    In Network and Sharing Center -> Advanced sharing settings -> Use user accounts and passwords to connect to other computers.
    But then all other users not having an account on the remote computer must enter the HomeGroupUser$ and password manually. Of course I can save this in the Credential Manager, but then I have to do it for every single user...
    Wednesday, November 18, 2009 11:31 AM
  • I think you are correct. We will need to use this method to workaround this issue. This is the classic way of network sharing.

    When using other user accounts on the computer to connect the target computer, we can also type Testuser and its password to access shared files.
    Thursday, November 19, 2009 6:35 AM

All replies

  • Hi TobyDE,

    Please help confirm following information:

    1. Try choose Share with --- Specific People --- add Testuser, give him Read&Write permission. Then go to Advanced Sharing in Share tab, check "Share this folder" box, click Permission button, add the Testuser, check Full Control and click OK to test.

    If not work, please:

    1. Try \\PC_A to see if we can access the target computer.
    2. Please let me know if both "Testuser" accounts have administrator permission.
    3. Check if there is any further the error under "You do not have permission to access blah. Contact your Network Administrator to request access". If so please let me know.

    Monday, November 16, 2009 10:01 AM
  • 1. Try choose Share with --- Specific People --- add Testuser, give him Read&Write permission. Then go to Advanced Sharing in Share tab, check "Share this folder" box, click Permission button, add the Testuser, check Full Control and click OK to test.
    Does not work. :( Same error message.

    1. Try \\PC_A to see if we can access the target computer.
    Yes we can.

    2. Please let me know if both "Testuser" accounts have administrator permission.
    Yes they have.

    3. Check if there is any further the error under "You do not have permission to access blah. Contact your Network Administrator to request access". If so please let me know.
    No there is not.

    The problem is, that PC_B automatically always logs on to PC_A with username "HomeGroupUser$" instead of the real name of the user.
    If I disable the homegroup on all computers, it works. But what I want is to use home groups and the good old user defined shares.
    Monday, November 16, 2009 5:54 PM
  • Hi TobyDE:

    I did some tests on creating same users on 2 systems.

    Please test following steps:

     

    1. Choose Share with --- Nobody.

    2. Choose Share with --- Specific People, add Testuser, give him Read&Write permission. (as in my first suggestion)

    3. Right click on the shared file, choose Properties. Go to Security tab, check if Testuser exists in Group or User name list. If not, add it and give Full Control permission.

    4. Go to Advanced Sharing in Share tab, check "Share this folder" box, click Permission button, add the Testuser, check Full Control and click OK to test. (as in my first suggestion)

    If issue still exists, try delete HomeGroupUser$ in step 3 and 4 (if exists) to see the result.

    And you can capture a screenshot of the Permission tab, the error and anyth valueable information and provided here.

    Refer here about how to upload a screenshot.

    Tuesday, November 17, 2009 10:03 AM
  • Hi,

    I did what you said. I apologize it's all german.

    Filesystem permissions:
    http://dqrbuw.blu.livefilestore.com/y1pAHE9fm1i-_RCWoSq8OK_Mwu4b-e4hZYTmY0iP-IaCAr8mUxDHPGdyRHXMrfGKiMAKD7yK0BmrLXwGr8uDn7NdHobtuhvLz1I/permissions.jpg

    Share permissions:
    http://dqrbuw.blu.livefilestore.com/y1pqPyNnQAL15lhGMsjXHTUWYcb1dZrZL38z2C2gt2CcSkgHC44KIorvvPj3UGMmZg9_N1UaDFvPHi_rFMS6r_5X131dwqTkDOI/shares.jpg

    Access denied on remote computer:
    http://dqrbuw.blu.livefilestore.com/y1pbzyjNR4WuHAWpJFOLI2D1ZznrkQLyW3uTTXih4UkWFuoYuxH0IJ6qRTl2XiYGxN05isTgED_vB8HwFfxMWjYWHjlDNIgwaCX/access_denied.jpg
    Tuesday, November 17, 2009 6:25 PM
  • Currently it seems that after join to a HomeGroup, it will use the HomeGroupUser$ account to access all shared folder instead of using current logon account. This can explain why disable HomeGroup can help get it work.

    I'm trying to do more tests on this issue to see if there is any solution.
    Wednesday, November 18, 2009 9:52 AM
  • Yes, that's right.

    There is a solution, but it is not very nice...
    In Network and Sharing Center -> Advanced sharing settings -> Use user accounts and passwords to connect to other computers.
    But then all other users not having an account on the remote computer must enter the HomeGroupUser$ and password manually. Of course I can save this in the Credential Manager, but then I have to do it for every single user...
    Wednesday, November 18, 2009 11:31 AM
  • I think you are correct. We will need to use this method to workaround this issue. This is the classic way of network sharing.

    When using other user accounts on the computer to connect the target computer, we can also type Testuser and its password to access shared files.
    Thursday, November 19, 2009 6:35 AM