none
Windows Experience Index Decreased after updating graphics drive.

    Question

  • Hey guys I am having a problem with windows experience index.My current index is 4.3 but when I update my graphics drive, it turns down to 3.2 ,So I am a bit confused whether to update it or not.Currently I am having Intel(R) HD Graphics Driver version 8.15.10.2622 and when I update to its latest version 8.15.10.2827 my windows experience index (graphics) reduces to 3.2 .

    I just want to know that should I update it ?Will it improve my computer's graphics?

    Tuesday, November 13, 2012 7:02 AM

Answers

  • Hi,

    In my option, we need to choose the most appropriate driver for our computer. If everything works fine now, it is recommended using drivers from the motherboard manufacturer. Because they that were specifically designed for your system.

    Thanks.


    Tracy Cai

    TechNet Community Support

    Thursday, November 15, 2012 2:00 AM
    Moderator

All replies

  • Hi,

    Please check out the reply in the following link:

    http://communities.intel.com/thread/30211

    Please Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Thanks.


    Tracy Cai

    TechNet Community Support

    Wednesday, November 14, 2012 7:31 AM
    Moderator
  • But it doesn't has a solution
    Wednesday, November 14, 2012 7:41 AM
  • Hi,

    In my option, we need to choose the most appropriate driver for our computer. If everything works fine now, it is recommended using drivers from the motherboard manufacturer. Because they that were specifically designed for your system.

    Thanks.


    Tracy Cai

    TechNet Community Support

    Thursday, November 15, 2012 2:00 AM
    Moderator
  • G'day,

    I had the same thing happen to me. I updated my graphics drivers and the rating went down. however, I figured out why that happened. When I installed the new drivers, it reset the 3D settings. For example, it disabled SLi on my twin nVidias. All I had to do was re-enable SLi and the rating went back to normal.

    Make sure that all your settings are the same as they were before hand. 

    I hope that works,

    Stephen

    Friday, January 11, 2013 1:56 AM