none
win 8 issue your pc ran into a problem

    Question

  • HI.

    Gotta an issue.

    When i start my  PC its restarting and fun only from second time. After one restart.

    Message i am revealing is:

    "your PC ran into a problem. This problem caused your PC to restart."

    Here are the logs (minidumps)

    https://skydrive.live.com/redir?resid=BF16B5E90EF16CA3!153

    Please help me to identify the software guilty in it.

    Appreciate a lot!

    Friday, January 25, 2013 6:16 PM

Answers

  • ok, driver verifier gave a better dump:

    *******************************************************************************
    *                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    *******************************************************************************
    
    DRIVER_VERIFIER_IOMANAGER_VIOLATION (c9)
    The IO manager has caught a misbehaving driver.
    Arguments:
    Arg1: 0000000000000226, An IRP dispatch handler has returned without passing down or completing this IRP,
    	or someone forgot to return STATUS_PENDING.
    Arg2: fffff880063f32d0, The address in the driver's code where the error was detected.
    Arg3: fffff9800c84e900, IRP address.
    Arg4: 0000000000000000
    
    Debugging Details:
    ------------------
    
    
    BUGCHECK_STR:  0xc9_226
    
    DRIVER_VERIFIER_IO_VIOLATION_TYPE:  226
    
    FAULTING_IP: 
    EMVSCARD+22d0
    fffff880`063f32d0 488bc4          mov     rax,rsp
    
    FOLLOWUP_IP: 
    EMVSCARD+22d0
    fffff880`063f32d0 488bc4          mov     rax,rsp
    
    IRP_ADDRESS:  fffff9800c84e900
    
    DEVICE_OBJECT: fffffa8006708e40
    
    CUSTOMER_CRASH_COUNT:  1
    
    DEFAULT_BUCKET_ID:  VERIFIER_ENABLED_VISTA_MINIDUMP
    
    PROCESS_NAME:  System
    
    CURRENT_IRQL:  2
    
    LOCK_ADDRESS:  fffff801bff44760 -- (!locks fffff801bff44760)
    
    Resource @ nt!PiEngineLock (0xfffff801bff44760)    Available
    
    WARNING: SystemResourcesList->Flink chain invalid. Resource may be corrupted, or already deleted.
    
    
    WARNING: SystemResourcesList->Blink chain invalid. Resource may be corrupted, or already deleted.
    
    1 total locks
    
    PNP_TRIAGE: 
    	Lock address  : 0xfffff801bff44760
    	Thread Count  : 0
    	Thread address: 0x0000000000000000
    	Thread wait   : 0x0
    
    
    
    SYMBOL_NAME:  EMVSCARD+22d0
    
    FOLLOWUP_NAME:  wintriag
    
    MODULE_NAME: EMVSCARD
    
    IMAGE_NAME:  EMVSCARD.sys
    
    DEBUG_FLR_IMAGE_TIMESTAMP:  457faecf
    
    FAILURE_BUCKET_ID:  0xc9_226_VRF_EMVSCARD+22d0
    
    BUCKET_ID:  0xc9_226_VRF_EMVSCARD+22d0
    
    Followup: wintriag
    ---------
    
    
        Loaded symbol image file: EMVSCARD.sys
        Image path: \SystemRoot\System32\Drivers\EMVSCARD.sys
        Image name: EMVSCARD.sys
        Timestamp:        Wed Dec 13 08:42:07 2006 

    so, the causing driver is EMVSCARD.sys. This driver seams to belong to an USB Smart Card Reader. So, update this really old driver (from 2006) or remove this device from your PC.

    "A programmer is just a tool which converts caffeine into code"

    • Marked as answer by Sasaman999 Saturday, January 26, 2013 2:42 PM
    Saturday, January 26, 2013 2:32 PM

All replies

  • Do you have AVG installed on the Windows 8 workstation?
    Friday, January 25, 2013 6:52 PM
  • You always get this crash:

    DPC_WATCHDOG_VIOLATION (133)
    The DPC watchdog detected a prolonged run time at an IRQL of DISPATCH_LEVEL
    or above.
    

    but the callstack only shows the kernel.

    Please activate driver verifier:

    http://channel9.msdn.com/Shows/Defrag-Tools/Defrag-Tools-16-WinDbg-Driver-Verifier

    http://channel9.msdn.com/Shows/Defrag-Tools/Defrag-Tools-17-WinDbg-Driver-Verifier-Part-2

    http://channel9.msdn.com/Shows/Defrag-Tools/Defrag-Tools-18-WinDbg-Driver-Verifier-Part-3

    to get a better dump.


    "A programmer is just a tool which converts caffeine into code"

    Saturday, January 26, 2013 7:40 AM
  • Noup! 

    I have already googled trough this type of error ;)

    tnx

    Saturday, January 26, 2013 12:26 PM
  • Hi.

    Thank you for a rely!

    I have activated driver  verifier and after hardly haven't lost my win 8  ;). eventually i restored last successful configuration.

    any way here are the new debugs

    https://skydrive.live.com/redir?resid=BF16B5E90EF16CA3!155

     file name Minidump 01_26

    Hope it'l help.

    I will deactivate driver  verifier for now, to save my system.

    Expecting your reply and thank you very much for the support!

    P.s. i never face easy cases, last time because of blue screens i had to change my motherboard. ;)


    • Edited by Sasaman999 Saturday, January 26, 2013 1:48 PM
    Saturday, January 26, 2013 1:36 PM
  • ok, driver verifier gave a better dump:

    *******************************************************************************
    *                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    *******************************************************************************
    
    DRIVER_VERIFIER_IOMANAGER_VIOLATION (c9)
    The IO manager has caught a misbehaving driver.
    Arguments:
    Arg1: 0000000000000226, An IRP dispatch handler has returned without passing down or completing this IRP,
    	or someone forgot to return STATUS_PENDING.
    Arg2: fffff880063f32d0, The address in the driver's code where the error was detected.
    Arg3: fffff9800c84e900, IRP address.
    Arg4: 0000000000000000
    
    Debugging Details:
    ------------------
    
    
    BUGCHECK_STR:  0xc9_226
    
    DRIVER_VERIFIER_IO_VIOLATION_TYPE:  226
    
    FAULTING_IP: 
    EMVSCARD+22d0
    fffff880`063f32d0 488bc4          mov     rax,rsp
    
    FOLLOWUP_IP: 
    EMVSCARD+22d0
    fffff880`063f32d0 488bc4          mov     rax,rsp
    
    IRP_ADDRESS:  fffff9800c84e900
    
    DEVICE_OBJECT: fffffa8006708e40
    
    CUSTOMER_CRASH_COUNT:  1
    
    DEFAULT_BUCKET_ID:  VERIFIER_ENABLED_VISTA_MINIDUMP
    
    PROCESS_NAME:  System
    
    CURRENT_IRQL:  2
    
    LOCK_ADDRESS:  fffff801bff44760 -- (!locks fffff801bff44760)
    
    Resource @ nt!PiEngineLock (0xfffff801bff44760)    Available
    
    WARNING: SystemResourcesList->Flink chain invalid. Resource may be corrupted, or already deleted.
    
    
    WARNING: SystemResourcesList->Blink chain invalid. Resource may be corrupted, or already deleted.
    
    1 total locks
    
    PNP_TRIAGE: 
    	Lock address  : 0xfffff801bff44760
    	Thread Count  : 0
    	Thread address: 0x0000000000000000
    	Thread wait   : 0x0
    
    
    
    SYMBOL_NAME:  EMVSCARD+22d0
    
    FOLLOWUP_NAME:  wintriag
    
    MODULE_NAME: EMVSCARD
    
    IMAGE_NAME:  EMVSCARD.sys
    
    DEBUG_FLR_IMAGE_TIMESTAMP:  457faecf
    
    FAILURE_BUCKET_ID:  0xc9_226_VRF_EMVSCARD+22d0
    
    BUCKET_ID:  0xc9_226_VRF_EMVSCARD+22d0
    
    Followup: wintriag
    ---------
    
    
        Loaded symbol image file: EMVSCARD.sys
        Image path: \SystemRoot\System32\Drivers\EMVSCARD.sys
        Image name: EMVSCARD.sys
        Timestamp:        Wed Dec 13 08:42:07 2006 

    so, the causing driver is EMVSCARD.sys. This driver seams to belong to an USB Smart Card Reader. So, update this really old driver (from 2006) or remove this device from your PC.

    "A programmer is just a tool which converts caffeine into code"

    • Marked as answer by Sasaman999 Saturday, January 26, 2013 2:42 PM
    Saturday, January 26, 2013 2:32 PM
  • Thank you very much for finding it!!!

    Unforgettably i can not find newer driver neither via "update driver software" nor via searching web.

    so i haven't decided what to do yet

    Thank you.

    Most probably it was the reason of blue screen for Win 7. But i have changed motherboard, CPU, RAM ;))))

    Tomorrow will disconnect card reader and provide the results of test.




    • Edited by Sasaman999 Saturday, January 26, 2013 11:32 PM
    Saturday, January 26, 2013 3:41 PM
  • Hi.

    I have disconnected the card reader and having no error claimed!

    BRAVO!

    Thank you for a solution!!!

    Only one little question worry me.

    after i have activated driver verifier i can see that my PC is not operating as fast as it was before. any idea?

    I have tried to disable driver verifier using command 

    [Windows]-R  -> Verifier /reset.

    Sunday, January 27, 2013 1:01 PM
  • yes, driver verifier slows down the PC. After disabling driver verifier you have to reboot.

    "A programmer is just a tool which converts caffeine into code"

    Sunday, January 27, 2013 8:17 PM
  • Hi.

    I am having same error again.

    Could you please take a look what is this time?, please.

    https://skydrive.live.com/redir?resid=BF16B5E90EF16CA3!156

    i assume it could be video card driver.

    Tnx a lot!

    • Edited by Sasaman999 Monday, January 28, 2013 7:30 PM
    Monday, January 28, 2013 7:30 PM
  • yes, this could be the graphic card driver:

    cdd!RmtPassThroughDisablePDEV
    cdd!RmtPassThroughEnablePDEV
    win32k!PDEVOBJ::EnablePDEV
    win32k!PDEVOBJ::PDEVOBJ
    win32k!hCreateHDEV
    win32k!DrvCreateMDEV
    win32k!DrvInternalChangeDisplaySettings
    win32k!DrvChangeDisplaySettings
    win32k!InitVideo
    win32k!RemoteConnect
    win32k!NtUserRemoteConnect
    nt!KiSystemServiceCopyEnd
    0x0
    
    
        Image path: \SystemRoot\System32\cdd.dll
        Image name: cdd.dll
        Timestamp:        Thu Sep 20 10:56:42 2012 (505ADA4A)
        CheckSum:         0003E451
        ImageSize:        00036000
        File version:     6.2.9200.16420
        Product version:  6.2.9200.16420
        File flags:       0 (Mask 3F)
        File OS:          40004 NT Win32
        File type:        3.4 Driver
        File date:        00000000.00000000
        Translations:     0000.04b0
        CompanyName:      Microsoft Corporation
        ProductName:      Microsoft® Windows® Operating System
        InternalName:     cdd.dll
        OriginalFilename: cdd.dll
        ProductVersion:   6.2.9200.16420
        FileVersion:      6.2.9200.16420 (win8_gdr.120919-1813)
        FileDescription:  Canonical Display Driver
    
    
        Image path: \SystemRoot\system32\DRIVERS\atikmpag.sys
        Image name: atikmpag.sys
        Browse all global symbols  functions  data
        Timestamp:        Fri Sep 28 03:12:52 2012 

    Install the AMD 13.1 driver.


    "A programmer is just a tool which converts caffeine into code"

    Tuesday, January 29, 2013 6:17 AM
  • Hello.

    Thank you for the support!

    I have downloaded driver sweeper, incompletely deleted all ATI software

    and installed ATD 13.1 version.

    At that point of time my  driver verifier was disabled

    and once after new drivers were installed i got same error ( when i turned on the PC it  was restarted) ;-(.

    Will provide the debugs as soon as it appear again.

    Decides just for a reference:  even when  driver verifier is disabled i can see the PC is operating slowly.


    • Edited by Sasaman999 Tuesday, January 29, 2013 6:00 PM
    Tuesday, January 29, 2013 5:59 PM
  • Hi

    The issue with graphik card  is repeated

    here are the debugs

    https://skydrive.live.com/redir?resid=BF16B5E90EF16CA3!158

    i even dunno what 2 do ;(

    Wednesday, January 30, 2013 9:15 PM
  • this time you have a BIOS issue:

    *******************************************************************************
    *                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    *******************************************************************************
    
    ACPI_BIOS_ERROR (a5)
    The ACPI Bios in the system is not fully compliant with the ACPI specification.
    The first value indicates where the incompatibility lies:
    This bug check covers a great variety of ACPI problems.  If a kernel debugger
    is attached, use "!analyze -v".  This command will analyze the precise problem,
    and display whatever information is most useful for debugging the specific
    error.
    Arguments:
    Arg1: 0000000000000003, ACPI_FAILED_MUST_SUCCEED_METHOD
    	ACPI tried to run a control method while creating device extensions
    	to represent the ACPI namespace, but this control method failed.
    Arg2: 0000000000000000, The ACPI Object that was being run
    Arg3: ffffffffc000009a, return value from the interpreter
    Arg4: 0000000000000000, Name of the control method (in ULONG format)
    
    Debugging Details:
    ------------------
    
    
    ACPI_OBJECT:  0000000000000000
    
    BUGCHECK_STR:  0xA5_ACPI_STATUS_INSUFFICIENT_RESOURCES
    
    CUSTOMER_CRASH_COUNT:  1
    
    DEFAULT_BUCKET_ID:  VERIFIER_ENABLED_VISTA_MINIDUMP
    
    PROCESS_NAME:  System
    
    CURRENT_IRQL:  2
    
    TAG_NOT_DEFINED_c000000f:  FFFFF88001A1BFB0
    
    FOLLOWUP_NAME:  ntacpitr
    
    MODULE_NAME: Unknown_Module
    
    IMAGE_NAME:  Unknown_Image
    
    DEBUG_FLR_IMAGE_TIMESTAMP:  0
    
    STACK_COMMAND:  kb
    
    FAILURE_BUCKET_ID:  0xA5_ACPI_STATUS_INSUFFICIENT_RESOURCES_VRF
    
    BUCKET_ID:  0xA5_ACPI_STATUS_INSUFFICIENT_RESOURCES_VRF
    
    Followup: ntacpitr
    ---------

    but I have no idea why you get this issue or how to fix it :(


    "A programmer is just a tool which converts caffeine into code"

    Wednesday, January 30, 2013 9:20 PM
  • this time you have a BIOS issue:

    *******************************************************************************
    *                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    *******************************************************************************
    
    ACPI_BIOS_ERROR (a5)
    The ACPI Bios in the system is not fully compliant with the ACPI specification.
    The first value indicates where the incompatibility lies:
    This bug check covers a great variety of ACPI problems.  If a kernel debugger
    is attached, use "!analyze -v".  This command will analyze the precise problem,
    and display whatever information is most useful for debugging the specific
    error.
    Arguments:
    Arg1: 0000000000000003, ACPI_FAILED_MUST_SUCCEED_METHOD
    	ACPI tried to run a control method while creating device extensions
    	to represent the ACPI namespace, but this control method failed.
    Arg2: 0000000000000000, The ACPI Object that was being run
    Arg3: ffffffffc000009a, return value from the interpreter
    Arg4: 0000000000000000, Name of the control method (in ULONG format)
    
    Debugging Details:
    ------------------
    
    
    ACPI_OBJECT:  0000000000000000
    
    BUGCHECK_STR:  0xA5_ACPI_STATUS_INSUFFICIENT_RESOURCES
    
    CUSTOMER_CRASH_COUNT:  1
    
    DEFAULT_BUCKET_ID:  VERIFIER_ENABLED_VISTA_MINIDUMP
    
    PROCESS_NAME:  System
    
    CURRENT_IRQL:  2
    
    TAG_NOT_DEFINED_c000000f:  FFFFF88001A1BFB0
    
    FOLLOWUP_NAME:  ntacpitr
    
    MODULE_NAME: Unknown_Module
    
    IMAGE_NAME:  Unknown_Image
    
    DEBUG_FLR_IMAGE_TIMESTAMP:  0
    
    STACK_COMMAND:  kb
    
    FAILURE_BUCKET_ID:  0xA5_ACPI_STATUS_INSUFFICIENT_RESOURCES_VRF
    
    BUCKET_ID:  0xA5_ACPI_STATUS_INSUFFICIENT_RESOURCES_VRF
    
    Followup: ntacpitr
    ---------

    but I have no idea why you get this issue or how to fix it :(


    "A programmer is just a tool which converts caffeine into code"


    It seems to be an iterrupt race, like when you get a null IRP. What do you think?

    Well this is the world we live in And these are the hands we're given...

    Wednesday, January 30, 2013 10:39 PM
  • It seems to be an iterrupt race, like when you get a null IRP. What do you think?


    the error code is  STATUS_INSUFFICIENT_RESOURCES. I've never seen this before, so I have no real idea.

    "A programmer is just a tool which converts caffeine into code"

    Thursday, January 31, 2013 5:56 AM
  • Hi.

    Now PC is restated without warning (which windows does) every time after booting. Here when PC is booted in some 4-5 minutes PC is restarted, it seems the restart is initiated by BIOS.

    Now PC is started with very low screen resolution - same as it was before changing VGA driver.

    Here are the logs.

    https://skydrive.live.com/redir?resid=BF16B5E90EF16CA3!159&authkey=!AJTAl5v77QiNxSc

    When i was purchasing motherboard (December 2012) i asked the seller to update bios, as the bios version was tailored to work with sandy bridge, and my CPU (Intel Core i5-3570K BX80637I53570K) is ivy bridge. 

    Will do following:

    1 But first I will delete VGA driver and check that PC is stable and is not restarted itslf <o:p></o:p>

    2 update bios (if there never version) or any way will change the BIOS<o:p></o:p>

    If it does not help

    3 I will pull out VGA card and will try to use integrated video.

     

    So I have lots of ideas what 2 do, but not sure   it’ll help ;)

     

    Tnx!




    • Edited by Sasaman999 Thursday, January 31, 2013 9:39 AM
    Thursday, January 31, 2013 6:55 AM
  • this time you get a GPU related crash:

    *******************************************************************************
    *                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    *******************************************************************************
    
    SYSTEM_SERVICE_EXCEPTION (3b)
    An exception happened while executing a system service routine.
    Arguments:
    Arg1: 00000000c0000005, Exception code that caused the bugcheck
    Arg2: fffff880038ab612, Address of the instruction which caused the bugcheck
    Arg3: fffff88019ad2390, Address of the context record for the exception that caused the bugcheck
    Arg4: 0000000000000000, zero.
    
    Debugging Details:
    ------------------
    
    
    
    nt!KeBugCheckEx
    nt!KiBugCheckDispatch
    nt!KiSystemServiceHandler
    nt!RtlpExecuteHandlerForException
    nt!RtlDispatchException
    nt!KiDispatchException
    nt!KiExceptionDispatch
    nt!KiPageFault
    dxgkrnl!ApplyPermissionWithinThisScope::ApplyPermissionWithinThisScope
    dxgkrnl!DMMVIDPN::DMMVIDPN
    dxgkrnl!VIDPN_MGR::CreateClientVidPn
    dxgkrnl!BTL_TOPOLOGY_CONSTRUCTOR::_ANCHOR_INFO::_FindAnchorAdaptersCallback
    dxgkrnl!BTL_TOPOLOGY_CONSTRUCTOR::_ANCHOR_INFO::_FindAnchorAdaptersCallback
    dxgkrnl!DXGGLOBAL::IterateAdaptersWithCallback
    dxgkrnl!BTL_TOPOLOGY_CONSTRUCTOR::_ANCHOR_INFO::_Query
    dxgkrnl!BTL_TOPOLOGY_CONSTRUCTOR::operator()
    dxgkrnl! ?? ::NNGAKEGL::`string'
    dxgkrnl!DxgkGetPathsModality
    win32k!DrvIsTemporarySettingChangeDisabled
    win32k!DrvChangeDisplaySettings
    win32k!xxxInternalUserChangeDisplaySettings
    win32k!xxxUserChangeDisplaySettings
    win32k!VideoPortCalloutThread
    win32k! ?? ::FNODOBFM::`string'
    win32k!NtUserCallNoParam
    nt!KiSystemServiceCopyEnd
    0x0
    

    Try the 13.1 or 13.2 drivers.


    "A programmer is just a tool which converts caffeine into code"

    Thursday, January 31, 2013 8:35 PM
  • I have deleted VGA driver and tried to update BIOS (but i can see it was not updated, anyway i have the latest version), and reset its settings.

    next step will be installing VGA driver again, if it does not help - will pull out VGA and try integrated video.

    Tnx for a support!

    Thursday, January 31, 2013 9:25 PM