none
Windows 7 Linux Samba Clients fail when Client for NFS is installed

    Question

  • When I install the NFS Client on Windows7 (add remove pgms- Windows Features-Services For NFS Client), Windows networking no longer is able to access the Samba (WORKGROUP) shares from those machines. It seems to work with both types of shares from a Mac OSX leopard, but the workgroup shares from Linux and Irix machines fail. The NFS shares from those machines still work. You can see from the example below that net view lists the \\SMOKE2 samba share, and ping smoke2, and showmount -e smoke2 work. But net view \\smoke2 (Path not found) is the error when trying to access the Samba share. 

    On the same Windows7 system, VirtualXP can access the same workgroup shares that fail on the Windows7 host ! This was not a problem until I installed NFS Client on Windows 7

    C:\Users\CT>net view

    Server Name            Remark

     -------------------------------------------------------------------------------

     

     

    \\SMOKE1               Smoke1:Samba 2.2.8.1

    \\SMOKE2               Samba Server

    \\SMOKE3               Smoke3

    C:\Users\CT>net view \\smoke2

    System error 53 has occurred.

     The network path was not found.

    C:\Users\CT>ping smoke2

     Pinging smoke2 [192.168.0.48] with 32 bytes of data:

    Reply from 192.168.0.48: bytes=32 time<1ms TTL=64

    Reply from 192.168.0.48: bytes=32 time<1ms TTL=64

    C:\Users\CT>showmount -e smoke2
    Exports list on smoke2:
    /usr/discreet                      *
    /usr/xfer                          *
    /sata/                             *

    Thursday, September 03, 2009 8:01 PM

Answers

  • Hi,

     

    At this time, please just try to add an entry for smoke2 in hosts file and check the issue:

     

    1.    Click Start, type “Notepad” in search bar.

    2.    After the item “Notepad” appears, right-click it and select “Run as Administrator“.

    Note: If prompted, please click Continue on the User Account Control (UAC) window.

    3.    In Notepad, click File – Open, type the following in File Name box and click OK to open the hosts file:

     

    %SystemRoot%\system32\drivers\etc\hosts

     

    4.    Add the following entry in the opened hosts file.

     

    192.168.0.48        smoke2

     

    And, click File – Save and close Notepad.

     

    Then, reboot the computer and check if you can access the share \\smoke2.

     

    Thanks.

     


    Nicholas Li - MSFT
    Wednesday, September 09, 2009 3:46 AM

All replies

  • Hi,

     

    Based on my research, I would like to suggest the following:

     

    1.    Enable NetBIOS over TCP/IP:

     

    1)     Go to “Control Panel\Network and Internet\Network Connections”.

    2)     Right-Click on the connection and choose Properties.

    3)     Find Internet Protocol (TCP/IP) Version 4 in the list.

    4)     Click Properties, and then click Advanced.

    5)     On the Advanced TCP/IP settings windows, go to “WINS” tab.

    6)     Under NetBIOS setting, click “Enable NetBIOS over TCP/IP”, and then click OK.

     

    2.    Please turn off the “Password Protected Sharing” in the Network and sharing center of the computers.

     

    Hope this helps. Thanks.


    Nicholas Li - MSFT
    Tuesday, September 08, 2009 9:22 AM
  • 6)     Under NetBIOS setting, click “Enable NetBIOS over TCP/IP”, and then click OK.

    This seemed to enable the shares via their IP Addresses ONLY.

    \\smoke2 still fails.

    \\192.168.0.48 works as a windows networking workgroup share now.

    Since ping smoke2 works, it seems that Client for NFS has introduced a bug into the ability of windows networking  to resolve the name of the server, only on some types of samba servers (Red Hat Linux and Irix Samba 2 and 3 servers, but BSD based OSX Leopard with NFS and Samba shares works fine) !

    What is the Chinese word for wierd ?

    Thanks for your help.
    Tuesday, September 08, 2009 3:11 PM
  • Hi,

     

    At this time, please just try to add an entry for smoke2 in hosts file and check the issue:

     

    1.    Click Start, type “Notepad” in search bar.

    2.    After the item “Notepad” appears, right-click it and select “Run as Administrator“.

    Note: If prompted, please click Continue on the User Account Control (UAC) window.

    3.    In Notepad, click File – Open, type the following in File Name box and click OK to open the hosts file:

     

    %SystemRoot%\system32\drivers\etc\hosts

     

    4.    Add the following entry in the opened hosts file.

     

    192.168.0.48        smoke2

     

    And, click File – Save and close Notepad.

     

    Then, reboot the computer and check if you can access the share \\smoke2.

     

    Thanks.

     


    Nicholas Li - MSFT
    Wednesday, September 09, 2009 3:46 AM
  • Thanks, we tried both hosts and LMhosts.sam , neither make a difference.

    We are working this issue with another thread in this forurm....

    http://social.technet.microsoft.com/Forums/en-US/w7itpronetworking/thread/227ca7c5-b862-4f89-846a-831f5e6cdee8/
    Monday, September 14, 2009 11:43 AM
  • Here's my "formula" for getting NFS on Linux working with Windows 7 Client for NFS.  It opens up some holes (like firewalls) initially, but gets you up and running and then you can lock things back down from there.

    Without a formula like this, you will probably spend countless hours scouring the Internet, trying to piece this puzzle together, with obscure errors by Bill Gates and company like Error 5 and Error 53 (not real helpful guys!)

    Hope you find it useful.

    Enjoy!
    Rick

    P.S.  I decided to post this after burning about 6 hours figuring all this out... (very frustrating - maybe I can also find this post next time I need it :-)


    NFS configuration from Windows 7 "Client for NFS" to Linux/UNIX NFS Server

    On CentOS (or other Linux variant):
    -----------------

    - Add to /etc/exports:
    /devpool 192.168.0.0/16(rw,sync)

    - Export the new NFS share
    exportfs -a

    Disable CentOS/Linux Firewall (or program in all ports required for portmap and other services to support NFSv4 across firewall!)

    - Restart NFS service (just for good measure)    
    service nfs restart 



    On Windows 7:  
    (You must be running Ultimate or Pro, a version of Windows 7 which supports Client for NFS)

    Install "Client for NFS" feature (Control Panel / Programs and Features / Services for NFS / Client for NFS)

    Disable Windows Firewall or other local firewall (open all required ports later)

    Use "Regedit" and add anonymous UID and GID to 500,500 (or whatever user ID you want to have access on CentOS)
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ClientForNFS\CurrentVersion\Default\AnonymousGid  (new DWORD 32)
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ClientForNFS\CurrentVersion\Default\AnonymousUid  (new DWORD 32)

    - Reboot 
      (or restart NFS Client from CMD line)
         nfsadmin client stop
         nfsadmin client start

    - Make sure you can see the Linux NFS exports from Windows 7

    showmount -e 192.168.146.131 (use your NFS Server's IP address)

    - If showmount hangs, it's probably a firewall or network routing issue 

    mount -o anon 192.168.146.131:/devpool V:

    If you get Error 53, the you must change the Network Priority order so that Client for NFS network provider is ABOVE the regular Windows Network provider (so NFS gets tried first; otherwise, you'll get prompted when trying to make connections and get Error 53, which will waste a LOT of your time as it did mine):

    http://answers.microsoft.com/en-us/windows/forum/windows_7-networking/is-there-a-way-to-change-network-provider-order-in/49acc0b0-89e5-4ee0-b30f-a8fe26e8f367

    (then reboot and try again with new network provider order - this will most likely resolve your SMB vs. NFS order issue)

    mount -o anon 192.168.146.131:/devpool V:

    Celebrate!

    Sunday, May 20, 2012 11:26 PM