none
Windows 7 Slow Internet Connection

    Question

  • Hello guys,

    I've just purchased a new Computer which comes with a pre-installed Windows 7 Home Premium 64bit operational system. However when I tried to go online wirelessly through my Linksys/Cisco N Router, everything is extremely slow. I usually like to check my connectivity speed and so I go to www.speakeasy.net/speedtest and do the speed test. The results for this new computer are download speeds between 600kps to 800kps and upload speeds between 6,000kpb to 7,000kps. Although upload speeds are even higher than normal, my download speed is extremely slow. I've also recently purchased a Laptop which has Windows Vista Home Premium as its operational system. When I do the same speed test, I get download speeds between 3,000kps and 6,000kps. I have a 12,000kps plan with Comcast for my Cable Internet. Internet has always worked really well with my old XP and my Laptop using Vista. I've read some of the posts here, and have tried to disable the Ipv6 and the Ipv4 and even using that command line "netsh int tcp set global autotuninglevel=disabled" none of these worked. Or perhaps I'm doing it wrong. Can somebody please help?

    • Moved by Nicholas LiModerator Wednesday, December 02, 2009 7:02 AM (From:Windows 7 Installation, Setup, and Deployment)
    Sunday, November 29, 2009 9:02 PM

Answers

  • Hi,

     

    Thank you for your update.

     

    At this time, we can see the issue should be more related to the wireless NIC or the wireless router. Please try the following to have a check;

     

    1.    Try another version of the wireless NIC driver; If there is a new version of the wireless NIC, please also try it.

    2.    Upgrade the router’s firmware.

     

    In addition, please also let us know the brand and model of the wireless NIC and the router.


    Nicholas Li - MSFT
    Friday, December 04, 2009 4:47 AM
    Moderator
  • Hey Nicholas Li,

    Just fyi, I changed my router from my Linksys N to a NetGear G and my internet speed all of the sudden went up to its normal 7-8MBS downloads and 3-5MBS uploads. Weird..... but it worked...

    Thanks for all your help.
    Saturday, December 19, 2009 4:12 AM
  • I had this SAME ISSUE. What I had to do was upgrade my routers firmware, and there were some Windows 7 compat. issues in there that were fixed.

    I upgraded firmware, restarted my router with reset, set it to factory default and then recreated my SSID and everything and now at Speedtest site Im back to normal

    I would for sure check to see if it is a router firmware issue

    Sunday, December 27, 2009 11:22 PM

All replies

  • This might fix it:

    1. Go to Control Panel > Power Options .
    2. Click Change plan settings next to your current power plan.
    3. Click Change advanced power settings.
    4. Double-click Wireless Adapter Settings .
    5. Double-click Power Saving Mode .
    6. Change the setting to Maximum Performance .
    Monday, November 30, 2009 8:19 AM
    Answerer
  • Hello Steve,

    It was already like that. Internet still slow.
    Monday, November 30, 2009 4:24 PM
  • Hi

    You better enable " Autotuning ", try the following reg tweaks.


    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings]
    "TCPAutoTuning"=dword:00000001

    Add this key too for a 64bit Win7
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Internet Settings]
    "TCPAutoTuning"=dword:00000001

    Good luck.


    Monday, November 30, 2009 4:40 PM
  • Hey ArcticBloom,

    How do I get to Registry again?
    Monday, November 30, 2009 4:44 PM
  • Hey ArcticBloom,

    How do I get to Registry again?

    Hi

    Start - run - typ " regedt32 ".

    Monday, November 30, 2009 4:50 PM
  • Hello ArcticBloom,

    Just added both keys, and the download speed increased a little bit, now it's between 700kps and 900kps, however my Vista Laptop is still much higher download speeds, all connected via Wireless. Do you have another suggestion?

    P.s. I appreciate your input.
    Monday, November 30, 2009 5:22 PM
  • Yes i do , add the following to increase connections :

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings

    Edit / New / DWORD (32-bit) Value - name =  MaxConnectionsPer1_0Server - check Decimal = 32

    Make a second with the name :  MaxConnectionsPerServer = 32

    Reboot and see if it works better this way.

    Monday, November 30, 2009 5:30 PM
  • Just to confirm, the second to be added is with the name: MaxConnectionsPerServer is also to be checked Decimal with the value = 32 also under: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings right?

    If that is the case I've done it correctly, and rebootted and unfortunately the speeds did not change. Tomorrow I'm going to plug an ethernet cable directly into the computer from the Comcast Modem and see what happens. I'll update.

    I don't know what could be causing this. Thank you so much for your continued help.
    Tuesday, December 01, 2009 8:12 AM
  • Hi

    If you use a router, make sure the Win7 network address is added as a trusted client.

    Take a look at Vista and setup the network settings in Win7 the same way.

    Look at your firewall in Win7, set it up as Default and see if it works then.

    Update your Network adapter driver in Win7.

    Take a good look at the start-up programs in Win7, and see wich of them uses a network connection.

    You can keep the registry settings you've changed for better performance anyhow.




    Tuesday, December 01, 2009 10:02 AM
  • Hey,

    I'm sorry for my computer illiteracy, could you be so kind as to give me some pointers as to how I go about getting these steps done? So far everything you've asked me to do has been within my grasp. Thank you so much!!

    Tuesday, December 01, 2009 3:32 PM
  •  

    Hi,

     

    Please try the following:

     

    1.    Run the following commands one by one in an elevated command prompt in Windows 7:

     

    netsh interface tcp set global rss=disabled

    netsh interface tcp set global autotuninglevel=disabled

    netsh int ip set global taskoffload=disabled

     

    2.    In addition, just for a test, please boot the Windows 7 computer to Clean Boot environment and check the speed.

     

    How to troubleshoot a problem by performing a clean boot in Windows Vista or in Windows 7

     

    3.    You may also check how it works when you connect to the router with wired connection.

     

    Hope this helps. Thanks.


    Nicholas Li - MSFT
    Wednesday, December 02, 2009 7:01 AM
    Moderator
  • Hey,

    I'm sorry for my computer illiteracy, could you be so kind as to give me some pointers as to how I go about getting these steps done? So far everything you've asked me to do has been within my grasp. Thank you so much!!


    Well I Gomes , i suggest you make contact with your Internet Provider and ask them for a bit of help and the proper network settings.

    Saves frustration and it's a lot quicker.

    Good luck
    Wednesday, December 02, 2009 8:46 AM
  • Hello Nicolhas Li,

    I've just included your suggestions, and unfortunately when I checked the speed in the Clean Boot enviroment, it was still slow. Same thing.

    I'll try to see how it goes on a wired connection. I'll update tomorrow. In the mean time do can you think of any other possible suggestions?

    P.s. Thanks for the input.
    Thursday, December 03, 2009 6:04 AM
  • Hi,

     

    Thank you for your update.

     

    Please also try:

     

    Disable SNP in Windows 7 by setting Registry as following:

    Note: Please perform a full-system backup first.

     

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]

    EnableTCPChimney=dword:00000000

    EnableTCPA=dword:00000000

    EnableRSS=dword:00000000

     

    Note: if the keys don’t exist, please create them first.

     

    In addition, please also go through this threads and ensure that you have tried all the suggestions.

     

    Thanks.


    Nicholas Li - MSFT
    Thursday, December 03, 2009 10:39 AM
    Moderator
  • Hey Nicholas Li

    Just as an update, as soon as I connected the ethernet cable from my router, I got a download speed of 12MBits ad upload of 7MBits, which is normal. Which tells me that the problem is in the wireless connection only. Based on this should I still try your suggestions?

    Thank you for your patience.
    Friday, December 04, 2009 12:45 AM
  • Hey I Gomes -

    I'm having the same issue with a Dell laptop I just upgraded to W7.  Slow as a dog on the wireless.  Works like a charm on the wired ethernet connection.  

    Watching with anticipation to see if anything "clicks" here and solves your issue.


    Friday, December 04, 2009 1:39 AM
  • Hi,

     

    Thank you for your update.

     

    At this time, we can see the issue should be more related to the wireless NIC or the wireless router. Please try the following to have a check;

     

    1.    Try another version of the wireless NIC driver; If there is a new version of the wireless NIC, please also try it.

    2.    Upgrade the router’s firmware.

     

    In addition, please also let us know the brand and model of the wireless NIC and the router.


    Nicholas Li - MSFT
    Friday, December 04, 2009 4:47 AM
    Moderator
  • Hello Nicholas Li,

    I tried to update the driver for the wireless card which is: Ralink 802.11n Wireless LAN Card, however it says that "The best driver software for your device is already installed." it also says that "Windows has determined the driver software for your device is up to date."

    How can I try another version?

    P.s. While I was connected with my Windows 7 desktop via wired connection, my Vista Laptop's wireless connection decreased quite a bit (although not as nearly slow as my Windows 7 desktop wireless connection). So just by being connected the Windows 7 wired connection took a lot of bandwith.

    P.s. 2 = Transferring files from the computer to an outside flash drive or harddrive using the Windows 7 desktop, is also extremely slow.

    Thank you for your continued responses, it is very welcomed.
    Monday, December 07, 2009 4:23 PM
  • Hey Nicholas Li,

    Just fyi, I changed my router from my Linksys N to a NetGear G and my internet speed all of the sudden went up to its normal 7-8MBS downloads and 3-5MBS uploads. Weird..... but it worked...

    Thanks for all your help.
    Saturday, December 19, 2009 4:12 AM
  • I had this SAME ISSUE. What I had to do was upgrade my routers firmware, and there were some Windows 7 compat. issues in there that were fixed.

    I upgraded firmware, restarted my router with reset, set it to factory default and then recreated my SSID and everything and now at Speedtest site Im back to normal

    I would for sure check to see if it is a router firmware issue

    Sunday, December 27, 2009 11:22 PM
  • I had similar problem after upgrading from Vista to Windows 7. It turned out that I had to update the driver of the USB wireless 802.11 b/g . Windows 7 provided that update.

    Wednesday, February 03, 2010 4:42 PM
  • For those with this problem, I would like to add my experience switching to Windows 7.

    Recently I went from XP to Win7 but my net speed was so slow and frustrating. I tried many of the things menttioned above but nothing helped. I even thought of going back to XP (the same computer worked very fine then) besides my other 2 computers which are connected to the same router has no problem with connecting to the internet.

    Today, I went to net-card properties and changed the speed from Auto Negotiate to 100 Mbps Full Duplex. Like magic ... I have full speed now - even better than with XP.

    Steps: Control Panel --> Network and Sharing Center --> Change Adapter Settings --> right click the conection and select properties --> select Configure button --> goto Advanced tab --> look for Link Speed and Duplex --> change Auto Negotiate to 100 Mbps Full Duplex.

    Note: the speed might depend on the routed and network card you use. My configuration is "Linksys WRT54G" router and "Intel(R) PRO/1000 MT Network Connection" net card.

    Saturday, May 15, 2010 3:17 PM
  • I had the same problems with Windows 7... Very slow wireless speed from wireless router. Normal DSL speed on-wire. After much research and attempts my trial-and-error, here's what worked for me.

    1- Change wireless router encryption to WEP, rather than WPA. (I understand switching to WPA2 could also help with some compatibility issues...)

    2- Uninstall router management software that came with router (My D-Link router came with a program called “Network Magic”. It seemed to be interfering with the Windows-7 wireless software that was already installed on my laptop. Uninstalling it noticeably improved my internet speed)

    3- Change wireless adapter settings: In "Properties", unclick "TCP/IPv6"

    4- Change wireless adapter settings: In "Properties/Configure", disabled Ad Hoc QoS  Mode.

    5- Change wireless adapter settings: In "Properties/Configure", changed Wireless Mode to 802.11g

    6- In Control Panel/Power Options: Change advanced power settings... Wireless adapter settings: set to Maximum Performance (ON and OFF battery modes).

    Hope this helps someone out there...

    Herrana
    Wednesday, January 12, 2011 11:05 PM
  • Hi Katrash..

     

    Thanks a lot for ur advice! It worked! Now my internet speed is awesome!

     

    I've been sufferring the slow internet speed for months.. Was to busy with work and i ignored it all this while. But finally i decided to check some help from internet. Ur solution was easy and on the dot!

     

    Thanks again!

    Monday, January 17, 2011 2:32 AM
  • I was having a bit of issues with multiple wireless USB dongles and adapters on my desktop (Win7 32-bit).  After running through nearly everything I could think of and find, I decided that I would mess around with some of the router configuration.  What ultimately resolved my issue was changing the Wireless Network Channel setting from Auto to a static channel.  Hope that is of help to others.
    Tuesday, May 24, 2011 6:48 PM