none
Windows 7 and *.ISO files

    Question

  • Hello.

    I'm new member here.

    I'm running Win 7 Ultimate now.
    When i was on my old Win XP, i often created backup *.ISO files from my applications CDs and DVDs. And after that i burn them (still on ISO files) on a blank DVD using third party burning software. So, on that burned DVD i have 3-4 or more *.ISO files.

    When i'm on XP, theres no problems when i explore the DVD using Windows Explorer. So i can copy or mounted the ISO file directly from the backup DVD.

    But, when i'm moved to Windows 7, heres go the problems.

    Everytime i put ANY DVD that contains *.ISO files inside into my DVD-ROM drive, Windows Explorer of Win 7 can't browse the DVD content. While, the other autorun menu pop up and ask me open it as a USB flashdrive (or so on, i'm a little forgot). But the most annoying here is I CAN'T BROWSE THE DVD CONTENTS because of that autorun pop up. If choose cancel, i still can't browse it.

    When i checked it using my laptop that still have Windows XP, the DVD is fine. I can browse it and copy it smoothly.

    So, whats wrong with Windows 7?
    Why it can't browse any DVD or CD that contains *.ISO files?

    Please help me on this one.

    Thank you.
    Big regards.
    Friday, January 01, 2010 2:26 PM

Answers

  • This behavior occurs if you burned this DVD with third party program. The program may load any third party filter drivers that is incompatible with Windows 7. I suggest you install the burning program in Windows 7. If the issue persists, or the DVD drive does not work after installing the program, please follow the steps below to remove filter drivers.

    1. Click "Start", in the Start Search box type "regedit" and press Enter. 
    2. Navigate to the following key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}

    3. Right click on "Class", click "Export"; please name the file as "RegBackup" (without quotation marks) and then save it to the C:\ drive as a backup.

    Note: In case we need to undo the modification, we can double click this RegBackup.reg file to restore the registry key.

    4. Highlight this key, on the right pane, check if the "Upperfilters" and "Lowerfilters" values are present. If so, please right click on the values and select "Delete" to remove them.

    After deleting filter drivers, please reload the drivers.

    Reinstall driver
    =====================

    1. Click "Start", in the Start Search box type "devmgmt.msc" and press "Enter".
    2. Expand "DVD/CDROM Drives".
    3. Right click the listed DVD/CD-ROM, and click "Uninstall". Please uninstall all devices.
    4. Restart the computer.

    The drivers will be loaded automatically.

    If the issue still occurs, I suggest you re-burn the DVD with Windows DVD maker as a final solution. 


    Arthur Xie - MSFT
    Tuesday, January 05, 2010 7:34 AM
    Moderator

All replies

  • Windows can, the question you need to ask "Why you can not".
    What software did you use the create the DVD's
    On what OS was this done??

    What hardware???


    You need to help us help you.
    Friday, January 01, 2010 3:19 PM
  • To explore the contents of a cd and avoid the attempted autorun, you can go into control panel, harware and sound, autoplay and set mixed content to "ask me everytime". On my machines, I've left everything else to "set as default" which will prompt me for an action to take except for cd/dvd's that don't have a setup or autorun, it gives just one open, open folder to view contents, it'll just show the contents of the drive. Another way is to in My Computer (or Computer) open it up to see the cdrom drive which will show the label (if you gave it one) of that CD/DVD. Just right click it and tell it to open in another window, it then shows me the contents of the disk even if it has "autorun.inf".
    MCSE, MCSA, MCDST [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Friday, January 01, 2010 4:32 PM
  • This behavior occurs if you burned this DVD with third party program. The program may load any third party filter drivers that is incompatible with Windows 7. I suggest you install the burning program in Windows 7. If the issue persists, or the DVD drive does not work after installing the program, please follow the steps below to remove filter drivers.

    1. Click "Start", in the Start Search box type "regedit" and press Enter. 
    2. Navigate to the following key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}

    3. Right click on "Class", click "Export"; please name the file as "RegBackup" (without quotation marks) and then save it to the C:\ drive as a backup.

    Note: In case we need to undo the modification, we can double click this RegBackup.reg file to restore the registry key.

    4. Highlight this key, on the right pane, check if the "Upperfilters" and "Lowerfilters" values are present. If so, please right click on the values and select "Delete" to remove them.

    After deleting filter drivers, please reload the drivers.

    Reinstall driver
    =====================

    1. Click "Start", in the Start Search box type "devmgmt.msc" and press "Enter".
    2. Expand "DVD/CDROM Drives".
    3. Right click the listed DVD/CD-ROM, and click "Uninstall". Please uninstall all devices.
    4. Restart the computer.

    The drivers will be loaded automatically.

    If the issue still occurs, I suggest you re-burn the DVD with Windows DVD maker as a final solution. 


    Arthur Xie - MSFT
    Tuesday, January 05, 2010 7:34 AM
    Moderator