none
KB2830477 filters Ctrl+Alt+Ins on Remote Desktop

    Question

  • After installing update 2830477 we can no longer use the Ctrl+Alt+Ins key combination. This happens to be the main hotkey for the application we use most of the time so it's really inconvenient.

    Is this a bug in this update or maybe something new has been mapped to this shortcut?

    Thanks

    Thursday, November 14, 2013 11:55 AM

Answers

  • Suggest you go to http://support.microsoft.com/ and report the problem directly to Microsoft for your problem.  Microsoft says it provides free technical support for problems with any update.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    • Marked as answer by apsicsm Tuesday, November 19, 2013 10:08 AM
    Thursday, November 14, 2013 5:48 PM

All replies

  • Suggest you go to http://support.microsoft.com/ and report the problem directly to Microsoft for your problem.  Microsoft says it provides free technical support for problems with any update.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    • Marked as answer by apsicsm Tuesday, November 19, 2013 10:08 AM
    Thursday, November 14, 2013 5:48 PM
  • Hi,

    If you suspect the issue is caused by a update 2830477, you can uninstall and hide this update in Windows Update to check the issue.

    Hide Windows 7 Updates that you do not Ever Want to Install

    http://technet.microsoft.com/en-us/magazine/ff382716.aspx

    As I known, this issue may be caused due to a configuration setting.

    To use the Ctrl-Alt-Insert key combination in Microsoft RDP, please perform the following configuration:

    1. Open the Remote Desktop Connection utility.
    2. Click Options.
    3. Open the Local Resources tab.
    4. Change the value for Apply Windows key combinations option under Keyboard to On the remote computer.
    5. All key combinations are sent to the remote desktop connection.

    Hope it works.

    Regards,

    Blair Deng


    Blair Deng
    TechNet Community Support

    Sunday, November 17, 2013 12:41 PM
  • Uninstalling the update is a valid workaround for myself, but I guess is not a good advice for our external users telling them to uninstall an update from their OS.

    It's not a problem with the Settings as it only happens with this specific hotkey, the problem appears only after this KB is installed and it works again if it's uninstalled.

    I am trying to find a way to do the report at support.microsoft.com as Rick suggested, but I haven't been able to find the right link yet.

    Thank you anyway.

    Monday, November 18, 2013 9:27 AM
  • I got a phone call with a Microsoft Technician yesterdey and he confirmed that this is not a bug and that this hotkey will no longer work as newer versions of the RD client are released :(

    Actually I found out that it's not working either with the version bundled with Windows 8.1 so I guess we'll have to learn living without this.

    I wonder what's the new functionality mapped to Ctrl+Alt+Insert in the latest Remote Desktop Client.

    Tuesday, November 19, 2013 10:08 AM
  • Hi apsicsm,

    Thank you for your update.

    Based on my knowledge, Ctrl+Alt+Insert does not have any specific function in latest RDP now.

    The latest RDP service only support the shortcut keys in following article:

    http://msdn.microsoft.com/en-us/library/aa383500%28v=vs.85%29.aspx"http://msdn.microsoft.com/en-us/library/aa383500(v=vs.85).aspx

    Hope it helps.

    Regards,
     
    Blair Deng


    Blair Deng
    TechNet Community Support

    Wednesday, November 20, 2013 9:53 AM