none
Windows 7 AutoLogon

    Question

  • I work for a public library. My public computers need to autologon to start our PC Reservation client. I used adm files in Windows XP which set the registry keys in HKLM\Software\Microsoft\Windows NT\CurrentVersion\Winlogon. It worked great in XP, but after rolling our Windows 7, I'm having issues. I've tried this method, as well as setting the registry keys manually. I've tried using the "control userpasswords2" account tool, as well as the Autologon program from Sysinternals.

    No matter which method I use, windows keeps resetting the value of the AutoAdminLogon registry key to 0 instead of 1, thus disabling auto logon. No matter what I do, it works for a few boots and then stops.

    Is there some process in the background that disables or resets this registry key. I understand the need for security and all, but I really need my PC's to autologon.

    Thursday, May 12, 2011 9:29 PM

All replies

  • Hi,

     

    Thanks for posting in Microsoft TechNet Forum.

     

    According to your description, it is recommended to check you registry settings, as far as I know, if no DefaultPassword string is specified, Windows NT automatically changes the value of the AutoAdminLogon key from 1 (true) to 0 (false), thus disabling the AutoAdminLogon feature:

     

    Note: please backup your registry before performing these steps

    1.    Start Regedt32.exe, and then locate the following registry subkey:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

    2.    Using your account name and password, double-click the DefaultUserName entry, type your user name, and then click OK.

    3.    Double-click the DefaultDomainName entry, type the domain name, and then click OK.

    4.    Double-click the DefaultPassword entry, type your password, and then click OK.

    Note If the DefaultPassword value does not exist, follow these steps:

    1)   Click Add Value on the Edit menu.

    2)   In the Value Name box, type DefaultPassword, and then click REG_SZ for the Data Type

    3)   Type your password in the String box, and then save your changes.

    4)   Double-click AutoAdminLogon entry, and then type 1 in the String box, and then save your changes.

    Hope it helps.

     

    Alex Zhao

    TechNet Subscriber Support in forum.

    If you have any feedback on our support, please contact tngfb@microsoft.com


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, May 13, 2011 9:46 AM
  • It took me endless nights, but I created a custom autologon.adm and imported into GP. If there is an easier way to do it, I am going to be pretty angry.....

    Friday, May 13, 2011 3:09 PM
  • Hi,

     

    I am just writing to check the status of this thread. Was the information that provided in previous reply helpful to you? Do you have any further questions or concerns? Please feel free to let us know.

     

    Alex Zhao

    TechNet Subscriber Support in forum.

    If you have any feedback on our support, please contact tngfb@microsoft.com


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, May 16, 2011 2:06 AM
  • I too have this problem and already have the password present. The "AutoLogonCount" String Value has also been removed to stop this reverting back to a value of "0"
    Monday, May 16, 2011 1:58 PM
  • Seems very much like this thread http://social.technet.microsoft.com/Forums/en-US/w7itproinstall/thread/bdef9529-5f8d-4411-a3a4-247686cab7fa

    Unfortunately there was no definite fix, just a few suggestions for the topic starter.

     

    Kind regards,

    Stephan Schwarz.


    If you one of these posts answered your question or issue, please click on "Mark as answer". If a post contained helpfull information, please be so kind to click on the "Vote as helpful" button :)
    Monday, May 16, 2011 2:22 PM
  • I've been thinking a script would be the way. Shame as would have been tidier without the need for this. Thanks for the reply
    Monday, May 16, 2011 4:14 PM
  • Hi,

     

    If you want to see if scripting can help you achieve this, you could ask for help in The Official Scripting Guys Forum.

     

    Then, you could assign user logon script or create a scheduled to run script at logon:

     

    Assign User Logon Scripts

     

    Schedule a task

     

    Hope it helps.

     

    Alex Zhao

    TechNet Subscriber Support in forum.

    If you have any feedback on our support, please contact tngfb@microsoft.com


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, May 18, 2011 9:58 AM
  • Hi,

     

    As we have found a workaround for this issue, we will mark it as ‘Answered’ as the previous steps should be helpful for many similar scenarios.

      

    BTW, we’d love to hear your feedback about the solution. By sharing your experience you can help other community members facing similar problems. Thanks for your understanding and efforts.

     

    Alex Zhao

    TechNet Subscriber Support in forum.

    If you have any feedback on our support, please contact tngfb@microsoft.com


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, May 20, 2011 1:58 AM
  • The information is "helpful" however none of it has solved my issue. I've tried all of this stuff. I've tried adm templates, I've tried changing the registry manually. I've tried the Sysinternals Autologon program, and I've tried using the control userpasswords2 to set the autologon username and password via the built in windows GUI. However, they all suffer from the same problem. AutoAdminLogon keeps getting changed back to 0 no matter what I do. I have no other policies in place that should be setting this back. Somehow, a windows process is changing it for me.

    None of this is anything that I don't already know or have tried. Is there some sort of Windows built in process that doesn't let you setup and autologon? I can see that it could potentially be a security problem, but some institutions, like mine, need the computers to log in automatically. I can't go around to 200 PC's and log them on every morning (I work for a large public library). This worked great in Windows XP, but its functionality in Windows 7 is hit & miss. It's NOT RELIABLE; and I need it to be 100%.

    Tuesday, May 24, 2011 3:29 PM
  • Incidentally, I also tried restricting registry permission to change the Winlogon key, and it resulted in Windows 7 continuously rebooting.
    Tuesday, May 24, 2011 3:33 PM
  • Is this x86 or x64?

    how did you deploy/install the PCs? Are you using MDT?

    How many user accounts do you have in the PC?

     

    Verify these settings and the reg value TYPE:

    AutoAdminLogon REG_SZ 1    -This is a STRING value instead of a DWORD
    DefaultDomainName REG_SZ   - Specify domain name else put local host name
    DefaultUserName Reg_SZ
    DefaultPassword REG_SZ    - Should not be blank
    ForceAutoLogon REG_SZ 1    -This is a STRING value instead of a DWORD

    Delete AutoLogonCount key and make sure it is not recreated.


    If it still fails check,
    what are the setting in here: HKLM\software\WOW6432NODE\Microsoft\WindowsNT\CurrentVersion\Winlogon ?

    Try clean booting with msconfig.exe and disable all 3rd party items, does it occur again?

    Does it continue to happen if you take the machine out of the domain (to rule out GPO/scripts)

     


    Sumesh P - Microsoft Online Community Support
    • Edited by Sumesh PModerator Thursday, May 26, 2011 10:50 AM edit
    • Proposed as answer by bubba34 Thursday, March 22, 2012 2:06 PM
    • Unproposed as answer by bubba34 Thursday, March 22, 2012 2:06 PM
    Thursday, May 26, 2011 10:49 AM
  • Were you able to verify these ?
    Sumesh P - Microsoft Online Community Support
    Monday, May 30, 2011 4:14 AM
  • gjkoz,

    Take a look at Logonexpert for Windows 7 automatic logon, it's easy to configure and control it remotely

    Tuesday, May 31, 2011 9:52 PM
  • The PC's involved are all Windows 7 32-bit. The affected PC's all have the same deployed image, which is a sysprepped ghost image. Following install, I have an adm file that deploys the registry settings you've stated above. I also manually run a reg file that inserts the same reg changes at my gpo. I've tried multiple other methods of deployement with the same failure rate. The contents of the winlogon key look like this:

     

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
    "ReportBootOk"="1"
    "Shell"="explorer.exe"
    "PreCreateKnownFolders"="{*************************}"
    "Userinit"="C:\\Windows\\system32\\userinit.exe,"
    "VMApplet"="SystemPropertiesPerformance.exe /pagefile"
    "AutoRestartShell"=dword:00000001
    "Background"="0 0 0"
    "CachedLogonsCount"="20"
    "DebugServerCommand"="no"
    "ForceUnlockLogon"=dword:00000000
    "LegalNoticeCaption"=""
    "LegalNoticeText"=""
    "PasswordExpiryWarning"=dword:00000007
    "PowerdownAfterShutdown"="0"
    "ShutdownWithoutLogon"="0"
    "WinStationsDisabled"="0"
    "DisableCAD"=dword:00000000
    "scremoveoption"="0"
    "ShutdownFlags"=dword:00000007
    "DefaultDomainName"="**MyDomain***"
    "AutoAdminLogon"="1"
    "DefaultUserName"="**MyUsername**"
    "ForceAutoLogon"="1"
    "AltDefaultUserName"="**MyUsername**"
    "AltDefaultDomainName"="**MyDomain**"
    "DefaultPassword"="**MyPassword**"
    "AltDefaultPassword"="**MyPassword**"

     

    Wednesday, June 01, 2011 7:13 PM
  • You can try installing the below hotfixes on an affected PC and see if the issue recurs. The hotfix updates the components responsible for the functionality

    977534 SHIFT does not override the automatic logon setting on a computer that is running a 64-bit edition of Windows Server 2003, Windows XP Professional x64 Edition, Windows 7 or Windows Server 2008 R2

    2468353 The MPR still calls the NPPasswordChangeNotify function to notify a password change event in Windows 7 or in Windows Server 2008 R2 even though the password change is unsuccessful


    Also enable auditing for the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon key to find out which process is modifying the key.


    Sumesh P - Microsoft Online Community Support
    Thursday, June 02, 2011 10:26 AM
  • were you able to test this on one of the boxes?

     


    Sumesh P - Microsoft Online Community Support
    Thursday, June 09, 2011 1:34 PM
  • This definitely sounds like some useful advice, I'll try it and see what happens.

    Thursday, June 23, 2011 1:48 PM
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

    I checked all of this:

    "Verify these settings and the reg value TYPE:

    AutoAdminLogon REG_SZ 1    -This is a STRING value instead of a DWORD
    DefaultDomainName REG_SZ   - Specify domain name else put local host name
    DefaultUserName Reg_SZ
    DefaultPassword REG_SZ    - Should not be blank
    ForceAutoLogon REG_SZ 1    -This is a STRING value instead of a DWORD

    Delete AutoLogonCount key and make sure it is not recreated."

    If you click the arrow head beside Winlogon there is a sub category called AutoLogonChecked. I clicked on this, set the (Default) value to 1, rebooted, and it logged on like it was supposed to. I rebooted several more times with no issues. I went back in, the (Default) value is back to (value not set), but so far I’ve had no problem with this computer auto logging on. This may be a coincidence, but I thought I would share.
    • Proposed as answer by bubba34 Thursday, March 22, 2012 2:18 PM
    Thursday, March 22, 2012 2:17 PM
  • Hello! I would like to know how to make a programmatic autologon. 

    What I need is to start a team for a domain user on Saturdays and other days if full working order.

    thanks

    Monday, March 31, 2014 3:26 PM