none
Windows 8.1 Moving Desktop Icons Problem

    Question

  • I just installed Windows 8.1 and I'm very happy with it. There is just one problem I have and I hope you can help me resolve it.

    I can't move my desktop icons. Windows is newly installed and I don't have any third-party software that could mess up everything. I searched across the web for different solution but none of these work. I tried to install all the updates but that didn't change anything. They said I should try pressing Escape button three times. I pressed Escape three times, but that also didn't work. Then somebody said that possibly the Esc button on keyboard may be stuck. But this problem continued even after I plugged out my keyboard!

    I can't think of another solution to try so I hope you can help me.

    EDIT: I'm really sorry, I saw Win 8.1 Visualization, but it says Virtualization :S I don't know what to do.

    • Edited by grgaa Sunday, December 08, 2013 10:52 AM Wrong category :(
    • Moved by Brandon RecordsModerator Friday, December 27, 2013 7:51 PM Moved to appropriate forum.
    Sunday, December 08, 2013 10:41 AM

All replies

  • Hi,

    Based on my research, please right-click desktop, click View, and uncheck Auto arrange icons.

    If the issue still persists, I suggest we create a new account to check if we can get rid of this problem.

    Create a user account:

    http://windows.microsoft.com/en-us/windows/create-user-account#create-user-account=windows-8

    Keep post.

    Regards,


    Kelvin hsu
    TechNet Community Support

    • Proposed as answer by MitzDriver Sunday, April 06, 2014 9:29 PM
    Monday, December 09, 2013 9:50 AM
    Moderator
  • I already tried to uncheck Auto arrange icons and adding another account. This issue is still present. The funny thing is that I also had this issue when I installed Windows 7 a year ago, but I resolved it by using this method you were mentoining - uncheking Auto arrange icons.

    If it helps: when I try to move any icon, my cursor changes to not-allowed cursor.

    I hope my newest information helped.

    By the way: I installed Fences to at least partly arrange my icons. But this issue was present before so this software is not causing my problem.

    Tuesday, December 10, 2013 9:24 PM
  • Hi,

    Based on the current situation, let us uninstall Fences to test it.

    Meanwhile, it may be caused by the third-party software. So, I suggest you try the clean boot mode and safe mode to narrow down the issue.

    How to perform a clean boot to troubleshoot a problem in Windows 8.1, Windows 8, Windows 7, or Windows Vista
    http://support.microsoft.com/kb/929135

    If the issue disappears in the Clean Boot environment, we can use a 50/50 approach to quickly narrow down which entry is causing the issue.

    Regards,


    Kelvin hsu
    TechNet Community Support



    Friday, December 13, 2013 8:39 AM
    Moderator
  • I uninstalled Fences and restarted computer. Nothing changed.

    Here comes the weird thing: when I tried to boot my computer in safe mode, the Windows logo appeared and a loading circle beneath it. When those two disappeared, the screen was just black. Nothing! I waited for like 15 minutes and then I shut it down by holding power button.

    So, no progress, what should I try next?

    Monday, December 23, 2013 8:10 PM
  • You could start an elevated CMD prompt and enter the command:

    SFC /SCANNOW

    This (System File Checker, provided by Microsoft) will restore any files currently under Windows protection and which might have been changed by malware or another tool you have tried / installed.

    Also, not to beat a dead horse, but, after having changed the Auto Arrange setting for the desktop, did you log off and on again and verify that the setting had been retained?

     

    -Noel


    Detailed how-to in my eBooks:  

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options

    Monday, December 23, 2013 10:20 PM
  • I tried  sfc /scannow a few times before because of another problem that also remained unsolved. Sfc discovers nothing.

    I'll try logging off and on while switching some Auto-arrange settings. Let's see, if that helps.

    Tuesday, December 24, 2013 9:19 AM
  • OK, I ran SFC in elevated CMD, just to make sure if there is really nothing wrong. But this time, it told me that some corrupt files were found:

    C:\WINDOWS\system32>sfc /scannow

    Beginning system scan.  This process will take some time.

    Beginning verification phase of system scan.
    Verification 100% complete.

    Windows Resource Protection found corrupt files but was unable to fix some
    of them. Details are included in the CBS.Log windir\Logs\CBS\CBS.log. For
    example C:\Windows\Logs\CBS\CBS.log. Note that logging is currently not
    supported in offline servicing scenarios.

    Tell me, if I should post that log file, but it's kinda huge.

    A quick look through log file shows that there are many log parts like "[DIRSD OWNER WARNING]" or "Ignoring duplicate ownership for directory ..."

    I hope that any of this additional data helps :)

    Tuesday, December 24, 2013 9:54 AM
  • Hi,

    Please upload the CBS.log file so that we can help you analyze them.

    Note: I highly recommend you use SkyDrive to upload collected files and to post screen shots/pictures. Although you might not be used to it, SkyDrive features a lot of free advanced functionality around file storage capacity, sharing, privacy, and collaboration:

    http://skydrive.com

    Regards,


    Kelvin hsu
    TechNet Community Support

    Monday, December 30, 2013 11:15 AM
    Moderator
  • MOVING ICONS need a FIX:

    I, myself have this game to play:  Moving my icons back into place.  I wouldn't however, like to someone with a gorgeous array of icons stemming from a deep-seated intelligence.  

    MICROSOFT needs torealize that this issue is, like many which arise with a new version of the OS, a matter for a fix.

    It is good that we communicate with Windows community advisors.  But, having parlied with up to a hundred individuals and gained their willing co-operation in changing the chairs and tables to try a new dance (to coin an expression from Australian bush dancing), Microsoft's good people must accept that it is time to get down with the code and see what is happening.

    It would appear, often, that what is happening to the buyers is not happening to the consultants.  But internal communication will, I believe, reveal that the Moving Icons Syndrome is running around, in-house.

    CONCLUSION:  Get a FIX, and put it on the Updates list.  

    Tuesday, February 11, 2014 11:53 PM
  • INCOMPATIBILITY:

    To add to my conclusion, I suspect that an amount of INCOMPATIBILITY is occuring.  This is, no doubt, where code brokers will start looking.

    I must say, Windows 7 was simply wonderful.  It seemed to fix itself.  I have been contemplating going to Windows 8.1 Pro.  But this particular item is where Microsoft will show that it can fix what it  broken upon delivery.

    CONCLUSION:  Windows 8.1, I believe, has a degree of INCOMPATIBILITY in the Desktop Icons functions, and should be fixed and field delivered as an Update.

    Tuesday, February 11, 2014 11:59 PM
  • CONCLUSION:  Windows 8.1, I believe, has a degree of INCOMPATIBILITY in the Desktop Icons functions, and should be fixed and field delivered as an Update.

    First they would ask for a repro procedure.  The OP was given an apparent known cause, "Fences", as a possible explanation for the symptom being discussed.  What's yours?



    Robert Aldwinckle
    ---

    Wednesday, February 12, 2014 2:40 AM
  • It may be hard for people who are experiencing the problem themselves (because of specific drivers, hardware, 3rd party stuff, voodoo, phase of the moon, or whatever) to understand that for other folks it never happens.  They may not even think to look for what they've done to cause it.

     

    -Noel


    Detailed how-to in my eBooks:  

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options

    Wednesday, February 12, 2014 6:42 AM
  • I have the same problem, but when I uninstalled Fences everything started to be OK again.

    But before that I could not move with the icon and also could not add any new file to desktopt. It looks like the desktopt was closed. 

    Wednesday, February 19, 2014 8:29 AM
  • I'm having the same issue with a Windows Surface 2 Pro tablet. I've tried the auto arrange off option and shut down and restarted the unit and it's still doing the move every time Windows does an update. ARRRGH! There is no Start8, no Fences, just Office 2012 and a web link to my company's web based cloud app.
    Thursday, March 13, 2014 5:27 PM
  • I already tried to uncheck Auto arrange icons and adding another account. This issue is still present. The funny thing is that I also had this issue when I installed Windows 7 a year ago, but I resolved it by using this method you were mentoining - uncheking Auto arrange icons.

    If it helps: when I try to move any icon, my cursor changes to not-allowed cursor.

    I hope my newest information helped.

    By the way: I installed Fences to at least partly arrange my icons. But this issue was present before so this software is not causing my problem.

    Also uncheck "Align icons to grid." Hope your problem is fixed!

    Saturday, March 15, 2014 3:52 AM
  • Dear all,

    I am also very upset. For a while I was contemplating whether to "subdue" to Windows recommendation to migrate to the better Windows 8.1 from Windows 8.0. Finally I did.

    I have Fences installed but from what I read above - that is not "it".

    This is critical for me! I need the fences due to the very intensive work, and I MUST move icons around... If I cannot, then - what good is this for me.

    I certainly hope and trust Microsoft is intensively working to get this resolved and would make a solution available shortly under Windows Update.

    Thank you,

    Elya.B

    Friday, March 28, 2014 4:59 AM
  • I read in another post clicking ESC several times worked for them so I tried it. Worked for me as well.

    • Proposed as answer by JLaMark Friday, August 08, 2014 4:20 AM
    Friday, March 28, 2014 3:55 PM
  • Wow! 3 quick escape key presses in a row freed up mu desktop icons. I would have never have expected it work, but it was easy to try. I'm not sure what it means to Microsoft, but it freed up my time to do what I need to do. It also freed up my ability to unpin IE Browser Tabs.

    Thanks to jdennismartin, I can move on.

    Friday, March 28, 2014 4:45 PM
  • Had the same problem with Fences. I right clicked on the icon and cut. clicked on the fence area and pasted. worked.
    Sunday, April 06, 2014 9:31 PM
  • I may have posted in the wrong place. However, I had the same problem with Fences also.

    I found that if you right click on the icon and click on cut, then hoover (not click on) over the fence to give it focus and then right click and past the icon will then be in the fence. Not perfect but works.

    Sunday, April 06, 2014 9:40 PM
  • How did you move your recycle bin?

    Wednesday, April 23, 2014 2:44 PM
  • I read in another post clicking ESC several times worked for them so I tried it. Worked for me as well.

    After encountering this exact same issue (note: my personal experience seems to be tied to an installation of SAPIENs PowerShell Studio 2014 - where my symptoms usually reveal themselves after running the program for a while.  Exiting the app makes no difference), and finding this thread, I was just about to exit out when I thought what the heck, give this a try.

    It worked for me as well, and it blew me a way.  ESC key 3 times very quickly "unlocked" the desktop after it had prevented me from moving icons around.

    Some kinda bug in the OS/PowerShell/.NET Framework?

    Monday, April 28, 2014 1:35 AM
  • More likely one or more hidden or completely transparent windows is/are holding the focus.  Next time it happens try using a tool like ProcExp (or even Task Manager or the TaskList command line command) to get a before and after list of windows open / processes running.

     

    -Noel


    Detailed how-to in my eBooks:  

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options

    Monday, April 28, 2014 6:20 PM
  • If you are using Fences, the problem is there. Download and install Fences 2.12 from the Stardock site, and your icons will behave normally following a reboot.

    DSM99

    Tuesday, May 13, 2014 3:20 PM
  • Bingo!  I had the same problem outlined in previous entries, and nothing solved my problem until I tried this cut and paste fix -- which worked like a charm.  Thanks for the good advice (which the next entry fine tunes).

    P.S. The immovable desktop icon glitch did not become a problem for me until after I installed Windows 8.1

    Friday, May 23, 2014 6:41 PM
  • So, I clicked view and the two (Auto Arrange and Lock to Grid) were already unchecked...

    Tuesday, June 24, 2014 1:48 AM
  • I also did this and yielded no positive results...
    Tuesday, June 24, 2014 1:49 AM
  • I tried this aswell ESC 3 times DID NOT work at all. I am still without an option...

    Tuesday, June 24, 2014 1:55 AM
  • So I found out, Download and install Fences 2.12 it will then prompt you to download 2.13 instead. Download and install (click 'yes') also install Start8 and BINGO! bug fixed...

    Tuesday, June 24, 2014 2:22 AM
  • Wow! 3 quick escape key presses in a row freed up mu desktop icons. I would have never have expected it work, but it was easy to try. I'm not sure what it means to Microsoft, but it freed up my time to do what I need to do. It also freed up my ability to unpin IE Browser Tabs.

    Thanks to jdennismartin, I can move on.

    Man it works....Hey support Team, share the word and stop telling people to reboot in safe mode and scan the OS for no reason
    Tuesday, August 05, 2014 2:05 PM
  • Wow! 3 quick escape key presses in a row freed up mu desktop icons. I would have never have expected it work, but it was easy to try. I'm not sure what it means to Microsoft, but it freed up my time to do what I need to do. It also freed up my ability to unpin IE Browser Tabs.

    Thanks to jdennismartin, I can move on.


    This solution also worked for me.  After doing some work in Hyper-V on my Win8.1Pro workstation I couldn't drag anything that was on my desktop, or anything to or from the desktop.  Tabs couldn't be dragged around in Firefox either.  I read this and it worked perfectly.  I wonder what could be causing this?  And why 3 rapid escape key press?  If anyone out there who might have access to Windows Dev teams at Microsoft can find the answer, that would be fantastic.  I'm just really curious now as to what this event is, and why escape in rapid three's seems to resolve it.  Anyway,  these instructions from jdennismartin was the Answer, in my opinion. Thank you, whoever you are.
    Friday, August 08, 2014 4:19 AM
  • It sounds like it could be malware to me.  Some suggestions...

    Try running a tool such as MalwareBytes AntiMalware or Avast Antivirus to see if maybe you have a virus, trojan, keylogger, etc. running.

    Review all the processes you have running using Task Manager or Process Explorer.  Research each one so that you know what it is (yes, that is tedious, but it's necessary).  Use the Sysinternals tool Autoruns to disable those programs you don't know you need from starting and running in the background.  At the very least this will save you some resources and make your computer run better.

    Good luck.

     

    -Noel


    Detailed how-to in my eBooks:  

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options

    Saturday, August 09, 2014 8:10 PM
  • As a few others have mentioned, mashing the ESC key three times did it for me.

    Best of luck!

    Tuesday, September 09, 2014 12:10 AM
  • First off, none of the previous solutions work. Sorry. I have a Surface 3 w/ 8.1. Uncheck "Auto-Arrange Icons": FAIL Uncheck "Allow themes to change desktop icons": FAIL Right click desktop & select "Refresh": FAIL What does work? Uncheck "Align icons to grid" (right click desktop, select view). By all means re-arrange your icons & use align icons to lineup icons uniformly but then you MUST uncheck it. Proof? Arrange icons as your desire then check auto-arrange on. Now open a TOUCH app like OneNote (NOT a desktop program). Change the orientation of Surface (by physically moving from landscape to portrait) & then back again. Go to the desktop & you will see your icons have moved. Now repeat same procedure with auto-arrange off. Your icons will remain in place. At least with the Surface the problem appears to occur when you change orientation/resolution while a touch app is open. Note it does not occur when changing orientation while on the desktop, or with a desktop program open.
    Thursday, September 11, 2014 12:33 PM