none
Language bar disappeared

    Question

  • Hi there,

     

    The problem seems to be a heritage from previous Windows versions. And seems M$ did not bother to work this problem out in Vista, there are still lots of requests in the net. Almost no "universal" solution up to date.

     

    Although, my case is somewhat unusual.

     

    At some point I noticed that the language bar had disappeared from it's usual place in the system tray. Thought it got hidden because it was inactive (I alsways use keyboard assignments). But that was not it. The usual sequence (alt+shift) did not work anymore. In regional settings->keyboards everything was fine as it should've been. Changes had no effect.

     

    After surfing the net for two days found a temporary solution to at least be able to switch between layouts. I had to assign ctr+1 and ctr+2 to inmlement a "fixed" switching between the languages. Extremely incomfortable.

     

    Now the most interesting part. When a request for elevation appears (grey transparent background), I can see the language bar floating on desktop, I can touch it, move it, change input language. But once the request is comleted (OK or Cancel), it's gone!!

     

    Another "mistery": the old scheme (alt+shift) works in non-unicode programs, such as command prompt, FAR etc. But doesn't want to work in any GUI application.

     

     

    Any suggestions? I know XP registry fixes but the seem to be of no use in Vista.

     

     

    --

    Yakor

     

    Monday, November 05, 2007 12:42 AM

All replies

  • Tuesday, January 29, 2008 10:08 AM
  • goto control panel >language options >keyboard and language options>change keyboard>language bar(second tab)>select integrated into taskbar

     

    sorry for language conversation I use ultimate turkish

    Tuesday, January 29, 2008 10:36 AM
  • Don't have a fix -- but the same problem. It just turned up right after the latest patches!!  -- The language bar was still in the taskbar but wasn't working. While attempting to "fix" it with deleting and re-setting the second language and keyboard the language bar disappeared alltogether. (not in the tool bars either), so I did the same with the keyboard toggle and assigned ctrl+1 and ctrl+2, very annoying. I switch between the two languages and keyboard layout frequently (German and English) and it's very annoying to notice that I have typed the wrong letters b/c I couldn't see which setting I was on. I tried the suggestion as posted but that one does not apply to Vista

    Any help will be appreciated.

    foxrose

    Thursday, February 14, 2008 5:30 AM
  • hi, I had the same problem like yours and all I did was resetting the default settings for system services that start up with windows vista. I had some of them disabled and then my language bar stopped working. I'm not sure which service exactly was the problem.

    Try resetting to default all windows services, do a restart and I guess your problem will be solved.
    Monday, March 10, 2008 6:05 PM
  • RUN    ctfmon.exe
    • Proposed as answer by brandongwh Thursday, May 20, 2010 12:20 PM
    Tuesday, June 17, 2008 11:16 AM
  • Great, worked for me! Great & simple solution!

     

    Simply check that CTFMON.EXE boots at startup (for all users).
    Use the following code (copy and paste to a .REG file) if you don't know how to add manually this executable to HKLM startup.

     

    Code Snippet

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run]
    "ctfmon"="CTFMON.EXE"

     

     

    Sunday, September 21, 2008 10:29 AM
  • Hi, i tried it also, but it only helped partially.

    I did make the .reg for the cftmon.exe to start at bootup, and it does start and is running, but i have to go to regional settings and turn the language bar off and on again to see it in system tray. Once i do this i can see it and use also keyboard shortcut,

    BUT once i reboot my laptop, the bar is not there anymore even though cftmon.exe is running. I have to go to regional settings again and turn it off and on again. This also affects the "language bar" option in the "toolbars" settings of the system tray :(

    Any hint where could be the problem? Thanks in advance for any hint.

    eRko
    Tuesday, February 03, 2009 3:13 PM
  • Thanks. It worked.
    Sunday, July 12, 2009 8:48 PM
  • Great, worked for me! Great & simple solution!

     

    Simply check that CTFMON.EXE boots at startup (for all users).
    Use the following code (copy and paste to a .REG file) if you don't know how to add manually this executable to HKLM startup.

     

     

    Code Snippet

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run]
    "ctfmon"="CTFMON.EXE"

     

     

     

     

    Could you please tell me how to do it step by step? I mean, you're supposed to go to regedit, aren't you? And then? I would be very thankful if you could write the steps down. :) Thanks.
    Sunday, October 11, 2009 8:07 PM
  • OMG. This solves my problem. I've tried delete 2nd language, tried to reset all settings, and etc..... for more than a day but this solves everything. So simple!
    Saturday, November 07, 2009 8:44 AM
  • Is there a way to get the Language bar to appear across all users in Windows 7? I'm finding you have to go in as every single user to change the display input.
    Monday, March 29, 2010 9:28 PM
  • Seems that it is Bugs in Vista and Win7~~~

    Or it is common stuffs of conflicts in Windows with other software?

     

    Thursday, April 01, 2010 4:53 AM
  • Every time after Micro Soft updates my Windows 7 online, the language bar would disappear, even after I repeat the entire  set-up steps for the language bar.  So I had to restore my computer to get rid of the new updates to have the language bar back.  But recently a friend got an idea: He put the Windows 7 diskette in the drive and then reboot the computer.  The language bar showed up like a miracle.  It seems that after the updates,  something in the system diskette is required for the language bar to re-appear.
    Monday, December 13, 2010 11:23 PM
  • RUN    ctfmon.exe
    This is wonderful and very useful, run the exe and restore your language bar!!
    • Proposed as answer by Erika vb Saturday, September 07, 2013 11:54 AM
    Wednesday, December 29, 2010 12:19 AM
  • Hi, everyone !

    I have the same problem with language bar and I tried all the tips and suggestions I read on almost top 20 google results forums... Finally I managed to make language bar show this way:
    Go to Region and Language (Control Panel -View By: Small icons) -> Keyboards and Languages tab -> Change keyboards... -> Language Bar tab -> select the Docked in the Taskbar radio button :) and then apply. So far nothing happens. I don't close the "Text Services and Input Languages" window and run ctfmon.exe, than click again over the radio button "docked in the taskbar" and again -> Apply. This makes the language bar appear. So it's all good, 

    BUT Most of the times i click OK to close the "Text Services and Input Languages" and it doesn't matter what I click on "region language" - OK or Cancel, the whole Taskbar disappears... 

    I hope this helps for many users with this problem, but mostly for MS to fix this Issue

    I have Windows 7 Professional, and the most annoying part is that this also happens on all of our Windows Server 2008 SP2 32 bit Terminal Servers (All are up to date atm) in Terminal Server Farm with TS Broker and all users have Remote Desktop Profile Paths.

    • Proposed as answer by DanJY Wednesday, November 28, 2012 8:31 PM
    Wednesday, January 19, 2011 9:20 AM
  • many many thanx brandongwh
    Tuesday, February 01, 2011 8:14 AM
  • for xp, here is what we do,

    control panel -> regional setting -> languages tab-> Details button-> Language bar button -> uncheck all option -> Ok button-> apply button->Language bar button again-> check all option -> Ok button again-> apply button again

    that's it.

    Friday, April 15, 2011 6:22 PM
  • RUN    ctfmon.exe

    OMG this really worked, thank you so much

     

    when I restart my computer I have to run ctfmon again. i can't find it in boot on mscofig. what else can i do?

    thanks

    Saturday, May 21, 2011 4:53 PM
  • It worked great with Windows 7 also. Instantly!

     

    Thanks for sharing

    el

    Thursday, July 14, 2011 6:20 AM
  •  Thanks. Running   " CTFMON.EXE "  The text EN and HELP logo or Language Bar  reappears !  It works . 

    1. Click the Windows Logo -> search ctfmon.exe -> click again on the "ctfmon.exe program" again. 

    2. Done ! " EN and HELP LOGO " appears !

    Monday, November 19, 2012 1:50 PM
  • Great fix!!!! Took me ages to figure this out. Thank you!
    Wednesday, November 28, 2012 8:32 PM
  • Thank youuuuuuuuuuu it worked! finally!!!!!!!!!!! xx
    Saturday, September 07, 2013 12:00 PM