none
Delete or Rename EML Files

    Question

  • How does one delete or rename an eml file? If I right-click on an eml file in Windows Explorer, there is no DELETE or RENAME function in the list.
    Tuesday, August 04, 2009 4:44 PM

Answers

  • Hi,

     

    Thank you for posting.

     

    I also tested this on my test machines and this issue didn’t occur.

     

    At this time, please try the following:

     

    1.    Scan your system to make sure that the system is virus free.

    2.    Please check if other files meet this issue.

    3.    Boot the system to Safe Mode and see if you can remove the eml file.

     

    Thanks.


    Nicholas Li - MSFT
    Thursday, August 06, 2009 11:16 AM
    Moderator

All replies


  • I just searched for .eml files with Vista.  Upon right-clicking one, I also noticed the "delete" option was not present.  Just as you say.

    But that is the search-result window.

    Next, I chose the right-click option "open file location".  That opened a new W.Explorer window.  There I could right-click and delete the .eml files.


    Maybe that's what you're also noticing?

    Tuesday, August 04, 2009 5:28 PM


  • Next, I chose the right-click option "open file location".  That opened a new W.Explorer window.  There I could right-click and delete the .eml files.



    Yes, that does work. Thank you very much. Deleting it from the Documents Library is what didn't work. In Vista it could be deleted from My Documents.
    Thursday, August 06, 2009 10:57 AM
  • Hi,

     

    Thank you for posting.

     

    I also tested this on my test machines and this issue didn’t occur.

     

    At this time, please try the following:

     

    1.    Scan your system to make sure that the system is virus free.

    2.    Please check if other files meet this issue.

    3.    Boot the system to Safe Mode and see if you can remove the eml file.

     

    Thanks.


    Nicholas Li - MSFT
    Thursday, August 06, 2009 11:16 AM
    Moderator
  • I'm seeing the same behavior; the view is through the Documents Library, though.  It looks to me like this is a bug in the Library view.
    Wednesday, September 02, 2009 12:46 AM
  • I just finished batting it out with Windows 7 64 bit / Outlook 2007 trying to open .EML files.

     

    The registry fixes listed everywhere do not work for this setup - Until you install Windows Live Mail.

     

    Before I installed Windows Live Mail I was able to manipulate .eml files without any issue, now I cannot.  Fix above using search and open file location works.

     

    Thx.

    Wednesday, March 30, 2011 5:55 AM
  • This is obviously a really old thread now, but for future readers I have a more specific fix...

    You need to make sure the .eml file is associated with Windows Live Mail first ("open file location" doesn't show up if the file automatically opens with Outlook). Change the default program to WLM by right-clicking the file and choosing "Open with". Then you are able to select "open file location" from that menu, which will take enable you to rename and delete the files...

    It appears as though you must be in the proper file path, eg. C:\Users\[User]\Documents rather than the shortcut Libraries\Documents.

    • Proposed as answer by jubjubsan Tuesday, January 03, 2012 12:49 PM
    Tuesday, January 03, 2012 12:49 PM
  • I've seen on other forums that this error occurs on Windows 7, a very simple metod to delete that eml file is to do it from command prompt, (cmd.exe), then :  del "path\to\file\xx.eml"

    Friday, March 16, 2012 8:28 AM
  • Works!!

    Thanks a lot!
    Wednesday, October 09, 2013 6:13 AM