none
Vista - Multiple Networks, Unidentified Network, Default Gateway 0.0.0.0

    Question

  • I have a problem that keeps appearing on a network that I manage. Several Vista computers have the same symptoms and are unable to connect to the Internet. In the Network and Sharing Center, while connected to the LAN, multiple networks are listed with one or more of them being an Unidentified Network. If I look at the output of "ipconfig /all", the default gateway has two addresses, with the first one being 0.0.0.0. If I open a command prompt with administrative priviledge, and run "route delete 0.0.0.0" followed by an "ipconfig /renew", the multiple networks disappear and the connection starts to work. This is only a temporary fix and the problem seems to reappear randomly. Is there a permanent fix for this or an update from Microsoft that will resolve this issue?

    Thanks,
    Shaun
    Thursday, September 04, 2008 1:59 AM

Answers

  • Hi Watson,

     

    Can you access the network?

     

    Please open the properties of the IP protocol, and manually assign a default Gateway. If the issue persists, you may manually remove the incorrect route. Click Start->All Programs->Accessories, right-click on Command Prompt and choose "Run as administrator". Then enter the following command.

     

    route print

     

    Please check if 0.0.0.0 is listed as gateway in the table. If so, please check the "Network destination" and "Netmask" of that line, and enter the following command.

     

    route delete -p [Network destination] mask [Netmask]

     

    Hope it helps

    Friday, September 12, 2008 9:12 AM

All replies

  •  

    ok...

    the same thing happend to me...

    im 13 and i was able to do it so hopefully you can....

     

     

    1)if you have any sort of wireless usb adaptor or a internal wireless adapter connected to your computer disable it before next steps

     

    2)shut down computer

     

    3)while the computer is shut down turn off the router or modem<>router and pull out the dc power in the back for 30 seconds

     

    4)after you have done that plug everything back in

     

    5)start up your computer and turn on router or modem<>router at the same time

     

    6)and then when windows has booted you should be automatically connected to the internet

     

    what this does is resets everything so if there are any wrong ip address or any other stuff like that it will put it back right : ]

     

    need any further infomation email me at im2hot4uluv@yhaoo.co.uk

    Sunday, September 07, 2008 5:11 AM
  • Hi Shaun,

     

    Is the above steps helpful?

     

    If the issue is not resolved, please let me know whether there are other Windows XP computer and they have this issue,  whether the computers are in a domain, or a workgroup. Additionally, if the computers are in domain, please let me know the system version of the server computer.

     

    When the behavior occurs, Windows Vista computers cannot obtain IP addresses from the router. This issue can be caused by the router that may be not compatible with Windows Vista. The following Microsoft article has introduced this situation. Please try the steps in one of the Windows Vista computers to test the result.

     

    Windows Vista cannot obtain an IP address from certain routers or from certain non-Microsoft DHCP servers
    http://support.microsoft.com/kb/928233

     

    If the issue is not resolved, I suggest that you change the router with another model if it is possible. If the issue does not occur, you may consider changing the router which is compatible with Windows Vista.

     

    Please try the above suggestions at your convenience.

    Monday, September 08, 2008 7:15 AM
  • I have the same issue, but with Server 2008 x64, and I'm not using DHCP. I'm setting a static IP (v4) address. When this is done, the two gateways apper in ipconfig: 0.0.0.0 and my correct Default gateway IP...

     

    Please help.

    Wednesday, September 10, 2008 12:24 PM
  • Hi Watson,

     

    Can you access the network?

     

    Please open the properties of the IP protocol, and manually assign a default Gateway. If the issue persists, you may manually remove the incorrect route. Click Start->All Programs->Accessories, right-click on Command Prompt and choose "Run as administrator". Then enter the following command.

     

    route print

     

    Please check if 0.0.0.0 is listed as gateway in the table. If so, please check the "Network destination" and "Netmask" of that line, and enter the following command.

     

    route delete -p [Network destination] mask [Netmask]

     

    Hope it helps

    Friday, September 12, 2008 9:12 AM
  • Hi Arthur!

    Thanks for the replay. I'we already done the procedure in your post. It resolved the issue.

    But... I would like to know why this is happening.

    I'm a administrator of over 350 windows servers, we are migrating to Server 2008, and two of twenty had this issue. The servers are also identical - Dell Power Edge 2950.

    As you can imagine, inconsitencies in our migration is not a "good" thing.

     

    Thanks

     

    The Doc.

    Friday, September 12, 2008 9:18 AM
  • This issue can occur after installing certain third party application which interfere with the normal functioning of the machine. Here are some articles regarding the similar issues:

     

    Default gateway On-link problem!?
    http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=2907026&SiteID=17

     

    Vista 64 + iTunes 7.6 (bonjour service specifically + Reboot = No Internet?)
    http://discussions.apple.com/thread.jspa?threadID=1346079

     

    Important Note: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

     

    May be some other programs that can cause this issue we have not found. The gateway may be added by them, and we could remove the gateway manually.

    Tuesday, September 16, 2008 5:26 AM
  • Hi everyboby,

     

    I had the same problem on Vista Business and after iTunes 8.0 installation (including Bonjour new version) the problem seems solved.

     

    Bye

    Tuesday, September 16, 2008 9:52 AM
  • Just to clarify. The Server 2008 installation was clean. No applications was installed. Totaly clean system. Setting the IP address was almoust the first ting I was doing on this system...

     

    No iTunes, or other apps installed Smile

     

    I suspect a bug in the OS here...

     

    The Doc.

    Tuesday, September 16, 2008 10:22 AM
  • This is clearly a Vista bug, nothing to do with thid party software. I run a network using NAC of over 6,000 nodes. I have seen this bug appear on brand new Vista boxes and have currently written a fix that we stick in user's startup folder to remove the route bug. The problem is that a default route appears with 0.0.0.0 0.0.0.0 with a better metric to the ones recieved from the DHCP frames from the DHCP server.

    It's no good simply blaming it on third party apps, it occurrs on fresh machines and is frankly embaressing.

    Even more embaressing is when vista decides to set the MAC address on the ethernet card to all zeros. After the release of SP1 I have seen no end of network issues and had to manually write these fixes to dish out to clients - currently I can't tell them that there is any permanent fix as MS is not acknowledging the issue.
    Friday, September 26, 2008 10:32 AM
  • Hi Doc,

     

    Sorry for the delay.

     

    Is the Windows Server computer in a domain? If so, is it a DC or just a member server?

     

    This behavior may also be caused by some network issues, such as loopback connection, incorrect router settings, etc. Does any other Windows Server computer or Windows Vista computer have this issue?

     

    Another possible cause is that when you manually assign IP address, the Default Gateway is not assigned. In Windows systems, by default 0.0.0.0 is the gateway. If the computer can connect to any other gateway, the gateway will be a backup Default Gateway. If the original Default Gateway (0.0.0.0 if you have not assigned) does not work, the backup Default Gateway will be functional.

     

    The following articles can be helpful.

     

    Default Gateway Configuration for Multihomed Computers

    http://support.microsoft.com/kb/157025

     

    The IP routing table: TCP/IP

    http://technet.microsoft.com/en-us/library/cc779122.aspx

    Thursday, October 09, 2008 3:46 AM
  • Hi Borne,

     

    Have you see the cases in this thread? When we maintain a domain with hundreds computers, or a small home network, we never encounter this issue.

     

    If it is a bug, not your Windows Vista systems, but any other would encounter the issue that multiple Default Gateways including 0.0.0.0 exist. However, actually most Windows Vista customers do not have this issue. Some customers who encounter this issue have found the reason and resolve it.

     

    I suspect that this is a server issue. The Trust Agent, Policy Server and Management System may be all Cisco products. There can be some compatibility problems. I suggest that you upgrade your whole NAC system to make it compatible with Windows Vista. For related information, please contact Cisco support or your NAC technical support.

    Thursday, October 09, 2008 5:08 AM
  •  Arthur Xie - MSFT wrote:

    Hi Doc,

     

    Sorry for the delay.

     

    Is the Windows Server computer in a domain? If so, is it a DC or just a member server?

     

    This behavior may also be caused by some network issues, such as loopback connection, incorrect router settings, etc. Does any other Windows Server computer or Windows Vista computer have this issue?

     

    Another possible cause is that when you manually assign IP address, the Default Gateway is not assigned. In Windows systems, by default 0.0.0.0 is the gateway. If the computer can connect to any other gateway, the gateway will be a backup Default Gateway. If the original Default Gateway (0.0.0.0 if you have not assigned) does not work, the backup Default Gateway will be functional.

     

    The following articles can be helpful.

     

    Default Gateway Configuration for Multihomed Computers

    http://support.microsoft.com/kb/157025

     

    The IP routing table: TCP/IP

    http://technet.microsoft.com/en-us/library/cc779122.aspx

     

    Hello Arthur, and thanks for your time.

    This happens right after install of the OS i finished, I enter the admin-password. Going to network connections, setting a static IP address AND gateway. When applying this, the 0.0.0.0 gateway AND my coustom one is still there... Meaning I had two gateways on one NIC.... (!!!). Of the 50 Server 2008 I have installed by now, this has happend on three... (Same harware).

     

    The Doc.

    Thursday, October 09, 2008 6:45 AM
  • I have the same issue.  I recieved a grace case from MS on this issue.  I work for a School District.  This issue has rearisen after SP1 for us.  I had the issue preSP1 on my Laptop.  SP1 resolved it.  Now our desktops are getting the problem It is in one lab of 30 new machines but slowly seems to be having the same issue elsewhere.  We just finished setting up over 900 new Vista machines with the plan to replace 900 more soon.  This needs to be resolved. 

    My issue happens when a Vista SP1 machine goes to sleep.  It wakes up and suddenly has a second Default Gateway of 0.0.0.0.  This being the primary default gateway, so it never uses the CORRECTLY ASSIGNED DEFAULT GATEWAY that existed prior to going to sleep and now is a secondary default gateway.  The DHCP is on a WINDOWS 2003 SERVER.

    MS support gave me one possible solution.  It did not work, maybe it will for other people.  Try adding the following registry keys if not present.
    Try the First Option and run tests.  If that fails try the second Reg Value
    HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
    DisableDHCPMediaSence        DWORD(1) Decimal

    If that does not work, try adding
    ArpRetryCount            DWORD(0) Decimal
    Tuesday, October 21, 2008 8:11 PM
  •  Arthur Xie - MSFT wrote:

    Hi Watson,

     

    Can you access the network?

     

    Please open the properties of the IP protocol, and manually assign a default Gateway. If the issue persists, you may manually remove the incorrect route. Click Start->All Programs->Accessories, right-click on Command Prompt and choose "Run as administrator". Then enter the following command.

     

    route print

     

    Please check if 0.0.0.0 is listed as gateway in the table. If so, please check the "Network destination" and "Netmask" of that line, and enter the following command.

     

    route delete -p [Network destination] mask [Netmask]

     

    Hope it helps

     

    Thank you.  This solved my issue.  Mine was a fresh install of Windows Server 2008.

    Wednesday, October 22, 2008 9:09 PM
  • WAAHHH!

     

    You guys are all talking computer talk. Can someone walk me through it like you're talking to someone who isn't so computer savvy?

     

    -Tac

    Thursday, November 04, 2010 3:30 PM