none
Mount VHD in Windows 8 not working

    Question

  • Windows 8 is supposed to allow you to mount a VHD and ISO file.

    I have Windows 8 Enterprise RTM and I can mount an ISO file, but not a VHD file.

    When I double click I get a dialog saying the application is not available.

    There is no option that I can find to turn this feature on.

    Suggestions?

    Doug


    Doug

    Tuesday, August 28, 2012 4:27 PM

Answers

  • Hey, I was just wondering if anyone had figured this out?  I am having the exact same problem.  .ISOs mount like they are supposed and their default application is File Explorer, but I can't set .VHDs to use File Explorer and they do not mount automatically.  I can still do it through Disk Management but I work with .VHDs a lot and it would be really great to have an easier system for mounting them.

    EDIT: Hey just in case you guys come back or someone else finds this, I figured it out mostly.  AnthonyDa was right, you do have to edit the registry.  As always when editing the registry I backed up the key that was already there before changing anything

    In my case I went to Computer\HKEY_CLASSES_ROOT\.vhd and in there is the default string value, I changed the data to Windows.VhdFile (I have no idea if that's right I just modeled it after the .iso one which was working).  I created a key under .vhd called "OpenWithProgids" and under that key there are two string values, the (Default) with (value not set) and I created a string value called Windows.VhdFile and didn't enter anything for data.

    No idea if any of that is actually what it's supposed to be, I modeled everything off of like at the registry values for .iso and .img

    That should add Windows Explorer as a possibility to the default application list.  After I selected that, I can right click and mount the .VHDs.

    Friday, November 16, 2012 10:08 PM
  • This fixed miy problem.

    I found this in some blog:

    In case it helps you, I just noticed that because I had WinZip associated with the .iso file extension (left over from the Windows 7 instance I upgraded), the Mount option did not show up in Explorer (and the Ribbon bar tab didn't show up when I selected either). But when I right-clicked on an .iso file and chose Properties, then clicked the Change button (next to "Opens With") and selected Windows Explorer as the program to associate with the .iso extension, suddenly the Mount option showed up on the right-click context menu and the ribbon bar tab did, too.

    Fixed my problem.


    Doug

    • Marked as answer by DougB12345 Sunday, December 16, 2012 7:15 PM
    Sunday, December 16, 2012 7:15 PM

All replies

  • Can you mount it through the disk management MMC?
    Tuesday, August 28, 2012 5:12 PM
  • Yes, the Attach VHD works fine from the Disk Management MMC.


    Doug

    Wednesday, August 29, 2012 3:22 PM
  • Hi,

    Windows 8 RTM Enterprise can mount VHD also. Just like mount ISO file, double click VHD file.

    What the detail error message did you receive when you mount VHD? Please try to mount another VHD file to see if the same issue occurs.

    Regards,

    Leo   Huang


    Leo Huang

    TechNet Community Support

    Thursday, August 30, 2012 6:06 AM
  • A dialog pops up, asking "How do you want to open this file".  You can then do a search for the application to try and open it.

    When I looked the default programs for .VHD - it says Unknown Program.  For ISO the default program was File Explorer.  I tried to assign explorer.exe as the default.  It said that program was not able to open that file type.

    On another Windows 8 Enterprise machine this works fine.  It has explorer.exe set as the default.  I checked the properties on both files.  There are the same.

    I do not want to re-install the Windows 8 system. 

    Doug


    Doug

    Thursday, August 30, 2012 12:58 PM
  • Hi,

    Did this issue occur before? And does your machine cannot mount all VHD files?

    I suggest to create another administrator account and login to see if the same issue occurs.

    If the issue persists, try to perform a system refresh for test.

    Regards,

    Leo   Huang


    Leo Huang

    TechNet Community Support

    Friday, August 31, 2012 6:29 AM
  • Before what?  With Win 8 installed I can not mount any VHD files. 

    Other Admins has the same problem.

    What do you mean a system refresh?

    Doug


    Doug

    Wednesday, September 05, 2012 7:45 PM
  • Win+C---settings---Change PC settings---General---Refresh your PC without affecting your files

    Regards,

    Leo   Huang


    Leo Huang

    TechNet Community Support

    Thursday, September 06, 2012 2:51 AM
  • Clearly doing a system refresh is not desirable.

    It would be nice to find something less interruptive.

    But thank you for the idea.

    Doug


    Doug


    • Edited by DougB12345 Thursday, September 06, 2012 7:40 PM
    Thursday, September 06, 2012 7:37 PM
  • Clearly doing a system refresh is not desirable.

    It would be nice to find something less interruptive.

    Doug


    Doug


    Yeah you just need to find the correct regedit value to edit and set it to the default value.
    Thursday, September 06, 2012 7:38 PM
  • Hey, I was just wondering if anyone had figured this out?  I am having the exact same problem.  .ISOs mount like they are supposed and their default application is File Explorer, but I can't set .VHDs to use File Explorer and they do not mount automatically.  I can still do it through Disk Management but I work with .VHDs a lot and it would be really great to have an easier system for mounting them.

    EDIT: Hey just in case you guys come back or someone else finds this, I figured it out mostly.  AnthonyDa was right, you do have to edit the registry.  As always when editing the registry I backed up the key that was already there before changing anything

    In my case I went to Computer\HKEY_CLASSES_ROOT\.vhd and in there is the default string value, I changed the data to Windows.VhdFile (I have no idea if that's right I just modeled it after the .iso one which was working).  I created a key under .vhd called "OpenWithProgids" and under that key there are two string values, the (Default) with (value not set) and I created a string value called Windows.VhdFile and didn't enter anything for data.

    No idea if any of that is actually what it's supposed to be, I modeled everything off of like at the registry values for .iso and .img

    That should add Windows Explorer as a possibility to the default application list.  After I selected that, I can right click and mount the .VHDs.

    Friday, November 16, 2012 10:08 PM
  • I also had the same problem and based on the post above, I checked the registry. It turned out that Virtualbox had altered the values. After changing the default value to Windows.VhdFile, everything was back to normal.
    • Proposed as answer by AnthonyDa Sunday, December 16, 2012 1:36 PM
    • Marked as answer by DougB12345 Sunday, December 16, 2012 7:15 PM
    • Unmarked as answer by DougB12345 Sunday, December 16, 2012 7:15 PM
    Sunday, December 16, 2012 10:56 AM
  • This fixed miy problem.

    I found this in some blog:

    In case it helps you, I just noticed that because I had WinZip associated with the .iso file extension (left over from the Windows 7 instance I upgraded), the Mount option did not show up in Explorer (and the Ribbon bar tab didn't show up when I selected either). But when I right-clicked on an .iso file and chose Properties, then clicked the Change button (next to "Opens With") and selected Windows Explorer as the program to associate with the .iso extension, suddenly the Mount option showed up on the right-click context menu and the ribbon bar tab did, too.

    Fixed my problem.


    Doug

    • Marked as answer by DougB12345 Sunday, December 16, 2012 7:15 PM
    Sunday, December 16, 2012 7:15 PM
  • Hey, I was just wondering if anyone had figured this out?  I am having the exact same problem.  .ISOs mount like they are supposed and their default application is File Explorer, but I can't set .VHDs to use File Explorer and they do not mount automatically.  I can still do it through Disk Management but I work with .VHDs a lot and it would be really great to have an easier system for mounting them.

    EDIT: Hey just in case you guys come back or someone else finds this, I figured it out mostly.  AnthonyDa was right, you do have to edit the registry.  As always when editing the registry I backed up the key that was already there before changing anything

    In my case I went to Computer\HKEY_CLASSES_ROOT\.vhd and in there is the default string value, I changed the data to Windows.VhdFile (I have no idea if that's right I just modeled it after the .iso one which was working).  I created a key under .vhd called "OpenWithProgids" and under that key there are two string values, the (Default) with (value not set) and I created a string value called Windows.VhdFile and didn't enter anything for data.

    No idea if any of that is actually what it's supposed to be, I modeled everything off of like at the registry values for .iso and .img

    That should add Windows Explorer as a possibility to the default application list.  After I selected that, I can right click and mount the .VHDs.

    A+++ yes.

    worked! ty

    Tuesday, February 26, 2013 2:33 AM
  • My last reply resolved my issue.  I think I marked it as a solution.

    Hope it works for you.


    Doug

    Tuesday, February 26, 2013 3:28 PM
  • Thanks jjafolla. That worked for me, too. XenCentre had taken over the VHD settings. This registry changed worked perfectly to resolve it.
    Wednesday, June 26, 2013 1:12 AM
  • Press Windows Key + X key

    Click Disk Management

    In Disk Management click on Action --->

    click on  Attach VHD -->

    click on browse -->

    click on .vhd file -->

    click open -->

    click on OK.

    Hope this helps someone.

    Sunday, December 29, 2013 6:30 AM