none
error code 0x80070522

    Question

  • I was trying to copy a file from d-drive >>> c-drive (vista ultimate) and received the following error code 0x80070522.

    I tried resetting to full control in security tab for properties of each drive  but to no avail.

    I know what that MAC advertisement is on about now. Coming to a sad realisation...

     

    Any help is always appreciated.

     

    blavatsky

     

    rca08207@bigpond.net.au

    Monday, June 11, 2007 4:48 AM

Answers

  • Hi,

    Make sure you have administrator privilages then try to disable UAC from Control Panel, it should work.

     

    Good luck

    Tuesday, June 19, 2007 1:05 PM

All replies

  • Hi,

    Make sure you have administrator privilages then try to disable UAC from Control Panel, it should work.

     

    Good luck

    Tuesday, June 19, 2007 1:05 PM
  • Hi,

     

    That is by design and is a function of User Account Control (UAC) and the
    ACL on the root of the drive. The ACL permits only Administrators and System
    from writing files to the root of the drive. UAC means that even if you are a
    member of the Administrator's group you do not run as an administrator unless
    you elevate.

    If you really want to, you can launch whatever process you use to write the
    files with as an administrator and then you can write there. If you try to
    drag and drop a file there you get an elevation prompt. The recommended
    solution is to not store data there though.

    or

     

    If you really are adamant about storing files in the root of the C: and you do not want to
    elevate each time, you can resolve the situation by adding an access control
    list entry for your account to the root of the drive, as follows:
    1. Click the Window button:All Programs:Accessories
    2. Right-click on Command Prompt
    3. Select Run as administrator and accept the prompt
    4. Run this command: icacls c:\ /grant fooSadOI)(CI)(M)

    That will grant the user foo modify permissions on c:\. All objects (OI) and
    containers (CI) will inherit those permissions. You would need to replace foo
    with the name of your user account.

    Once you do that any application you run as user foo will be able to store
    data in the root of the C: drive. You will also have losened a default
    security setting, with all the caveats that entails.

     

     blavatsky wrote:

    I was trying to copy a file from d-drive >>> c-drive (vista ultimate) and received the following error code 0x80070522.

    I tried resetting to full control in security tab for properties of each drive  but to no avail.

    I know what that MAC advertisement is on about now. Coming to a sad realisation...

     

    Any help is always appreciated.

     

    blavatsky

     

    rca08207@bigpond.net.au

    Sunday, June 24, 2007 7:40 AM
  •  

    "icacls c:\ /grant fooOI)(CI)(M)"

     

    I have this problem too, but I can't see the command..The smiley face is in the way...

    Monday, November 26, 2007 6:06 AM
  • Following what the Live Messenger smiley's shortcut, it should be
    icacls c:\ /grant foo:(OI)(CI)(M)


    Cheers.
    Thursday, April 03, 2008 7:25 AM
  • I have the same problem.
    I tried to disable the UAC, set to full control the c:\ permissions and the same error persist.


    I don´t no more what to do.  I think the vista have more one policy to denied this access....

    Please help me!!!
    Tuesday, June 03, 2008 2:43 PM
  • ok on the c: drive you cannot do more than disabling for good uac and try again, but in any other drive that does not have an os installed, try taking off all the security perimssions on all the files and add everyone with full control access, the same error appeared to me and i am using windows 7 beta, and i fix it doing that, i hope it works for you!!! ^_^_^!!!
    Thursday, January 29, 2009 8:14 AM
  • THANKS DEAR, DISABLING UAC FROM CONROL PANEL REALLY WORKED
    Wednesday, July 29, 2009 6:21 AM