none
Not working: Folder Options -> View -> Hide empty drives in the Computer folder

    Question

  • My laptop has a built in SD card reader.  I just installed Windows 7 x64 Ultimate Edition and have installed all available Window updates.

    When I go to:

    Control Panel -> Folder Options -> View "tab"

    and uncheck the box for "Hide empty drives in the Computer folder", the SD card reader still does not appear when I go into the Computer folder.

     

    I have also tried going into the registry:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

    to change:

    HideDrivesWithNoMedia

    from 1 to 0, but that does not work either.

     

    Can someone please help me get my SD card reader to appear in the Computer folder even when there is no card inserted into it?

    Thanks.

    Friday, August 20, 2010 1:54 PM

Answers

  • The card readers on my desktop computer (one connected internally via a USB header on the motherboard), one on my monitor and one on my printer all work the way they should.  When "Hide empty drives in the Computer folder" is checked, none of them are visible in the Computer folder.  When "Hide empty drives in the Computer folder" is unchecked, they all become visible.

     

    The card reader in my laptop is connected internally via micro-USB, but it's different.  It does not actually appear in the Device Manager until a card is inserted into it.

    That's probably why the "Hide empty drives in the Computer folder" does not work with my laptop's card reader.

    • Marked as answer by IsLNdbOi Monday, August 23, 2010 2:12 PM
    Monday, August 23, 2010 2:11 PM

All replies

  • Hi,

    Thanks for posting in Technet.

    What is the model of your computer and card reader? You may need to download the latest Windows 7 compatible driver for the card reader from the manufacturer website and install it to resolve the issue.

    Arthur Xie
    TechNet Subscriber Support in forum 
    If you have any feedback on our support, please contact tngfb@microsoft.com.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Monday, August 23, 2010 7:34 AM
    Moderator
  • It is an Acer Aspire 1810T notebook.  I do not know what the card reader is.

    This feature (showing empty drives in the Computer folder) has worked before.  It's now that I've done a clean install of Windows 7 Ultimate x64 that it has started to not work.

     

    Clean install of Windows 7 Ultimate x64 w/ all available Windows updates installed.

    Monday, August 23, 2010 8:30 AM
  • Once you've made the empty drives visible via settings, have you inserted a SD card into it?  The reason I ask is the card reader is the sort of device that only presents itself to the system once media has been installed.  In other words, it might need media to"kick off" the process of being able to show the drive from that point forward.

    DAS

    Monday, August 23, 2010 1:50 PM
  • The card readers on my desktop computer (one connected internally via a USB header on the motherboard), one on my monitor and one on my printer all work the way they should.  When "Hide empty drives in the Computer folder" is checked, none of them are visible in the Computer folder.  When "Hide empty drives in the Computer folder" is unchecked, they all become visible.

     

    The card reader in my laptop is connected internally via micro-USB, but it's different.  It does not actually appear in the Device Manager until a card is inserted into it.

    That's probably why the "Hide empty drives in the Computer folder" does not work with my laptop's card reader.

    • Marked as answer by IsLNdbOi Monday, August 23, 2010 2:12 PM
    Monday, August 23, 2010 2:11 PM
  • Go to 'Services' and check if 'Shell Hardware Detection' is running. If its disabled then set it to automatic.

    Thursday, April 05, 2012 7:31 PM