none
Code 80072F78 - Windows Update encountered an unknown error.

    Question

  • I just did a clean install of Windows 7 RC 64bit on my desktop computer. Initially everything worked fine and I was able to obtain updates without issue from Windows Update. Then I installed Office 2007 with SP2 and ran Windows Update again to get the various other updates I knew were available for Office 2007 help files and the Powerpoint security patch.

    However, now whenever I run Windows Update it informs me of the available updates, but when I attempt to install them I keep getting the error:
    Code 80072F78 - Windows Update encountered an unknown error.

    Following the online help everything I found seems to suggest this is a network issue but I don't have any problems communicating either on my local network or the internet. I'm using the built in Firewall with default settings but no third party firewall and I tried disabling my Antivirus (nod32). Nothing seems to help. If I repeatedly hit the Try again button it eventually does install some but not all of the updates. Doing this I'm down to only 2 uninstalled updates from 13 but it's a pain and very slow since it needs to create a restore point before each install.

    It doess seem like the issue is with downloading the updates rather than installing them because as I watch the progress it craps out after downloading a few percent. If it gets far enough it seems like it maanges do download some of the updates so then goes on to install them.

    I have a laptop running the same OS on the same network and it's had no problem with updates.

    Any suggestionts?

    Thanks!
    Monday, May 18, 2009 4:26 PM

Answers

  • The problem is most likely in NOD32.  Go into your advanced settings and deselect active mode for the svchost.exe in the web access protection and try to update again.

    • Marked as answer by SaMcp1123 Monday, June 08, 2009 3:12 PM
    Wednesday, June 03, 2009 11:07 PM

All replies

  • The problem is most likely in NOD32.  Go into your advanced settings and deselect active mode for the svchost.exe in the web access protection and try to update again.

    • Marked as answer by SaMcp1123 Monday, June 08, 2009 3:12 PM
    Wednesday, June 03, 2009 11:07 PM
  • Hello Magritte,

    This sounds like possible corrupted, broken or missing.  Open an administrative command prompt and type sfc /scannow.  Have your Windows 7 RC disk handy in case there are errors as it will require the disk to repair the files.
    Thursday, June 04, 2009 1:13 AM
  • Hello Magritte,

    This sounds like possible corrupted, broken or missing.  Open an administrative command prompt and type sfc /scannow.  Have your Windows 7 RC disk handy in case there are errors as it will require the disk to repair the files.

    Thanks. I gave it a try but no errors were reported.
    Thursday, June 04, 2009 4:21 AM
  • The problem is most likely in NOD32.  Go into your advanced settings and deselect active mode for the svchost.exe in the web access protection and try to update again.


    Interesting. I looked at my laptop which hasn't had update issues and NOD32 didn't have active mode enabled for svchost.exe, but the desktop did. So this may really be the cause.

    I'm going to leave it enabled to see if the next update fails, then disable it to see if it really explains the issue.

    Thanks!
    • Proposed as answer by Intergen Sunday, July 29, 2012 12:28 AM
    Thursday, June 04, 2009 4:23 AM
  • Thanks! I had the same problem for the last month, y disable de Active Mode for the svchost.exe in NOD32 and now it works.

     

     

    Monday, April 26, 2010 2:31 PM
  • Hey, I just fixed this issue: it's not my internet connection NOT my date time settings etc. etc. Even though we do not need proxy, I still checked "Use a proxy server....." in internet options->connections->lan settings in IE No need to fill in Address for proxy and just live the port to 80 Then I started windows update...voila it worked. FYI This is in my laptop Acer 4743G - Windows 7 64bit
    Thursday, March 24, 2011 2:09 PM