none
Cisco RVS4000 - QuickVPN client on Windows 7 Ultimate 64bit

    Question

  • Hi, I've recently purchased a Cisco / Linksys router RVS4000 VPN. The only reason I got this model was to use the VPN connection from my laptop.

    I am running the latest version of QuickVPN (1.4.1.2) on Windows 7 Ultimate 64bit on the client computer. Somehow it seems that's impossible to communicate with the router. When starting QuickVPN, the connection stalls at "Verifying Network" then it all ends with "The remote gateway is not responding. Do you want to wait?".

    I spent quite a bit of time talking with Cisco technical support, and their conclusion was that it's because of Windows 7 Ultimate. I was told that any version of Windows 7 works, except for the Ultimate. Or at least they don't know what extra layer of security Windows 7 Ultimate might have that doesn't allow the comunication.

    Is there anybody having a solution for Win7 Ultimate?

    Thank you,

    Alin

    Thursday, October 14, 2010 11:55 AM

Answers

  • Hi Miya,

    Thank you for your reply. I've done a lot of tests during these past days and narrowed down the problem to the network setup. I was successful connecting using QuickVPN on my laptop from a couple of locations, while from the workplace I cannot. The only difference between success and failure was the network, since I didn't change anything on my laptop.

    My only confusion here is that from the same workplace I can connect without a problem using a desktop running Windows XP. The thing is that once logged in domain, the Windows firewall gets turned off automatically by the "Domain Policy". Reading different forums, the general idea was that for QuickVPN to work, Windows Firewall needs to be turned on for Win 7 and off for XP. This could explain why XP works and 7 not on the same network.

    Having said that, I believe that my issues have nothing to do with the Windows version, but with the network. As I've posted the same thing on Cisco's forum website I'll continue working with them and I think that we should close this thread here.

    Thank you again,

    Alin

    Friday, October 22, 2010 11:41 AM

All replies

  • Hi,

     

    Thanks for the post!

     

    I search the problem you encountered, it’s a common issue, not only on Windows 7 Ultimate. Most of them are related to firewall is misconfigured or the IPSec service is not running on the computer. You can refer to this thread: http://www.linksysinfo.org/forums/showthread.php?t=42553

     

    Hope it helps!

     

    Please Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

     

    Regards,

    Miya


    This posting is provided "AS IS" with no warranties, and confers no rights. | Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Miya YaoModerator Friday, October 22, 2010 4:47 AM
    • Unmarked as answer by AlinF Friday, October 22, 2010 11:22 AM
    Monday, October 18, 2010 7:26 AM
    Moderator
  • Hi Miya,

    Thank you for your reply. I've done a lot of tests during these past days and narrowed down the problem to the network setup. I was successful connecting using QuickVPN on my laptop from a couple of locations, while from the workplace I cannot. The only difference between success and failure was the network, since I didn't change anything on my laptop.

    My only confusion here is that from the same workplace I can connect without a problem using a desktop running Windows XP. The thing is that once logged in domain, the Windows firewall gets turned off automatically by the "Domain Policy". Reading different forums, the general idea was that for QuickVPN to work, Windows Firewall needs to be turned on for Win 7 and off for XP. This could explain why XP works and 7 not on the same network.

    Having said that, I believe that my issues have nothing to do with the Windows version, but with the network. As I've posted the same thing on Cisco's forum website I'll continue working with them and I think that we should close this thread here.

    Thank you again,

    Alin

    Friday, October 22, 2010 11:41 AM
  • Hi,

    I had the exact same problem and both the Cisco guy and myself concluded that my ISP was blocking the ports used by IPSec. But before i contacted my ISP to check with them I noticed there was new firmware released for my router. I upgraded and all of a sudden everything started working.

    give that a Try

     

    Hossein

    Thursday, February 10, 2011 11:13 PM
  • I purchased Cisco WRN210 which supports 10 VPN connections. I did many test. talk to five different cisco support. They suggested that my ISP blocked ports. After I spent 2 hours talking to three comcast support I conclude it's not the ISP problem. So far the VPN client works with XP, Win7 Ulti 32 but not Win7 Ulti 64. I installed two brand new Windows use the same Windows installation CD, 32Bit windows works but not 64Bit windows. But at least three of the five cisco support insist the newest QuickVPN client 1.4.1.2 should work with any Windows 7. In the end none of those tech support can get their lab PC Windows 7 64bit to work. They blame their lab PC Windows got messed up. I believe they new client software simple does not work with 64bit Windows. Cisco support finally believe my router is bad get it replaced with a new one. But the result is the same. May be there is something on the Windows need to be configured. I already try many different firewall settings. So far no luck. I keep trying.
    Saturday, February 19, 2011 5:47 AM
  • Reinstall you Windows 7 Ultimate in x86(32bit) mode should work. It works for me but not 64bit.
    Wednesday, March 02, 2011 3:44 AM
  • This post are very helpfull! Really windows firewall must be on , but on my laptop eset firewal must be off (or may be tunned). This magicaly turns on VPN functions of QuickVPN !!!

    Thanks!

    Sunday, June 12, 2011 2:27 PM
  • hai miya,

                  Thanks for your suggestion, i had the same issue going through your forum it relay helped me. Thank you again

     

    Regards

    Ramalingam.S

    Thursday, September 29, 2011 4:14 AM
  • Folks, i'm having hack of a time with QuickVPN working on Windows 7.  I have the follwoing configuration on my laptop:

    Windows 7 Ultimate - Service Pack 1

    Windows Firewall is on

    IPsec Service is running

    QuickVPN 1.4.1.2 is installed

    Router on my end is varifed to allow IPsec

     

    I was able to connect with Windows XP before.  Any hints would be appreciated.

    Sunday, December 25, 2011 9:33 PM
  • Similar problems... Noticed the following

     

    Cannot get QuickVPN to work from the Windows 7 Professional 64 bit.

    Hower it will run from a Windows XP Virtual PC running as a guest under the Windows 7 Professional 64 bit.

    Noted that the failures seem to be related to the 'wget' tests that are performed after the connection has been established.. Check the log and wget files in the QuickVPN installation directory for more info

    Saturday, December 31, 2011 10:46 PM
  •  Hello everyone,

    Some things to be aware of...

    Router Requirements:

    1. Depending on the device Remote Management needs to be on and configured for port 443 or 60443.
    2. Users need to be created and enabled.
    3. Only One Connection per User Account.
      1. Username and passwords must match and are case sensitive.
    4. Local Network Subnet must be different than Remote Network Subnet.
    5. If using Certificate the .pem file needs to be exported and placed under the “C:\Program Files\Cisco Small Business\QVPN Client” folder.

    Microsoft XP SP3 (until 2014)

    1. Must be running Service Pack 3
    2. Must have the Windows Firewall Off (you can have the firewall on but ICMP Echo Requests are required inbound through the software Firewall for a connection to establish.)
    3. Must have IPSec Services Running

    Windows Vista/ 7

    1. QuickVPN must run Vista Service Pack 2 or run in Vista Service Pack 2 compatibility for Windows 7.
    2. Windows Firewall needs to be on. (Other Firewall software will interfere.)
      1. Add ICMP rules to the Windows Firewall.
    3. Must have IPSec Services Running.
    4. You can test QuickVPN in safe mode with networking on Windows 7. XP will not because IPsec services will not start. (Note some antivirus and other programs will still run in safe mode.)

    The QuickVPN Utility is just a front end interface that allows for a user friendly interface on configuring the Microsoft IPSec service to connect to the router. (That’s why it doesn’t work on any operating system but Microsoft.)

    First the client connects using SSL to the router and looks for a certificate.

    If you are using a certificate it in needs to be installed or you can click no and bypass the certificate warning.

    The next step authenticates the user name and password supplied to the router. Only one client per username can be logged in at one time. Once the user authenticates the IPSec tunnel will negotiate and establish. (Up until this point if anything fails you will get the 5 error message screen.)

    At this point the client sends an ICMP Echo Request through the tunnel to the internal IP address of the router. (Yes, if you look the user is connected in the status of the routers interface for the tunnel.) The inside IP address determined during the authentication phase. The router sends an ICMP Echo Reply back through the tunnel to the client. (If this fails you will get the error Remote Gateway not responding.)

    Out of the server thousand QVPN issues I have trouble shot it is 90%, or more the client’s windows firewall. The other 5% is third party software or firewall, 3% is customers using the same IP subnet on both sides of the tunnel, and the last 2% is configuration issues on the router.

    Software like Windows Defender and other Antivirus and software will modify the TCP/IP stack and the security of the operating system. Some of these software’s will run in safe mode and others modify settings that even if removed from the computer will continue to prohibit the QuickVPN process.

    Since XP, Microsoft has continued to make their operating systems more secure. The more secure you make something the more user unfriendly, and more productivity prohibiting it becomes. We all want our environment secure, but everyone’s environment is different, and manually changes must be made to allow traffic that we want to work through this added security.

    I would like for Microsoft to comment on this thread and confirm that by default Windows 7 is a more secure operating system then XP, and will block ICMP from other subnets than its own by default.


    • Proposed as answer by TechGeek123 Thursday, February 09, 2012 8:23 PM
    • Edited by TechGeek123 Thursday, February 09, 2012 10:49 PM
    Thursday, February 09, 2012 5:59 PM
  • The original post is dated 2010 but TechGeek123, you've written a comprehensive answer in 2012.

    Thanks. Your post is the best info there is to this problem.

    Thanks again.

    btw, is there any way the VPN connection can be done manually without using the VPNClient software?

    Friday, February 17, 2012 1:29 AM
  • I was told at one time there was a document that showed you how to do it, but I haven't been able to find it on our network. I will ask around and see if we can find it. Now it might only be good for XP but I will check.

    Friday, February 17, 2012 4:40 PM
  • I have been asked to provide the steps to setup ICMPv4 rules on the Windows 7 and Vista firewalls. Note this is opening up the firewall on the computer to potential attacks and should be done at ones own risk. If you have an edge firewall you will greatly reduce the risk from the internet. Also note that Some programs including Windows Defender will remove the rules periodicly so this might have to be re-entered from time to time.

    Setting up Windows ICMPv4 Firewall rules on Windows 7 & Vista

    1. First you will need to open up Network and Sharing Center; you can do this by going to the Control Panel or right clicking on the network adapter icon in the lower right by the time.
    2. Click on Windows Firewall Link.
    3. Click on the Advanced Settings .
    4. Click on the Inbound Rules .
    5. Click on New Rule .
    6. Choose Custom Rule, then click Next .
    7. Choose All programs then click Next .
    8. Choose ICMPv4 from the Protocol type: pull down then click Next .
    9. Choose Next
    10. Make sure Allow the connection is selected and click Next .
    11. Name the Firewall rule appropriately and click Finish. Repeat steps 4 thru 11, but name the rule ICMPv4 Out or something.
    • Edited by TechGeek123 Thursday, February 23, 2012 3:41 PM Easier to read
    Thursday, February 23, 2012 3:38 PM
  • Please note the following:

    WRVS and RVS routers need the remote management port to be 8080 or something other than 443 or 60443 if it is enabled.


    Friday, March 16, 2012 8:15 PM
  • with all due respect this is silly... PING works out of the box on all Win 7 platforms with or without Defender or Security Essential from MS. 

    This is not the problem with QuickVPN. The issue is that the ping to the remote router internal IP address is not going out the right network interface or is being dropped on the way to or from the remote router. While I am having the same QuickVPN issues with Verifying remote network, I can ping the remote gateways external WAN address.... so ping and ICMP are all ok. The issue is something else.

    Sunday, November 18, 2012 1:22 AM
  • Hey tzo4tzo, I here ya.  Check out my situation I posted on Cisco's website and haven't ever heard an answer either.

    Nov 19, 2012 8:06 PM (in response to kyle traynor)
    RVS4000 QuickVPN "The remote gateway is not responding. Do you want to wait?"

    Here's my situation, which actually shows that I don't think anyone here knows the true answer... unless I'm missing something, which is entirely possible.

     

    I have a laptop with 64-bit Windows 8 Pro installed.  Installed QuickVPN and didn't really expect it to work.  I previously had 64-bit Windows 7 Ultimate and I was successfully connecting to my RVS4000.  I didn't even have to alter my configuration with Win7.  Anyway, as expected, I was getting the "Remote gateway is not responding. Do you want to wait?" message when I tried under Win8.  I went through all of the items listed in various other discussions, including setting compatibility mode to Vista SP2 for QuickVPN, opening ICMPv4 in my firewall, configuring my RVS4000 correctly, having a different subnet mask, etc.  I still couldn't connect and received the same message.

     

    Well today I was at a coffee shop that had free wifi.  It was totally open with no encryption or anything.  I connected to it and set it as a Public connection in Windows.  Just for the heck of it I started up QuickVPN and tried to connect to my RVS4000.  To my surprise it worked!  I could get to my server and other computers on my home network without any problems.

     

    Now here's the interesting part.  I carry around my VerizonWireless 4G Jetpack for times I need an internet connection when none are available.  Basically it is a wireless access point.  I've gone through it and set the subnet mask different from my home network too.  Well I disconnected from the coffee shop wifi and did not change ANYTHING on my laptop.  I connected to my 4G Jetpack access point, started up QuickVPN and tried to connect to my RVS4000.  Not successful.  It returned the same dreaded message as above.  I went back into my access point and turned all security on it off, similar to the coffee shop's, and set it as a Public connection in Windows.  Still couldn't connect.  At this point, everything from what I could see was set the same between my wifi and the coffee shop's, but I could only get a VPN connection using the coffee shop's wifi.

     

    I tried all kinds of other settings, but to no avail.  I went back and connected to the coffee shop's wifi and everything continued to work with QuickVPN.  Since I did not change any setting on my laptop and could get a VPN connection through the coffee shop's wifi and not my own 4G access point, I know it is nothing with my laptop configuration, nor my RVS4000.  What is the REAL problem here?  Does anyone really know the true answer, or does anyone care to figure it out?

     

    This is very frustrating, and based on other discussion boards and this one, others are very frustrated too with no answers.  Any help would really be appreciated.  Thanks!

    Friday, November 23, 2012 9:47 PM
  • @JoeyBag Did you found any answer for this?
    • Edited by Ishaq Hasham Thursday, September 25, 2014 10:59 AM Adding tag
    Thursday, September 25, 2014 10:58 AM