none
COM Surrogate has stopped working

    Question

  • I've read the posts about this and nothing is working for me.

    I started getting this message a few weeks ago.  It comes up whenever I go into the folder I have video files stored in.  It pops up, telling me the COM Surrogate has stopped working and allows me to close the box - and when I do, another one comes up telling me the same thing, etc etc.  I have upgraded Divx, I don't have Nero, searches don't seem to bring back any results for Urge (all common causes it seems) so I don't know what to do.


    This is the first actual problem/annoyance I've had with Vista so far.

    Searches on Google have said that the Vista Codec Package is a fix for it, but I don't want to risk downloading this from some random site - especially if it's not going to work.


    Thanks in advance for any help.

    Friday, May 09, 2008 9:35 AM

Answers

  • Nathan

     

    Try this fix. 

     

    Go to Start. 

    Right click on Computer, and select Properties.

    Click on Advanced System Settings, click the Advanced Tab,

    In the Performance section, click Settings.

    Select the "Data Execution Protection" tab, and then click the 'Turn on DEP for all programs and services except those I select' option.

    Click the Add button, and then browse to C:\Windows\System32\dllhost.exe

    Click Open, click OK on the warning message.

    Click Apply/OK.

     

    Try to access one of those folders again.

     

    Let us know the results.

     

     

     


    If this post helps to resolve your issue, click the Mark as Answer button at the top of this message.
    By rating a post as Answered, you help others find the answer more quickly.


    Ronnie Vernon
    Microsoft MVP
    Windows Desktop Experience

    Friday, May 09, 2008 6:58 PM
    Moderator

All replies

  • Nathan

     

    Try this fix. 

     

    Go to Start. 

    Right click on Computer, and select Properties.

    Click on Advanced System Settings, click the Advanced Tab,

    In the Performance section, click Settings.

    Select the "Data Execution Protection" tab, and then click the 'Turn on DEP for all programs and services except those I select' option.

    Click the Add button, and then browse to C:\Windows\System32\dllhost.exe

    Click Open, click OK on the warning message.

    Click Apply/OK.

     

    Try to access one of those folders again.

     

    Let us know the results.

     

     

     


    If this post helps to resolve your issue, click the Mark as Answer button at the top of this message.
    By rating a post as Answered, you help others find the answer more quickly.


    Ronnie Vernon
    Microsoft MVP
    Windows Desktop Experience

    Friday, May 09, 2008 6:58 PM
    Moderator
  • Hey Ronnie

     

    Thanks a million, the fix has worked for me. 

     

    I got a warning regarding viruses, should I do anything to avoid this?

     

    Thanks again

    Sunday, October 26, 2008 12:40 AM
  • Hey Ronnie

     

    Can you please help me with my com surrogate your option did not fix my computer.

     

     

    José

     

    Monday, November 03, 2008 1:13 PM
  • This fix is simple Jose.  Just have one codec pack on your system (CCCP is the best) so have a look around to see if you have inadvertantly installed others as backup.  Uninstall them and reboot.  Job Done!

    Sunday, November 30, 2008 1:09 PM
  • nathan2551 said:

    I've read the posts about this and nothing is working for me.

    I started getting this message a few weeks ago.  It comes up whenever I go into the folder I have video files stored in.  It pops up, telling me the COM Surrogate has stopped working and allows me to close the box - and when I do, another one comes up telling me the same thing, etc etc.  I have upgraded Divx, I don't have Nero, searches don't seem to bring back any results for Urge (all common causes it seems) so I don't know what to do.


    This is the first actual problem/annoyance I've had with Vista so far.

    Searches on Google have said that the Vista Codec Package is a fix for it, but I don't want to risk downloading this from some random site - especially if it's not going to work.


    Thanks in advance for any help.



    don't do stupid like they said, I got the same problem and learned from those advice make thing more crazy, and if you do like Nathan said, your windows media no more working with .avi files, it just turn off the message as well.  This is windows Vista setup problem and what you have to do just go to control panel and Folder options, then View and take out the check mark from the box say Display file icon on thumnails, that's it
    Dan
    Saturday, December 20, 2008 8:49 AM
  • thank u Ronnie Vernon it works  for me yepie!!
    Sunday, March 29, 2009 3:54 PM
  • I have tried all of the above and it still does not work.  In fact, it now shows the error message as soon as I start up the computer.  Doesn't wait until I get into the folder any more.
    Once in the folder holding video files, I get the "COM Surrogate has stopped working" every few seconds.

    Otherwise, my Vista is working well.  This issue has been going on for well over a month now and I have attempted both of the above fix options on several occassions.  None of the attempts have worked and today I started getting physical with the keyboard.


    Please, Please, Please can someone come up with a fix for this problem?  If not by altering a setting, then by a patch of some kind.

    Thanks,

    Col...
    Saturday, April 04, 2009 8:04 AM
  • I have tried all of the above and it still does not work.  In fact, it now shows the error message as soon as I start up the computer.  Doesn't wait until I get into the folder any more.
    Once in the folder holding video files, I get the "COM Surrogate has stopped working" every few seconds.

    Otherwise, my Vista is working well.  This issue has been going on for well over a month now and I have attempted both of the above fix options on several occassions.  None of the attempts have worked and today I started getting physical with the keyboard.


    Please, Please, Please can someone come up with a fix for this problem?  If not by altering a setting, then by a patch of some kind.

    Thanks,

    Col...

    Did you take off the check mark at the box Always show icons, never thumbnails ???
    Dan
    Saturday, April 04, 2009 5:09 PM
  • Unfortunately, yes.  I was un-checked.  No difference before/after.

    I have just tried resetting the "default settings" in the hope that it makes a difference.

    Col...
    Saturday, April 04, 2009 8:26 PM
  • Unfortunately, yes.  I was un-checked.  No difference before/after.

    I have just tried resetting the "default settings" in the hope that it makes a difference.

    Col...

    Is this link help you some how http://www.howtogeek.com/howto/windows-vista/fix-for-com-surrogate-has-stopped-working-error-in-vista/

    I have windows vista SP1, it was running fine until Nero 7 come in my system, and I have problem "COM Surrogate has stopped working". After so many researched I figured out, uncheck 2 boxes in folder options "Always show icons, never thumbnails" and "Display file icon on thumbnails", read these two sentences you can see the conflict by themself !!!

    Hope you can fix this problem soon!

    Daniel 
    Dan
    Saturday, April 04, 2009 9:59 PM
  • I have the same problem, related to COM Surrogate. I have been dealing with this really anoying problem for several weeks, and i'm getting tired of it. If this continues, i'm going back to good linux ubuntu, which excels in multimedia content  (almost flawless, even when rotating the 3d desktop cube).

    I was very disappointed after installing windows vista SP2 today in the morning, because it provided a temporary "solution" to this problem. For those of you who have this problem, the messages will disappear after installing SP2 because the explorer will switch to the ugly icons view instead of thumbnails. While this workaround will be useful for a few days, it is not a solution, but a simple trick.

    If you switch back to thumbnail view, the problem appears again, even after updating to SP2.


    To microsoft guys: Please provide a patch for Vista! this is really anoying because my laptop, which i use almost exclusively for entertainment, shows this message over and over when I open folders containing video files.

    By the way, the solution of Ronnie didn't work at all. It made things worse. My computer has hardware DEP, so i don't see why i should disable DEP to any program. Anyway, I disabled DEP to the COM Surrogate and the message didn't show anymore, but it resulted in explorer crashing a few seconds later on my computer, after that i decided to perform the windows update in the hope that the problem was already solved but nothing.

    Please post when the update is ready! I'm getting bored at home :(
    Tuesday, August 25, 2009 4:13 PM
  • THIS DOESN'T WORK. You can't Browse after hitting the add button. When I enter the file into the box, the file you are having problems with pops up and where are you to go from there? You are ABLE to get a virus or WORSE!
    Wednesday, September 02, 2009 4:51 AM
  • Thank you so much . It worked for me !!!!
    =)

    Princesa guacamole
    Sunday, November 08, 2009 3:05 AM
  • I've read the posts about this and nothing is working for me.

    I started getting this message a few weeks ago.  It comes up whenever I go into the folder I have video files stored in.  It pops up, telling me the COM Surrogate has stopped working and allows me to close the box - and when I do, another one comes up telling me the same thing, etc etc.  I have upgraded Divx, I don't have Nero, searches don't seem to bring back any results for Urge (all common causes it seems) so I don't know what to do.


    This is the first actual problem/annoyance I've had with Vista so far.

    Searches on Google have said that the Vista Codec Package is a fix for it, but I don't want to risk downloading this from some random site - especially if it's not going to work.


    Thanks in advance for any help.


    just install a codec pack............... cccp has worked just fine for me, click next on everything, do not tick or untic anything, just "next all the time" job done
    Thursday, November 12, 2009 2:27 PM
  • I get every thing but the one thing I don't get is where is the Performance section please any one help me I have windows Vista Ultimate 
    Wednesday, December 09, 2009 4:43 AM
  • Thank you, this really helps me  -so far-.

    My problem started right after downloading a program from CNET called KMPlayer.

    I did what you sugested, and it's working.

    I got a warning from the computer, saying about possible vulnerabilityes.

    But I did it anyway and so far so good.  
    Tuesday, December 15, 2009 11:20 PM
  • It tells me that You can not set DEP attributes on 64-Bit executables.

    My Windows Installation is 1 day old.

    Friday, October 14, 2011 7:49 PM
  • I have installed the CCCP and still having the problem.

    I have it when I open pictures not folders.

    I had not installed TheKMPlayer or Nero yet.

    Friday, October 14, 2011 8:10 PM
  • This may work in a windows 7 32bit but not in 64bit! :-(

    Monday, January 16, 2012 2:59 AM
  • Does this fix works's on Win7 64bit too?

    Tuesday, April 09, 2013 7:43 AM