none
Can't pin windows file explorer to taskbar

    Question

  • On a fresh install of Windows 8, windows file explorer is already pinned to the task bar on the desktop. I accidently unpinned this icon and now I cannot get it back. The logical way to do this is to go to the start screen, right click file explorer and choose the 'Pin to taskbar', but for some reason I don't get this option for file explorer. I can pin lots of other desktop applications, but just not file explorer. I work mostly from the desktop so it's really annoying to have to flick back to the start screen every time I want to start file explorer.

    Thinking I must be going mad, I tried the same thing on the Windows Server 2012 desktop and now I have exactly the same problem there!!


    Thursday, November 29, 2012 11:06 PM

Answers

  • Thanks for the suggestion Leo but that didn't work.

    However, I did chance upon a solution. It doesn't explain why this happens in the first place, but the following worked for me...

    1. From the start screen, right click on the 'File Explorer' shortcut and choose 'Open File Location' (at lower left). This switches to desktop mode and opens the folder containing the shortcut.
    2. Right click on the shortcut from here and choose properties.
    3. Change the target to "C:\Windows\explorer.exe"
    4. Clear everything from the Start In field and click OK.
    5. Right click on the shortcut again and now you have the option to 'pin to taskbar'.

    • Marked as answer by chamsoft Monday, December 03, 2012 11:07 AM
    Monday, December 03, 2012 11:06 AM

All replies

  • Try 'browser choice' again and reselect it.

    If on the desktop drag it to the taskbar.

    • Edited by d r h Thursday, November 29, 2012 11:57 PM
    Thursday, November 29, 2012 11:55 PM
  • Not sure what you mean by 'browser choice' - where is that?

    I can create a shortcut to file explorer on the desktop, but it's not possible to drag and drop it on the taskbar (I get the red circle mouse icon when dragging over the taskbar).

    Friday, November 30, 2012 1:19 AM
  • I also just reproduced this on another Windows 8 machine I have running under Hyper-V. I can resolve the problem by deleting my profile, so when I log back in windows creates a new default profile with file explorer pinned to the task bar. If I un-pin it with the new profile I once again lose the option to re-pin it.

    So it's definitely reproducible, but deleting the profile is not an acceptable solution.

    Friday, November 30, 2012 1:24 AM
  • So if you go into the Windows 8 Metro start screen, open up the charms bar, select search - and search for "file" - you should see the file explorer appear to the left. You should be able to then right-click it and select pin to task bar in the desktop.

    Are you saying that method doesn't work?

    Friday, November 30, 2012 1:27 AM
  • That's correct. The first part works - I can search for 'file' and the shortcut appears on the left, but when I right click on file explorer only 3 options appear at the bottom:

    1. Unpin from Start
    2. Open new window
    3. Open file location

    Also, when I used the search method just now to locate the shortcut I also see a shortcut for 'FileZilla'. If I right click on this icon I do get the option to 'Pin to taskbar', so it's something specific to file explorer.


    Friday, November 30, 2012 1:35 AM
  • Hi,

    Windows Explorer should has the option to pin to taskbar:

    If you don’t have this option, try to use SFC /scannow to check system files.

    Or you can perform a system refresh for test:

    Click Control Panel
    Click General on the left column
    Under the Refresh your PC without affecting your files, click Get started


    Leo Huang
    TechNet Community Support

    Monday, December 03, 2012 7:07 AM
    Moderator
  • Thanks for the suggestion Leo but that didn't work.

    However, I did chance upon a solution. It doesn't explain why this happens in the first place, but the following worked for me...

    1. From the start screen, right click on the 'File Explorer' shortcut and choose 'Open File Location' (at lower left). This switches to desktop mode and opens the folder containing the shortcut.
    2. Right click on the shortcut from here and choose properties.
    3. Change the target to "C:\Windows\explorer.exe"
    4. Clear everything from the Start In field and click OK.
    5. Right click on the shortcut again and now you have the option to 'pin to taskbar'.

    • Marked as answer by chamsoft Monday, December 03, 2012 11:07 AM
    Monday, December 03, 2012 11:06 AM
  • Solved my issue! Thanks
    Monday, December 31, 2012 9:51 AM