none
Can not push software via Group Policy

    Question

  • Trying to push software via Group Policy. XP Machines take the software fine. Windows 7 machines give the following:

    Event ID: 101: The assignment of application Adobe Flash Player 10 ActiveX from policy TestWin7Push failed.  The error was : %%1274

    Event ID: 103: The removal of the assignment of application Adobe Flash Player 10 ActiveX from policy TestWin7Push failed.  The error was : %%2

    Event ID: 108: Failed to apply changes to software installation settings.  The installation of software deployed through Group Policy for this user has been delayed   until the next logon because the changes must be applied before the user logon.  The error was : %%1274

    Event ID: 1112: The Group Policy Client Side Extension Software Installation was unable to apply one or more settings because the changes must be processed before system startup or user logon. The system will wait for Group Policy processing to finish completely before the next startup or logon for this user, and this may result in slow startup and boot performance

    no matter how many times you reboot the system, the software doesnt push. (again XP Machines are all fine)

    I tried setting in the policy: Always wait for the network at computer startup and logon - Enabled .... but that hasnt helped either

     

     

     

     

    Wednesday, June 23, 2010 3:52 PM

All replies

  • I am currently rolling out Windows 7 and have ran into the same issue. All Win7 clients have the exact same image. After I make a change or push software out, it seems all the XP clients work but random Win7 boxes get the stup 1274 error.  Some work and some don't..  its about 50/50. Like you, I have my wait for the network at computer startup enabled.

    The only workaround I have found is to delete the 'group policy' key found at hklm\software\microsoft\windows\currentversion\group policy. The machine reboots and reapplies all the assigned software. This no fix by any means. I would love to find the cause of this.

    Wednesday, June 23, 2010 6:56 PM
  • This issue occurs if the installation file is not compatible with UAC, because of that you cannot open the *.exe file on a network location unless you log on with a domain administrator account.

    If you turn off UAC this issue should not occur.


    Arthur Xie - MSFT
    Thursday, June 24, 2010 8:37 AM
    Moderator
  • UAC is turned off and still getting the issue
    Wednesday, June 30, 2010 3:35 PM
  • Same.  UAC was turned off on my Win7 image.  The image itself is about as vanilla as you can get otherwise.
    Wednesday, June 30, 2010 4:08 PM
  • I have the same problem. Is it possible that it has to do something with the language settings? The software got installed on english Windows 7 but not on a german OS. However it was installed on german Vista. Well, i try to set the advanced deployment option "Ignore language when deploying this package". Because the users are currently working I'll report tomorrow if that helped.

    Ralf

    Update:

    In our environment setting the advanced deployment option "Ignore language when deploying this package" solved the problem.

    • Edited by Ralias Wednesday, August 04, 2010 10:50 AM Update
    Tuesday, August 03, 2010 9:01 AM
  • Have you found a solution to this?

    I am working with the current release of flash and getting the same errors on win 7 machines. Also getting

     

    "The installation source for this product is not available.  Verify that the source exists and that you can access it"

    on win xp machines, which is weird because I installed the firefox msi no problem from the same directory.

    Friday, August 20, 2010 4:13 PM
  • I was able to fix this by enabling Computer Configuration > Policies > Administrative Templates > System > Group Policy > Policy > Startup policy processing
     
    Changed amout to wait (in seconds) to 30 
    I know it says it defaults to 30 seconds if left unconfigured but just enabling the policy worked for me ironically. After enabling the policy it defenitely fixed my problem on most every Windows 7 box we have. We now have startup scripts that actually run now as a result as well.
    • Proposed as answer by PhishJY Monday, November 15, 2010 6:33 PM
    Friday, October 29, 2010 7:50 PM
  • Thanks btenney!  That worked like a charm!

    Monday, November 15, 2010 6:34 PM
  • Alacar, Did you ever figure the answer?

    I've tried the solutions above, but they do not work.

    I'm seeing the exact same errors in your post,

    101
    103
    108
    1112

    Changing the wait time makes no difference, except reboots take a little longer now.

    Wednesday, January 19, 2011 1:19 AM
  • Thanks, though I'll also point out that I also had to 'redeploy' the application as a tip had pointed out elsewhere.
    Friday, March 04, 2011 3:39 PM
  • Thanks for this tip! It worked for me as well. 
    Tuesday, April 05, 2011 10:44 PM
  • Alacar -- did you ever get this issue solved? I am having the EXACT same problem.

     

    Windows 2003 active directory domain

    Windows 7 client machines

    Thursday, June 02, 2011 8:33 PM
  • I've noticed that installing Win 7 SP1 solve the problem
    Tuesday, July 05, 2011 4:55 PM
  • I was able to fix this by enabling Computer Configuration > Policies > Administrative Templates > System > Group Policy > Policy > Startup policy processing
     
    Changed amout to wait (in seconds) to 30 
    I know it says it defaults to 30 seconds if left unconfigured but just enabling the policy worked for me ironically. After enabling the policy it defenitely fixed my problem on most every Windows 7 box we have. We now have startup scripts that actually run now as a result as well.
    This did the trick for me!  Thanks for the help.  It does not make sense that this setting would need to be configured since 30 is the default.
    Saturday, July 30, 2011 7:33 PM
  • I had the same problem too and this also did the trick for me too...

    this is the link where I found the resolution

    http://mywinsysadm.wordpress.com/2011/07/22/windows-7-the-assignment-of-application-from-policy-failed-the-error-was/

    Monday, March 12, 2012 2:34 PM
  • I started to receive the same errors recently. Last week I was able to deploy the MBAM client MSI file through GPO to two different systems and this week the same GPO fails to deploy with the same error messages you are receiving. The system I am installing on is also a fresh image with not much on it but device drivers and all the latest MSFT updates.
    Thursday, June 07, 2012 11:14 PM
  • This worked perfectly for me.  I do agree that it seems a little off that by default it is 30 seconds but will not work unless you manually set it to 30.  Doesn't make since
    Tuesday, July 17, 2012 1:12 PM
  • btenney, thanks a lot. It solved my problem
    Thursday, July 18, 2013 12:48 PM