none
Windows 7 - 64bit - Problem with Mapped Network Drives locking explorer up.

    Question

  • We have two systems in the office running Windows 7. Both are laptops. One is running Win 7 Professional (64 bit) and one is running Home Premium (64 bit). After being connected to the network for a few hours, the explorer locks up when trying to access a mapped drive on the network. When this problem happens the computer becomes severely unstable.

    Has anyone seen this issue or know how to fix it??
    Wednesday, February 10, 2010 4:56 PM

Answers

All replies

  • I have a similar problem. I had not associated it with mapped drives, but they are. I have had the system lock up when trying to delete or rename files on mapped drives.

    I have also experienced deleting a file and having it reappear. But when I try and delete it again, Windows says that it cannot access the file. Eventually (like after rebooting) the files go away.
    Wednesday, February 10, 2010 6:01 PM
  • I've looked all over the net and I have seen many other people reporting this problem but the troubleshooting process is confusing. We tried the secpol.msc fix and we're testing this now. Looking for any other possible solutions. Shared resources over the network is mission critical and this problem has nearly rendered my boss's new laptop unusable. He is running this on a brand new Sony VAIO w/ i7 processor. I can post more specs as needed.
    Friday, February 12, 2010 6:50 PM
  • Hi Jason – Maxtool,

    Since the issue is not occurring by booting the computer in Safe Mode with Networking, this might be an issue if any of the non- Microsoft applications or services are conflicting. Performing clean boot on the computer would narrow down the issue and find the culprit.

      1. Click Start, type msconfig in the Start Search box, and then press ENTER.
          User Account Control permission: If you are prompted for an administrator password or for a confirmation, type the password, or click Continue.
       2. On the General tab, click Selective Startup.
       3. Under Selective Startup, click to clear the Load Startup Items check box.
       4. Click the Services tab, click to select the Hide All Microsoft Services check box, and then click Disable All.
       5. Click OK.
       6. When you are prompted, click Restart.
       7. After the computer starts, check whether the problem is resolved.

    After you determine the startup item or the service that causes the problem, contact the program manufacturer to determine whether the problem can be resolved. Or, run the System Configuration Utility, and then click to clear the check box for the problem item.

    Note: Please ensure that the computer is set to start as usual by following the step 7: Reset the computer to start as usual, from the article: How to troubleshoot a problem by performing a clean boot in Windows Vista or in Windows7: http://support.microsoft.com/kb/929135.

    You may temporarily disable the anti-virus software on the computer and check. Make sure to enable the security software back on the computer.




    Thanks and Regards:
    Swathi B - Microsoft Support.

    Visit our Microsoft Answers Feedback Forum and let us know what you think.


    Saturday, February 13, 2010 5:44 PM
  • Ok I apologize I screwed up. I spoke with my boss and this problem DOES happen in safe mode with networking running.

    I gave him the steps you listed above and he told me he had already done this and the problem was still happening.
    Monday, February 15, 2010 5:23 PM
  • We just got two new boxes:

    Intel i5 Processors
    8gb Ram
    1gb Video card
    Win7 64bit

    SAME PROBLEM!!! After an hour on the network mapped drives stop responding causing the explorer to hang. If you try to reboot the system sits at Logging Off forever.
    Tuesday, March 02, 2010 5:42 PM
  • Ok. I found an article here http://support.microsoft.com/default.aspx/kb/297684 regarding the server dropping an idle connection after a set period in time. Could it be that the connection is getting dropped and the bug is that Win7 isnt reestablishing the connection?? OR maybe Win7 doesnt know the connection has been severed.
    Tuesday, March 02, 2010 6:08 PM
  • Hi,

    We just got a new rig at our shop running Win7x64 and are having the same problem.  It's not ust related to the mapped drive but the computer on which the drive is mapped to.

    We have 20 or so computers in our network and 1 acts as the server for all our files (running Windows XP).  The Win7x64 machine can see all of them AND connect to them in the Windows Explorer -> Network pane after a clean boot, but after a period of time we can still see all computers and connect to all save for he server (the only computer that requires a password to view on the network).  The computer still remains usable until we try to access the mapped drive at which point the computer is toast and requires a hard reboot.

    For our case it seems to be related to a mapped drive on a password protected computer as I can still access all the other computers shared folders but cannot access the server.  It seems to lose the credentials and refuses to prompt for new credentials.  Attempting to access the server fails to connect but does not hang the computer, only when we try to access the mapped drive does the computer hang.

    Needless to say it's frustrating and we have been searching for a solution since all our project files are on the network and this problem makes the computer useless. Is this strictly related to x64 or would installing the 32bit version of Win7 alleviate this?

    Cheers

    **UPDATE: Following the instructions on the link provided by Jason I disabled auto timeout on the XP machine serving the files by the command:

    net config server /autodisconnect:-1

    We left the machine on all night and came back i the morning and so far it is working just fine.  While this has stopped the machine from becoming unusable, it does not correct the underlying problem as to why Windows 7x64 does not reconnect to a network share after it has timed out.  According to windows support the timeout allows the server to manage its resources and any session that has timed out is supposed to reconnect quickly.

    To compare I was running windows 7 RC(32 bit) on my 5 year old M70 laptop and had no problems on this exact same network.
    Wednesday, March 03, 2010 12:26 AM
  • We tried this same solution on one of the systems we map a drive from and after 1/2 a day on a new Win7 box we have yet to see this problem happen so I'm thinking that this is probably a fix for this. Well....let me rephrase that. This is a BAND AID for what is obviously a problem with Windows 7 64bit. And we have confirmed that this only happens on the 64 bit version. I'm guessing that basically Win7 is unaware that it has been disconnected from a drive and isn't smart enough to time out then attempt a reconnect.

    What truly boggles the mind is the fact that a bug this big actually got into the final product. :P
    Wednesday, March 03, 2010 8:58 PM
  • I am having the same issue on my network!  We have 80+ XP machines accessing our file server with no issues however all of a sudden our win7x64 machines are locking up randomly when accessing the shares on our fileserver.  Our file server is running 2008 standard R2, I tried the net config /autodisconnect:-1 but still I am having the same issue.  Do I need to reboot after I run the command?  Any help would be great as my presidents EA is affected by this.
    Wednesday, March 10, 2010 7:23 PM
  • Update: Issue fixed.

    Ok it turns out this was not Windows7 related at all.  I created a new antivirus policy and forgot to uncheck the network drives for scanning.  Doh!

    Thursday, March 11, 2010 8:15 PM
  • So much for Live Alerts... the only e-mail I received was for the most recent post by xxuser1981xx after he solved the problem, d'oh. 

    xxuser1981: No you don;t have to reboot after running "net config /autodisconnect:-1".  I know your issue is solved, but for anyone else who stumbles across this there you go.

    Jason: Yeah, it's only 64 bit.  Windows 7 was better in every respect to XP on my ageing laptop.  Less memory used, CPU temps were down, aero looked beautiful and did not bog my system (with an ageing video card) and the network performance was better than XP (faster and more reliable).  Think of my embarrassment telling my co worker how wonderful 7 is only to have his new rig come to a crashing halt because of this.  It makes the computer unusable and as you said this is a band-aid since the file server (only running XP) can't manage it's connections and resources so people stay logged in with ridiculous idle times and others can't get on to access files.

    Hoping theres a fix soon.

    Cheers
    Friday, March 12, 2010 12:33 AM
  • Yeah. I have yet to get a single alert. Is there actually a product made by Microsoft that works as intended?

     

    So it's now the 25th of March and the problem continues. My own system running Win7 64x hasnt had a lockup in a few days but I also disconnected myself from our domain controller and I don't have any server drives mapped. The systems I DO have drives mapped to are running WinXP and I disabled the autodisconnects on them. The other two guys here have their boxes connected to our server which is running Win2k3. It's my theory that Win7 doesnt play nice with Win2k3.

    All I know is that all future system upgrades have been put on hold and we're not buying another single copy of Win7 until this problem is verified fixed. This creates a new headaches as Windows XP systems are getting harder and harder to purchase! Come on MS. Fix this bug please.

    Thursday, March 25, 2010 11:14 PM
  • Ummm, no this issue isn't solved. Maybe that solved xxuser1981xx's problem but not the problem in Jason's original post. The computer doesn't hang randomly. It hangs specifically when you try to access the mapped drive on the windows 7x64 machine after the session has been disconnected. It doesn't matter if it's through windows explorer or solidworks. Once the machine is stuck only a hard reset will recover. We do not use antivirus and it has been confirmed the issue was due to the server disconnecting an idle session. Once I turned off autodisconnect on the server all has been fine. But this is not ideal since the sever cannot manage connections now. I had windows 7RC 32 bit and this was NOT a problem. In fact windows 7 32 bit was flawless! Thi is an issue specific to win7x64 as nothing has changed on the network except the new computer running win7x64. Please do not sweep this aside as a virus scan issue as it is not.

     

    Cheers

    Sunday, March 28, 2010 7:16 PM
  • OK i think i might of solved the problem, both me and my room mate have a NAS for our itunes music, both using the same build of windows 7 64bit, but different hardware, he has had no problems, i was discussing with him the problem and he thinks its getting timed out which makes sense. So i went to the device manager and disabled one of the 2 built in LAN connections to the motherboard, this might not be applicable to anyone else, next thing I did was go into the properties of the network controller i am currently using. Then under the advanced tab i had an option for "Wake-Up capabilities", it was defaulted to "link Change" so i changed it to "none", they do give more options but this one seemed most applicable as i am not familiar with networking any more than an home network. So my computer has been on for about 6 hours now and i can still connect to it. so my fingers are crossed hoping this is a fix.

    also i am aware of my grammar and punctuality, it sucks. 

    hope this works for you cause it was a real nuisance for me.

    Tuesday, March 30, 2010 5:35 AM
  • ok i suck its still doing it, only if i heavily use Firefox like multiple tabs, or large youtube videos.
    • Proposed as answer by Alisida Monday, March 11, 2013 7:08 PM
    Tuesday, March 30, 2010 7:21 AM
  • Interesting to see if there is any common hardware between our systems.

    We have an Asus P7P55D-E motherboard with an intel i7860, Intel X25-M 80GB SSD and Nvidia Quadro Fx1800.  Everything else is onboard (AUDIO, LAN, USB and SATA)

    Our motherboard only has single Gigabit LAN but looking into the sleep or power options for the port might yield something.

    Either way if the computer can't access the Mapped drive for whatever reason it should simply time out and give the good ol' "You do not have permission to access this network resource" or similar error rather than completely nuke the computer forcing a hard boot.

    Also Antivirus should be able to access and scan a network drive, in fact may packages list this as a benefit to have a single anti virus scan multiple computers, so again a band aid fix, not a real solution.

    Jason, any common hardware?

    Cheers

    Darren

    Tuesday, March 30, 2010 9:20 PM
  • I am experiencing the same problem.  I have two notebook computers, one running Win7 32 bit, one running Win 7 64 bit.  The drive I am having problems mapping  is a WD Mybookworld.  The problem only exists on the 64 bit machine when it is connected via wireless.  The system was working perfectly up until mid to late February and then something changed.  I can not put my finger on what.  No new hardware and no new software, save the normal updates from Microsoft.  I am running Microsoft's security software.

    I am using a Belkin N+ router.  The router refused to fix the IP address for the drive.  The IP address was fixed through the drive's GUI.  Up to that point the Win7 64 bit machine could not see the network drive at all.  This allowed Win7 and WD software to see the drive.  Once the drive is mapped the folders are visible, but not accessable.

    The problem makes it seem like the RAID 1 drive failed.  It did not.  I could connect to it through a network switch and then through my router after giving it a fixed IP.  Win7 and WD's software allowed me to map the drives through my router wirelessly, but it would not allow access to the folders.

    The drive is showing up as both a computer and a drive under different views of the network in Win7.

    Let me know if this description helps someone smarter than me sort out what is going on.

    Wednesday, March 31, 2010 2:56 PM
  • I am experiencing the same problem.  I have two notebook computers, one running Win7 32 bit, one running Win 7 64 bit.  The drive I am having problems mapping  is a WD Mybookworld.  The problem only exists on the 64 bit machine when it is connected via wireless.  The system was working perfectly up until mid to late February and then something changed.  I can not put my finger on what.  No new hardware and no new software, save the normal updates from Microsoft.  I am running Microsoft's security software.

    I am using a Belkin N+ router.  The router refused to fix the IP address for the drive.  The IP address was fixed through the drive's GUI.  Up to that point the Win7 64 bit machine could not see the network drive at all.  This allowed Win7 and WD software to see the drive.  Once the drive is mapped the folders are visible, but not accessable.

    The problem makes it seem like the RAID 1 drive failed.  It did not.  I could connect to it through a network switch and then through my router after giving it a fixed IP.  Win7 and WD's software allowed me to map the drives through my router wirelessly, but it would not allow access to the folders.

    The drive is showing up as both a computer and a drive under different views of the network in Win7.

    Let me know if this description helps someone smarter than me sort out what is going on.

    I want to be clear that everything works when connected via copper.  The problem only exists for the Win7 64 bit machine when it is connected  wireless.  The 32 bit machine connects fine via wireless.  Both used to work via wireless for a couple of months. 

    Wednesday, March 31, 2010 2:56 PM
  • Exact same problem on my HP laptop running Win7 64-bit, connecting to a ReadyNAS.

    For me, the problem was caused by CheckPoint ZoneAlarm firewall. After uninstalling it, the problem went away. Simply disabling it did not help.

    Wednesday, March 31, 2010 5:44 PM
  • This is NOT the solution to the problem the rest of us are having.

    I also appear to have an issue of additional files being added to my list of offline files. When I view my offline files I see files and folders that I have not marked as "always available offline" (or whatever it is). When I try to delete the folders, it only deletes some of them (NOTE: it states that it does not delete the network files, just the offline copies).

    Wednesday, March 31, 2010 11:06 PM
  • Hi everyone.

    I was very angry about this issue. I have 2 network drives which I have to use. Everytime I tried to save whatever to those drives,

    win7 64 just crashed and I had to press reset from my comp.

     

    SOLVED the issue by >>

    From network and sharing center, I had worknetwork. Friend said "change it to home, I have it and I can save to network-drives".

    Changed and now it works.

    Tuesday, April 06, 2010 11:57 AM
  • Already tried that no dice.

     

    I think what truly infuriates me is that the only way to get an answer to this is to contact Microsoft and PAY THEM for support on what is obviously a SERIOUS problem with their networking. I'm not going to go off on a "this is why macs are better" rant, but its stuff like this that makes me love the Mac OS.

     

    What confounds me is that a problem THIS BIG and it still has not been address by the folks in Redmond. I mean this is literally rendering computers here unusable.

    Tuesday, April 06, 2010 4:43 PM
  • I have same problem. DC Server 2003, 20 clients Win 7 64 bit. After ½-1 hours alla mapped drivers have red X, and they cant connect network share. User have login script, which connect drivers.

     

    I have make many changes, KeepConn, authentic method changes, but still  having same problem. Maybe back to XP Pro and no problems with network drivers.

    Tuesday, April 13, 2010 6:14 PM
  • ** UPDATE **

    So changing the network-type didnt help me, but. I solved my issue by adding another LAN-card to my desktop-PC.

    The integrated LAN-caused this problem... And now everything works like a charm.

    Tuesday, April 13, 2010 9:48 PM
  • So i have fixed mine, well so far it has worked, I went to my computer shop and got a new NIC (Intel Gigabit CT 10/100/1000 PCI-E Ethernet Network Adapter)

    no issues so far improved speed slightly, only cost $43 cdn here is the link http://ncix.com/products/index.php?sku=41946&vpn=EXPI9301CT&manufacture=INTEL%20CORPORATION

     

    Good luck everyone

    Sunday, May 16, 2010 2:51 AM
  • try this go into regedit locate HK_Local_Machine\system\currentcontrolset\Lsa\kerberos\parameters*

    if key not present create it click add key create parameters key create new key on edit menu click add value

    value name : maxTokenSize

    data type REG_Dword

    radix :decimal

    value dats:65535

    the default value for MAXTOKENSIZE is 12000decimal set this value to 65535decimal,FFFF hexadecimal if value is set incorrectly to 655535 hexadecimal kerberos authentication may fail

    Wednesday, March 30, 2011 5:37 PM
  • I found the answer today - and have been looking for months.

    Go to Control Panel - under System settings - GoTo Power Settings

    Then GoTo "Change when the computer sleeps"

    Here is where you find "Change Advanced Power Settings"  Click it    

    You may need to click on "change settings that are currently unavailable" to make changes below

    1) uncheck Hard disk - and change settings for the hard disk "while plugged in" to 180 minutes.  The hard drive will go to sleep after 3 hours of non-use. Make longer if needed.

    2) uncheck Wireless adaptor - and change "Plugged in" to maximum performance

    3) uncheck Sleep - and make sure all "Pllugged in" options read Never

    4) uncheck PCI Express and make sure everything is on Maximum

    I don't know if all 4 changes above are needed - but one of these changes seem to be working on five of our new computers that were putting the Red X on the connected Network drives.  I hope someone at Microsoft puts this information out to the public -

    I can be reached at 973-292-0025

    Scott

    Tuesday, October 16, 2012 9:15 PM
  • I found the answer today - and have been looking for months.

    Go to Control Panel - under System settings - GoTo Power Settings

    Then GoTo "Change when the computer sleeps"

    Here is where you find "Change Advanced Power Settings"  Click it   

    You may need to click on "change settings that are currently unavailable" to make changes below

    1) uncheck Hard disk - and change settings for the hard disk "while plugged in" to 180 minutes.  The hard drive will go to sleep after 3 hours of non-use. Make longer if needed.

    2) uncheck Wireless adaptor - and change "Plugged in" to maximum performance

    3) uncheck Sleep - and make sure all "Pllugged in" options read Never

    4) uncheck PCI Express and make sure everything is on Maximum

    I don't know if all 4 changes above are needed - but one of these changes seem to be working on five of our new computers that were putting the Red X on the connected Network drives.  I hope someone at Microsoft puts this information out to the public -

    I can be reached at 973-292-0025

    Scott

    • Proposed as answer by Scotty-Guitar Tuesday, October 16, 2012 9:17 PM
    Tuesday, October 16, 2012 9:17 PM
  • Changing the Power settings issued resolved this issue for our new Window 7 (64bit) Network issue as well.

    Thank you.

    Thursday, April 17, 2014 8:47 PM
  • thank you, you have ended 1 month of pain
    Thursday, May 22, 2014 4:20 PM
  • Thanks so much! Disabling network scanning in Norton fixed it for me.
    Thursday, July 10, 2014 8:51 PM