none
Turning off auto click

    Question

  • Hi,
    I've recently got a new laptop with windows 7 on it.
    There's this feature on it where if you leave your mouse or touchpad hovering over something clickable for about 5 seconds. It will automatically click it.
    I want to turn this feature off but I can't find it anywhere in the control panel under Mouse or anything to turn it off. I've searched online but there have been unable to find any solutions except for one for windows XP however I need to locate where I can turn this feature on or off using Windows 7. 

    Any help would be appreciated.
    Monday, November 16, 2009 8:42 PM

Answers

  • OK, i found what i had to do to turn that stupid thing off.

     

    Go to

    start>type 'mouse'>hardware>properties>driver>update driver

     

    after that the options for the touchpad change and i was able to turn off autoclick and adjust touchpad settings

    Wednesday, March 31, 2010 9:34 PM
  • Hi,
    I've recently got a new laptop with windows 7 on it.
    There's this feature on it where if you leave your mouse or touchpad hovering over something clickable for about 5 seconds. It will automatically click it.
    I want to turn this feature off but I can't find it anywhere in the control panel under Mouse or anything to turn it off. I've searched online but there have been unable to find any solutions except for one for windows XP however I need to locate where I can turn this feature on or off using Windows 7. 

    Any help would be appreciated.
    Hi

    Open Control Panel / Ease of Access Center / Make the mouse easier to use.

    Remove the check mark from the "Activate a window by hovering over it with the mouse'' option. Apply/OK.

    Hope this helps.

    Thank You for using Windows 7

    Ronnie Vernon MVP
    Monday, November 16, 2009 9:13 PM

All replies

  • Hi,
    I've recently got a new laptop with windows 7 on it.
    There's this feature on it where if you leave your mouse or touchpad hovering over something clickable for about 5 seconds. It will automatically click it.
    I want to turn this feature off but I can't find it anywhere in the control panel under Mouse or anything to turn it off. I've searched online but there have been unable to find any solutions except for one for windows XP however I need to locate where I can turn this feature on or off using Windows 7. 

    Any help would be appreciated.
    Hi

    Open Control Panel / Ease of Access Center / Make the mouse easier to use.

    Remove the check mark from the "Activate a window by hovering over it with the mouse'' option. Apply/OK.

    Hope this helps.

    Thank You for using Windows 7

    Ronnie Vernon MVP
    Monday, November 16, 2009 9:13 PM
  • thanks a lot!

    didn't see that I could scroll down.
    that's kinda embarrassing.
    Tuesday, November 17, 2009 1:09 AM
  • It doesn't disable it.

    My touchpad will still autoclick after hovering over something for 2-3 seconds.
    Note: this is when I have no mouse plugged in

    Any other suggestions?
    Saturday, November 21, 2009 6:49 AM
  • It doesn't disable it.

    My touchpad will still autoclick after hovering over something for 2-3 seconds.
    Note: this is when I have no mouse plugged in

    Any other suggestions?

    Getting Psssd with windows7 , autoclick won't turn off !! Drives me bonkers doesn't allow me time read, it autoclicks when not wanted :(
    running w7 starter on  brand new dell mini

    Sunday, December 06, 2009 6:06 PM
  • Getting Psssd with windows7 , autoclick won't turn off !! Drives me bonkers doesn't allow me time read, it autoclicks when not wanted :(
    running w7 starter on  brand new dell mini


    Hi

    If the Windows 7 settings in the Ease of Access options doesn't turn this function off, the only other place where it could be coming from is the options for the Touchpad.

    Check your manual for the location of the Touchpad options.

    Hope this helps.

    Thank You for using Windows 7

    Ronnie Vernon MVP

    Sunday, December 06, 2009 10:04 PM
  • Getting Psssd with windows7 , autoclick won't turn off !! Drives me bonkers doesn't allow me time read, it autoclicks when not wanted :(
    running w7 starter on  brand new dell mini


    Hi

    If the Windows 7 settings in the Ease of Access options doesn't turn this function off, the only other place where it could be coming from is the options for the Touchpad.

    Check your manual for the location of the Touchpad options.

    Hope this helps.

    Thank You for using Windows 7

    Ronnie Vernon MVP


    I've been there. Can't find any option that would apply. Really this is a bad news feature. Suddenly things get activated and drive me bonkers. Can't even set the wait time. Some times moving the pointer across a window activates advertisements or unwanted control panel choices. Making text size  readable 125% makes windows expand past the screen so I have to reduce the size to get to scroll bars. Windows 7 is a terrible dissapontement so far .
    Monday, December 07, 2009 1:58 PM
  • What brand is your computer ?

    I know some Brands have their own software with settings like the one you describe. Perhaps checking that software if you have any since the built in function is deactivated in Windows 7.
    Monday, December 07, 2009 3:47 PM
  • This might work for you:  Go to the menu as listed above but Activate the hovering (click both the box and the Apply button) and then Deactivate hovering (unclick the box and then Apply). 
    Saturday, December 19, 2009 11:32 PM
  • The ease of Access option does not work for me either.  I go into the properties of the touchpad, which is were this option would be turned off in vista, and there is nothing to be found.  Is there any other way to turn this 'feature' off?
    Wednesday, March 31, 2010 9:23 PM
  • OK, i found what i had to do to turn that stupid thing off.

     

    Go to

    start>type 'mouse'>hardware>properties>driver>update driver

     

    after that the options for the touchpad change and i was able to turn off autoclick and adjust touchpad settings

    Wednesday, March 31, 2010 9:34 PM
  • OK, i found what i had to do to turn that stupid thing off.

     

    Go to

    start>type 'mouse'>hardware>properties>driver>update driver

     

    after that the options for the touchpad change and i was able to turn off autoclick and adjust touchpad settings

    Okay  - as a second input, cause this was driving me crazy too but User156's advise wasn't helping (though it was the closest).  I tried what user156 suggested and it didn't work - the "update driver" function wasn't even available.  However I backtracked and this time instead of going to "hardware" I went to the "device settings" tab and then clicked the "settings" button.  Under that screen there is a "tapping" option.  Click on it to expand and then uncheck the box.

    Seems to be working so far.

    Friday, July 23, 2010 11:49 PM
  • I'm using an Acer Aspire 5741 laptop and I have the same problem. I just tried what kylemac has suggested and it seems to be working so far. Only time will tell.
    Monday, November 08, 2010 3:37 AM
  • "Ease of Access" doesn't work. "Activate the window while hovering over it with the mouse" is not a default option, however I've been experiencing this since I bought the computer. I've been trying to resolve this issue for about a year. I've actually spoke to Microsoft tech support who informed at the time of my call that they were "UNAWARE" of this issue. Clearly I still have no resolution. While typing this very text my cursor is situated somewhere else on this page and multiple times later I've repositioned it and began to type again. This flaw needs to be resolved. I was hoping to get clear answers here however I see that's not going to happen. Mr. Moderator Microsoft screwed up. I have already let them know more than once that they screwed up. The closest resolution has something to do with changing a value in the registry to a 00000010 or something to that nature. This will only increase the time of hover before the "Auto Click" option takes effect or so they say. Mr. Moderator this feature has ruined documentation that I was working on, it has downloaded unwanted software, and it has closed windows that I was actively using all because it was hovering over a button. It would be nice if you could actually help resolve this issue instead of giving guff to others becaused they voiced their displeasure with this Microsoft products feature. They dropped the ball; lets just admit it and try to find a resolution. Kim
    Friday, May 27, 2011 9:42 PM
  • Kylemac - your answer seems to have helped me.  I did it a few hours ago, and low and behold, nothing I've typed got highlighted and deleted.  Thanks because I was ready to throw this acer netbook out the window on more than 1 occasion.  Here are the full directions for Windows 7 Starter:

    start

    type 'mouse' at the bottom

    select mouse under control panel

    "device settings" tab

    clicked the "settings" button

    Under that screen there is a "tapping" option

    select/highlight Tapping

    uncheck the enable tapping box that appears

    Wednesday, February 15, 2012 11:44 PM
  • THANK GOD! Your answer saved me tearing all my hair out! this feature is EXTREMELY ANNOYING!,,,Thanks again!
    Wednesday, July 11, 2012 1:40 AM
  • THANK YOU, KYLEMAC!!!   I have had the same problem, and did just what the Microsoft "experts" have said to do (go to Accessibility and uncheck "Activate a Window").  Well that doesn't work!  This "feature" has driven me nuts and I can't believe how much time I have wasted.  Now WHO would think of searching obscure subfolders and landing on TAPPING, then unchecking the "enable tapping" box?  So far, this has worked.  I would give anything if there was some way Microsoft would make this an easy fix to find from a Google search.  I image there are many people who think it's THEIR fault and either live with it, curse the darkness, or buy a Mac.
    Sunday, August 12, 2012 12:14 AM
  • Kylemac - your answer seems to have helped me.  I did it a few hours ago, and low and behold, nothing I've typed got highlighted and deleted.  Thanks because I was ready to throw this acer netbook out the window on more than 1 occasion.  Here are the full directions for Windows 7 Starter:

    start

    type 'mouse' at the bottom

    select mouse under control panel

    "device settings" tab

    clicked the "settings" button

    Under that screen there is a "tapping" option

    select/highlight Tapping

    uncheck the enable tapping box that appears


    I dont have the "Device settings" Tab. Or I cant find it.
    Friday, September 07, 2012 9:07 PM
  • Just like playmike5 I too cannot find "device setting tab" when I click mouse from control panel.

    Any ideas?

    Tuesday, September 18, 2012 3:10 PM
  • Thanks Ronnie!


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Tuesday, September 18, 2012 3:43 PM
  • Hey Keyvie,

    How do you suggest we change access registry to do what you suggested? Can you give us a step by step guide. This is killing me.

    Tuesday, November 06, 2012 4:40 AM
  • Hi

    Open Control Panel / Ease of Access Center / Make the mouse easier to use.

    Remove the check mark from the "Activate a window by hovering over it with the mouse'' option. Apply/OK.

    Hope this helps.

    Thank You for using Windows 7

    Ronnie Vernon MVP

    Well, Mr. Vernon, perhaps it would help if the default setting for this "undocumented feature" was not unchecked already. The vast majority of users losing their hair over this have already explored the achingly obvious options. This ridiculous "feature" has singlehandedly reduced the quality of my experience with Windows 7 to one of ongoing frustration!

    There needs to be a properly researched and documented solution to this failing feature. This isn't some lunatic fringe complaint. Without a solution Windows 7 cannot be considered to be 'ready for prime-time'.

    Please do what you can to move this forward.

    Thanks


    • Edited by T_moteo Monday, December 10, 2012 9:15 AM
    Monday, December 10, 2012 9:13 AM
  • Amen brother!!

    C'mon Microsoft, the solution to bugs in Windoze 7 is NOT to release Windoze 8!!

    Monday, December 10, 2012 9:23 AM
  • In the previous post, 'Playmike5' wrote:

    "I dont have the "Device settings" Tab. Or I cant find it."

    .

    Assuming we are still referring to a laptop with a touchpad; if you have the current Synaptics touchpad driver installed, the 'Device Settings' tab should be located on the far right of the 'Mouse Properties' window.

    The reason I am restating the obvious is not to be insulting, but hopefully to clarify. When I originally read the post in question, the wording lead me to believe that 'Device Settings would be visible from the 'Control Panel' window. It wasn't until I decided to use BOTH of my brain cells, that I finally saw that you had to open 'Control Panel' and click on 'Mouse' which opens the 'Mouse Properties' window, from which you will hopefully find the 'Device Settings' tab on the far right.

    Kidding aside, though this procedure has apparently relieved me of the 'hover activation' fiasco (for which I am grateful to the originators, BTW..) This is a work-around at best, not a solution. A solution will achieve the same ends WITHOUT eliminating a useful touchpad function such as tapping. So please Microsoft, put on your thinking caps!

    Thanks again to the contributors, 'User156' and 'kylemac'.





    • Edited by T_moteo Monday, December 10, 2012 10:16 AM
    Monday, December 10, 2012 10:03 AM
  • Hi,

    I've recently got a new laptop with windows 7 on it.
    There's this feature on it where if you leave your mouse or touchpad hovering over something clickable for about 5 seconds. It will automatically click it.
    I want to turn this feature off but I can't find it anywhere in the control panel under Mouse or anything to turn it off. I've searched online but there have been unable to find any solutions except for one for windows XP however I need to locate where I can turn this feature on or off using Windows 7. 

    Any help would be appreciated.


    Hi,

    I tried the other suggestions that were on the blog but they didn't work for me.  Finally setting the below has reduced the click frequency to almost no auto clicks for me on Windows 7 HP TouchSmart320PC.  Control Panel-Hardware and Sound-Pen and Touch>>Pen Options(tab) - unticked both the Pen buttons options (right click equivalent, pen to erase..) and Apply - OK.

    Hope this helps.

    Sunday, December 01, 2013 1:27 AM
  • On My Dell I absolutely do not have a Device Settings tab under Mouse Properties.    I had to select the Dell Touchpad tab and then select Click to change Dell Touchpad settings.  THEN I could see an option for Tapping and I disabled it.  Agreed, this is a workaround.  I use the tapping feature when my mouse is disconnected.  What a nuisance.  I'm glad to see that I wasn't just being/going crazy. 
    Monday, January 06, 2014 11:19 PM
  • I know this is marked as the answer, but read on ... only thing that worked for me and several others was posted below by kylemac.  So weird that the "tapping" setting for the touchpad seems to affect the mouse-over auto-click for both the touchpad and my wireless mouse.  Oh well, glad to get the dang thing turned off.  (This is my second time at this post .. had to reimage my 2 year-old computer.  This post helped me two years ago and again today.  Thanks kylemac!)
    Wednesday, May 28, 2014 3:53 PM