none
I keep getting a "invalid MS-DOS function" when I try to move, delete, or rename files (ANY file).

    Question

  • I am unable to do anything except make copies of files - documents, picture, videos, music, nothing.  I can't move them to new folders, rename them, or even delete them: it just says "invalid MS-DOS function."  I'm not trying to move them to a disc or a drive or anything, I'm literally just trying to move something from one file to another and delete some pictures I don't want anymore.  I've checked the properties on the files and I don't see anything saying that it's a read-only or anything; I don't think any security settings have changed.  Everything is completely fine and workable on my flash drive, which is plugged into the computer.  Any ideas on how to fix this?  I need to organize my stuff.

    Saturday, March 01, 2014 1:38 AM

Answers

  • Hi,

    First, you may check if the flash disk is a good one as Forest brook mentioned.

    This error generally means that the media you are copying from wether it be a hard drive, CD-ROM or DVD-ROM is corrupted in some way. For the optical drives, you will need to get a new copy of the media or try it in a different drive, and for the hard drives, run some sort of hard disk repair software.

    As I know, you will not be able to copy some of the files if they are copy protected. However, ideally you should be able to copy the recorded files.

    I also would like to share the following troubleshooot methods with you to check this issue.

    Method 1: If you are trying to copy the files from NTFS format to a FAT 32 format, I suggest that you follow the below link and run the Hotfix:

    http://support.microsoft.com/kb/949073

    Method 2:
    a. Click Start, type regedit in the Start Search box, and then press ENTER.
    b. Locate and then click the following registry subkey: HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\System
    c. On the Edit menu, point to New, and then click DWORD Value.
    d. Type ‘CopyFileBufferedSynchronousIo’ (without quotes) to name the new entry, and then press ENTER.
    e. Right-click CopyFileBufferedSynchronousIo, and then click Modify.
    f. In the Value data box, type 1, and then click OK.
    g. Exit Registry Editor.

    Before perform the menthod 2, please refer to the link below to back up the registry first.

    http://support.microsoft.com/kb/322756 How to back up and restore the registry in Windows.

    Method 3: You may consider to run CHKDSK on your computer, if there are any bad sectors on the hard disk.

    Hope it helps.

    Regards,

    Blair Deng


    Blair Deng
    TechNet Community Support

    Monday, March 03, 2014 6:24 AM

All replies

  • Do you see the same problem with a different flash disk? If not then the file system on the problem stick is probably damaged. Save the files elsewhere, then reformat the disk.
    Saturday, March 01, 2014 6:32 AM
  • Hi,

    First, you may check if the flash disk is a good one as Forest brook mentioned.

    This error generally means that the media you are copying from wether it be a hard drive, CD-ROM or DVD-ROM is corrupted in some way. For the optical drives, you will need to get a new copy of the media or try it in a different drive, and for the hard drives, run some sort of hard disk repair software.

    As I know, you will not be able to copy some of the files if they are copy protected. However, ideally you should be able to copy the recorded files.

    I also would like to share the following troubleshooot methods with you to check this issue.

    Method 1: If you are trying to copy the files from NTFS format to a FAT 32 format, I suggest that you follow the below link and run the Hotfix:

    http://support.microsoft.com/kb/949073

    Method 2:
    a. Click Start, type regedit in the Start Search box, and then press ENTER.
    b. Locate and then click the following registry subkey: HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\System
    c. On the Edit menu, point to New, and then click DWORD Value.
    d. Type ‘CopyFileBufferedSynchronousIo’ (without quotes) to name the new entry, and then press ENTER.
    e. Right-click CopyFileBufferedSynchronousIo, and then click Modify.
    f. In the Value data box, type 1, and then click OK.
    g. Exit Registry Editor.

    Before perform the menthod 2, please refer to the link below to back up the registry first.

    http://support.microsoft.com/kb/322756 How to back up and restore the registry in Windows.

    Method 3: You may consider to run CHKDSK on your computer, if there are any bad sectors on the hard disk.

    Hope it helps.

    Regards,

    Blair Deng


    Blair Deng
    TechNet Community Support

    Monday, March 03, 2014 6:24 AM