none
thumbs.db being accessed by Windows Explorer - folder cannot be deleted

    Question

  • I get this message all the times when I delete a folder on a remote drive. It deletes the contents of the folder but then a message pops up saying that the folder can't be deleted because "thumbs.db" is being accessed by Windows Explorer. If I wait a couple of minutes and try again then the folder gets deleted.
    Anyone having this problem? It is annoying!
    Wednesday, November 04, 2009 9:55 AM

All replies

  • Hi,

     

    Thumbs.db is created when using thumbnail preview. If is normal and not necessary to delete it.


    For more information about Thumbs.db, you may refer to the following link.

     

    http://en.wikipedia.org/wiki/Windows_thumbnail_cache

     

    Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

      

    If you still want to remove it, you will have the following options.

     

    1.    Hide the Thumbs.db. Click Start, type Folder Options into Search bar and press Enter. Switch to View tab, point “Don’t show hidden files, folders, or drives” and check “Hide protected operating system files (Recommended)” boxes.

    2.    Disable creating Thumbs.db. Click Start, type Folder Options into Search bar and press Enter. Switch to View tab, check “Always show icons, never thumbnails” box.

    3.    Delete Thumbs.db. You may use the following command to delete it or use a third party software, Unlocker to delete it. Right click on installation file and click “Run as administrator” to install it. After finishing the installation, right click on the file which you want to delete and click Unlocker to remove it.

     

    Note: The third-party product discussed here is manufactured by a company that is independent of Microsoft. We make no warranty, implied or otherwise, regarding this product's performance or reliability.

     

    Del {Drive Letter}:Thumbs.db /f/s/q/a

     


    Arthur Li - MSFT
    • Marked as answer by Alexander SklarEditor Thursday, November 05, 2009 8:54 AM
    • Unmarked as answer by UtenteAnonimo Thursday, November 05, 2009 10:02 AM
    • Proposed as answer by Martin 7 Tuesday, March 09, 2010 3:18 AM
    Thursday, November 05, 2009 5:35 AM
    Moderator
  • Thanks for your answer but it is not an answer to my problem. I agree that it should not be necessary to delete thumbs.db files manually and it is not what I am trying to do.

    I am trying to delete folders and the operation fails with a message reporting that "thumbs.db" is in use and cannot be deleted.

    It's not the same thing.

    Thursday, November 05, 2009 10:01 AM
  • Hi,

     

    It is possible that the folder thumbnail preview cache was still in use by Windows Explorer when you were trying to delete the folder.

     

    You may try the Option 1 I provided to disable thumbnail preview and try to delete the folder again.

     

    Good luck!


    Arthur Li - MSFT
    Friday, November 06, 2009 2:23 AM
    Moderator
  • I'm having the same silly problem.
    If I wait a couple of minutes and try again then the folder gets deleted.
    Instead of waiting, I'm able to delete the folder by simply clicking on a different folder, then deleting the desired folder by right-click > Delete.

    As a less drastic alternative to Arthur's suggestion to "Always show icons, never thumbnails," I'm using group policy to disable thumbs.db creation on network shares. (Thumbnails for local folders are still cached normally, I believe, in the local centralized database.)
    • Run gpedit.msc.
    • Enable the following policy: User Configuration > Administrative Templates > Windows Components > Windows Explorer > Turn off the caching of thumbnails in hidden thumbs.db files

    Credit goes to this older thread: Windows 7 and "Folder In Use" error on network shares .
    • Proposed as answer by John Eddowes Sunday, January 23, 2011 9:19 PM
    Friday, November 06, 2009 4:51 PM
  • Turning off or disabling the thumbnails allows me to delete a folder that contains a thumbs.db file, but I want to use the thumbnail feature AND be able to delete a folder without having to keep changing my thumbnail setting. Why would there need to be a thumbs.db file for an empty folder anyway? Maybe there's a good technical reason, but from a user's view it seems like a bug.

    Saturday, November 07, 2009 12:25 PM
  • To aid others in searching for this thread, the message displayed in the "File In Use" pop-up is: "The action can't be completed because the file is open in Windows Explorer. Close the file and try again."
    Saturday, November 07, 2009 7:35 PM
  • Why would there need to be a thumbs.db file for an empty folder anyway? Maybe there's a good technical reason, but from a user's view it seems like a bug.

    Exactly. Explorer gives the clumsy impression that it's tripping over its own feet. From the user's point of view, Explorer should release its own lock on thumbs.db and finish deleting the darn folder.

    @Arthur_Li
    Arthur, can you report this as a bug or feature suggestion? Although there may be sound technical reasons for this behavior, users shouldn't have to jump through hoops to delete a folder with Explorer at its default settings.
    Saturday, November 07, 2009 7:38 PM
  • Yep, I'm seeing this, too. I was clearing out some very old folders on one of our network shares, I went into one to see what the contents were, a few files and one bitmap. Went up to parent level, could not delete, got this message over and over. Saw the above and clicked on another folder, then this folder, could delete it.

    Microsoft, there's a bit of a bug here...
    Monday, November 09, 2009 6:37 PM
  • Hi All,

     

    In Windows 7, all the thumbs.db files are saved in the following path.

     

    %LocalAppData%\Microsoft\Windows\Explorer

     

    Windows 7 does not create the thumbs.db in each picture folder again. All the thumbs.db files you want to delete should be created by the previous operating systems and saved in the picture folders.

     

    After deleting the thumbs.db files in Windows 7, you should not encounter the same issue in future.

     


    Arthur Li - MSFT
    Wednesday, November 11, 2009 4:24 AM
    Moderator
  • Windows 7 does not create the thumbs.db in each picture folder again. All the thumbs.db files you want to delete should be created by the previous operating systems ...
    Arthur, are you sure this applies to network shares , the subject of this thread? Your statement contradicts the Wikipedia article linked in your first reply.

    I ran a quick test. Without the group policy workaround I mentioned above, Windows 7 definitely creates new thumbs.db files on network shares whenever I switch to a thumbnail view.

    After deleting the thumbs.db files in Windows 7, you should not encounter the same issue in future.

    Because Windows 7 creates new thumbs.db files, the problem continues to occur when simply trying to move, rename, or delete a remote folder.

    Arthur, I'm fine with the group policy workaround. However, the issue here is ease of use: do you really want to frustrate users with a not-quite-self-explanatory "File In Use" pop-up, where clicking "Try Again" is often futile? Should we really have to search for workarounds to perform basic file operations?
    Wednesday, November 11, 2009 2:30 PM
  • Windows 7 does not create the thumbs.db in each picture folder again. All the thumbs.db files you want to delete should be created by the previous operating systems ...
    Arthur, are you sure this applies to network shares , the subject of this thread? Your statement contradicts the Wikipedia article linked in your first reply.

    I ran a quick test. Without the group policy workaround I mentioned above, Windows 7 definitely creates new thumbs.db files on network shares whenever I switch to a thumbnail view.

    I bet you have actually spelled the reason for this problem:

    - early design decision: cache is centralised therefore thumbs.db management no longer necessary therefore delete operation can be simplified.
    - later... change of plan in design: centralised cache not to be implemented on remote shares
    - impact on "delete" operation for remote shares overseen
    - result: "delete" operation on remote shares flawed!

    Wednesday, November 11, 2009 5:19 PM
  • For network locations and local folders that are exposed in a Homegroup, Win7 will create thumbnails in a thumbs.db at the same level as the files for which they’re being generated.

     

    The message “File In Use” is caused due to some thumbnails are in the process of being generated. Once that process is completed, thumbs.db is closed and no longer in use. Hence clicking “Try again” will allow the file to be deleted.


    Arthur Li - MSFT
    Friday, November 13, 2009 7:44 AM
    Moderator
  • For network locations and local folders that are exposed in a Homegroup, Win7 will create thumbnails in a thumbs.db at the same level as the files for which they’re being generated.

     

    The message “File In Use” is caused due to some thumbnails are in the process of being generated. Once that process is completed, thumbs.db is closed and no longer in use. Hence clicking “Try again” will allow the file to be deleted.


    Arthur Li - MSFT

    So basically Microsoft has redesigned Windows Explorer with usability in mind (that's what I read in the press) but a user will get a message about an unknown file (what's thumbs.db for an inexperienced user???) being in use and the simple delete operation will fail. You might have explained the reason behind the scenes but from a usability point of view this is a major bug!
    Besides "Try again" will not work if you try again immediately which is what most people would do.
    Finally this was not a problem in previous windows versions so there is a way to do things properly.
    Please file a bug report because FOR US USERS this is a bug.

    Friday, November 13, 2009 8:31 AM
  • Once that process is completed, thumbs.db is closed and no longer in use. Hence clicking “Try again” will allow the file to be deleted.
    Arthur, thanks for confirming the cause. However, to be clear, "Try again" often fails even after repeated clicking for 30 seconds. The delay quickly becomes impractical when dealing with a large number of network folders.

    Perhaps my shares are particularly susceptible to delay because I have thumbnail generation disabled on the host; thus, when a Win7 client accesses a share, it must generate thumbs.db from scratch.
    Sunday, November 15, 2009 8:26 PM
  • I say this lovingly, but it's hard to believe engineers when they're this dense. You think, surely he or she is trolling.

    Further, if there's an explorer nav bar, it seems a thumbs.db folder in the main pane can't be deleted for... well I gave up waiting.
    Friday, November 20, 2009 11:08 PM
  • I have the same problems deleting folders from network shares.   At the moment I'm on Windows 7 deleting folders from a Windows Vista system sharing files, but this obnoxious problem has been going on for as long as I can remember.  

    I do not want to disable thumbs .   This is clearly a BUG - Explorer should stop using thumbs before executing a delete operation.   "Try again" almost never works.    You can leave it sitting there for hours and it will still be unable to delete thumbs.   If you select another folder, then right click on the folder you want to delete, it will go away.  

    It's particularly problematic if you're trying to delete several folders.   

    Friday, January 08, 2010 4:09 PM
  • Is this required on all of the machines or just the affected server?  I am assuming, with gpedit, it will propegate throughout the organisation, but I thought it wise to be certain.  Thank you.
    Tuesday, February 09, 2010 4:03 PM
  • It'd be great if Microsoft would actually tell us if they have any intention of fixing this bug.  It's so fundamental that it wastes my time every day.  Why am I using Windows at all if it can't even manage it's own files?
    Monday, February 22, 2010 3:01 AM
  • I have an HP ex495 Windows Home Server & have quite a few folders on those network shares that encounter this problem regularly. I rename folders constantly for certain collections I have (movies mainly) and move files around. I get this error ALL THE TIME. My workaround is to cut & paste from the network share to my desktop, rename or delete, then move back to the network share if it's a simple rename. That's is ungodly time consuming. Because the files are so large, it can take a few minutes just to rename one stinking file.

    I CANT disable thumbnail view on network shares because that would defeat the purpose (would be painful to view family pictures & whatnot). I mean, do I really have to disable this on one of my several computers, then turn all the other computers off, then use that one PC to just rename? That's a bit insane.

    This is not a situation where I can come back a few min later and do what I need to do, and everything works. It's completely random. I could be sitting in the main directory where all the folders are located, try to rename 15 of ~100, and only one will allow me to rename. Also, these folders have been sitting in the shares for >1 month. Why are they being accessed right now? Makes not sense (to the layman, i.e. me).

    This is extremely frustrating and I can't be the only one who is running into this issue. I mean, this is extremely clunky and never happened on XP (which I upgraded to Win7 from XP, didn't like Vista).

    /signed a truly frustrated Win7 + WinHomeServer customer

    **EDIT**

    I just ended up doing this as explained above. I'm not entirely sure what it does, but now I can alter whatever I want and no problem with issues on the network drive. Unfortunately I'll have to do this for all computers. I hope this doesn't slow down my media center PC. I assume I'd have to do this on all PC's (all are off except the one I'm using now).

    As a less drastic alternative to Arthur's suggestion to "Always show icons, never thumbnails," I'm using group policy to disable thumbs.db creation on network shares. (Thumbnails for local folders are still cached normally, I believe, in the local centralized database.)
    • Run gpedit.msc.
    • Enable the following policy: User Configuration > Administrative Templates > Windows Components > Windows Explorer > Turn off the caching of thumbnails in hidden thumbs.db files
    Sunday, March 07, 2010 2:43 PM
  • I just wanted to second (10th, whatever) this as a bug and a constant source of frustration with Win7 for me as well.

    Every file I have that is not part of an OS, an installed program, or a temp/junk file is on a file server at either my home or office.  In other words, nearly every directory I create or delete during the day is on a network share somewhere, so I'm constantly running into this issue.  Win7 takes even longer to release its file lock on thumbs.db over a WAN, too.  (I'm assuming the operation that's holding the lock is sync'ing the now-empty directory with the thumbs.db file).

    That being said, I've been doing web development for many years, and have a ridiculous amount of images stored here there and everywhere, and having previews cached for those is a big plus, nay a necessity at times.  So I have no desire to disable thumbnail caching.

    As a related feature recommendation: It would be great to have the option, on a Win2K3 or Win2K8 file server, to have thumbnail generation handled by the server, and not the client(s).  The server obviously has much better bandwidth to its own disks, and it would obviate the need for each client to manipulate the thumbs.db file.  This would be particularly great over WAN connections.   ( <-- Last paragraph for my own fun -- I'm not naive enough to believe that any of this will actually be read/implemented/function correctly). 

    Thanks,
    Scott

    Saturday, March 20, 2010 12:52 AM
  • I wonder if Steve Ballmer ever uses his computer to delete local or remote folders. I'd love to ask.

     

     

    Saturday, March 20, 2010 7:58 PM
  • I can confirm the same problem and this bug is so annoying. Living in a world with MediaCenter, Windows Home Server and other network storage devices it is amazing that this bug has not been fixed yet. It is easily reproducable!
    Anders Heick | Software Architect | HandStep
    Monday, March 22, 2010 9:03 AM
  • Microsoft knows this is a problem and clearly doesn't care to resolve it and also clearly thinks that their customers deserve to be condescended to about it.

    Clearly if a delete operation is being performed against the file you would think that MS would be smart enough to code an automatic release of the file by the thumbnail database service, but no, they think it's ok for us to wait...and wait... and wait... for an unlock to occur... on an empty folder.

    So clearly the solution is to turn off the feature altogether since it's broken, MS doesn't care, and all it does is make us wonder why we aren't running Macs.

    Friday, April 02, 2010 8:29 PM
  • My experience is that the thumbs.db is being modified/generated inside subfolders without me even opening those subfolders.  I'm looking at a folder full of subfolders. I select a bunch and delete them only to be prompted about the thumbs.db being in use and not deleted insides seveal of the subfolders I've not touched in months.  So, I guess there is a recursive thumbnail processing going on as well.  Close Explorer and re-open, go in and delete the few remaining folders works.  Painful and poor programming.
    Monday, May 10, 2010 2:48 PM
  • Another easy way to get to this unwanted situation is to duplicate a network folder (with graphics in it). It will be called "Foldername - Copy". Then try to rename it. "The Action can't be completed because the folder of a file in it is open in another program." is the message that shows.

    This never happened to me in XP Pro in the same situation accessing the same servers.

    My (bad) workaround is to remote into the server, go into the managing the shares / open files section and close the open thumbs.db that is causing the problem. I realize most people won't have rights to do that.

     

    Friday, June 18, 2010 4:17 PM
  • This problem has stretched across several machines, operating systems and even servers that we have owned.  I have even thought maybe my old boss paid to have a curse put on me.  I am glad to see this discussion.  I know that I am not too crazy.  I have experienced almost all of these problems at some point and no one could explain it.

    I recently discovered that the culprit seemed to be the thumbs file.  I would try to delete it and it would not delete either.  These thumb files are being created in most of the subfolders when I am transferring files onto or within the server.  We are using windows server 2003.

     

    A couple days ago I discovered that if you change the view of the folder (I was using list) to icons you are allowed to delete the thumbs file and thus perform any action on the file. 

     

    I am using Windows 7 pro.  I am not sure if this will work for the other systems.  This process is a little less painful, but if you have many folders in folders it is still a pain. 

    I agree this is a major bug and it has been around for awhile.

    Thursday, July 01, 2010 11:41 PM
  • Please oh Please tell me there is a bugfix or acknowledgement of this bug in Windows 7 thumbs.db caching on a Network Share! We need a product manager to see this thread. No Product Manager worth their salary would allow such a "feature" to be released. It is extremely annoying and a significant draw on productivity. We want to have the benefits of cached thumbnails, but we don't want that benefit to slow us down, when it's supposed to speed things up! Other software handles this problem fine (ready: Picasa to name one). This is a bug, not a feature. Please address our pain at least with an acknowledgement!
    Friday, October 15, 2010 3:37 PM
  • as far as i can tell, i don't think this is relegated ONLY to servers or network shares.

    this is happening on my Win 7 laptop, which is not 'pro' and not part of a domain or anything.

    it is win 7 64-bit home premium. now, i do use it to copy movies to folders, and those seem to be the folders with the issue. and i do use it, from time to time, in a 'media center' role - i.e., play the movies in those folders from other locations. so some of these folders are shared out via Media Center, but not shared in the traditional "net use" or 'network share' meaning.

    i also am very bothered that Microsoft does not care to fix this issue.

    thanks.

     

    Saturday, October 16, 2010 8:03 AM
  • We finally turned off the option to create thumbs.db in Group Policy. They were appearing all over our network and including folders that are processed by batch jobs and were failing because of the unexpected files. Not to mention the very annoying problem of not being able to delete folders all the time, of course.
    • Edited by Rob.FordMVP Monday, October 18, 2010 8:39 PM typo
    Monday, October 18, 2010 8:39 PM

  • I d like to confirm the problem and would say that consider such a behavior as a BUG in windows explorer
    Denis Ivchenkov
    Thursday, October 21, 2010 2:29 PM
  • Is there still no good answer to this problem ??
    naive
    • Proposed as answer by Michael_84 Tuesday, September 24, 2013 11:07 AM
    • Unproposed as answer by Michael_84 Tuesday, September 24, 2013 11:07 AM
    Friday, October 29, 2010 8:46 AM
  • Yes, very annoying.

    It's seems no one will fix it, right?

     

    []'s

    Monday, December 06, 2010 2:18 AM
  • Yes, indeed. This is EXTREMELY annoying. I have a media center PC where I store all my music/videos/etc and I purposely disabled thumbnails on that PC. I noticed they were still being created and preventing me from managing my folders, since I'm constantly deleting/moving items for organizational reasons. I finally figured out it was my networked workstation, from which I remotely copy over media, that was creating them.

    This behavior should definitely be changed. In the meantime, thanks to this thread I have my workaround. My workstations are not on a domain, this is just a home workgroup, and I'm running Windows 7 across the board. I typed "gpedit.msc" from the command line and enabled the following policy:

    User Configuration\Administrative Templates\Windows Components\Windows Explorer\ -

    "Turn off the display of thumbnails and only display icons on network folders"

    Then just type "gpupdate /force" at the command line so it takes effect right away. I was immediately able to do a search/delete for every thumbs.db file.

    Cheers.

    Sunday, December 12, 2010 3:10 PM
  • I also see this issue on any machine running windows 7, whether client, server or not networked. 

    I especially encounter it when doing maintenance on my USB drives. It's extremely annoying and IS a bug. 

    I did not encounter it as a power user of XP, or 2000, or a light user of Vista professional.

    I do see it in win 7 ultimate professional both 64 and 32 bit editions, networked and otherwise. 

     

    I do almost 100% of my file maintenance and access in Windows Explorer (yes, I grew up in DOS), and would really appreciate this being fixed. It is a source of constant irritation.


    Stephanie
    Monday, December 20, 2010 8:37 PM
  • Please fix this, Microsoft. It eats away lots of time and makes for a convoluted workflow when I clean up my harddrives and my file server...
    Sunday, January 09, 2011 9:19 PM
  • I had the same issue. It's a bug in Win 7 Explorer when working with network shares.

    Explorer starts trying to create thumbs.db when you first click on the folder, then you delete the folder quickly so the file gets deleted before the thumbs.db is fully created. The thumbs.db file remains locked while the thumbnail process waits to fail and time out.

    If you keep pressing retry for a few seconds eventually it deletes the folder, after the thumbnail creation process has failed and released the file.

    I found the group policy edit suggested above works just fine. I applied the policy setting to my 2 laptops, my Win 7 MCE box and my home server and it is no longer an issue. Also browsing network shares is much quicker too...

    A gpedit workaround is fine for us experienced users, but Explorer should not be so stupid to keep trying to create a thumbs.db for a folder you are in the process of deleting. How do we submit a bug report for this?

    Sunday, January 23, 2011 9:27 PM
  • A gpedit workaround is fine for us experienced users, but Explorer should not be so stupid to keep trying to create a thumbs.db for a folder you are in the process of deleting.

    Agreed. In the meantime, if anyone finds this faster or easier, here's the .reg file equivalent of the group policy fix discussed above.

    (Paste the text below into Notepad, save it with a .reg extension, and then double-click the file.)

     


    Windows Registry Editor Version 5.00

    ; Enables group policy: "Turn off the caching of thumbnails in hidden thumbs.db files"

    [HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Explorer]
    "DisableThumbsDBOnNetworkFolders"=dword:00000001
    • Proposed as answer by Thirtybird Saturday, February 05, 2011 12:30 AM
    Thursday, January 27, 2011 4:46 AM
  • Thanks JoeBoxer - that took care of the problem and will work on any version of Win 7.
    Saturday, February 05, 2011 12:31 AM
  • Took care of the problem for myself and a co-worker as well.  Thanks!
    Tuesday, March 01, 2011 9:41 PM
  • Thanks, this little .reg file seems to have worked for me.
    Friday, March 11, 2011 2:32 PM
  • Glad I found this thread.  +1 for this horrible bug.  Here's an arguably even easier way to set the policy.  Bring up a (administrator) CMD prompt and type:

     

    REG ADD "HKCU\Software\Policies\Microsoft\Windows\Explorer" /v "DisableThumbsDBOnNetworkFolders" /t REG_DWORD /d 1 /f

     

    And you're done.

    Saturday, March 26, 2011 1:59 PM
  • Another one for this bug, although I have found a way to delete the folders, if you set the folder containing the thuimbs.db into tile view in Explorer and then go back up to the parent directory, the folder will delete without problem.
    Sunday, May 15, 2011 8:51 PM
  • This bug, or poor design, has been around for ages and Microsoft refuses to acknowledge it's a problem.

    Much like the new "expanding folder bug" in explorer (where you select a new folder on the left and then serveral seconds later explorer expands the originally selected folder ANYWAY...) these severe usability issues go unfixed and unacknowledged.

     

    And as you can see there's no more MS responses since the MS guidelines are to never acknowledge bugs they won't or can't figure out how to fix, just let customers continue to complain until they go away :)

    Thursday, June 30, 2011 8:10 PM
  • If you set the folder containing the thuimbs.db into tile view in Explorer and then go back up to the parent directory, the folder will delete without problem.

    Good one, yes. And I also use Unlocker. By the way, my problem is not on servers or shared things or whatever. I'm a lone user, and I have this problem a lot. I want to put into order my collection of files (be it recipes, knitting patterns, pictures, pdf ebooks, music or whatever) and I constantly do deleting, renaming, moving etc... Now it's impossible. For every time I have to right click and use unlocker, and it unlocks it only for one action. If I want to rename and then move, I have to unlock again. To see what things are before deciding to rename or delete or whatever, I need to see thumbnails, tiles are not good enough. I need to be able to read the titles of the .pdfs or books, or the title of the music album. So it gets infinitely laborious.

    By the way, another problem I have with Windows 7 (and it's a random problem) is that the folders don't refresh themselves. So if I rename, the old name stays, so if then I want to open the folder, it says it doesn't exist (and yes, with that name it doesn't), so I have to constantly hit the F5 button.

    Otherwise I love Windows 7, but those two things are driving me crazy. I was thinking that it was just me, because I updated without uninstalling Vista, and I was thinking of reinstalling them (in the beginning the problem was not so bad), but thanks to this thread I now know that it's not that.

    Wednesday, September 07, 2011 4:39 PM
  • How to Turn off Caching of Thumbnails in Thumbs.db Files

    People sometimes report that they cannot manipulate their folders as they want to because Explorer has a Thumbs.db file open.  Windows 7 apparently generates these files for compatibility with older software that may expect such files to exist in folders with, for example, photos in them.

    Unless you're running such old software, you can just turn this off without consequences (except that your system won't be fooling with your photo files to make Thumbs.db files in the background).  Thumbnail views will STILL WORK, as Windows 7 Explorer now actually stores its thumbnails in a central database for its own use.

    With Windows 7 Professional and above you can disable this through the Group Policy Editor:

    • Click the Start orb
    • Enter gpedit.msc in the search box and hit Enter.
    • Expand User Configuration - Administrative Templates - Windows Components.
    • Click on Windows Explorer.
    • Right-click the entry "Turn off the caching of thumbnails in hidden thumbs.db files" and choose Edit.
    • Enable the setting.

    Note: If you have a version of Windows that does not provide the Group Policy Editor, the above change can be done through a registry modification. NOTE: BE VERY CAREFUL WHEN MODIFYING THE REGISTRY.

           [HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\ Explorer]

           DisableThumbsDBOnNetworkFolders   REG_DWORD    0x00000001

    You will want to log off and back on again (or reboot) after making these changes.

    -Noel

    • Proposed as answer by Noel Carboni Wednesday, September 07, 2011 4:59 PM
    Wednesday, September 07, 2011 4:59 PM
  • Thanks Arthur_Li! The Unlocker you have mentioned is an excellent tool. I have a Vista on a simple home laptop - not shared with any other computer, not remotely connected .

    I was unable to delete a particular folder - no matter what I did. I showed the icons and deleted thumbs.db file. Still I could not delete an empty folder. Then I installed Unlocker program as suggested by you. I right clicked on the folder and selected Unlock. After few seconds of analysis, it found the program which was unlocking it - the Quicktime. Once unlocked, the folder got deleted immediately.

    Very annoying problem, solved using simple program Unlocker without going through the risky REGISTRY modifications mentioned in the later posts. Moreover all the later posts were mentioning to shared folders in network.

    Thanks once again!     

    Friday, October 14, 2011 8:13 AM
  • Thanks a ton for this, now I can finally rename my folders without Windows 7 actually acting up on me.
    7/
    Sunday, November 27, 2011 7:37 AM
  • Noel,

    Many, many thanks for this. Problem solved. There are many, many annoyances like this in Windows 7, which the Microsoft team refuse to admit as serious usability problems. A single issue is fine, but an army of them just makes Windows annoying to use.

    I recently bought a Mac for my wife. I am thinking of switching over over myself, all due to issues like this - and to people like Mr. Li who work at Microsoft -  friendly and courteous, but completely unable to acknowledge or solve the actual problem. A work-around is not a solution to bad design.

    I work in financial IT, and there's a well-known phrase the traders use to describe their experiences with developers - "everything he said was absolutely correct, but was completely useless" (with the implicit, "It did not solve my problem, so why do we even have these people around if they're just wasting our time and money?" tacked to the end)

    You sir, understand this, and were able to give the community the answer it actually needed. Many thanks!

    Wednesday, May 23, 2012 5:50 PM
  • I agree with everyone here that this error is really annoying. How could they not have caught it before the release?

    Thank you very much for the workaround!!!

    Tuesday, June 05, 2012 9:36 PM
  • If you just want to get over your current problem without modifying registries, etc, maybe because, like me, you just want to purge a directory and this is preventing you from doing so, then you can issue the below command using the command prompt inside the folder you're trying to delete:

    del /F /A:H Thumbs.db

    It essentially just force deletes that hidden file.  Good luck!

    • Proposed as answer by Admanb Monday, June 18, 2012 2:25 PM
    Monday, June 18, 2012 2:24 PM
  • Windows 7 apparently generates these files for compatibility with older software that may expect such files to exist in folders with, for example, photos in them.  Unless you're running such old software, you can just turn this off without consequences (except that your system won't be fooling with your photo files to make Thumbs.db files in the background).  Thumbnail views will STILL WORK, as Windows 7 Explorer now actually stores its thumbnails in a central database for its own use.

    While Noel's answer was basically just a combination of two previous solutions, it was nice getting a clearer explanation for why Windows was creating these thumbs.db files, and that turning them off would not impact Thumbnail view.

    To clarify his registry modification instructions (for anyone new to editing the registry):

    • Go to Start, type in regedit and hit Enter.
    • Expand HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Explorer.  If you do not see an Explorer folder, you can create one.  Right click the Windows folder and select New > Key.  A new folder will be created under Windows; name it Explorer.
    • Right click Explorer and select New > DWORD value.  Name it DisableThumbsDBOnNetworkFolders
    • Double click DisableThumbsDBOnNetworkFolders, change "Value data" from 0 to 1, and click OK.

    Or, of course, you can just create a reg file like joeboxer suggested.

    Monday, August 13, 2012 11:11 PM
  • Its simple.

    Go to folder option

    View tab

    Uncheck the option "Display file icon on thumbnails"

    This worked for me, however i'm not sure about the impact of doing this

    Tuesday, August 14, 2012 11:40 AM
  • the point is that the functionality is broken.

    If you had to boot to safe mode to empty the recycle bin ("it's a simple solution, just boot to safe mode!") it would be similar. This is unintended. There is no way they meant these files to behave this way. They need to make them completely disposable.

    Like, if a process is actively writing to a file called Thumbs.db and a delete gets called on the file, ANY operation wins and the file itself loses. This is annoying to no end.


    You are no longer AFK.

    Sunday, September 23, 2012 2:43 AM
  • Agree. Windows 7 is really dumb.

    "This action can't be completed because the file is open in Windows Explorer."

    I'm looking at the file in Windows Explorer! How else do they expect us to delete the file?

    Tuesday, October 16, 2012 9:00 PM
  • Hi asterismW

    I've been having this locked folder problem for a while now, and I want to try your fix (Windows 7 Home Premium doesn't allow me to do gpedit).  I got as far as creating the new key, but for the DWORD I am offered the choice of creating a DWORD (32-bit) value or a DWORD (64-bit) value.  My Windows 7 is 64-bit.

    Do I choose 64-bit to match the Windows version, or is the thumbnail disable function a 32-bit value?

    Thanks for any help you can offer.

    Sunday, November 11, 2012 5:11 PM
  • 32 bit.

    Registry access is substantially the same regardless of the instruction set.

     

    -Noel


    Detailed how-to in my eBooks:  

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options

    Sunday, November 11, 2012 9:55 PM
  • Thanks for your quick and helpful response, Noel.  I'm going to give it a shot tonight.
    Sunday, November 11, 2012 10:38 PM
  • Good luck.  Make sure you log out and back on again to test the change.

     

    -Noel


    Detailed how-to in my eBooks:  

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options

    Monday, November 12, 2012 12:58 AM
  • Hello everyone.  Add me to the list of it's now 2013 and this is STILL a problem in Windows 7 unfortunately.  Did everyone just configure the "Turn off the caching of thumbnails in hidden thumbs.db files" GPO setting?  Is there a similar setting if you are only using Server 2003? (assuming this setting is from doing GPO's in a newer version of server than 2003).

    Monday, January 28, 2013 3:35 PM
  • Any solution available for hide thumbs.db with unhide of protected files enabled?

    Thx

    Friday, February 01, 2013 2:01 PM
  • This still happens in Windows 8.

    Yippie!

    Friday, June 14, 2013 11:01 AM
  • Yes, and the same "To Work" solution I presented above still applies.  Use the policy editor if you can, registry editor if you can't, then enjoy doing without this particular trouble ever again.

      

    -Noel


    Detailed how-to in my eBooks:  

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options

    Friday, June 14, 2013 7:28 PM
  • It's not a solution, it's a workaround, and it's rediculous that after 6 years it STILL ISN'T FIXED!
    Wednesday, October 16, 2013 7:30 AM
  • Your impression of what should be and reality differ.  :)

    I suggest that only one can change.

     

    -Noel


    Detailed how-to in my eBooks:  

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options

    Wednesday, October 16, 2013 5:16 PM
  • If you cut the Thumbs file, then you can move it, delete it from the new location and delete the folder.

    It allows you to move but not directly delete when it's in use for some reason.

    Friday, December 20, 2013 10:53 AM
  • This is an old post ofcourse, but it does contain nonsense. Empty directories where no images are kept still have this error, and a process that takes 30+ seconds to scan an empty directory, finding nothing and writing nothing is just not a realistic thing to come up with.

    It looks more like a network lock that lingers for some time before it really disappears.

    This bug has been around for ages (6+ years?) and even though it's just a minor problem really, it does make you wonder if MS uses their own OS for real. Surely MS developers must be frustrated by the same thing.

    But even so, stating obviously false facts is misleading and only adds to the frustration of many Windows followers.

    Monday, January 06, 2014 10:44 AM
  • stating obviously false facts is misleading and only adds to the frustration of many Windows followers.

    Use quoting please.  It's not clear what post you're responding to.

    Windows followers need only configure the local policy to avoid using thumbs.db in order to be permanently free of this problem, with no downside.

     

    -Noel


    Detailed how-to in my eBooks:  

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options

    Monday, January 06, 2014 1:34 PM
  • Windows followers need only configure the local policy to avoid using thumbs.db in order to be permanently free of this problem, with no downside.

    -Noel

    1 - No downside except the labor required to modify the default Windows configuration.  Local group policy doesn't fix the many computers I am responsible for.  Domain group policy changes require a bureaucratic change management process.  Time is money.

    2 - After configuring these things on my workstation, it was still not allowing me to delete my thumbs.db file (or the parent folder) from a network share, claiming it was in use:

    • Folder Options > View > "Don't show hidden files, folders, or drives"
    • Folder Options > View > "Hide protected operating system files (Recommended)"
    • Local Computer Policy > User Configuration > Administrative Templates > Windows Components > File Explorer > "Turn off the caching of thumbnails in hidden thumbs.db files" (ENABLED)
    • Folder Options > View > "Always show icons, never thumbnails" (CHECKED)
    • Folder Options > View > "Display file icon on thumbnails" (UN-checked)

    I confirmed that the file was not actually open by checking the Server 2008 Resource Monitor on the file server, as well as Computer Management > System Tools > Shared Folders > Open Files.

    The 3rd-party Unlocker tool claimed that the file was not locked, but it was able to delete it for me nonetheless.  I tried that before trying del /f but that may have worked as well.



    • Edited by Fëanor Saturday, January 11, 2014 1:24 AM
    Saturday, January 11, 2014 1:23 AM
  • I love you and joeboxer.

    This was being a nightmare in windows 8. Microsoft technical support didn't know how to solve it after one month dealing with them and escalating it 3 levels (!).  They insisted that the problem was that my files were corrupted... (even though I prove them wrong, cause the problem didn't happen on another PC with Windows 7).  I was about to install windows 7... 

    Thanks a lot!!


    Friday, January 31, 2014 11:49 PM