none
Windows 7 Ultimate Upgrade from Windows Vista Premium problems

    Question

  • Hello,

    I have a Dell XPS 1530 laptop with windows  vista premium, I upgraded to windows 7 Ultimate, before I did this I ran the windows 7
    upgrade advisor and I was told this laptop is ready for upgrade to windows 7 Ultimate.

    When I started the upgrade I was told I should get the latest Bios and I did update to the latest Bios.
    After the upgrade I started having problems wth the video adapter driver and also with the intel wireless adapter driver, I have:

    1- Intel Wireless Wifi Link 4965 AGN
    2-The video aadpter is Nvidia GeForce 8600MGT

    I downloaded and installled the latest available drivers for both (1 and 2 above) for windows 7, however I still having the folowing problems:
    1- from time ime I loss the wireless connection (this never happened before with vista) it only happened after the upgrade.
    2- The screen somtimes becomes black and I get the display adapter recovered from a problem.
    3- The mouse freezes sometime and I have to turn the computer off and on to recover.

    Are there any solutions ideas to the above problems that I am having?

    Thanks

    Oakarim
    Sunday, December 20, 2009 8:59 PM

Answers

All replies

  • Did you go back to Dell's website and dewnload the new Windows 7 drivers (chipset first). I just check Dell's website http://support.dell.com/support/topics/global.aspx/support/dsn/en/document?journalid=7B26334BE80F622DE040AE0AB5E13539&docid=364754 regarding Windows 7 compatibility and there are no Windows 7 drivers available. If Windows update doesn't find drivers for your hardware, you might have to install the drivers in Vista compatibility mode.  As for connection problems, I found mine has disappeared after I disabled power saving features on the NIC's. I also disabled IPv6 since I'm using an old linksys wireless b/g. As for Nvidia, check this thread http://social.technet.microsoft.com/Forums/en/w7itprohardware/thread/38f25c1d-de67-4c74-8845-2cd3a15d8e41. Is the mouse wireless/bluetooth or usb?
    MCSE, MCSA, MCDST [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Sunday, December 20, 2009 10:54 PM
  • Hello,

    Yes the first thing I did was to check dell.com:


    There is no drivers for windows 7.


    where do we disable power saving for the wireless?
    What is IPv6?

    The mouse is the laptop mouse it is not USB or external one.

    The big problem is the wireless problem.

    Thanks

    Oakarim
    Monday, December 21, 2009 3:50 PM
  • Read here on how to install Vista drivers in Windows 7 via compatibility mode http://social.technet.microsoft.com/Forums/en-US/w7itprohardware/thread/80cae5ee-dc98-4a2f-8284-a1ab826059b7

    To disable power saving of your nic's go here, Control Panel/Network and Sharing Center, left side of the screen choose Change Adapter Settings, Choose Wireless Network Connection, right click and go to Properties. You'll see a Configure button towards top right (see Connect Using section), click it and another screen opens, choose Power Management tab far right, uncheck "Allow the computer to turn off this device to save power". Repeat the process for the Local Area Connection.

    IPv6 is  is the next-generation Internet Layer protocol for packet-switched internetworks and the Internet. Which brings up another possible issue for you too - What is your wireless router connection? (what device - be specific as to model # etc). You may have to update the firmware on it.

    yes, mouse is your touchpad or your pointing stick (yours may have both), again driver issue see links above
    Same for wireless problem - but again, router may need firmware update to be Windows 7 compliant

    To uncheck the use of IPv6, repeat steps like you were going to disable power saving of the nic's, you will see a windows section that says "This connection uses the following items:" Look for Internet Protocol Version 6 (TCP/IPv6), uncheck it - but only after you've done everything else and nothing else worked (at that point)

    MCSE, MCSA, MCDST [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Monday, December 21, 2009 5:28 PM
  • If a driver is designed for Windows Vista and not compatible with Windows 7, it may not work even you force install it. The video adapter driver can be downloaded from the following Dell website.

    Drivers & Downloads for XPS M1530 

    The websites indicates that the drivers are for Windows Vista. You can also try the latest video driver from NVIDIA.

    NVIDIA DRIVERS 195.62 WHQL

    And try the wireless driver from the following Intel website.

    Intel Download Center

    Important Note: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

    If the above drivers do not help, you may need to wait the manufacturers to release Windows 7 compatible drivers.


    Arthur Xie - MSFT
    Tuesday, December 22, 2009 6:56 AM

  • Hello,

    The first thing I did was to check in Dell web site: Drivers & Downloads for XPS M1530 

    but didn't find drivers for windows 7.

    Regarding:

    The websites indicates that the drivers are for Windows Vista. You can also try the latest video driver from NVIDIA.

    NVIDIA DRIVERS 195.62 WHQL

    This is what have installed now and having problem from time to time

    And about:


    And try the wireless driver from the following Intel website.

    Intel Download Center


    This where I  downloaded the latest driver for windows 7 and which I have the problem


    The upgrade adviser should told me about these problems before Upgrading...


    Thanks

    OaKarim
    Tuesday, December 22, 2009 1:13 PM