none
Windows 7 experiences 100% disk busy and system completely unresponsive

    Question

  • Windows 7 experiences 100% disk busy and system compleltely unresponsive - won't even move the mouse pointer. Occurs anything from a few minutes to an hour after connecting to a VPN to which many other Windows 7 users connect with no problem. The problem sometimes clears itself in 5-30 minutes but on other occasions has carried on overnight. Disk activity will subside and then stop if I pull out the network cable.

    Happens without me doing anything specific to trigger the problem although usually (not always) associated with using Outlook.

    Once the problem begins ResourceMonitor quickly falls behind and stops responding but as the problem gathers pace a typical Resource Monitor showing would be “System” with pid 4 writing about 9MB/sec to pagefile.sys, lsass.exe was reading about 8MB/sec from pagefile.sys, and other programs such as iexplorer, outlook and avp were reading substantial amounts from pagefile.sys. The physical memory was only about 50% utilised at that time.

    This was happening on a laptop which had been rebuilt clean with 32 bit Windows 7 after previously working with Vista - with Vista I had experienced similar symptoms on two or three occasions scattered over a period of three months - with Windows 7 it was every time I connected the VPN.

    I got a different brand new laptop, ran it OK for a week with XP (including using the VPN) then did a clean rebuild with 64 bit Windows 7 - and immediately get the problem back again with the same symptoms. This machine has 4GB memory, 250GB disk with 200GB free - when the problem happened there was 2.5GB memory available - so why the pagefile writing?

    Even when the problem isn't occurring, when the VPN is up I can see in Resource Monitor that at certain times lsass.exe is intermittently grabbing and releasing very large amounts of memory.  Typically I had over 2GB available, but periodically lsass.exe would spike sometimes with a commit size of over 2GB, lasting for just one or two seconds on the Resource Manager snapshot.

    I tried running with no pagefile.sys.  I didn't get the disk busy problem, but I was getting prompts for me to close some applications even though if I switched to Resource Monitor it could be showing 2GB available - presumably the prompts were caused by the lsass.exe spikes.

    I'm wondering whether when I have pagefile in use the lsass.exe spikes are causing thrashing even though it appears that I have plenty of memory.
    Monday, February 08, 2010 12:01 PM

Answers

All replies

  • Hi PeterGeraghty,

     

    I would like to suggest you update the antivirus program definition and scan the system in Safe Mode.

     

    If no virus is found, I also would like to suggest you update the BIOS and the chipset drivers, then check the hard disk for errors.

     

    If the issue persists, you may also test the issue in Safe Mode with Networking and Clean Boot.

     

    What’s the result?

     

    Regards,


    Arthur Li - MSFT
    Wednesday, February 10, 2010 2:59 AM
  • I've got the same problem with several notebooks in the last two years while authenticating from remote session through VPN or IPSec to domain servers. Systems are Windows Vista x86, Windows Vista x64, or Windows 7 x64; all either with Norton Internet Security 2010, or Microsoft Forefront Client Security. The newest BIOS and drivers. Several hard disks exchanged.

    lsass.exe process consumes almost all available RAM, so the disk is fully occupied with swapping.

    The problem persisted both in Safe mode with networking, and in Clean Boot.

    The problem never reveals itself while the machines are connected locally in the domain's LAN.

    This is a well known problem in Windows Server 2008 and Windows Vista, with provisional hotfixes on http://support.microsoft.com/kb/971265

    There is proposed work around on this site, also:

    "To work around this issue, use the Kerberos authentication."

    I've changed the primary method of the authentication from Certificate to Kerberos on Windows 7 to succesfully mitigate the problem in some cases. Unfortunately, there remain cases when lsass.exe commits more then 9 GB on system with 4 GB RAM.

    vjj

    • Proposed as answer by vjj Friday, July 30, 2010 11:45 AM
    Thursday, July 29, 2010 8:38 PM
  • This issue was raised as a support issue with Microsoft and after several months of investigation by their engineers it became apparent that some incorrect settings in the ISA firewall server were relevant to this problem.  The problem went away when the sys admin guy changed the firewall settings.  Microsoft then closed the issue, although really it is not good that the client gets stuffed because of a mistake in the server set up.

    Tuesday, November 23, 2010 11:33 PM
  • First of all, moderators, please don't take the following personally as I can only assume the moderators here are not responsible for the production of Windows operating systems.

    I would like to point out that the HDD 100% activity problem has in no way been resolved with Microsoft operating systems. My current PC running Windows 7 x64 has this problem, as had my last machine running Vista x86, neiher of which I used to connect to VPNs. This has been a point of discussion with friends and colleagues on a number of occasions, each of whom used their PCs for various tasks. A quick search on the net will indicate that this problem is endemic with Microsoft operating systems, often rendering the machine in question next to unusable until the software finishes working itself into a frenzy, and in the process greatly reducing the lifespan of the hard disk. Of course no one on any forum of the dozens I checked has an answer to the problem, which would seem to indicate yet another example of the shabby production standards reached when a monopoly is acquired in industry - this issue of malfunction being the mere tip of the iceberg with regard to the long long list of Windows malfunctions since the first day I pressed the on button on a pc. I'm tired of spending money on hard drives and wasting countless hours in front of overblown calculators, which is what Microsoft operating systems reduce my powerful hardware to due to the technically incompetent production of the software. Of course the age-old peripheral-compatible complexity excuse will be slammed down once again on the polished board table in Microsoft Ivory Towers.

    Now I buy Chinese manufactured PCs because of the appalling day by day reduction in quality of Western hardware, and as soon as those hardworking people produce an operating system which gains enough ground to offer any sort of rivalry to the tyranny of anti-progression that is Windows I will gladly comply, even if that means learning how to type every character of Chinese.

    A crank or malcontent is what I will most likely be called for this, but if this is the truth the whole world of PC users are cranks and malcontents due to being forced to settle for Windows, or the only other alternative: build their own hardware manufacturing plant and software industry from wood.



    Saturday, April 02, 2011 7:19 PM
  • I agree that this problem is endemic to Microsoft operating systems - XP, Vista, Win 7 and probably Win 8 (don't know about 8 - not going there). I am currently running two, identical HP P7-1240 systems, one with Win 7 Home Premium and the other with Ubuntu 12.04. As I type this reply, the hard drive continues to thrash about on the Win 7 box, while the Ubuntu box sits quietly in the corner. I keep the Win 7 box for those times I need to collaborate with other MS Office users, but do most of my real work on my more reliable Linux box. Generally, I have found that I can maintain an entire Linux system with 10 to 20 times less effort than it takes to install and debug a single piece of Windows software, to say nothing of premature hard drive failures (Western Digital and/or Hitachi drives seem to hold up best). Linux boots much faster, never locks up or breaks down, attracts no viruses and includes just about every program you could ever want for free.

    A new (for me) feature of Windows 7 is a propensity for the current open window to briefly disappear, revealing the Windows desktop, then pop back up at the point where it left. No data loss, just a bit annoying - as I always expect the worst from Windows.

    Bottom line, I view Windows as a product similar to an American car in the early 70's. Not very reliable, but it usually will get you where you need to go, as long as the drive is not mission critical. I expect Windows 8 will be just as adequate, but I'll not be updating until Microsoft does something to Office to prevent it from working on Win 7 (even though I can save documents in docx format in the free, Libre Office Writer included in most Linux distributions).

    Saturday, November 24, 2012 5:16 AM
  • Ok here we go, I have already solved this issue on my own. I was caused by several updates that occured over the past year, so there are multiple reasons its doing it.

    First off disable windows indexing service (May be labeled windows search), by clicking start and typing services.msc. Double click on windows indexing service click stop and change start up to disabled. Your disk usage should be down to 50% now. (MS updated triggered this issue)

    Also disable both of these if you have ngen process is eating cpu usage.> Microsoft .NET Framework NGEN v4.0.30319_X64 and Microsoft .NET Framework NGEN v4.0.30319_X86 (MS update triggered this issue to) They say it takes 15-20 mins to run its course but it fails and runs long after it is done.

    Look in your process lists for things that are running while you are IDLE using CPU when your doing nothing (You may see spooler, or media center processes look them up and disable the ones you dont need in services.msc) Disk usage should now be 0%

    Next located Customer service experience program and disable it also (You may have to look a bit to find it in task scheduler). Personally I think when I click i dont want to participate, the tasks should be disabled automatically but it still starts on its own still in the background doin god knows what. Click start type task click task schedule.

    • Proposed as answer by MS_Guru_Tom Saturday, November 24, 2012 5:15 PM
    Saturday, November 24, 2012 5:15 PM