none
Windows 7 Ultimate - Painfully slow file transfer on ethernet network (cables only)

    Question

  • Hi

    Just bought and installed Win7 Ultimate 64bit on my desktop pc. All quite wonderfull so far :).
    However I have major performance issues with network file transfer (for backup).

    My home server runs WinXP Pro 32bit.
    The day before I installed Win7 Ultimate 64bit on my desktop PC, I transfered all my pictures+docs to my server, it was
    around 32 GB and it took less than an hour.

    Now today, if I try doing the same from Win7 Ultimate 64bit to WinXP Pro 32bit, the transfer speed slows to below 1 mb/s within a minute.

    Facts :
    Network :
    All uses ethernet cables, only. NO Wifi, at all.
    Linksys router.

    Server PC:
    100MB Ethernet
    WinXP Pro 32bit
    Shared folders

    Desktop PC:
    Nvidia nForce Ethernet (10/100/1000)
    Win7 Ultimate 64 bit
    Drivers up to date from Nvidia's site
    MB: Asus P5N-T Deluxe (nForce 780i chipset)
    Shared folders

    Transfer speed before (using WinXP 32, both machines):
    32 GB less than an hour

    Transfer speed after (now using Win 7 Ultimate 64bit on desktop and WinXP Pro 32 bit on server):
    32 GB, transfer speed drops way below 1mb/s within a minute and takes >12 hours if I where to let it complete.

    What I have tried:
    1. RDC disable - no improvement
    2. Force 100Duplex on both machines - no improvement
    3. Update network drivers - no improvement
    4. Transfer files either way - no improvement
    5. Disable AutoTuning - no improvement
    6. Installing IPV6 on my server - no improvement(however my router does NOT support IPV6 so that MIGHT by a FAR shot be a problem for Win7)
    7. Use SyncToy to copy files - no improvement
    8. Use explore copy/paste - no improvement
    9. Googled for hours on end and attempted x number of other suggested fixes - no improvement


    Questions:
    1. Does anyone know if this is a known problem for:
          Nvidia nForce drivers
          Windows 7 Ultimate 64 bit
          Other
    2. Are there a fix underways?
    3. Does anyone have any suggestions for fixes I might try or an actual solution?


    Last fact:
    Im desperate and frustrated :S.


    Will appreicate any helpfull/enlightenning comment :).


    Kind Regards
    Christian Mikkelsen
    Saturday, October 24, 2009 1:47 PM

Answers

  • Try RichCopy. It's not a fix for the problem but you might get better throughput.

    http://technet.microsoft.com/en-us/magazine/2009.04.utilityspotlight.aspx

    Tom
    Sunday, October 25, 2009 5:39 PM
  • Wow thx Thomas.


    I've been using Robocopy for a long time now, but this here is definitly a big improvement and
    better alternative by the looks of it.
    Im digging into it as speak, thx a mil :).


    Kind Regards
    Christian Mikkelsen
    Sunday, October 25, 2009 8:44 PM
  • Hi

    Just a followup.
    I reinstalled Windows from scratch with drivers, keeping an ekstra eye on the installation order and boom
    everything is working top notch.
    Guess I must have made some kind of error during the initial installation or a fix in either a driver or windows
    have been released.
    Anyhow I'm a happy guy with a good transfer rate again.
    Using both Robocopy and RichCopy for backup now :).

    Kind regards
    Christian Mikkelsen
    Wednesday, October 28, 2009 11:13 PM

All replies

  • Opps forgot a couple of common ones:

    Desktop PC
    Uses AVG Free.

    10. Tried uninstalling AVG Free - no improvement
    11. Disabled firewall - no improvement
    12. Tried downgrading to nForce drivers from version 15.51 to 15.35 - no improvement
    13. Tried copying files using the free version of Total Commander - no improvement

    Thoughts:
    Should I try installing Windows 7 Ultimate 32 bit instead?


    Anyone who can help me out :) ?
    Saturday, October 24, 2009 3:10 PM
  • Have you ruled out any CPU utilization issues, such as disabling anti-virus or other background processes? You can simply check the task manager for that. Maybe try booting to the Windows 7 disc, and from a command prompt (Recovery environment), copy some files to see if it is just as slow. That may help determine if you have an environment-specifc issue with your Windows 7 installation or a hardware problem.

    Saturday, October 24, 2009 3:55 PM
  • I have tried disabling (actually completely uninstalling) my anti virus (AVG Free) with no result.
    Have just attempted:

    14. Map the network drive + copy from command line - no improvement
          The task mgr network utilization shows high spikes very 10 sec or so, but then drops to 0 for 10 secs.
          The CPU utillization shows a 1-2% utilization.
          Im running a DualCore Intel E8500 3.16 Ghz, with 4 GB Ram FSB 1333(As far as I remember.

    Thx for the suggestion, I will try using the Windows 7 disc now and write back afterwards.

    Kind regards
    Christian Mikkelsen
    Saturday, October 24, 2009 4:42 PM
  • I tried by booting but it made no difference :(.
    Thx though for the suggestion.

    Saturday, October 24, 2009 5:29 PM
  • Since you seemed to have covered a good bit a troubleshooting, the only other thing I can suggest off the top of my head is trying a different NIC if you have one available. Maybe Windows 7 is being tempermental with the Nvidia.
    Saturday, October 24, 2009 7:05 PM
  • Don't think I have that option, but I'll have to look through my old stuff first :).
    Just keeps bugging me that everything else seems to run smoothly, browsing via network, remote desktop, etc, but just
    not file transfers :S.

    Saturday, October 24, 2009 8:46 PM
  • To determine if it is an SMB (File and Print Sharing) issue, you could try using another method such as FTP or WebDAV. I have not heard of any issues going between Windows 7 and XP myself, but you never know. If I recall correctly, XP Pro includes IIS FTP and maybe WebDAV. If it doesn't, you can download a free FTP server such as WarFTP and try that.

    Saturday, October 24, 2009 9:09 PM
  • Tried the FTP without any luck.
    Also tried copying via apps like GBridge, since the RDP seems to run smoothly, but it gave the same result, nada!
    Im going to do a fresh install of Win7 Ultimate 64 Bit, to give it one last shot, keeping an extra eye on the driver installation sequence and hope for the best.

    But if anyone out there can think of any explanation why the transfer speed starts high and drops to less than 1 Mb/s, please give me hint :), cause
    im going nuts (have to do manual external drive backup until this is fixed :S ).

    I believe it to be either:
         a. The nForce drivers from nvidia (using newest 15.51 whql) - My motherboard is a P5N-T Deluxe, i780 chipset
         b. Some secret limitation "feature" in Windows 7 Ultimate which is not functioning prober.... yet.

    Will write back if I find a solution.


    Kind regards
    Christian Mikkelsen
    Sunday, October 25, 2009 4:20 PM
  • Try RichCopy. It's not a fix for the problem but you might get better throughput.

    http://technet.microsoft.com/en-us/magazine/2009.04.utilityspotlight.aspx

    Tom
    Sunday, October 25, 2009 5:39 PM
  • Wow thx Thomas.


    I've been using Robocopy for a long time now, but this here is definitly a big improvement and
    better alternative by the looks of it.
    Im digging into it as speak, thx a mil :).


    Kind Regards
    Christian Mikkelsen
    Sunday, October 25, 2009 8:44 PM
  • Hi

    Just a followup.
    I reinstalled Windows from scratch with drivers, keeping an ekstra eye on the installation order and boom
    everything is working top notch.
    Guess I must have made some kind of error during the initial installation or a fix in either a driver or windows
    have been released.
    Anyhow I'm a happy guy with a good transfer rate again.
    Using both Robocopy and RichCopy for backup now :).

    Kind regards
    Christian Mikkelsen
    Wednesday, October 28, 2009 11:13 PM
  • Good to know. We will probably never know what caused the orogonal problem. I am glad it is OK now.

    Tom
    Thursday, October 29, 2009 12:06 AM
  • Just great :(  ...reinstall??? Did your problem every resurface after reinstall?  I see this only when network copy large (~4GB) files from windows 7 -> 1 particular WinXP system.  Here is what does and doesnt work:

                 windows7        winxp sys1         winxp sys2              linux

                      x------------------>        19MB/Sec,  then randomly hangs in 0-5 minutes

                      x--------------------------------------->  19MB/Sec

                      <----------------x          30MB/sec

                      <-----------------------------------x 30MB/sec

                      <--------------------------------------------------------> 45MB/sec (wow! copy to/from linux MUCH faster)

    All above was done with the integrated 1GB ethernet in my system:  Realtek PCIe GBE.  As a test I disabled the integrated, and installed an Intel PCIe ethernet, ...SAME PROBLEM.

     

     

    Friday, June 04, 2010 6:57 PM
  • Yes, I agree.  I don't think a re-install is an adequate solution.  I am having same problem as original poster and have done most of the same steps.  Windows 7 64bit Professional edition.  Same issues going from Win7 ---> WinXP sp3, but not the other way around. 

    I have seen many with this issue (and probably a lot more that goes unreported from clueless users).  Any other ideas what it could be?  It seems to me that it hangs soon after it is "discovering" the files it needs to copy.  Sometimes it will fail during the copy several times.

     

    Monday, June 28, 2010 4:04 AM
  • Yes, I agree.  I don't think a re-install is an adequate solution.  I am having same problem as original poster and have done most of the same steps.  Windows 7 64bit Professional edition.  Same issues going from Win7 ---> WinXP sp3, but not the other way around. 

    I have seen many with this issue (and probably a lot more that goes unreported from clueless users).  Any other ideas what it could be?  It seems to me that it hangs soon after it is "discovering" the files it needs to copy.  Sometimes it will fail during the copy several times.

     

    OK, I believe I have fixed this issue without a reinstall.  My best guess is the reason the guy above had his issue fixed with a reinstall is because during the 2nd install he chose not to be part of a Windows 7 "Homegroup".

    To fix the dreadfully slow file copy issue FROM a Win7 x64 system TO a WinXP x32 file share/server, etc.

    1. Turn off the Windows 7 Homegroup feature by "leaving" it.  This can be located in: Control Panel\Network and Internet\HomeGroup
    2. Make sure you have Network discovery, Public Folder Sharing, File and Printer Sharing, etc. ON in both your network profile here as well: Control Panel\Network and Internet\Network and Sharing Center\Advanced sharing settings
    3. Logoff when prompted and Reboot

    Note:  You can still be part of a windows workgroup, but leave the homegroup.  Once you do that your file copy issues should be solved.

    I didn't 'find' this solution, but I started thinking about network discovery and offline files in Win7.  The offline files feature I believe is what causes this bug, but not sure.  Anyway, it's an easy thing to try and if it doesn't work you can easily revert back.

    This change fixed my file transfer issues completely.  What was taking hours to copy from Win7 Pro to an XP sp3 system now takes a minute or two.

    -footballcoach

    • Proposed as answer by footballcoach Monday, June 28, 2010 4:31 AM
    Monday, June 28, 2010 4:31 AM
  • RE: " OK, I believe I have fixed this issue without a reinstall.  My best guess is the reason the guy above had his issue fixed with a reinstall is because during the 2nd install he chose not to be part of a Windows 7 "Homegroup"."

    OK, I TRIED THIS,  It made no difference whatsoever for me.  Copy from Win7 --> WinXP sp3 still stalls 1 to a few minutes after starting it.  And just like indicated by others, a WinXP sp3  --> Win7 copy is no problem...

    Thursday, July 15, 2010 2:28 AM
  • Here's another victim... recently reinstalled a HP Compaq 6715s laptop with Win7 64bit. The My Documents folder is on a share of my WinXP 2005 Media Center system, with offline files enabled. I did pick the option to join a home group during install.

    As per instructions by footballcoach, I dropped the home group (to make sure, I disabled both 'homegroup xxxx' services as well, after I left the homegroup). Its my wifes business laptop, so I'll have to wait and see whether her long delays when saving files are gone now. Will drop the results here later.

     

    Sunday, July 25, 2010 9:20 PM
  • I'm also having a similar issue with a factory installed Alienware laptop. (Also speaking to their tech support in parallel.)

     

    Either using the gigabit card or wireless card I can get 700-800K downloads from the internet (max my ADSL can handle) but transfers on my network between either an XP laptop, Win7 x64 ultimate or my DNS323 NAS max out at 150K and are normally around 100K.

    The steps I've tried so far include all of the above that have already been tried and I'm stumped.

     

    Seems very odd as FTP speeds on my network are also identically affected.

     

    I do have AVG Internet Security installed, but I disable the firewall and still get the same problem.

    Wednesday, August 04, 2010 7:59 PM
  • Has anyone found anything else?  I too have slow speeds transfering files windows 7  to windows 7 and windows 7 to xp.  Also have Slower speeds transfering from Server 2008 to a windows 7 machine and vice versa. 3rd Party programs are not an option.
    • Proposed as answer by StanJ17 Sunday, December 05, 2010 2:03 PM
    Thursday, August 19, 2010 3:15 PM
  • Yes, I agree.  I don't think a re-install is an adequate solution.  I am having same problem as original poster and have done most of the same steps.  Windows 7 64bit Professional edition.  Same issues going from Win7 ---> WinXP sp3, but not the other way around. 

    I have seen many with this issue (and probably a lot more that goes unreported from clueless users).  Any other ideas what it could be?  It seems to me that it hangs soon after it is "discovering" the files it needs to copy.  Sometimes it will fail during the copy several times.

     

    OK, I believe I have fixed this issue without a reinstall .  My best guess is the reason the guy above had his issue fixed with a reinstall is because during the 2nd install he chose not to be part of a Windows 7 "Homegroup".

    To fix the dreadfully slow file copy issue FROM a Win7 x64 system TO a WinXP x32 file share/server, etc.

    1. Turn off the Windows 7 Homegroup feature by "leaving" it .  This can be located in: Control Panel\Network and Internet\HomeGroup
    2. Make sure you have Network discovery, Public Folder Sharing, File and Printer Sharing, etc. ON in both your network profile here as well : Control Panel\Network and Internet\Network and Sharing Center\Advanced sharing settings
    3. Logoff when prompted and Reboot

    Note:  You can still be part of a windows workgroup, but leave the homegroup.  Once you do that your file copy issues should be solved.

    I didn't 'find' this solution, but I started thinking about network discovery and offline files in Win7.  The offline files feature I believe is what causes this bug, but not sure.  Anyway, it's an easy thing to try and if it doesn't work you can easily revert back.

    This change fixed my file transfer issues completely.  What was taking hours to copy from Win7 Pro to an XP sp3 system now takes a minute or two.

    -footballcoach

    I could drag something into my Win7 folder while on the WinXP computer, but I couldn't transfer a file either direction from the Win7 computer.
    This solution worked for me!  Thanks
    Thursday, October 14, 2010 11:31 AM
  • I am running Windows 7 64-bit and have two nVidia nForce Ethernet 10/100/1000 ports (driver 73.2.0.0) on my motherboard (XFX nForce 780i 3-Way SLI). I recently bought a Netgear ReadyNAS Duo and found it very slow to copy my files onto the NAS. I am connected using cables via a BT HomeHub 2. The Networking tab of the Windows Task Manager showed only 3-5% Network Utilization. Having read lots of Forums and suggestions I tried disabling everything on the Network Adaptor. Now I get really good transfer rates and the Network Utilization is 80-90 %. I found the settings in Start -> Control Panel -> Network and Internet -> Network and Sharing Center and clicked on Change Adaptor Settings on the left-hand pane. Then right-clicked the Adaptor icon and selected Properties. Then clicked the Configure button and seleced the Advanced tab. These are the settings I have that I set to Disabled (Device sleep on disconnect, Flow Control, Interrupt Moderation, IP Checksum Offload, 3 x Large Send Offload, Low Power Idle Mode, Low Power State Link Speed, Priority & VLAN, Receive Side Scaling, 4 x Checksum Offload, Wake on Magic Packet, Wake on pattern match, WakeOnLAN From PowerOff). I left the Speed/Duplex Settings as Auto Negotiation.
    • Proposed as answer by John Elion Monday, January 03, 2011 5:27 PM
    Sunday, December 05, 2010 2:20 PM
  • I experienced similar problems to those described in this thread - my Internet downloads froze, and local network copies were painfully slow.  In particular, I observed that large file copies from XP to Win7 achieved 80-99% network utilization as shown by the task manager whether "pull" from Win7 or "push" from XP, but the reverse only achieved 1% network utilization.

    The post by Stan17 proved helpful, but I felt it was worth exploring which of the many settings he disabled was the culprit (realizing it could have been a combination).  I found that the Large Send Offload v2 was the culprit, and I left both IPv4 and IPv6 disabled.  My settings, slightly different from those listed by Stan, were:

    ARP Offload - Enable
    Ethernet@WireSpeed -Enable
    Flow Control - Auto
    Interrupt Modulation - Enable
    IPv4 Checksum Offload - Rx & Tx Enabled
    Large Send Offload (IPv4) - Enable
    Large Send Offload v2 (IPv4) - Disable
    Large Send Offload v2 (IPv6) - Disable
    Network Address - Not present (radio button)
    NS Offload - Enable
    Priority & VLAN - Priority & VLAN Enabled
    Receive Side Scaling - Enable
    RSS Queues - RSS 4 Queues
    Speed & Duplex - Auto
    TCP & UDP Checksum Offload (IPv4) - Rx & Tx Enabled
    TCP & UDP Checksum Offload (IPv6) - Rx & Tx Enabled
    VLAN ID - 0
    Wake Up Capabilities - Both
    WOL Speed - Lowest Speed Advertised

    The settings above provided satisfactory file transfer results - nearly 99% network utilization for file transfers both ways.  Enabling Large Send Offload v2 (IPv4) triggered the slow file transfers which sent me looking for this thread.

    None of the other proposed solutions I found here and elsewhere worked for me - removal from HomeGroup, disabling autotuning with the netsh command, disabling RSS, removal of IPv6, etc.

    Thanks to Stan for posting such a detailed reply.  I hope Microsoft will explore what is wrong with Large Send Offload v2.

     

    Monday, January 03, 2011 5:43 PM
  • Thank You John

    That was it.  Set Large Send Offload v2 (IPv4) -  to Disable and Poof!

    From 1Mb to 33mb in seconds.  Thank you

    • Proposed as answer by aic90 Thursday, January 06, 2011 5:05 AM
    Wednesday, January 05, 2011 3:39 AM
  • I have had this problem for MONTHS between a Server 2008 machine and Windows 7 Business machine.  I have tried so many things including replacing nics and drivers of all flavors.

    The solution was to disable the Large Send Offload IPv4 AND IPv6 on the Windows 7 PC.  That did it!! Finally!!!

    I had disabled Large Send Offload on the Server but that didn't help.  I had disabled Large Send Offload on the Windows 7 machine but only IPv4.  The trick is to disable both IPv4 and IPv6.

    Thank you so very much for solving this frustrating problem.

    I feel like I have a brand new computer that is soooo fast!!!

    Thursday, January 06, 2011 1:58 AM
  • I experienced similar problems to those described in this thread - my Internet downloads froze, and local network copies were painfully slow.  In particular, I observed that large file copies from XP to Win7 achieved 80-99% network utilization as shown by the task manager whether "pull" from Win7 or "push" from XP, but the reverse only achieved 1% network utilization.

    The post by Stan17 proved helpful, but I felt it was worth exploring which of the many settings he disabled was the culprit (realizing it could have been a combination).  I found that the Large Send Offload v2 was the culprit, and I left both IPv4 and IPv6 disabled.  My settings, slightly different from those listed by Stan, were:

    ARP Offload - Enable
    Ethernet@WireSpeed -Enable
    Flow Control - Auto
    Interrupt Modulation - Enable
    IPv4 Checksum Offload - Rx & Tx Enabled
    Large Send Offload (IPv4) - Enable
    Large Send Offload v2 (IPv4) - Disable
    Large Send Offload v2 (IPv6) - Disable
    Network Address - Not present (radio button)
    NS Offload - Enable
    Priority & VLAN - Priority & VLAN Enabled
    Receive Side Scaling - Enable
    RSS Queues - RSS 4 Queues
    Speed & Duplex - Auto
    TCP & UDP Checksum Offload (IPv4) - Rx & Tx Enabled
    TCP & UDP Checksum Offload (IPv6) - Rx & Tx Enabled
    VLAN ID - 0
    Wake Up Capabilities - Both
    WOL Speed - Lowest Speed Advertised

    The settings above provided satisfactory file transfer results - nearly 99% network utilization for file transfers both ways.  Enabling Large Send Offload v2 (IPv4) triggered the slow file transfers which sent me looking for this thread.

    None of the other proposed solutions I found here and elsewhere worked for me - removal from HomeGroup, disabling autotuning with the netsh command, disabling RSS, removal of IPv6, etc.

    Thanks to Stan for posting such a detailed reply.  I hope Microsoft will explore what is wrong with Large Send Offload v2.

     


    Where do i find these setting so i can change mine?

    Thanks.

    Monday, January 10, 2011 3:57 AM
  • This should get you there 'from scratch':

    - Start Menu -> Control Panel

    - Network and Internet

    - Network and Sharing Center

    - Choose Connection ("Local Area Connection" or your wireless connection; near the top on the right)

    - Press "Properties" button

    - Press "Configure" button

    - Pick "Advanced" tab

    The properties will appear in the listbox at left. When you select a property the current choice appears in the dropdown at right, and the dropdown has your other choices.

    Thursday, January 13, 2011 3:23 AM
  • Wow, Thank you to everyone who posted on this thread. I have been trying to resolve my network speed problems for about a week now.  

    A week ago I copied a 2GB+ file from one win7 pc to another and it took a lot longer then I expected so I decided to see what was happening. I used Task Manager "Network" tab and noticed that when copying large files I would typically see 90-95% utilization for about 5-8 seconds then utilization would drop to 0% for about 5-10 seconds. This would continue until the file was copied.  Only seamed to happen with files above 1GB

    During the course of the past week I tried a lot of  "google solutions" most, if not all, are listed here but with no improvement. Found this sight this morning and am happy to say the following worked for me. .

    Large Send Offload v2 (IPv4) - Disable
    Large Send Offload v2 (IPv6) - Disable

    Thank you


    • Proposed as answer by PaulGuitar Friday, February 17, 2012 4:15 AM
    Thursday, January 13, 2011 10:13 PM
  • I have tried every solution I could find searching these post, yet nothing has resolved the slow file transfer problem.  No matter what I do transfers always start out around 500K/s then within 2 seconds drop to <200K and network utilization never exceeds 3%.

    What I have tried:
    1. RDC disable - no improvement
    2. Force 100Duplex on both machines - no improvement
    3. Update network drivers - no improvement
    4. Transfer files either way - no improvement
    5. Disable AutoTuning - no improvement
    6. Large Send Offload v2 (IPv4) - Disable - no improvement
    7. Large send Offload v2 (IPv6) - Disable - no improvement
    8. Use RichCopy to copy files - no improvement
    9. Use explore copy/paste - no improvement
    10.Googled for hours on end and attempted x number of other suggested fixes - no improvement
    11.Removed from Home Group - no improvement
    12.Replaced Eth. cables - no improvement

    Win7 Pro 64bit   ver. 6.1.7600 build 7600
    i5 760 2.8GHz
    Asus P7H55-M Pro w/latest bios
    onboard Realtek 8112L Gigabit Lan adapter
    6Gig RAM
    1T Hitachi HDs721010CLA332 SATA
    Optowrite DVD r/w IDE
    GeForce 9500GT w/1G RAM

     

    About the only thing I have not done is to reinstall Windows, but that just seems too extreme.   There has to be an answer as to why this is happening.   Are there any diag tools which can point where to look or are there any other solutions out there that I have not yet come across and tried?

     

    Appreciate any help,

    Paul

     

     

     

    Sunday, January 16, 2011 3:29 PM
  • I've tried several solutions, the one that ended up solving this for me was to disable the SMB2 protocol. So far I've only done it on a couple of Win7 workstations, but it seems to work.

    Open a command prompt as Administrator and copy/paste the following two commands and reboot.

    sc config lanmanworkstation depend= bowser/mrxsmb10/nsi

    sc config mrxsmb20 start= disabled

     

    I thinks it's a bad workaround, but so far this is working. I cannot remember where I found the solution, so I cannot take credit for this myself ! It should also work if you disable SMB2 on the server.

    Hope it works !

    Best regards,

    Tommy

    Tuesday, January 18, 2011 1:41 PM
  • I experienced similar problems to those described in this thread - my Internet downloads froze, and local network copies were painfully slow.  In particular, I observed that large file copies from XP to Win7 achieved 80-99% network utilization as shown by the task manager whether "pull" from Win7 or "push" from XP, but the reverse only achieved 1% network utilization.

     

    Same here!  Though I was copying to/from a samba share (ooo, I know, I'm bad).  Copying from samba was lightning fast, while copying to the samba share was dog slow.

     

    We're talking about huge difference here...  copying from samba was at roughly 100MB/sec (800mbit), while copying TO samba was often 4MB/sec.  (Factor of 20 difference!)

     

    I disabled ipv4 offloading, and while copying to is not quite as fast as copying from, it's a night and day difference!  Now I can copy up at roughly 600Mbps -- good enough to stop looking and just be happy!

    Tuesday, January 18, 2011 4:24 PM
  • Thank you for the suggestion.  Unfortunately no change in transfer speed after making the change and restarting.

    So, I can now add disable SMB2 to the list of things tried.

    I don't know how this could have an affect on any of this, but the switch my PCs are connected to is a Cisco 2950 running IOS 12.1(22)EA10

    Tuesday, January 18, 2011 5:03 PM
  • Pmona2000 wrote: "I have tried every solution I could find searching these post, yet nothing has resolved the slow file transfer problem.  No matter what I do transfers always start out around 500K/s then within 2 seconds drop to <200K and network utilization never exceeds 3%."

    I have the exact same problem on a toshiba laptop running windows 7 64bit on my network. My other 3 computers on the network run windows XP and copy files at about 8MBytes/s.

    Now this is the interesting part: I connected my windows 7 laptop directly to an XP computer using a crossover cable, and now file copying works fine! So could there be a compatibility problem between my network and windows 7 ?

    I've tried 2 different switches and one hub, all work fine copying files with XP, but not with windows 7.

    So anyone got any idea why using a crossover cable works, and can this be used to find a fix to the problem ?

     

     

     

     

    Friday, January 21, 2011 8:44 PM
  • I don't believe it is a network problem.   As a test I installed winscp on both my Win7 and XP boxes.  Using winscp I was able to transfer files at full line rate to my Linux servers.   It seems to only be a problem between windows machines, specifically, win7 machines and others.  Between two XP machines, transfers are full rate.   This leads me to believe it is a SMB problem.    When I experience the slow transfers, it is between shares mapped on each of the machines.
    Friday, January 21, 2011 8:58 PM
  • I was able to test using FTP between my windows PCs and see a small increase in transfer rates, but it is still well below what it should be.  While on the XP box and pulling a file from the WIN7 box, I was getting ~500K, and pushing a file I was able to get 2M; so roughly 5% and 20% network utilization respectively.
    Saturday, January 22, 2011 1:24 AM
  • I've been doing some more testing over theweekend.

    On my windows 7 computer I now have:

    Disable TCP AutoTuning and Receive Side Scaling.
    Turn off the Windows 7 Homegroup
    Turned off ALL Task Offload settings on the network adapter and set Speed and duplex to 100Mbps full duplex.

    As before, Copying any files between any windows XP computers on the network works fine at about 8Mbytes/sec.
    I can now copy files from any windows XP computer to my windows 7 computer at about 8Mbytes/sec.
    However, copying the same files from windows 7 to windows XP transfers at only 200kbytes/sec. (about 2% utilization)

    It does not make any difference wheter the file transfer is initiated from a windows XP or a windows 7 PC, it is the direction of copy that makes the differernce.


    I can get file copying to work fine both ways by using a cross over cable.
    When I connect the crossover cable to the windows 7 computer, it makes the connection an "unidentified public network" in Network and sharing centre.
    I then click on the network (the bench symbol) select turn on discovery and file sharing, and make it a private network.
    Now file copying both ways will work just fine, but as soon as I connect the two computers back on the network, the problem is back.


    I've also used Microsoft Network Monitor 3.4 to do a network trace.
    The trace covers copying a single 3MB file from windows XP to windows 7 and takes less than 1 second.
    Then I have copied the same file from windows 7 to windows XP. This copy takes over 25 seconds.

    Now I need to find someone that can analyze the trace, or work out why using a crossover cable works.

    Monday, January 24, 2011 4:15 PM
  • moved to this thread:

    Why is Windows 7 so slow in copying network files?

    http://social.technet.microsoft.com/Forums/en/w7itproperf/thread/4537c7b6-9761-41c5-8b47-0ecb831c8575

     

    Wednesday, January 26, 2011 1:45 PM
  • I've got an equal or the same issue here:

    My network consists of:
    - Windows 7 x64 Pro Desktop PC (this is my one)
    - Win XP 32 Pro Desktop (my wife's)
    - Ubuntu x64 Server (A Backup server)

    If I copy data from my PC to the server, I get the full 100MBit throughput. But if I copy data from my to my wife's PC, the transfer rate drops to ~300kb/s. The funny thing is, that if my wife copies data from my drive to her's, she can use the full bandwitdh...

    This problem exists since the last reinstallation of Win7. Before, I was able to use the network in full speed... But I do not want to reinstall my windows to possibly remove the network error...

     

    Wednesday, February 09, 2011 2:24 PM
  • When will microsoft admit there is a problem with running windows 7 to an xp computer.

    this problem has been  happening since day 1.

    I have also turned off all of the tuning, compression, ipv6, this and that.

    it is a turtle to copy or start a program on a windows 7 box through the network from the xp machine.

    also see the problem on sbs 2003 server all xp computers on the network start the database program quickly.

    the new windows 7 box SAS.

     

    Sunday, February 13, 2011 5:03 PM
  •  

    Using Windows 7 Ultimate and Windows Server 2008 R2

    Two machines, connected via 1GB 1000base-T LAN, with a 1Gb switch between... and yes, I've tried swapping cables and ports. Server has two RAID5's, a 6 platter and an 8 platter. Workstation has two RAID5's, a 3 SSD and a 4 platter. Both sides using Intel CPU's and a RealTek 8100C chipset Gb LAN, same LAN drivers.

    Using Windows Explorer to COPY a 20GB file:

    Server Disk1 to Server Disk 2: >250MB/s (Server disk I/O isn't an issue).

    Server Disk2 to Server Disk 1: >250MB/s (Server disk I/O isn't an issue).

    Workstation Disk1 to Disk2: >150MB/s (Workstation disk I/O isn't an issue).

    Workstation Disk2 to Disk1: >150MB/s (Workstation disk I/O isn't an issue).

    Server Disk1 to Workstation Disk2: 91MB/s (near 100% LAN utilization).

    All looks good so far:

    Workstation Disk2 to Server Disk2: 25MB/s declining to 17MB/s; occasionally as low as 9MB/s. 

    Some of the changes listed above appeared to work for a few moments. I've seen as high as 90MB/s for a few seconds, but it declines rapidly under 30MB/s... so no fix that has lasted. 

    It appears there is something in Windows 7 that prevents fast transmits; or something in Windows Server 2008 that blocks fast receives. I have set the server-side receive training to disabled, normal, highlyrestricted, and experimental and the Win7 side to off, normal, and highlyrestricted in various combinations. Again, nothing concrete to report as an improvement.

    What would the MS Gurus suggest I do with NetMonitor as far as capturing something worth their time to diagnose?

     

     

    Tuesday, March 15, 2011 6:30 AM
  • I've got an equal or the same issue here:

    My network consists of:
    - Windows 7 x64 Pro Desktop PC (this is my one)
    - Win XP 32 Pro Desktop (my wife's)
    - Ubuntu x64 Server (A Backup server)

    If I copy data from my PC to the server, I get the full 100MBit throughput. But if I copy data from my to my wife's PC, the transfer rate drops to ~300kb/s. The funny thing is, that if my wife copies data from my drive to her's, she can use the full bandwitdh...

    This problem exists since the last reinstallation of Win7. Before, I was able to use the network in full speed... But I do not want to reinstall my windows to possibly remove the network error...

     


    This issue seems to be running rampat among Win7 users trying to network to non-Win7 machines.  The following link has also been covering this topic in detail.  Check the troubleshooting steps I've taken towards the bottom of the thread.

    http://social.technet.microsoft.com/Forums/en/w7itproperf/thread/4537c7b6-9761-41c5-8b47-0ecb831c8575

    Saturday, March 19, 2011 7:41 PM
  • This issue seems to be running rampat among Win7 users trying to network to non-Win7 machines.  The following link has also been covering this topic in detail.  Check the troubleshooting steps I've taken towards the bottom of the thread.

    http://social.technet.microsoft.com/Forums/en/w7itproperf/thread/4537c7b6-9761-41c5-8b47-0ecb831c8575

    Win7 and Server2008R2 are essentially the same version of Windows... 'cept server doesn't have all the "user friendlies" attached (they can be added tho). And most of the posts above yours discuss Windows to Windows slowness, including references to the "other" thread suggestions that don't work for us. So unless you can add "Helpful" commentary?

     


    Saturday, March 19, 2011 11:04 PM
  • I had this same issue with a Windws 7 SP1 Enterprise box (HP DC7700SFF), eventually and after much struggle, I came to find the cause of my nighmares. It was a poor quality ethernet cable and the switch were this computer was connected (Ovislink NSH5A) that were not understanding each other, possibly due to the poor ethernet cable performance. Changed the ethernet cable for a good quality new one and this made the transfer rate to swoop up to a whopping 20Mb per second.
    Tuesday, December 06, 2011 9:00 PM
  • Wednesday, December 28, 2011 9:42 PM
  • Very interesting article.  Can you please put that in laymans terms that the rest of us can understand?

    Kirk Gustafson

    Tuesday, February 14, 2012 7:36 PM
  • I did try ALL of the recommendations. No significant help, what so ever.  What did work was disabling Windows Search (by disabling the Windows Search indexing service). 

    As a side note, most folk don't know the average SATA 3Gb/s HDD can't maintain or sustain 100MB/s (thus can't keep a 1GbE pipe full). Some disks are pretty lame and barely keep the 1GbE link at 33%. 

    Other notes: Explorer copies are slowest; Robocopy is pretty fast - faster if you make use of the multi-threading options; Richcopy blazes, but with the caveat it often misses files because they are in use -- so watch your logs when copying important folders.

    Tuesday, February 14, 2012 9:04 PM
  • Wow, Thank you to everyone who posted on this thread. I have been trying to resolve my network speed problems for about a week now.  

    A week ago I copied a 2GB+ file from one win7 pc to another and it took a lot longer then I expected so I decided to see what was happening. I used Task Manager "Network" tab and noticed that when copying large files I would typically see 90-95% utilization for about 5-8 seconds then utilization would drop to 0% for about 5-10 seconds. This would continue until the file was copied.  Only seamed to happen with files above 1GB

    During the course of the past week I tried a lot of  "google solutions" most, if not all, are listed here but with no improvement. Found this sight this morning and am happy to say the following worked for me. .

    Large Send Offload v2 (IPv4) - Disable
    Large Send Offload v2 (IPv6) - Disable

    Thank you


    Thank you guys so much.  I have 5 pc's networked in the house with various media files on each.  Everything worked fine except for one hardwired pc.  It could grab files just fine but if I tried playing a video file or copying a file off of that pc I would only get 80kb/s.  I set Large Send Offload v2 (IPv4) - Disable
    Large Send Offload v2 (IPv6) - Disable and all issues were resolved!

    Friday, February 17, 2012 4:17 AM
  • Yes, I agree.  I don't think a re-install is an adequate solution.  I am having same problem as original poster and have done most of the same steps.  Windows 7 64bit Professional edition.  Same issues going from Win7 ---> WinXP sp3, but not the other way around. 

    I have seen many with this issue (and probably a lot more that goes unreported from clueless users).  Any other ideas what it could be?  It seems to me that it hangs soon after it is "discovering" the files it needs to copy.  Sometimes it will fail during the copy several times.

     

    OK, I believe I have fixed this issue without a reinstall.  My best guess is the reason the guy above had his issue fixed with a reinstall is because during the 2nd install he chose not to be part of a Windows 7 "Homegroup".

    To fix the dreadfully slow file copy issue FROM a Win7 x64 system TO a WinXP x32 file share/server, etc.

    1. Turn off the Windows 7 Homegroup feature by "leaving" it.  This can be located in: Control Panel\Network and Internet\HomeGroup
    2. Make sure you have Network discovery, Public Folder Sharing, File and Printer Sharing, etc. ON in both your network profile here as well: Control Panel\Network and Internet\Network and Sharing Center\Advanced sharing settings
    3. Logoff when prompted and Reboot

    Note:  You can still be part of a windows workgroup, but leave the homegroup.  Once you do that your file copy issues should be solved.

    I didn't 'find' this solution, but I started thinking about network discovery and offline files in Win7.  The offline files feature I believe is what causes this bug, but not sure.  Anyway, it's an easy thing to try and if it doesn't work you can easily revert back.

    This change fixed my file transfer issues completely.  What was taking hours to copy from Win7 Pro to an XP sp3 system now takes a minute or two.

    -footballcoach


    This worked great for me. Leaving the homegroup on all of my Windows 7 PC's stopped the ridiculous lag when transferring data from one computer to another.
    • Edited by Vorstus Tuesday, February 21, 2012 10:44 AM Typing Error
    • Proposed as answer by Vorstus Tuesday, February 21, 2012 10:44 AM
    • Unproposed as answer by Vorstus Tuesday, February 21, 2012 10:44 AM
    Tuesday, February 21, 2012 10:43 AM
  • Autotuning, RDC, duplex, etc didn't make a difference for me.

    What it turned out to be was power managment.

    I disabled power management from the configure button for the NIC.

    From the "advanced" tab, I disabled "energy star" option.  Network copies went from 4-5MBps to 60-118MBps.  This was a Marvell NIC

    On a 2nd computer, with a Realtek NIC, the "green ethernet" and "energy efficient ethernet" that needed to be disabled.

    On a 3rd, with an Intel NIC, it was "energy efficient ethernet", "reduce link speed during standby" and "reduce link speed during system idle"

    Jumbo frames didn't make a difference until the power management options were changed.

    Sunday, March 11, 2012 8:29 PM
  • THXXXXXX this fixed it
    Friday, April 06, 2012 7:27 AM
  • Thanks very much John, this worked perfectly.  I had been struggling for a week with this and tried most of the other solutions proposed before I found your post.  This fixed it right away!  I have both a Thecus NAS and a NetGear ReadyNAS Duo that I could download from at 35MB/s but writes back were down to around 200KB/s!  I now have consistent reads/writes at around 25MB/s.

    Thanks again!

    Saturday, April 14, 2012 1:02 AM
  • I've been struggling with this for nearly a week. Found John Elion's fix, ran it and bingo! All's good. Did these power management things too - just to really hammer it home and now all is sweetness and light.

    But, you've got to ask what's going on with Microsoft when a topic like this can run, unfixed, from Oct 09 to Jan 11 / Mar 12. It's not as if file copy were a rarely used or trivial function. I'm baffled 'ere.

    Anyway, my purpose in writing is really just to thank all you people who put the effort in end eventually did the vendors' job for them.

    Thanks John Elion and smjain.


    Ray

    Wednesday, May 16, 2012 9:02 AM

  • This is the most frustrating Win7 problem with an answer that has eluded almost every forum on the internet regarding its solution.

    ....UNTIL NOW

    I have heard every bogus solution/......too many to mention.

    The problem for everyone is the same.... WIN7 Terribly Slow file transfer (kilobits,),,Slow FILE Copy..over networks, drive to drive,, usb to drive'.. blah blah blah..

    This is the only solution that has taken my file/copy/transfer/network write speeds from mere kilobits per second... up to 15+mb per second from usb to sata.

    Go To Start... type "CMD" hit enter.. copy and paste each of these 3 lines below, ONE AT A TIME and hit enter...you will get an OK after each successful entry.. Then restart your computer test out your fast speeds....Then curse every hack that told you to download a "file transfer manager" to fix such a basic windows function .

    netsh interface tcp set global rss=disabled

    netsh interface tcp set global autotuninglevel=disabled

    netsh int ip set global taskoffload=disabled




    • Edited by TeMpTeK Thursday, June 07, 2012 2:19 AM
    • Proposed as answer by CEmmitt Tuesday, July 23, 2013 9:10 PM
    Thursday, June 07, 2012 2:11 AM
  • I've had this problem for almost a year, and not yet found a solution until now. ^^

    Step 2 did it for me, thanks! :D

    Saturday, June 09, 2012 10:50 PM
  • Requirement for full speed ethernet transfers (75% of 1000 every transfer +) is a Non-blocking, wire-speed transmission switch!


    Examples:

    •ZyXEL's GS1100-16 16 Port Desktop GbE Switch is a 16-port 10/100/1000 switch (I'm getting 700-800Mbit or 80Mbyte transfers)

    •ZyXEL's GS1100-24 The GS1100-24 is a 24-port 10/100/1000 switch

    •ZyXEL's GS-108B 10/100/1000Mbps Port Desktop GbE Switch is a 8-port 10/100/1000 switch

    •Cisco SR2024 24-port 10/100/1000 Gigabit Switch

    •SMC Networks - SMC8508T - EZ Switch 10/100/1000 - 8-Port 10/100/1000 Gigabit Unmanaged Switch

    •Linksys SR2016 The 16-Port 10/100/1000 Gigabit


    Please try the examples given but if you don't have the right switch then it won't matter what you do at the OS


    Regards,


    Jason

    Thursday, July 12, 2012 12:55 AM
  • Hi all,

    I've been fighting with a similar/related issue at home recently.  Am running an ASUS RT-N16 router with Tomato firmware installed on it.  One Windows 7 Pro 32-bit PC connected via wired connection, one Windows 7 Pro PC 64-bit (also wired), and one Windows 7 Home Premium 64-bit connected via wireless.  Internet speeds were fine but copying files from one PC to another via shared folders was ridiculously slow.  I tried a bunch of solutions from online that I can't even remember all of now, but probably removing IPv6, changing TCP/IP settings (though I did not change MTU on the workstations), etc.  What finally worked for me was enabling jumbo frames in the advanced network settings of my router.  Speeds when copying from the laptop over the wireless to either desktop PC are now 1 to 2 MB/second, which is decent for a wireless connection I think, and certainly better than the 20KB/second that I was getting.  Desktop to desktop over the wired connection is too fast to measure.   Just thought I'd pass it on as I've been fighting with this issue for quite a while.

    Wednesday, July 25, 2012 3:39 AM
  • Another update.  After enabling jumbo frames on the router, I discovered that copying files from the Windows 7 x64 desktop to the laptop was still slow (20KB/sec).  I disabled the two settings for the wired network card on the x64 desktop that others have mentioned:

    Large Send Offload v2 (IPv4) - Disable
    Large Send Offload v2 (IPv6) - Disable

    and problem solved.  I also disabled jumbo frames on the router after this and am still getting good speed, so that seems to be the fix that did it for me.  Thanks to all for posting here.

    • Proposed as answer by Caliban51 Sunday, November 11, 2012 10:20 AM
    Saturday, July 28, 2012 5:02 PM
  • I was experiencing slow network transfer speeds issues when copying files from my Windows 7 x64 PC to my Western digital 2TB NAS. I was getting 28 KB/S  transfer rate which is shocking. When running XP in a virtual machine on the box i was getting 5-10MB/S

    After trying 100's of things the only setting that fixed it for me

    TCP Checksum offload (IPV6) when this was set to RX/TX enabled the default setting i got 28KB/S when copying files to the NAS. As soon i set this to disabled i got 10MB/S straight away and it has never dropped


    • Edited by c4rm0 Tuesday, September 18, 2012 8:02 PM
    Tuesday, September 18, 2012 8:00 PM
  • Remove IPv6 from network properties.

    If your internal or external networks do not  require  IPv6 protocol, better remove it under network connection properties. Keeping IPv6 in your computer sometimes slows down network by trying to register IPv6 addresses, or trying to get IPv6 address, or trying to resolve IPv6. Better remove it if it’s not required.

    Monday, February 25, 2013 3:13 PM
  • Remove IPv6 from network properties.

    If your internal or external networks do not  require  IPv6 protocol, better remove it under network connection properties. Keeping IPv6 in your computer sometimes slows down network by trying to register IPv6 addresses, or trying to get IPv6 address, or trying to resolve IPv6. Better remove it if it’s not required.

    Monday, February 25, 2013 3:16 PM
  • I'm adding a "me too" post re: Extremely Slow Windows 7 File Copy fix:

    Disabling Large Send Offload v2 in IPV4 and IPV6 on my RealTek GigE NIC's Advanced adapter settings worked for me, to the tune of a 38MB file copy from a local SSD-->another PC over a GigE network going from seven minutes down to a couple of seconds.

    This thread needs a bump to get it further up in Google's search results. I've been going crazy for a day on this, mostly finding rants, not solutions.

    FWIW, I'd previously tried  a full update of my BIOS, Intel Chipset, etc, drivers, and the driver for this NIC to the most recently available versions, which ranged in age from 3/2011-3/2013.  No joy.

    I'd also tried booting into safe mode (ie, no sense in blaming Adobe, Norton, etc!), disabling indexing, disabling thumbnail generation, disabling differential compression, autotuning, etc.

    What I *hadn't done until a few minutes ago is tried copying the file from between local disks on the machine.  Duh!  From disk-->disk, the copy was pretty much instant, and made me finally realize that this was a network thing.  I'm pretty sure that a lot of other people aren't experiencing this problem and aren't narrowing in on the 'network' part of this issue soon enough.

    Some of the commonly proposed fixes (disabling thumbnails, etc) probably do improve the results for some people under some scenarios, but only because they reduce the amount of network traffic... I believe this has added to the noise/confusion surrounding this issue.

    Anyway, thanks!

    Monday, March 11, 2013 4:02 PM
  • Well, I have had the same issue for the past couple of days.

    I am backing up about 110 GB of data from win7 to vista on wired connection via router.

    I tried many of the proposed solutions here including exiting home group and disabling the Large send loadoff but nothing worked.

    Except by chance I stumbled upon a quirky solution.

    I happened to open my firefox on the receiving computer (the vista computer that I am copying the files to) and when it was downloading some firefox update from the internet, the local file transfer rate went skyrocketing simultaneously.  I thought, "that's strange.  I thought the competing bandwidth would slow down the transfer even more", but the opposite was true.

    So I did a little test, I opened firefox, started watching some youtube vidoes on the receiving computer and at the same time transferred large files over.  Lo and behold, the problem solved.

    Before this quirky solution, I was getting around 200 to 500 KB/s transfer speed.  Now, I am getting 10MB/s !!!  That's 20x faster.  What???  How can this be?

    Perhaps someone with more tech experience can look into this and find some explanation for it.  Because it's the last thing I expected.

    Saturday, May 25, 2013 6:27 PM
  • No solution I could find on google for 3 hours worked for me. So I used something alternative.

    I just wanted more speed to pass all my files from my old system(XP) to my new one (windows 7), my speed was 2.6MiB, even with FTP server/client and a bit slower with windows 7 copy.

    What I did to solve this W7 shittynes was to remove the windows 7 factor:

    • I copied the XP SATA and LAN drivers from my new pc motherboard disc to an usb stick.
    • Boot the new PC (windows 7) with mini windows XP from hiren's boot CD.
    • on mini windows xp I had to "show hidden devices" on device manager to install network driver, then ran the mini xp network setup, my sata disks were detected automatically, if yours aren't, you will have to install the driver.
    • After having network and hard disk installed accessible I setup a quick FTP client on the old PC(normal XP) with hiren's cd HBCD menu->browsers / file managers-> Everything.
    • On the new pc (mini windows XP) I used hiren's boot ftp client HBCD menu->network->winscp.

    "Everything" ftp server is crappy but with windows XP+windows 7 my network use was 22% max, with windows XP+ mini windows XP, the network use is between 80% and 90%, the old pc has 100mbit lan, so that limits me but this solution could certainly work on 1gbit lan.

    I understand this solution is not very good for everyone but hope is good for someone.

    Sunday, June 09, 2013 7:01 AM
  • I've had this issue of "slow erratic file copy" over the network for a couple of months, still trying to resolve.

    Symptons: Stuck on "calculating" screen ..., copy starts at full speed (100MB/s then slows to below 1Mb in seconds), speed-up and slows right down again until eventually the file copy finish, the whole network appears to choke all other connections are affected.

    The only workaround that seems to work is by temporarily disabling the internet connection on the PC where files are being pulled from.  I.e. if the internet connection is active on the PC that files are being copied from then I get the symptoms above.  If the internet connection is disabled then files copy at full speed (+/- 100MB/sec).

    Tried this on all 4 PC's running windows 8 on my network.  Weird but it works for me. Still would like to know why this happens or what is causing it.

    Tuesday, July 02, 2013 12:02 PM

  • This is the most frustrating Win7 problem with an answer that has eluded almost every forum on the internet regarding its solution.

    ....UNTIL NOW

    I have heard every bogus solution/......too many to mention.

    The problem for everyone is the same.... WIN7 Terribly Slow file transfer (kilobits,),,Slow FILE Copy..over networks, drive to drive,, usb to drive'.. blah blah blah..

    This is the only solution that has taken my file/copy/transfer/network write speeds from mere kilobits per second... up to 15+mb per second from usb to sata.

    Go To Start... type "CMD" hit enter.. copy and paste each of these 3 lines below, ONE AT A TIME and hit enter...you will get an OK after each successful entry.. Then restart your computer test out your fast speeds....Then curse every hack that told you to download a "file transfer manager" to fix such a basic windows function .

    netsh interface tcp set global rss=disabled

    netsh interface tcp set global autotuninglevel=disabled

    netsh int ip set global taskoffload=disabled




    +1

    I've been trying to figure-out this problem for a few years, mainly copying from Win7/2008 to XP/2003.  I tried the "Large Send Offload" in a number of different networks (thinking it would help, knowing turning-off firewalls, homegroup, etc does not)

    I've run these commands on my Win7 x64 SP1 laptop using WI-FI (to prove it's not just affecting Ethernet) and fixed my slow transfer speeds when copying from Win7 to my QNAP TS-110 NAS (which I frequently use to backup my files).  Just to double-check, I re-enabled the above commands (except 'autotuninglevel') and rebooted, tested again and found myself back on the slow transfer speeds (I've since disabled them again and slow transfer are fixed).

    Connection: Intel Centrino 1030 Wireless-N adapter, connected @ ~72Mbps
    File transferred to NAS: 519MB compressed RAR file
    Speed before running the netsh commands:  ~1.65MBytes/sec
    Speed after: ~4.50MBytes/sec

    Just to clarify and to eliminate any other possible cause eg. caching, I ran this test twice (run disable commands, reboot, run enable commands, reboot, run disable commands, reboot), and saw the same transfer speeds.  "Large Send Offload" setting does not exist on the 1030 Wireless-N, so I can rule this out too.

    Thanks TeMpTeK, I shall be testing this on my Win7 & 2008 machines at work! :)


    • Edited by CEmmitt Tuesday, July 23, 2013 9:34 PM Clarify 2nd para
    Tuesday, July 23, 2013 9:32 PM
  • I was experiencing similar problems, and my fix was a mirror of what you did:

    Large Send Offload v2 (IPv4) - Enable
    Large Send Offload v2 (IPv6) - Enable

    What the problem was, is I have Gigabit exclusively internally and two of my computers did NOT have that enabled. Taking your advice first, I disabled on the one PC that is was and my whole intranet ground to a halt (almost).
      Next I Enabled all interfaces, then tested a 30 gig video file transfer SCREEMS at about 2 seconds to completion!


    Robert Seward- Sr. E.T., MCP NT4.0, W2K, CompTIA A+ -Everything I ever did was new the first time I tried it- -me

    Wednesday, July 31, 2013 6:59 PM
  • Large Send Offload (LSO) is located in Device Manager under your network adapter, so this requires Administrator Privileges.

    Follow these steps:

    1. Open Start Menu, right-click on Computer and select Properties
    2. Under Control Panel Home located on the left side of the window click on Device Manager
    3. You will get a list of all devices on your machine. Expand Network Adapters.
    4. Find your Network Card and double-click on it.
    5. Select Advanced tab. You will get a list filled with different options.
    6. Select Large Send Offload V2 (IPv4) and set the value to Disabled.
    7. Do the same for Large Send Offload V2 (IPv6) if it is available.
    8. Click OK and restart PC.
    9. Repeat for each PC on the network.
    • Proposed as answer by J. Laveque Friday, November 15, 2013 12:46 PM
    Friday, November 15, 2013 12:44 PM
  • Yes, I agree.  I don't think a re-install is an adequate solution.  I am having same problem as original poster and have done most of the same steps.  Windows 7 64bit Professional edition.  Same issues going from Win7 ---> WinXP sp3, but not the other way around. 

    I have seen many with this issue (and probably a lot more that goes unreported from clueless users).  Any other ideas what it could be?  It seems to me that it hangs soon after it is "discovering" the files it needs to copy.  Sometimes it will fail during the copy several times.

     

    OK, I believe I have fixed this issue without a reinstall.  My best guess is the reason the guy above had his issue fixed with a reinstall is because during the 2nd install he chose not to be part of a Windows 7 "Homegroup".

    To fix the dreadfully slow file copy issue FROM a Win7 x64 system TO a WinXP x32 file share/server, etc.

    1. Turn off the Windows 7 Homegroup feature by "leaving" it.  This can be located in: Control Panel\Network and Internet\HomeGroup
    2. Make sure you have Network discovery, Public Folder Sharing, File and Printer Sharing, etc. ON in both your network profile here as well: Control Panel\Network and Internet\Network and Sharing Center\Advanced sharing settings
    3. Logoff when prompted and Reboot

    Note:  You can still be part of a windows workgroup, but leave the homegroup.  Once you do that your file copy issues should be solved.

    I didn't 'find' this solution, but I started thinking about network discovery and offline files in Win7.  The offline files feature I believe is what causes this bug, but not sure.  Anyway, it's an easy thing to try and if it doesn't work you can easily revert back.

    This change fixed my file transfer issues completely.  What was taking hours to copy from Win7 Pro to an XP sp3 system now takes a minute or two.

    -footballcoach

    After trying all the other solutions on here and the rest of the google search results, this fix worked for me.

    I was stuck transferring at about 300kb. After leaving the Homegroup I'm not getting over 10mbyte speeds.

    Thanks!!
    Thursday, February 06, 2014 3:36 PM