none
User does not have sufficient access rights

    Question

  • After installing Windows XP Mode and Windows Virtual PC I try to run the setup for Windows XP Mode. Get through to "Start Setup" and get the following error... "The virtual machine configuration could not be created. User does not have sufficient access rights". Hardware is capable, virtualization is turned on in the BIOS, only user on this machine with full administrative rights. This is a brand new machine with a clean install of Windows 7 professional x64. All available updates have been installed.

    Specs:
    MB - Intel DX58SO
    CPU - Intel i7 950 @ 3.06 GHz
    RAM - 8 GB DDR3 @1066 MHz
    HD - 1.5 TB

    Note: originally virtualization was not turned on in the BIOS. Turned it on and power cycled before proceeding according to instructions for the BIOS.
    Sunday, December 13, 2009 2:54 PM

Answers

  •  
    Got it!
     
    Did two things differently:
    1. Control Panel > Programs & Features > Turn Windows features on or off > Windows Virtual PC: on .... before installing XP mode
    2. elected not to have security enabled when asked during the install procedure.

    Wondering out loud... I had 2 machines, one installed flawlessly and the other had the access rights issue. The only difference was the one that had the problems originally had virtualization turned off. After the first attempt, that setting was changed in the BIOS and powered down but still would not work. Would Virtual PC set itself to "off" by default if virtualization is not enabled in the BIOS thus requiring you to manually turn it on for a successful install? The second machine had virtualization already turned on and the install process went through without a problem and without having to do the above steps.
    Sunday, December 13, 2009 11:22 PM

All replies

  •  
    Got it!
     
    Did two things differently:
    1. Control Panel > Programs & Features > Turn Windows features on or off > Windows Virtual PC: on .... before installing XP mode
    2. elected not to have security enabled when asked during the install procedure.

    Wondering out loud... I had 2 machines, one installed flawlessly and the other had the access rights issue. The only difference was the one that had the problems originally had virtualization turned off. After the first attempt, that setting was changed in the BIOS and powered down but still would not work. Would Virtual PC set itself to "off" by default if virtualization is not enabled in the BIOS thus requiring you to manually turn it on for a successful install? The second machine had virtualization already turned on and the install process went through without a problem and without having to do the above steps.
    Sunday, December 13, 2009 11:22 PM
  • There are many reports of people enabling virtualization in the bios but it doesn't really "stick" in the enabled state. Some people report that they have to turn off or unplug the machine to make sure the changes stick. Also, once it is set, it can become unset on some machines after resuming from hibernation. In those cases, the bios is faulty and the resolution is to get an updated bios that proper reports hardware virtualization after resuming from hibernation.

    • Proposed as answer by famkiwi Saturday, February 06, 2010 7:28 PM
    Monday, December 14, 2009 1:28 AM
  • Im having the same problem.

    I have updated my BIOS and did not solve the problem.

    what do I do?
    Saturday, February 06, 2010 7:31 PM
  •  
    Got it!
     
    Did two things differently:
    1. Control Panel > Programs & Features > Turn Windows features on or off > Windows Virtual PC: on .... before installing XP mode
    2. elected not to have security enabled when asked during the install procedure.

    Wondering out loud... I had 2 machines, one installed flawlessly and the other had the access rights issue. The only difference was the one that had the problems originally had virtualization turned off. After the first attempt, that setting was changed in the BIOS and powered down but still would not work. Would Virtual PC set itself to "off" by default if virtualization is not enabled in the BIOS thus requiring you to manually turn it on for a successful install? The second machine had virtualization already turned on and the install process went through without a problem and without having to do the above steps.

    After installing the XP Mode VPC, XP Mode stated that the hardware Virtualization wasn't enabled. I Enabled the feature in the bios and tried to configure XP Mode once more. Then I got the "...User does not have sufficient access right." My next step was to search the web for a solution. Then I came across your process and realized that installing the XP Mode without hardware virtualization enable initially could cause installation issue. Thusly, I   

    1. DISABLED (unchecked) the Windows Virtual PC in the "Turn Windows features on or off" panel (Control Panel > Programs & Features > Turn Windows features on or off).
    2. Restarted the PC and made sure Hardware Virtualization was ENABLED in the BIOS
    3. Back in Windows, I went back to the "Turn Windows features on or off" panel and ENABLED (checked) Windows Virtual PC
    4. Restarted PC
    Then I was able to configure Windows XP Mode.

    MAJOR THANKS to kevenslin for your troubleshooting time and sharing your resolve with us!

    Wednesday, August 04, 2010 3:49 PM
  • Sorry if I'm resurrecting an old thread but this one seems to have made the most progress...

    I've gone through everything above, I've run havdetectiontool.exe and enabled Virtual PC in Control Panel/Turn Windows Features...etc. I've uninstalled and reinstalled, in the default folders and on my non-boot drive, and I've tried installing with Automatic Updates on and off. I always got the 'insufficient access rights' message.

    My user account is an administrator account but today for the hell of it I tried enabling the Administrator account and installing there. And it worked! So I logged out and back in to my own admin account and... 

    "the virtual machine configuration could not be created. User does not have sufficient access rights"

    So I'm half way to a solution, but it's hardly ideal. Does anybody have any suggestions for me?

    Friday, October 14, 2011 4:17 PM
  • I had the "User does not have sufficient access rights" problem and solved it as follows:

    1. Open Explorer, press Alt key to display menu, select Tools > Folder Options

    2. In the View tab, uncheck Hide protected operating system files

    3. Click OK

    4. Navigate to the C:\Users\<username>\Virtual Machines folder and rename desktop.ini to desktop.ini.bak

    Windows Virtual PC will recreate the file when launched.

    Sounds crazy, but it works! (That's why logging into a new account worked for you, javelin10uk -- fresh desktop.ini).

    Figured it out thanks to the brilliant ProcMon from Microsoft SysInternals



    • Edited by rkm0 Monday, February 06, 2012 10:25 AM
    • Proposed as answer by Farooq-Malik Thursday, October 10, 2013 7:02 AM
    Monday, February 06, 2012 10:00 AM
  • dont worry about virtualization, etc. Instead of just clicking on Start Menu \ Windows Virtual PC\Windows XP Mode, RIGHT CLICK and select "Run as administrator" (btw, the user should belong to the administrators group...)

    That worked for me.

    • Proposed as answer by aleangelico Wednesday, May 02, 2012 4:49 PM
    Wednesday, May 02, 2012 4:49 PM
  • I know it's an old post, yet the problem is actual.

    All above mentioned solutions have been executed on my W7 Pro 64-bit laptop to no avail. I feel like I have run out of options and would like to know if someone has another thought.

    My laptop is a quad core Intel i5 2.67Ghz, virtualization is enabled in the BIOS, Virtual PC is enabled under Windows components.

    Last thing I want to do is a reinstall, if that is what it takes then so be it. Please advice me what to do. Thx!


    • Edited by Fucktard Tuesday, June 25, 2013 2:57 PM replaced dual by quad
    Tuesday, June 25, 2013 2:22 PM
  • this option work for me. first i enable it from Bios because it was turned off. then i got this error. i tried to make it turn on from windows features but it was already. then i renamed the desktop.ini to desktop.ini.bak and then after it, in first try it did not work then in 2nd try it worked i also changed the name to something else which i was first trying with the same name and let the memory allocation at 512Mb then i changed it again from settings.

    thanks rkmo

    Thursday, October 10, 2013 7:02 AM