locked
SSD and Windows 7

    Question

  • According to the Microsoft blog linked to below, when an SSD is recognized scheduled Defrag will be disabled, as will Superfetch, prefetch, and ReadyBoost. I have an Intel SSD Gen.2 installed with Windows 7 x64 and all of those things are not disabled except for ReadyBoost. Why didn't Windows 7 turn off what the article states should be turned off? Is this a case of my SSD not being recognized or a bug in Windows 7?

    Will disk defragmentation be disabled by default on SSDs?

    Yes. The automatic scheduling of defragmentation will exclude partitions on devices that declare themselves as SSDs. Additionally, if the system disk has random read performance characteristics above the threshold of 8 MB/sec, then it too will be excluded. The threshold was determined by internal analysis.

    The random read threshold test was added to the final product to address the fact that few SSDs on the market today properly identify themselves as SSDs. 8 MB/sec is a relatively conservative rate. While none of our tested HDDs could approach 8 MB/sec, all of our tested SSDs exceeded that threshold. SSD performance ranged between 11 MB/sec and 130 MB/sec. Of the 182 HDDs tested, only 6 configurations managed to exceed 2 MB/sec on our random read test. The other 176 ranged between 0.8 MB/sec and 1.6 MB/sec.

    Will Superfetch be disabled on SSDs?

    Yes, for most systems with SSDs.

    If the system disk is an SSD, and the SSD performs adequately on random reads and doesn’t have glaring performance issues with random writes or flushes, then Superfetch, boot prefetching, application launch prefetching, ReadyBoost and ReadDrive will all be disabled.

    Initially, we had configured all of these features to be off on all SSDs, but we encountered sizable performance regressions on some systems. In root causing those regressions, we found that some first generation SSDs had severe enough random write and flush problems that ultimately lead to disk reads being blocked for long periods of time. With Superfetch and other prefetching re-enabled, performance on key scenarios was markedly improved.

    http://blogs.msdn.com/e7/archive/2009/05/05/support-and-q-a-for-solid-state-drives-and.aspx
    Monday, November 09, 2009 7:16 PM

All replies

  • Hi,

    As I know, currently there are many drives that don't properly report that they are SSDs when queried, so Windows is not able to properly apply the SSD optimizations to those drives. You can check to see if an SSD has been properly detected by looking in Disk Defragmenter. To do this, please refer to the following steps:

    1)Open Disk Defragmenter
    2)Click the Configure schedule button
    3)Click the Select disks button

    If the disk is missing from the list, then it has been detected as an SSD and will not be automatically defragmented.

    If the disk is an SSD, but has not been detected as such, then it's important to remove the check next to the disk in this list so that Windows does not attempt to defragment the drive, which will reduce the life of the drive.

    Best Regards
    Dale

    Wednesday, November 11, 2009 3:25 AM
  • All it says next to that box where you can place a check mark is All Disks. I have 3 SSD's installed, no RAID. I unchecked the box for scheduled defragmenting immediately after installing Windows 7.

    Since it says All Disks next to that box, does that mean my SSD's are or are not recognized? Under Current Status it shows the drive letters of my SSD's.

    All my SSD's are Intel G2.

    What about boot prefetching, application launch prefetching, ReadyBoost and ReadDrive?

    Wednesday, November 11, 2009 3:00 PM
  • 1. Since it says All Disks next to that box, does that mean my SSD's are or are not recognized?

    Answer: Yes, these disks are not recognized as SSDs on your computer.

    2. What about boot prefetching, application launch prefetching, ReadyBoost and ReadDrive?

    Answer
    These features are disabled on system disks that are SSDs. If the disk isn't the system disk, it is re-enabled to improve performance as the blog describes. To make Windows 7 well support SSDs, you'd better upgrade your firmware. 

    For more information, please refer to the following websites as well.

    Solid-state drive

    Best Regards
    Dale

    Thursday, November 12, 2009 2:43 AM
  • 1. Since it says All Disks next to that box, does that mean my SSD's are or are not recognized?

    Answer : Yes, these disks are not recognized as SSDs on your computer.

    2. What about boot prefetching, application launch prefetching, ReadyBoost and ReadDrive?

    Answer
    These features are disabled on system disks that are SSDs. If the disk isn't the system disk, it is re-enabled to improve performance as the blog describes. To make Windows 7 well support SSDs, you'd better upgrade your firmware. 

    For more information, please refer to the following websites as well.

    Solid-state drive

    Best Regards
    Dale


    My firmware? I have the latest firmware from Intel with TRIM on all my SSD's. Why doesn't Windows 7 recognize my system disk as an SSD?

    I have "C" drive as system disk and both "E" and "F" are at present empty, but I intend to use them for backing up.
    Thursday, November 12, 2009 7:22 PM
  • Based on further research, Intel recommends users install the firmware update and toolbox, and run the Trim function daily to ensure best performance. Please try to download the firmware upgrade and the Intel SSD Toolbox and Optimizer. These latest tools are designed to help better manage and retain the out-of-box performance of Intel SSDs.

    Best Regards
    Dale



    Friday, November 13, 2009 3:38 AM
  • Based on further research, Intel recommends users install the firmware update and toolbox, and run the Trim function daily to ensure best performance. Please try to download the firmware upgrade and the Intel SSD Toolbox and Optimizer . These latest tools are designed to help better manage and retain the out-of-box performance of Intel SSDs.

    Best Regards
    Dale



    I already told you I have the latest firmware, and it includes TRIM. I also have the Toolbox, which is not needed if you use a Microsoft AHCI driver: "When using the latest Microsoft Windows* 7 operating system with Microsoft AHCI storage drivers the OS will contain native support to execute the Intel® SSD Optimizer on an Intel SSD without requiring any user interaction."

    "Microsoft Windows* 7
    Microsoft* AHCI
    Native OS support (Intel® SSD Toolbox not required)"

    My question remains, why is my Intel G2 SSD not recognized by Windows 7? My firmware is 2CV102HA and it is the latest firmware from Intel.
    Friday, November 13, 2009 2:17 PM
  • Have you contacted Intel for information? This SSD may be not supported currently in Windows 7.

    Best Regards
    Dale
    Monday, November 16, 2009 2:38 AM
  • Have you contacted Intel for information? This SSD may be not supported currently in Windows 7.

    Best Regards
    Dale

    I haven't contacted Intel and don't know if they know any more than you about Windows 7 and this disk. I read somewhere Windows 7 is supposed to recognize SSD by detecting zero rotation in disk.
    Monday, November 16, 2009 2:16 PM
  • My question remains, why is my SSD not recognized in Windows 7? From what I read somewhere, Windows 7 is supposed to recognize SSD by zero rotation of the disk. Is this a bug in Windows 7, a defect of my Windows 7 copy, or what? The Intel Toolbox recognizes all my SSD as SSD, and other software programs recognize my SSD as SSD, so the problem seems to be in Windows 7.

    In Device Manager my disks are recognized as Intel SSD....
    Monday, November 16, 2009 7:50 PM
  • As I mentioned above, there are many drives that don't properly report that they are SSDs when queried, so Windows is not able to properly apply the SSD optimizations to those drives. You need to contact manufacturer for the exact information. Moreover, I noticed that you have installed 3 SSDs on your computer, please try to connect only one SSD to see if it is detected as SSD and applied the SSD optimizations correctly.

    Best Regards
    Dale

    Tuesday, November 17, 2009 2:07 AM
  • I have the same issue as ambizytl. I did a clean install of Windows 7 x64 Professional and it did not recognize my two OCZ Vertex 120gb drives as SSD . Both drives were listed in the Disk Defragmenter list. Seeing that ambizytl has Intel SSD's and I have OCZ SSD drives, I suspect Windows 7 has a problem here.   
    Tuesday, November 17, 2009 12:57 PM
  • I have the same issue as ambizytl. I did a clean install of Windows 7 x64 Professional and it did not recognize my two OCZ Vertex 120gb drives as SSD  . Both drives were listed in the Disk Defragmenter list. Seeing that ambizytl has Intel SSD's and I have OCZ SSD drives, I suspect Windows 7 has a problem here.   
    That is exactly what I have been trying to get through to the Moderator--the problem is with Windows 7.
    Tuesday, November 17, 2009 9:02 PM
  • As I mentioned above, there are many drives that don't properly report that they are SSDs when queried, so Windows is not able to properly apply the SSD optimizations to those drives. You need to contact manufacturer for the exact information. Moreover, I noticed that you have installed 3 SSDs on your computer, please try to connect only one SSD to see if it is detected as SSD and applied the SSD optimizations correctly.

    Best Regards
    Dale


    I had same issue when only one SSD was installed. More importantly, that should not matter for system disk. Do you know how Windows 7 is supposed to detect an SSD? My understanding is it detects an SSD by it having zero rotation of the disk--such is the case only with SSD.
    Tuesday, November 17, 2009 9:06 PM
  • I have the same issue as ambizytl. I did a clean install of Windows 7 x64 Professional and it did not recognize my two OCZ Vertex 120gb drives as SSD  . Both drives were listed in the Disk Defragmenter list. Seeing that ambizytl has Intel SSD's and I have OCZ SSD drives, I suspect Windows 7 has a problem here.   
    This is definitely a bug in Windows 7:

    "Windows 7 will set Defrag off as a default, when detecting non-rotating media, improving device endurance by reducing writes. "

    http://news.softpedia.com/news/The-Windows-7-Evolution-to-NAND-Flash-Solid-State-Disks-SSDs-98097.shtml
    Wednesday, November 18, 2009 10:59 PM

  • I just got an Intel X-25m (ssdsa2m080g2GN), installed a clean Ultimate 7 x64 on it and it also isn't recognizing it as SSD.  I had to manually disable the defrag.

    It's not like I bought a no name vendor piece of garbage SSD here.


    Saturday, November 21, 2009 7:08 PM
  • @ambizytl:
    I am wondering the same thing as you. I have an Intel G2 and I recently noticed in the App event viewer that defrag had been successfully completed for my C: (SSD) drive. In the Defrag tool interface, sure enough, it listed the date that it had been run. Interestingly, reading Dale's post above, and looking at the scheduler (Select Disks ), I don't see my C: (SSD) drive listed. I'm wondering if that's what they mean by Defrag being disabled for the SSD. And if so, why did defrag run on my SSD drive?

    Does yours look the same way (i.e. none of the SSDs listed in the Select Disks screen)?

    I would _really_ like Microsoft to describe a good way to tell if Windows 7 is treating my SSD properly. :-)
    Saturday, November 28, 2009 8:15 AM
  • I have the same issue as ambizytl. I did a clean install of Windows 7 x64 Professional and it did not recognize my two OCZ Vertex 120gb drives as SSD  . Both drives were listed in the Disk Defragmenter list. Seeing that ambizytl has Intel SSD's and I have OCZ SSD drives, I suspect Windows 7 has a problem here.   
    This is definitely a bug in Windows 7:

    "Windows 7 will set Defrag off as a default, when detecting non-rotating media, improving device endurance by reducing writes. "

    http://news.softpedia.com/news/The-Windows-7-Evolution-to-NAND-Flash-Solid-State-Disks-SSDs-98097.shtml

    @ambizytl:
    The article you site above is pretty old, but I know AnandTech said the same thing about Windows 7 detecting drive rotation speed. Below is a quote from a more recent, though admittedly still relatively old MSDN blog:

    Will disk defragmentation be disabled by default on SSDs?

    Yes. The automatic scheduling of defragmentation will exclude partitions on devices that declare themselves as SSDs. Additionally, if the system disk has random read performance characteristics above the threshold of 8 MB/sec, then it too will be excluded. The threshold was determined by internal analysis.

    The random read threshold test was added to the final product to address the fact that few SSDs on the market today properly identify themselves as SSDs. 8 MB/sec is a relatively conservative rate. While none of our tested HDDs could approach 8 MB/sec, all of our tested SSDs exceeded that threshold. SSD performance ranged between 11 MB/sec and 130 MB/sec. Of the 182 HDDs tested, only 6 configurations managed to exceed 2 MB/sec on our random read test. The other 176 ranged between 0.8 MB/sec and 1.6 MB/sec.

    http://blogs.msdn.com/e7/archive/2009/05/05/support-and-q-a-for-solid-state-drives-and.aspx

     

    It would still be nice to know _from Microsoft_ how drives declare to Win7 that they are SSDs, and where Win7 is recording that in the registry.

    Saturday, November 28, 2009 8:32 AM
  • The article you quote does not specifically state how an SSD declares itself an SSD. The article I quoted specifically said by rotation and so does Anandtech as you know.


    What is very interesting and quite disappointing is no one from Microsoft has come forward with an official explanation, which leads me to believe there is a bug in Windows 7. This is not a matter of Intel or OCZ or any brand, this is an issue with Windows 7.
    Saturday, November 28, 2009 2:07 PM
  • @ambizytl:

    Did you notice the command in the article that I referenced for supposedly checking Windows 7's awareness of you SSD (TRIM enabled)? They suggest opening a DOS window as Administrator and typing the following:

    fsutil behavior query DisableDeleteNotify

    Below is a quote about what it returns:
    "Correct, if fsutil reports that "DisableDeleteNotify" is 0, then Trim is enabled.  (The feature is sometimes referred to using different names:  Trim == Delete Notification == Unused Clusters Hint.)  The setting is written in terms of disabling something because we like to use values of 0 for defaults."

    Also, did you see the screen shot of my Select Disk screen (above)? Can you post a picture of your Select Disk screen? Does it list any of your drives?
    Saturday, November 28, 2009 4:04 PM
  • The command only tells you TRIM is enabled in Windows 7--TRIM is enabled by default regardless of what kind of drive you have.

    I already posted what is in Select Disks. I saw what you show and?

    The real issues are Windows 7 does not always set defrag off for SSD and both Superfetch and prefetching are enabled.
    Saturday, November 28, 2009 5:04 PM
  • I second all your concerns.

    Just installed Windows 7 Enterprise on a Samsung PB22-J 128Gb in a Dell T3500 - WEI only comes back with a rating of 5.9 which I've read is usual (capped) if the drive is not recognized as an SSD.  Also defrag, superfetch etc. still all enabled.

    Dale, please escalate within Microsoft to get us at the official explanation of what determines whether an SSD will be detected as such - and if non-detection is a bug, at least let us know so we don't start RMA'ing our drives, controllers, motherboards etc which some people have done:

    http://www.avforums.com/forums/hard-drives-memory-ram-cards-sticks/1115422-samsung-ssd-issue.html

    Quote from link "Well.....Ive tested my SSD in a mates pc, and it still only came up 5.9! And I checked his, and it scored 7.2! So now I know it's my SSD, and not my MB and that's a relief, as its much easier to swap the SSD!"

    Thanks
    Thursday, December 03, 2009 11:42 PM
  • Same problem for me. I know ambizytl and I have been posting on Intel's forum about this.

    I just updated to the latest firmware in my Intel 160GB G2 SSD. I then reformatted with Windows 7 Ultimate x64.

    I have an Intel DP55KG motherboard with the P55 chipset, latest BIOS and AHCI turned ON. I disable all onboard and legacy devices and I use Intel's SATA0 connection for my SSD.

    Installed Windows, downloaded all Windows Updates, installed latest DirextX, installed latest Intel chipset driver, skipped the Intel AHCI driver and instead kept the default Microsoft AHCI driver for full TRIM support. Updated all other drivers. Checked Windows Update one last time. Ran the Windows Experience Index and got a 7.5.

    Checked defrag and it is ON, scheduled and ALL DISKS are selected. I only have one drive (the Intel SSD). No other drives, no optical discs, no USB thumb drives, etc.
    All other supposed Windows 7 SSD optimizations have not happened (Prefetch, Superfech, etc.).

    I went through this same process the last time Intel released a firmware for the SSD and the same experience.

    At this point, I am thinking it is a Windows 7 issue.
    Friday, December 04, 2009 3:34 AM
  • Hi All,
    Apparently there are some Intel/Microsoft issues that are not resolved yet with the Gen2 SSD drive. Read here for one. You may not have restore points as well.

    The firmware update has been removed from Intel downloads for now. I would suspect that the new firmware update will resolve some issues when it is available.
    Friday, December 04, 2009 12:10 PM
  • Hello Nano, in case you are not aware of, Intel has recently released a new firmware update tool (02HD) for the X-18/X25 series SSD to fix the drive-bricking issues.  You can download it here and so far the user experiences have been positive (see Intel forum here ).

    I'd also like to chime in on this issue.  I have an Asus P6T Deluxe board with the latest BIOS installed.  SATA mode is set to AHCI in BIOS.  My Intel X25-M G2 SSD (w/ 02HA firmware) is installed on the SATA0 port and another WD Caviar Black 500GB HDD is installed on SATA1 port.  However, unlike others have reported, my Win7 Ultimate (x64) DID recognize the SSD and disabled Defrag, ReadyBoost, and Superfetch.  However, I am not sure if Prefetch was disabled since I still see files in the C:\Windows\Prefetch folder.
    Friday, December 04, 2009 5:14 PM
  • Hi All,
    Apparently there are some Intel/Microsoft issues that are not resolved yet with the Gen2 SSD drive. Read here for one. You may not have restore points as well.

    The firmware update has been removed from Intel downloads for now. I would suspect that the new firmware update will resolve some issues when it is available.

    That has only to do with system restore and nothing about our SSD being recognized with defrag set to off--and that is the Toolbox, not firmware. Zorlac posted above with latest firmware and his drive is still set to defrag in Windows 7.

    Do you know how Windows 7 is supposed to detect an SSD and turn off defrag? Superfetch? Prefetch?
    Saturday, December 05, 2009 1:57 PM
  • Hello Nano, in case you are not aware of, Intel has recently released a new firmware update tool (02HD) for the X-18/X25 series SSD to fix the drive-bricking issues.  You can download it here and so far the user experiences have been positive (see Intel forum here ).

    I'd also like to chime in on this issue.  I have an Asus P6T Deluxe board with the latest BIOS installed.  SATA mode is set to AHCI in BIOS.  My Intel X25-M G2 SSD (w/ 02HA firmware) is installed on the SATA0 port and another WD Caviar Black 500GB HDD is installed on SATA1 port.  However, unlike others have reported, my Win7 Ultimate (x64) DID recognize the SSD and disabled Defrag, ReadyBoost, and Superfetch.  However, I am not sure if Prefetch was disabled since I still see files in the C:\Windows\Prefetch folder.

    What your case means to me is perhaps this issue of SSD being detected and turning off certain services could be related to the Windows 7 version being used. Otherwise, just a bug in Windows 7.
    Saturday, December 05, 2009 1:59 PM
  • I have a new Dell Latitude XT2 with a Samsung SSD, and I also found that defrag was enabled.
    Saturday, December 12, 2009 4:54 AM
  • Same issue with Lenovo T60 with Intel X25-M 80G G2.
    Wednesday, December 16, 2009 12:53 PM
  • Brand new Win7 x64 box with a Crucial 128GB M225 SSD with latest firmware (which specifically says
    it has support for TRIM). 

    Also not detected as an SSD by Win7, and Defrag was on, so I turned it off. 

       ian
    Thursday, December 17, 2009 10:38 AM
  • Also have a Gen1 (50nm, G1) 80gb X25-M Intel SSD and Win7 did not detect it, it had enabled defragsvc and all that (superfetch, etc).  Would be lovely if there was a way to tell Win7 I have an SSD.  Intel SSD Toolbox doesn't suggest anything for me to do (everything is 'ready to use').
    Monday, December 28, 2009 8:23 PM
  • Guys defrag Is not turned off in the service. load the disk defragmenter. And click configure shedule and then select disk.
    If you SSD is not listed there then it got detected.
    Its just Microsoft did not put it clear since there is a tick on Select all disk. It mean all disk in the current box. and for me there is none.

    For testing . check on a computer with a nomal HDD. you will see the select all disk and the disk in question. With an SSD you will only see select all disk. And there is none so it ok.
    Wagnard
    Wednesday, December 30, 2009 10:29 PM
  • No, it really isn't OK since Superfetch and prefetch are enabled.
    Friday, January 01, 2010 8:00 AM
  • The Samsung PB22-JS3 128gb SSD gave me a WEI of 7.2 in Win7 x32 but fell to 5.9 in Win7 x64, FWIW.

    Friday, January 01, 2010 10:14 PM
  • The Samsung PB22-JS3 128gb SSD gave me a WEI of 7.2 in Win7 x32 but fell to 5.9 in Win7 x64, FWIW.


    Do you have TRIM firmware installed? If not, then that would explain the difference. Drives without TRIM lose performance over time. I have Windows 7 x64 and get 7.7 in WEI. I have an Intel G2 SSD 160GB.
    Saturday, January 02, 2010 1:16 AM
  • No, it really isn't OK since Superfetch and prefetch are enabled.
    Superfetch and prefetch are not disabled for all SSD that are found.
    THey are disable based of their performance with random read or write (cant remember the one exactly)

    Defrag is always disabled for the SSD drive tho. (not the service).


    Wagnard
    Saturday, January 02, 2010 4:03 AM
  • My Intel G2 SSD with WEI of 7.7 is not fast enough??? And I had to disable Disk Defragmenter in Services local myself.
    Saturday, January 02, 2010 2:22 PM
  • ambizytl:

    It might not make any difference but is the SSD running in Ultra DMA Mode 6.  I have an Asus 6PT Deluxe Motherboard and, when I first set it up using the first two ports for my Hitachi Hard drives, I found they were running in PIO Mode 4 even though they should have been in Ultra DMA Mode 6.  I found this out when I was getting ready to install my G2 160 SSD, so I moved my DVD drives to ports 1 and 2 and installed the SSD on port 3 and my hard drives on ports 4 and 5.  All drive now show up correctly.  After installing the SSD, I ran the WEI and received a 7.8 score.  Defrag was not available for the SSD but remains on for the 2 Hitachi drives.  Superfetch was changed to manual and has not started. 

    I purchased my SSD from Newegg at the end of November and installed it over the Thanksgiving weekend.  It had the older firmware at the time it was installed and I ran it a couple of weeks before updating it to the latest Intel firmware.
    Saturday, January 02, 2010 5:00 PM
  • I have 3 Intel SSD units in my computer. All three are in UDMA 7 according to HD Tune--I question the accuracy of what HD Tune reports. Regardless, the transfer mode is SATA 300 for all of them.

    After first installing Windows 7 and running WEI, I did get a rating of 7.8, but subsequent tests show 7.7.

    Are you saying Defrag and Superfetch were on before you changed ports or you didn't check that before changing ports? I have a Gigabyte MB and the SSD's are in the appropriate ports 0, 1, and 2 with SATA DVD in port 5.

    Are you running in AHCI mode?
    Sunday, January 03, 2010 3:28 PM
  • After doing quite a bit of reading on this subject, I believe that this thread is very important.  I appreciate all of the input that has been placed into this issue thus far.  I have an Intel 160GB G2 which I recently installed.  I initially checked the disk defrag after installing Windows 7.  It was still enabled.  I am currently on vacation but should be home on Tuesday.  I will definately be checking the other variables as soon as I can.  Wolfie2u's comments are quite interesting as far as the ports are concerned.  I'm not sure why his computer would have behaved this way.  This might be worth experimenting with as well.  As it stands so far it seems that for someone running a SSD they should at least considering disabling {disk defragmenter, Superfetch, Prefetch, Readyboost}.  There is alot of speculation out there.  What we really need is the one and only "SSD Tweak Guide" based on fact/truth rather then speculation and random case reports.  Also, I am running in AHCI mode.  This is the prefered mode for Intel SSD drives.

    Monday, January 04, 2010 3:04 AM
  • But we shouldn't have to disable what Windows 7 is supposed to disable. I don't know what issue Wolfie2u has with his computer, but the ports reading in PIO 4 mode could be something Windows 7 did. I have 3 SSDs installed with one in Ultra DMA 6 and the other two in PIO 4 mode according to Device Manager. I also noticed duplicate listings for ports 0 and 1, very odd.
    Tuesday, January 05, 2010 1:41 AM
  • As an experiment, I switched my main SSD from port 0 to port 2, port 2 was and is in Ultra DMA 6 mode. I looked in Services local and Superfetch is still on automatic and started. So, whatever solved the problem for Wolfie2u is not solving it for me, at least the PIO 4 mode/Ultra DMA 6 thing is not making any difference in AHCI mode.
    Tuesday, January 05, 2010 7:55 PM
  • I have a Samsung PM*00/P-22J. Defragmentation was on (STILL SCHEDULED!), SuperFetch was on....WHAT GIVES?!
    Saturday, January 16, 2010 8:18 PM
  • May be your SSD does not correctly identify itself as SSD.
    AFAIK this is done via the "rotations per minute" meta information provided
    by the drive. SSDs report here 0rpm.

    Win-J
    Sunday, January 17, 2010 12:17 PM
  • May be your SSD does not correctly identify itself as SSD.
    AFAIK this is done via the "rotations per minute" meta information provided
    by the drive. SSDs report here 0rpm.

    Win-J

    The problem is with Windows 7 and not the brand of SSD.
    Sunday, January 17, 2010 11:48 PM
  • I think most of you guys are just reading your results incorrectly...
    I just followed these directions from the above post:

    "1)Open Disk Defragmenter 

    2)Click the Configure schedule button 
    3)Click the Select disks button

    If the disk is missing from the list, then it has been detected as an SSD and will not be automatically defragmented."

     

    First, when you open up disk defrag, it'll list ALL the disks regardless whether it's SSD or HDD.

    Now when you click on "Turn on schedule", check "run on a schedule (recommended)", click on "select disks..."

    In the box, you will see a few options:

    (select all disks)

    (C:)

    (D:)

    etc.

     

    If all your disks were SSD none of the partition letters would show up in the list, BUT I think you would still see the "select all disks" part.

    For me, I have an Intel G1 SSD raid setup as the C: partition and two hard drive storage partitions as D: and E:, so in my list, I see: select all disks, D:, and E:, but no C: since it's an SSD.

    Hope this helps some of you.

     

     

     

    • Proposed as answer by bnc2 Tuesday, February 02, 2010 3:56 PM
    Tuesday, February 02, 2010 12:58 AM
  • I suggest to everyone that they check with whoever made their SSD and check to make sure they have the latest firmware. I am aware that Intel has released new firmware after some of their products were having problems.

    Vote if answered or helpful, I am running for Office (joke)! IT/Developer, Windows/Linux/Mainframe RaidMax Smilodon, 680W, Asus M2NBP-VM CSM AMD X2 4200+, 2GB DDR2-800, x600, more details on my site, need a video card for the Windows machine, the 8600 GT fried
    Tuesday, February 02, 2010 5:02 AM
  • If you think Windows 7 has correctly detected your SSD and you have a Generation 2 SSD with a WEI of 7.7 or higher, check if you have Superfetch disabled and report back here.
    Tuesday, February 02, 2010 3:26 PM
  • You need to look back at the first few postings, which included my reply and the reply from a moderator.

    "All it says next to that box where you can place a check mark is All Disks. I have 3 SSD's installed, no RAID. I unchecked the box for scheduled defragmenting immediately after installing Windows 7.

    Since it says All Disks next to that box, does that mean my SSD's are or are not recognized? Under Current Status it shows the drive letters of my SSD's.

    All my SSD's are Intel G2."

    "1. Since it says All Disks next to that box, does that mean my SSD's are or are not recognized?

    Answer : Yes, these disks are not recognized as SSDs on your computer. "
    Tuesday, February 02, 2010 3:31 PM
  • Go see if there is new firmware over on Intel's site.
    Vote if answered or helpful, I am running for Office (joke)! IT/Developer, Windows/Linux/Mainframe RaidMax Smilodon, 680W, Asus M2NBP-VM CSM AMD X2 4200+, 2GB DDR2-800, x600, more details on my site, need a video card for the Windows machine, the 8600 GT fried
    Tuesday, February 02, 2010 3:33 PM
  • Go see if there is new firmware over on Intel's site.
    Vote if answered or helpful, I am running for Office (joke)! IT/Developer, Windows/Linux/Mainframe RaidMax Smilodon, 680W, Asus M2NBP-VM CSM AMD X2 4200+, 2GB DDR2-800, x600, more details on my site, need a video card for the Windows machine, the 8600 GT fried
    I installed the new firmware long ago--and that is the current firmware update. Do you have Superfetch disabled by Windows 7?
    Tuesday, February 02, 2010 7:12 PM
  • This thread has a check-mark that is supposed to indicate the question is answered? What in heavens name is the answer?
    • Proposed as answer by limekiln Thursday, February 04, 2010 9:35 PM
    Thursday, February 04, 2010 4:25 PM
  • I think most of you guys are just reading your results incorrectly...
    I just followed these directions from the above post:

    "1)Open Disk Defragmenter 

    2)Click the Configure schedule button 
    3)Click the Select disks button

    If the disk is missing from the list, then it has been detected as an SSD and will not be automatically defragmented."

     

    First, when you open up disk defrag, it'll list ALL the disks regardless whether it's SSD or HDD.

    Now when you click on "Turn on schedule", check "run on a schedule (recommended)", click on "select disks..."

    In the box, you will see a few options:

    (select all disks)

    (C:)

    (D:)

    etc.

     

    If all your disks were SSD none of the partition letters would show up in the list, BUT I think you would still see the "select all disks" part.

    For me, I have an Intel G1 SSD raid setup as the C: partition and two hard drive storage partitions as D: and E:, so in my list, I see: select all disks, D:, and E:, but no C: since it's an SSD.

    Hope this helps some of you.

     

     

     


    I believe Mrnoobie's post quoted above is the answer. I had originally thought that my OCZ Vertex SSD's were not being recognized by Windows 7. I was wrong. The inital list of disks that Defrag shows contains all the disks. When you try to select disks from the Defag scheduler, that is when the SSD's are excluded.  I have also verified that my windows prefetch folder is nearly empty which also confims that Windows 7 has recognized my OCZ Vertex boot volume as a SSD.
    • Proposed as answer by ihjones Saturday, October 30, 2010 3:04 AM
    Thursday, February 04, 2010 4:52 PM
  • Do you have Superfetch disabled?

    As I recall, the drive letters were shown--I have since disabled Disk Defragmenter.

    Plus, I have 144 files in the Windows Prefetch folder.

    Friday, February 05, 2010 2:25 AM
  • The few who posted here (2-3) their SSD is being recognized by Windows 7 have not answered the question: Do you have Superfetch disabled?

    The supposed answer is not really an answer. I looked back at my posts above and there were drive letters, so the post marked as an answer is not really an answer.
    Sunday, February 07, 2010 1:55 PM
  • The few who posted here (2-3) their SSD is being recognized by Windows 7 have not answered the question: Do you have Superfetch disabled?

    The supposed answer is not really an answer. I looked back at my posts above and there were drive letters, so the post marked as an answer is not really an answer.

    The Superfetch service is NOT started (manual status) on my Win 7 Pro OCZ Vertex SSD system. I have a triple boot setup with both Win 7 RC1 and Vista Ultimate on traditional hard drives (Western Digital Caviar black). On both of those systems the Superfetch service IS started. This seems to indicate that on my system, Win 7 Pro has correctly identified and setup my OCZ Vertex SSD.
    Sunday, February 07, 2010 2:37 PM
  • The few who posted here (2-3) their SSD is being recognized by Windows 7 have not answered the question: Do you have Superfetch disabled?

    The supposed answer is not really an answer. I looked back at my posts above and there were drive letters, so the post marked as an answer is not really an answer.

    The Superfetch service is NOT started (manual status) on my Win 7 Pro OCZ Vertex SSD system. I have a triple boot setup with both Win 7 RC1 and Vista Ultimate on traditional hard drives (Western Digital Caviar black). On both of those systems the Superfetch service IS started. This seems to indicate that on my system, Win 7 Pro has correctly identified and setup my OCZ Vertex SSD.

    That is on your system and has nothing to do with those of us who have Superfetch Started and on Automatic. What that means to me is there is a bug/problem in Windows 7 recognizing SSD's and there is no answer that satisfies the question I raised in this thread. Furthermore, as I said previously, the drive letters are shown unlike your case with regard to Disk Defragmenter.

    The other 1-2 people who I asked about Superfetch have not responded. You have mixed drives and I have all SSD's, three of them.
    Sunday, February 07, 2010 3:05 PM
  • Seeing as I initially had posted that Win 7 also had a problem identifyng my OCZ Vertex SSD, I realized I was wrong after reading Mrnoobie's post. It was clearly an answer for me (and perhaps others) and no one is implying that it fixes your dilema.  To use your language, "That is on your system and has nothing to do with those of us who have Superfetch Stopped and on Manual"  Lighten up! YMMV as always :)
    Sunday, February 07, 2010 3:18 PM
  • Do you realize I started this thread with questions? For you to mark an answer that satisfies your dilemma is quite rude as my questions remain unanswered.

    You cannot speak for "those" as you are the only one posting here that Superfetch is not running.

    Sunday, February 07, 2010 4:44 PM
  • Worth repeating here is the post from Mr. Pig above:

    @ambizytl:
    I am wondering the same thing as you. I have an Intel G2 and I recently noticed in the App event viewer that defrag had been successfully completed for my C: (SSD) drive. In the Defrag tool interface, sure enough, it listed the date that it had been run. Interestingly, reading Dale's post above, and looking at the scheduler (Select Disks ), I don't see my C: (SSD) drive listed. I'm wondering if that's what they mean by Defrag being disabled for the SSD. And if so, why did defrag run on my SSD drive?

    Does yours look the same way (i.e. none of the SSDs listed in the Select Disks screen)?

    I would _really_ like Microsoft to describe a good way to tell if Windows 7 is treating my SSD properly. :-)

    Sunday, February 07, 2010 7:10 PM
  • I have the Intel X-25M G2 with latest firmware, configured in a NON RAID.  My motherboard is a P5n32e SLI Plus motherboard.  I am using Windows 7 x64.

    These were the default settings after a fresh install:

    Superfetch service is ON.
    Prefetch folder filled with files.
    Indexing is ON
    SSD does not show up under SELECT DISKS on Defragmenter, but does show up on the main list
    ReadyBoost cannot be used on USB flash drives, it says "The system disk is already fast enough...ReadyBoost is unlikely to provide additional benefit"
    fsutil behavior query disabledeletenotify is 0

    I think Windows identified my drive as an SSD.  Are we sure Superfetch, and Prefetch is suppoed to be OFF?
    Sunday, February 07, 2010 10:22 PM
  • "fsutil behavior query disabledeletenotify is 0 " all that command means is Windows 7 is sending the TRIM command and has nothing to do with your SSD. The command will be on by default regardless of the driver, etc.

    As for Superfetch, etc., see the first post in this thread and work your way down.

    Your SSD shows up in Disk Defragmenter and you think Windows 7 recognizes your SSD?

    From Mr. Pig above:

    @ambizytl:
    I am wondering the same thing as you. I have an Intel G2 and I recently noticed in the App event viewer that defrag had been successfully completed for my C: (SSD) drive. In the Defrag tool interface, sure enough, it listed the date that it had been run. Interestingly, reading Dale's post above, and looking at the scheduler (Select Disks ), I don't see my C: (SSD) drive listed. I'm wondering if that's what they mean by Defrag being disabled for the SSD. And if so, why did defrag run on my SSD drive?

    Does yours look the same way (i.e. none of the SSDs listed in the Select Disks screen)?

    I would _really_ like Microsoft to describe a good way to tell if Windows 7 is treating my SSD properly. :-)

    Monday, February 08, 2010 2:58 AM
  • @ambizytl:

    I appreciate all the work you have been doing. Sorry for not getting back sooner, I had given up on this, as it does not appear to be a priority to MS. Here is a picture of my defrag window, showing that my C: drive (Intel G2 SSD) was defragged before I disabled defragmenter, even though the SSD is not shown in the "Select Disk" list on the next window. Interestingly, that was before I applied the "Trim" firmware.

    The Superfetch service is Started and set to Automatic. In the registry, EnablePrefetcher & EnableSuperfetch both have a value of 3, which apparently means that they are enabled. There are current files in the Windows\Prefetch folder. I don't know any other way to check Prefetch or Superfetch.

    I do have two spindle drives in a RAID 1 config, which might influence the Win7 config, but clearly Win7 is not doing everything that we have been told. Ten bucks says they fix it in the first service pack.
    Wednesday, February 10, 2010 2:09 AM
  • I have the same situation as you with regard for Superfetch and Prefetch, I also disabled defragmenter, and I am not doing RAID.
    Sunday, February 14, 2010 2:07 PM
  • OCZ Vertex 120 GB SSD with fw 1.5, this one is not recognized by Windows 7 x86 Ultimate as a SSD Disk!
    Neither Windows 7 x64 Ultimate or Enterprise will recognize it.

    For me this is issue is still unsolved
    Sunday, February 21, 2010 1:31 PM
  • Check for a firmware update for the solid state drives.

    Vote if answered or helpful, I am running for Office (joke)! IT/Developer, Windows/Linux/Mainframe RaidMax Smilodon, 680W, Asus M2NBP-VM CSM, AMD X2 4200+, 2GB DDR2-800, HD2400 Pro, more details on my site, need a new boot disk, existing one is 5 years old
    Sunday, February 21, 2010 3:23 PM
  • Check for a firmware update for the solid state drives.

    Vote if answered or helpful, I am running for Office (joke)! IT/Developer, Windows/Linux/Mainframe RaidMax Smilodon, 680W, Asus M2NBP-VM CSM, AMD X2 4200+, 2GB DDR2-800, HD2400 Pro, more details on my site, need a new boot disk, existing one is 5 years old

    I have the latest firmware update and like so what? And how do you know Jojje44 doesn't have the latest firmware update? I don't know what your answer has to do with the issues of Superfetch, etc. with regard to Windows 7 and SSD.

    Furthermore, Intel has never said the second firmware update is needed to those who installed the first one successfully. I have the second firmware update installed on all three of my SSD's, and I don't see anything different relevant to this thread.
    Sunday, February 21, 2010 8:20 PM
  • Check for a firmware update for the solid state drives.

    Vote if answered or helpful, I am running for Office (joke)! IT/Developer, Windows/Linux/Mainframe RaidMax Smilodon, 680W, Asus M2NBP-VM CSM, AMD X2 4200+, 2GB DDR2-800, HD2400 Pro, more details on my site, need a new boot disk, existing one is 5 years old

    By the way, he has an OCZ Vertex and has the latest firmware update Version 1.5. Now you would have known that had you looked at the OCZ forum.

    He does state quite clearly he has "fw 1.5"
    Sunday, February 21, 2010 8:28 PM
  • I also suggest checking for updated chipset drivers etc. SSD drives seem to not be well suitable for personal machines, seems they are better off with servers.

    Vote if answered or helpful, I am running for Office (joke)! IT/Developer, Windows/Linux/Mainframe RaidMax Smilodon, 680W, Asus M2NBP-VM CSM, AMD X2 4200+, 2GB DDR2-800, HD2400 Pro, more details on my site, need a new boot disk, existing one is 5 years old
    Sunday, February 21, 2010 8:52 PM
  • I have all the latest drivers. Seems to me you are just grasping at straws, just like when you replied to that guy who has the latest firmware. So now it's the chipset drivers, etc. What do you have next? Of course, you wouldn't say the issue is Windows 7 because you don't have the same problem. Goody for you. ;-) The rest of us? Well, we all have something screwy going on. :-))
    Sunday, February 21, 2010 9:01 PM
  • At this point then I can only suggest contacting the hardware manufacturer and inquire with them.

    Vote if answered or helpful, I am running for Office (joke)! IT/Developer, Windows/Linux/Mainframe RaidMax Smilodon, 680W, Asus M2NBP-VM CSM, AMD X2 4200+, 2GB DDR2-800, HD2400 Pro, more details on my site, need a new boot disk, existing one is 5 years old
    Sunday, February 21, 2010 9:03 PM
  • At this point then I can only suggest contacting the hardware manufacturer and inquire with them.

    Vote if answered or helpful, I am running for Office (joke)! IT/Developer, Windows/Linux/Mainframe RaidMax Smilodon, 680W, Asus M2NBP-VM CSM, AMD X2 4200+, 2GB DDR2-800, HD2400 Pro, more details on my site, need a new boot disk, existing one is 5 years old

    Really? What kind of SSD do you have? What kind of SSD do all those with same situation as me have? You insist the problem lies with manufacturer and I insist the problem lies with Windows 7. One person without same issue as most of us does not mean we are all with defective SSD's!

    Unless you can provide advice that deals directly with the problem, I don't know what your purpose here is. You just came back into this thread with advice to someone to update to latest firmware without realizing he had the latest firmware. Nice.

    Looking back at your other post to me advising latest firmware, you again neglected to notice the person to whom you responded had the latest firmware. Have you nothing else to do but come in here with useless suggestions?
    Sunday, February 21, 2010 9:20 PM
  • Ok here goes:

    I Have a OCZ Vertex 120GB with latest released fw, i.e 1.5 with TRIM and GC support.

    I have tried this drive with Windows 7 Home, Business, Ultimate & Enterprise - all fails for me to detect it as an SSD disk.

    Further more, I have also tested the same SSD disk with Windows Server 2008 R2, which also failed to detect it as an SSD disk

    So you blamed my other hardware for beeing at fault (ok, non-updated at least) so I moved the drive to another computer testbed, trying Windows 7 Professional (non-detected again)

    All machines are updated with all available updates from both vendor & Microsoft for other devices. Non of the machines have any hardware issues marked in Device Manager, Windows Update doesn't have any available updates for my systems (not up to 2010-02-19 at least)

    Don't get me wrong here!
    This does not mean that I don't think OCZ, IBM etc can't be at fault here and that they are not fully compliant with Microsoft Windows 7/Server 2008. What I do say is:
     - together they fail in detect 100% of the times if a SSD disk is attached to different systems out there.

    Something could defenetly be improved detection wise by the Microsoft OS's out there!
    Can the different SSD disk vendors do something too to improve the current issue, probably (a lot of us are also on those forums and activly trying to get it working from that angle too)
    Monday, February 22, 2010 3:28 AM
  • Well, here are two posts from bnc2 that indicate his OCZ Vertex is being recognized as an SSD in Windows 7--and that should point the issue to Windows 7 being  buggy and not the manufacturer, at least not in a logical sense:

    "I had originally thought that my OCZ Vertex SSD's were not being recognized by Windows 7. I was wrong. The inital list of disks that Defrag shows contains all the disks. When you try to select disks from the Defag scheduler, that is when the SSD's are excluded.  I have also verified that my windows prefetch folder is nearly empty which also confims that Windows 7 has recognized my OCZ Vertex boot volume as a SSD."


    "The Superfetch service is NOT started (manual status) on my Win 7 Pro OCZ Vertex SSD system. I have a triple boot setup with both Win 7 RC1 and Vista Ultimate on traditional hard drives (Western Digital Caviar black). On both of those systems the Superfetch service IS started. This seems to indicate that on my system, Win 7 Pro has correctly identified and setup my OCZ Vertex SSD."

    The detection of an SSD by Windows 7 should be as simple as detecting a disk with zero rotation.
    Monday, February 22, 2010 4:25 AM
  • Hi all, my two cents worth:

    - Just purchased a G2 80GB SSD and updated firmware to 02HD. This is the only 'hard' drive installed internally.

    - Installed Windows 7 Ultimate x64. WEI 7.8 for Disk.

    - Fired up defragmenter. Sure enough, it was scheduled to be defragmented. Disabled service. Also appeared in scheduler.

    - Dug into registry to see whether SuperFetch and PreFetch were on. PreFetch said it was on in Services. Both showed '3' value in Reigstry. Turned both to '0'.

    - In short, my experience mirrors OPs.

    Something else I noticed is that the SSD has to be 'mounted' at every boot, like an 'add new device' sound goes off three times and adds 'Intel SSD... ATA device' each time. I think this may be linked to AHCI and hot-plug support? Not sure if this is worth mentioning, or if it's just my setup.

    I'm not fazed so much personally as disabling the services has done the trick, but I do hope you get an answer OP, because you've highlighted something that could be screwing over a fair few non-tech-minded people out there who like new shiny drives and don't know about these things.

    Good luck!
    Wednesday, February 24, 2010 12:13 PM
  • Thanks, juzz86, for your input and well wishes.

    For those who may be interested, you don't have to look in the registry to find out if Superfetch is enabled: you can hit Start and type either services local or local services (works both ways) in the search bar and click on View local services and then scroll to Superfetch or other services you want to check. While there, you can change services to Disabled if desired.

    Wednesday, February 24, 2010 8:52 PM
  • Not sure who this might help, but I have an INTEL 160G2 with the latest firmware. It gets detected properly with superfetch off and not selected in defragmenter.

    The deframentation service/task is on, but as others have pointed out, if you look under "Configure schedule" and "Select disk..." and your drive is not in that list, and on the main page it says "Never run" while on my other disks it has run.

    It wouldn't detect properly until the intel chipset drivers were installed, that's also when WEI got to 7.7.

    I have 11 files in the prefetch folder, but they all seem to date before I installed the chipset driver.

    Monday, March 15, 2010 10:11 PM
  • Superfetch has been on in my system along with prefetch ever since installation--and I've had WEI score of 7.7 from the beginning. I have also read elsewhere of people with a WEI of 7.7 having Defrag on and in some cases actually running on their SSD!
    Tuesday, March 16, 2010 12:48 PM
  • Not sure who this might help, but I have an INTEL 160G2 with the latest firmware. It gets detected properly with superfetch off and not selected in defragmenter.

    The deframentation service/task is on, but as others have pointed out, if you look under "Configure schedule" and "Select disk..." and your drive is not in that list, and on the main page it says "Never run" while on my other disks it has run.

    It wouldn't detect properly until the intel chipset drivers were installed, that's also when WEI got to 7.7.

    I have 11 files in the prefetch folder, but they all seem to date before I installed the chipset driver.

    By the way, you should read the post by juzz86 above, just two posts above yours.
    Tuesday, March 16, 2010 7:25 PM
  • I just contacted INTEL, and they say. As the disk itself is detected as an SSD or not. There's nothing wrong with the HARDWARE=DISK the problem lies in the OS. He further tells me that I have to replace the SSD or try it in another system. If problems persist I would have to contact them again.

    Well...as many users with different setup/chipset hardware and so on. Have the same problem I think its safe to say its not the SSD. Microsoft have to work on a solution to this problem. As you guys probably have contact with ppl working at MS i think you should let them know that this is a problem and issue a fix ASAP.

    Tuesday, May 18, 2010 9:43 AM
  • It seems plausible that Windows 7 programmers got everything right under SSD auto-detection and auto-configuration, except provision for users of a simple check that it has worked as intended.

    It is reasonable that services including defrag and superfetch are left enabled, because users might add a HDD at any time even if the system only has a primary SSD. All is well as long as those services do not operate on the SSD itself. Some services including ReadyBoot (not ReadyBoost) seem intended to work whatever the drive type. It seems that ReadyBoot involves an adaptive list of files to load at boot - not a cache that would be counterproductive on an SSD.

    One risk may be that add-on programs (including well-intentioned OEM maintenance assistants, which are not properly designed to distinguish SSD from HDD computer models) might manually override the Win 7 auto-configuration to schedule things like defragmentation. Or does Win 7 block such attempts?

    We see above that some 'obvious checks' can be misleading if the design is for the services to run but only work on the relevant drive types. The problem is we have not learned of an effective check to confirm that all is indeed well.

    In a future update, perhaps windows will provide a confirmation under properties of a drive or disk that "This drive has been detected as a fast SSD and the following services will not operate on it: defragmentation, superfetch......".

    Until then, can MS engineers advise interested customers of a reliable check?

    Some SSD users may choose to 'take the risk' and disable services anyway. But most are likely to be happy with the Win 7 autoconfiguration, if only we can check that it has indeed auto-detected and configured the SSD in our particular computers.

     

    • Proposed as answer by Gaspard Tuesday, June 08, 2010 1:55 AM
    Sunday, June 06, 2010 10:56 PM
  • "It is reasonable that services including defrag and superfetch are left enabled, because users might add a HDD at any time even if the system only has a primary SSD. All is well as long as those services do not operate on the SSD itself."

    I and many others have superfetch and prefetch enabled and they are supposed to be off. Some people have reported those services were off by default, thus, something is not quite right. The microsoft blog I linked to in first post above says those services are disabled (I don't have a first generation SSD and my WEI score is 7.7):

    Will Superfetch be disabled on SSDs?

    Yes, for most systems with SSDs.

    If the system disk is an SSD, and the SSD performs adequately on random reads and doesn’t have glaring performance issues with random writes or flushes, then Superfetch, boot prefetching, application launch prefetching, ReadyBoost and ReadDrive will all be disabled.

    Initially, we had configured all of these features to be off on all SSDs, but we encountered sizable performance regressions on some systems. In root causing those regressions, we found that some first generation SSDs had severe enough random write and flush problems that ultimately lead to disk reads being blocked for long periods of time. With Superfetch and other prefetching re-enabled, performance on key scenarios was markedly improved.

    Monday, June 07, 2010 7:02 PM
  • It seems plausible that Windows 7 programmers got everything right under SSD auto-detection and auto-configuration, except provision for users of a simple check that it has worked as intended.

    It is reasonable that services including defrag and superfetch are left enabled, because users might add a HDD at any time even if the system only has a primary SSD. All is well as long as those services do not operate on the SSD itself. Some services including ReadyBoot (not ReadyBoost) seem intended to work whatever the drive type. It seems that ReadyBoot involves an adaptive list of files to load at boot - not a cache that would be counterproductive on an SSD.

    In a future update, perhaps windows will provide a confirmation under properties of a drive or disk that "This drive has been detected as a fast SSD and the following services will not operate on it: defragmentation, superfetch......".

    Until then, can MS engineers advise interested customers of a reliable check?

    Some SSD users may choose to 'take the risk' and disable services anyway. But most are likely to be happy with the Win 7 autoconfiguration, if only we can check that it has indeed auto-detected and configured the SSD in our particular computers.


    I agree with the above post, it's impossible to check at the moment if Windows services are operating on the SSD or if they run but don't use the SSD... I suggest Microsoft to update the Drive properties with a checkbox somewhere for "This drive is an SSD" (which could be ticked manually if your drive is not detected)
    Tuesday, June 08, 2010 1:58 AM
  • It seems plausible that Windows 7 programmers got everything right under SSD auto-detection and auto-configuration, except provision for users of a simple check that it has worked as intended.

    It is reasonable that services including defrag and superfetch are left enabled, because users might add a HDD at any time even if the system only has a primary SSD. All is well as long as those services do not operate on the SSD itself. Some services including ReadyBoot (not ReadyBoost) seem intended to work whatever the drive type. It seems that ReadyBoot involves an adaptive list of files to load at boot - not a cache that would be counterproductive on an SSD.

    In a future update, perhaps windows will provide a confirmation under properties of a drive or disk that "This drive has been detected as a fast SSD and the following services will not operate on it: defragmentation, superfetch......".

    Until then, can MS engineers advise interested customers of a reliable check?

    Some SSD users may choose to 'take the risk' and disable services anyway. But most are likely to be happy with the Win 7 autoconfiguration, if only we can check that it has indeed auto-detected and configured the SSD in our particular computers.


    I agree with the above post, it's impossible to check at the moment if Windows services are operating on the SSD or if they run but don't use the SSD... I suggest Microsoft to update the Drive properties with a checkbox somewhere for "This drive is an SSD" (which could be ticked manually if your drive is not detected)
    You can look at services local to find out if superfetch is enabled and running, and you can check disk defragmenter.
    • Proposed as answer by ihjones Friday, October 22, 2010 5:18 PM
    Wednesday, June 09, 2010 1:05 AM
  • Sorry I accidentally proposed this above incorrect statement as an answer..

     

    It is not required that Disk defragmenter is shown as disabled to constituted detection of an SSD..     Disk defragmenter service will never be disabled, however if an SSD is detected the system will disable the scheduling of Disk Defragmenter only for those volumes. 

     

    Also Superfetch has never been proven to be harmful in any way towards an SSD and is a part of memory management having no bearing on this issue and has no reason to be disabled.

    Prefetch on the other hand in conjunction with Disk defragmenter would be catastrophic to an ssd if allowed to have any influence..  Luckily the scheduling of defragmenter has been disabled on all SSD volumes,  so unless the user initiates a defrag on the drive there is nothing to worry about..

    This is where to check

    All programs >> Accessories >> System Tools >> Disk Defragmenter >> (if not enabled turn on schedule..) then select the Configure Schedule Button >> Run on a schedule then select disks button >> here you will confirm that any volumes residing on an SSD will have been properly detected and will NOT be listed ..  After confirming that Windows has infact detected your drive as an SSD you may disable the scheduling option in the previous window at your discretion..

     

     

     

     

    Friday, October 22, 2010 5:54 PM
  • You appear to have another incorrect statement above: "Also Superfetch has never been proven to be harmful in any way towards an SSD and is a part of memory management having no bearing on this issue and has no reason to be disabled."

    Intel recommends disabling Superfetch for SSD with Windows 7: http://download.intel.com/support/ssdc/hpssd/sb/newusersguide.pdf

    Basically, everything you said had nothing to do with what Windows 7 is supposed to do according to the statement from Microsoft made long ago--shown in my first post here. You should also read posts 3 & 4 above.

    Friday, October 22, 2010 10:09 PM
  • Before you decide whether the advice from Intel regarding Superfetch is valid or not ,  I advise you to search for the differences between Superfetch and prefetch then you'll have a better understanding of my post..

    you really believe the content of posts 3 & 4 are that valuable??  really??

    I accidentally proposed your above incorrect statement as an answer, it was a mistake for two reasons; one because it was not my intention, secondly because your statement is incorrect and misleading..  put it this way,  I gather from your posts that if Superfetch is enabled and running then the  interpretation of this would lead you to believe that an SSD was not detected?   if this is the case then you would be wrong and your statement misleading.

     

    Remember this is a new technology, one that will take a while for folks to understand.   your concern has been answered already more than once it appears.

     

    Saturday, October 23, 2010 1:18 AM
  • I will take what Intel says about the product they made. As for posts 3 & 4, you have a response from a Microsoft Moderator. You also have in one of my posts above, a statement from Microsoft technology about the superfetch, etc.

    Personally, I will take what Intel suggests for their products over anything you find by googling.

    My concern has never been answered. What is supposed to be disabled is not disabled.

    Saturday, October 23, 2010 1:18 PM
  • Well that's to bad.

    Since you would rather believe Intel before doing your own research did you ask Intel why Superfetch needs to be disabled??  After Microsoft have implied they re-enabled the feature??  (also quoted in the very same article you refer too and quoted in the first post, which BTW is a very old blog).

    Why didn't Windows 7 turn off what the article states should be turned off? Is this a case of my SSD not being recognized or a bug in Windows 7
    
    
    

    Seems like I explained, a Moderator explained , others have explained, yet you still choose not to listen or attempt to understand.   Let me help you here. 

    Disk Defragmenter is IIRC the ONLY method to confirm if the SSD is detected, there are other signs but nothing difinitive.   So Listed under "(Select All Disks)" (where you looked previously) means to select with one check all the disks listed below, yes you can select each individual disk listed below under this option available for defragmenter scheduling.  The logic does not indicate which drives are disabled from defrag.  If under "(Select All Disks)" your SSD is not shown then this confirms SSD detection.  Comprehend now?  If you still have trouble with this logic, try connecting an HDD to the system and recheck the drives available for scheduled defrag listed under (select All Disks).   Exclusion of an SSD from automatic defrag is to prevent massive harmful writes to the drive both from fragmented files and prefech's reorganizing of files for boot and application launch.   You'll notice here that we're talking about prefetch not superfetch but that's a whole other issue.

    Microsoft could have labeled this better but (select All Disks) then to leave a blank space underneath gives a misleading indication, but the logic is completely correct.  if the ssd is not listed windows successfully detected the SSD and has removed it (disabled) from scheduled defrag.  This does not mean that you can not manually defrag the ssd at all, which you also implied in another post was wrong but infact has no bearing on the issue.

    My concern has never been answered. What is supposed to be disabled is not disabled.

    While it wasn't exactly written clearly but in the first post is your answer.   I understand your frustration but maybe you should read the blog again because only the scheduling of defragmenter is definitively disabled from SSD's :)

     

     

     

     

     

     

    Saturday, October 23, 2010 6:31 PM
  • You need to re-read what Microsoft technology said. Seems to me you just want to argue. I know what Intel says, and I know what Microsoft technology said. You may twist things around and believe what you wish. Now it is possible you have a reading comprehension issue, which may explain why you say what you did. The very first post here by me goes into what should be disabled in Windows 7:

     

    Will disk defragmentation be disabled by default on SSDs?

    Yes. The automatic scheduling of defragmentation will exclude partitions on devices that declare themselves as SSDs. Additionally, if the system disk has random read performance characteristics above the threshold of 8 MB/sec, then it too will be excluded. The threshold was determined by internal analysis.

    The random read threshold test was added to the final product to address the fact that few SSDs on the market today properly identify themselves as SSDs. 8 MB/sec is a relatively conservative rate. While none of our tested HDDs could approach 8 MB/sec, all of our tested SSDs exceeded that threshold. SSD performance ranged between 11 MB/sec and 130 MB/sec. Of the 182 HDDs tested, only 6 configurations managed to exceed 2 MB/sec on our random read test. The other 176 ranged between 0.8 MB/sec and 1.6 MB/sec.

    Will Superfetch be disabled on SSDs?

    Yes, for most systems with SSDs.

    If the system disk is an SSD, and the SSD performs adequately on random reads and doesn’t have glaring performance issues with random writes or flushes, then Superfetch, boot prefetching, application launch prefetching, ReadyBoost and ReadDrive will all be disabled.

    Initially, we had configured all of these features to be off on all SSDs, but we encountered sizable performance regressions on some systems. In root causing those regressions, we found that some first generation SSDs had severe enough random write and flush problems that ultimately lead to disk reads being blocked for long periods of time. With Superfetch and other prefetching re-enabled, performance on key scenarios was markedly improved.

    Saturday, October 23, 2010 9:57 PM
  • And now for those who don't know what Intel says:

     

    Disable Superfetch(For Microsoft Windows Vista and Windows 7)
    •On your “Start” search menu, type “services.msc”. Scroll down and find the “Superfetch” line, and double click it to open up its properties.
    •Change the “Startup Type” to “disabled”.
    •Superfetch is designed to open your frequently used programs more quickly. However, this technique doesn’t speed up an Intel SSD’s performance significantly and can ultimately have a negative effect on the performance of the drive. Superfetch is not a feature on Microsoft Windows XP.

     

    Source is Intel User Guide: http://download.intel.com/support/ssdc/hpssd/sb/newusersguide.pdf

    Saturday, October 23, 2010 10:01 PM
  • And now for those who don't know what Intel says:

     

    Disable Superfetch(For Microsoft Windows Vista and Windows 7)
    •On your “Start” search menu, type “services.msc”. Scroll down and find the “Superfetch” line, and double click it to open up its properties.
    •Change the “Startup Type” to “disabled”.
    •Superfetch is designed to open your frequently used programs more quickly. However, this technique doesn’t speed up an Intel SSD’s performance significantly and can ultimately have a negative effect on the performance of the drive. Superfetch is not a feature on Microsoft Windows XP.

     

    Source is Intel User Guide: http://download.intel.com/support/ssdc/hpssd/sb/newusersguide.pdf

    ambizytl If it makes you happy by all means disable Superfetch!  But I would not recommend disabling a perfectly balanced caching mechanism which microsoft themselves specifically caution users not to disable when using SSD's, more to the point they particularly specify that Superfetch will only disable itself and some other features if certain criteria when measuring the performance of SSD's are met.  This taken from a more up to date official Microsoft document instead of the old blog you continue to reference

     

    you really ought to get yourself up to date with the technology and the supporting documents bofore being rude to everyone simply because you do not listen,

    Everybody here is trying to help you ;)

     

     

    Sunday, October 24, 2010 1:34 AM
  • You need to re-read what Microsoft technology said. Seems to me you just want to argue. I know what Intel says, and I know what Microsoft technology said. You may twist things around and believe what you wish. Now it is possible you have a reading comprehension issue, which may explain why you say what you did. The very first post here by me goes into what should be disabled in Windows 7:

     

    Will disk defragmentation be disabled by default on SSDs?

    Yes. The automatic scheduling of defragmentation will exclude partitions on devices that declare themselves as SSDs. Additionally, if the system disk has random read performance characteristics above the threshold of 8 MB/sec, then it too will be excluded. The threshold was determined by internal analysis.


    Ok did you attempt to establish is your SSD is detect agin by this method previously described ?

    Disk Defragmenter is IIRC the ONLY method to confirm if the SSD is detected, there are other signs but nothing difinitive.   So Listed under "(Select All Disks)" (where you looked previously) means to select with one check all the disks listed below, yes you can select each individual disk listed below under this option available for defragmenter scheduling.  The logic does not indicate which drives are disabled from defrag.  If under "(Select All Disks)" your SSD is not shown then this confirms SSD detection.  Comprehend now?  If you still have trouble with this logic, try connecting an HDD to the system and recheck the drives available for scheduled defrag listed under (select All Disks).   Exclusion of an SSD from automatic defrag is to prevent massive harmful writes to the drive both from fragmented files and prefech's reorganizing of files for boot and application launch.   You'll notice here that we're talking about prefetch not superfetch but that's a whole other issue.

     

    Sunday, October 24, 2010 1:42 AM
  • And now for those who don't know what Intel says:

     

    Disable Superfetch(For Microsoft Windows Vista and Windows 7)
    •On your “Start” search menu, type “services.msc”. Scroll down and find the “Superfetch” line, and double click it to open up its properties.
    •Change the “Startup Type” to “disabled”.
    •Superfetch is designed to open your frequently used programs more quickly. However, this technique doesn’t speed up an Intel SSD’s performance significantly and can ultimately have a negative effect on the performance of the drive. Superfetch is not a feature on Microsoft Windows XP.

     

    Source is Intel User Guide: http://download.intel.com/support/ssdc/hpssd/sb/newusersguide.pdf

    ambizytl If it makes you happy by all means disable Superfetch!  But I would not recommend disabling a perfectly balanced caching mechanism which microsoft themselves specifically caution users not to disable when using SSD's, more to the point they particularly specify that Superfetch will only disable itself and some other features if certain criteria when measuring the performance of SSD's are met.  This taken from a more up to date official Microsoft document instead of the old blog you continue to reference

     

    you really ought to get yourself up to date with the technology and the supporting documents bofore being rude to everyone simply because you do not listen,

    Everybody here is trying to help you ;)

     

     


    You don't know what the word rude means.. I presented an up-to-date document from Intel and you know better? I am not wasting my time discussing anything with you. As for others, all they need do is read the thread--everything that needs to be said has been said.
    Sunday, October 24, 2010 4:17 PM
  • many good helpful people have presented you with a method to determine how to check if the ssd detection routine has been successful and you have some issue with interpretation, isn't that the reason you're here?

    You have presented an old Microsoft staff blog (not even an official white paper) as the reason for your concern regards which services may be disabled depending on WEI criteria, then suggest Windows is failing to disable features which you feel for some unkown reason need to be disabled!

    The Microsoft blog says:

    Will disk defragmentation be disabled by default on SSDs?

    Yes. The automatic scheduling of defragmentation will exclude partitions on devices that declare themselves as SSDs. Additionally, if the system disk has random read performance characteristics above the threshold of 8 MB/sec, then it too will be excluded. The threshold was determined by internal analysis.

    So I think we all aggree Disk Defragmenter shall be disabled based upn this criteria.  By the way, this strategy has not changed to date. You have been given the method to confirm disabling of the disk fragmentater scheduling has been completed for your SSD, yet failed to interpret the information correctly.

    The Microsoft blog also says:

    Will Superfetch be disabled on SSDs?

    Yes, for most systems with SSDs.

    If the system disk is an SSD, and the SSD performs adequately on random reads and doesn’t have glaring performance issues with random writes or flushes, then Superfetch, boot prefetching, application launch prefetching, ReadyBoost and ReadDrive will all be disabled.

    Initially, we had configured all of these features to be off on all SSDs, but we encountered sizable performance regressions on some systems. In root causing those regressions, we found that some first generation SSDs had severe enough random write and flush problems that ultimately lead to disk reads being blocked for long periods of time. With Superfetch and other prefetching re-enabled, performance on key scenarios was markedly improved.

     

    Again what part of the above makes you so certain that these features should be turned off??    The key is that based on the above these features were initially disabled based on ALL the required criteria to be met.  

    Currently the policy based on WEI performance criteria is to turn off (not disable) ReadyBoot, ReadyBoost, and the SuperFetch service with all of it's registry features enabled, these items are completed only if the various criteria are met.  Additionally, the scheduling of Disk Defragmenter will always be disabled, this policy has not changed.

     

    I don't think that Microsoft is under any obligation to disable features of their operating system based upon some guide by Intel which recommends to customers of their SSD's to disable Superfetch or any of it's other features.   It would behoove Microsoft to ensure that disk defragmenter is disabled from any automatic operation which may cause an excess of life threatening writes.  This has been accomplished.  

    Again if you are an Intel customer and have one or more of their SSD's in a system and you feel that disabling the Superfetch service is important, then no one is stopping you from disabling it however Microsoft in their latest publication has cautioned users not to disable the service.

    ;)

     

     

     

     

    • Edited by ihjones Sunday, October 24, 2010 5:53 PM
    Sunday, October 24, 2010 5:30 PM
  • First generation SSDs were not in production at the time of that statement, so the concern for them have no bearing on those of us with second generation SSDs.Thus, the statement presented about Superfetch being disabled was to be expected--and should have been implemented as stated.

    What Intel suggests should apply to all SSDs, regardless of brand.

    I am not interested in what you think, nor am I interested in having any further discussion with you. I am quite satisfied to let the people read this thread and make up their own minds what to believe. There are quite a few people who have posted to this thread besides me--and they don't share your views.

    Sunday, October 24, 2010 5:52 PM
  • What Intel suggests should apply to all SSDs, regardless of brand.

    Why?

     

    First generation SSDs were not in production at the time of that statement, so the concern for them have no bearing on those of us with second generation SSDs.Thus, the statement presented about Superfetch being disabled was to be expected--and should have been implemented as stated.

     

    I have no problem with this, it is my understanding also.  I'm assuming your interpretation leads you to believe Superfetch and all of its other features should be disabled??  Exactly where do you get this from when it is also stated that certain criteria is required to be met before implementation?  Also this is an old blog,  the most official publication does not use the word 'Disabled' when referencing Superfetch even if all the criteria required is met, so again why do you feel there is a bug in windows which is preventing the Superfetch service from being turned off??

    And what of scheduling of the Disk Defragmenter, has it been disabled for SSD drives on your system?

    Sunday, October 24, 2010 6:14 PM
  • 1. Since it says All Disks next to that box, does that mean my SSD's are or are not recognized?

    Answer : Yes, these disks are not recognized as SSDs on your computer.

    2. What about boot prefetching, application launch prefetching, ReadyBoost and ReadDrive?

    Answer
    These features are disabled on system disks that are SSDs. If the disk isn't the system disk, it is re-enabled to improve performance as the blog describes. To make Windows 7 well support SSDs, you'd better upgrade your firmware. 

    For more information, please refer to the following websites as well.

    Solid-state drive

    Best Regards
    Dale


    Respectfully the moderator here is incorrect with answer #1 

    Since the question "Select all drives"  does not indicate any SSD's listed beneath it does infact confirm that the SSD was properly detected and disabled from the schedule of Disk Defragmenter.

    Moderator, I realize that the correct method is described in your first post, perhaps you will correct the above answer to reflect the stated earlier method for the benefit of your readers?

    Sunday, October 24, 2010 6:52 PM
  •  

    Both these screenshots indicate and confirm all SSDs on each system have be detected correctly and have been excluded from the Disk Defragmenter schedule.

     

    No System SSD's listed under (Select all Disks) is the indication SSD detection has been successful

    Disk Defragmenter schedule 1

     

    The absence of system SSD's listed under (Select all Disks) is the indication SSD detection has been successful

    Disk Defragmenter schedule 2

     

    Correct SSD detection will not prevent any user from manually initiating a defrag on any SSD volume, users beware!


    Sunday, October 24, 2010 7:31 PM
  • What Intel suggests should apply to all SSDs, regardless of brand.

    Why?

     

    First generation SSDs were not in production at the time of that statement, so the concern for them have no bearing on those of us with second generation SSDs.Thus, the statement presented about Superfetch being disabled was to be expected--and should have been implemented as stated.

     

    I have no problem with this, it is my understanding also.  I'm assuming your interpretation leads you to believe Superfetch and all of its other features should be disabled??  Exactly where do you get this from when it is also stated that certain criteria is required to be met before implementation?  Also this is an old blog,  the most official publication does not use the word 'Disabled' when referencing Superfetch even if all the criteria required is met, so again why do you feel there is a bug in windows which is preventing the Superfetch service from being turned off??

    And what of scheduling of the Disk Defragmenter, has it been disabled for SSD drives on your system?

    How many times have said I am not interested in discussing this with you? Is it so difficult for you to understand that? This thread was started by me November of 2009 with a statement from Microsoft and questions. Nothing will change what was written based on Microsoft's own research. Old Blog? The information given was for those asking questions about Windows 7 and it came from technological research. We who have second generation SSDs expected what the Microsoft Blog stated--simple. 

    The last post before yours was in June of 2010!

    I am not interested in what you have to say--and you are not here for my benefit. I think you obviously have some sort of agenda. Again, I am not interested in discussing this thread with you.

    You ask where I got the Superfetch...and it is in the first post you read--you know, the first post in this thread. Old? Not for me--end of discussion. What Intel says should apply to all second generation and later SSDs--just my opinion. Intel suggests disabling Superfetch--and I provided the link.


    As far as I'm concerned, the Microsoft Blog answer & question thing remains valid.


    Sunday, October 24, 2010 10:00 PM
  • 1. Since it says All Disks next to that box, does that mean my SSD's are or are not recognized?

    Answer : Yes, these disks are not recognized as SSDs on your computer.

    2. What about boot prefetching, application launch prefetching, ReadyBoost and ReadDrive?

    Answer
    These features are disabled on system disks that are SSDs. If the disk isn't the system disk, it is re-enabled to improve performance as the blog describes. To make Windows 7 well support SSDs, you'd better upgrade your firmware. 

    For more information, please refer to the following websites as well.

    Solid-state drive

    Best Regards
    Dale


    Respectfully the moderator here is incorrect with answer #1 

    Since the question "Select all drives"  does not indicate any SSD's listed beneath it does infact confirm that the SSD was properly detected and disabled from the schedule of Disk Defragmenter.

    Moderator, I realize that the correct method is described in your first post, perhaps you will correct the above answer to reflect the stated earlier method for the benefit of your readers?


    Are you saying his second answer is correct? Do you have an SSD? If you do, is Prefetching disabled? It sure isn't on my SSDs.

    Now you have read my final reply to you. This is my final reply to you. I am not going to reply to you again. When I get an email stating it is from you, I will delete it. I am not wasting one second more on you. Whatever you write here from now on is not for my benefit. Personally, I don't think you suddenly came here for my benefit.


    I repeat, this is my final reply to you. There will not be any further replies by me to you.


    Bye!

    Sunday, October 24, 2010 10:06 PM

  • Your question
    According to the Microsoft blog linked to below, when an SSD is recognized scheduled Defrag will be disabled, as will Superfetch, prefetch, and ReadyBoost. I have an Intel SSD Gen.2 installed with Windows 7 x64 and all of those things are not disabled except for ReadyBoost. Why didn't Windows 7 turn off what the article states should be turned off? Is this a case of my SSD not being recognized or a bug in Windows 7?


    his earlier post

    Hi,

    As I know, currently there are many drives that don't properly report that they are SSDs when queried, so Windows is not able to properly apply the SSD optimizations to those drives. You can check to see if an SSD has been properly detected by looking in Disk Defragmenter. To do this, please refer to the following steps:

    1)Open Disk Defragmenter
    2)Click the Configure schedule button
    3)Click the Select disks button

    If the disk is missing from the list, then it has been detected as an SSD and will not be automatically defragmented.

    If the disk is an SSD, but has not been detected as such, then it's important to remove the check next to the disk in this list so that Windows does not attempt to defragment the drive, which will reduce the life of the drive.

    Best Regards
    Dale

    To which you asked

    1. Since it says All Disks next to that box, does that mean my SSD's are or are not recognized?

    The correct answer as per Dale's earlier post: Yes they are recognized, it is normal to see (Select ALL Disks ) against the only checkbox here.  This means if checked that all disks below this line will be selected, since the window is void of any SSD listing this confirms that the SSD's have been properly detected and excluded from the schedule.  This should have been the end to your question, unfortunately there was some mixup with "are or are not recognized?"  which led to a huge misunderstanding IMO.


    1. Since it says All Disks next to that box, does that mean my SSD's are or are not recognized?

    Answer : Yes, these disks are not recognized as SSDs on your computer.

    2. What about boot prefetching, application launch prefetching, ReadyBoost and ReadDrive?

    Answer
    These features are disabled on system disks that are SSDs. If the disk isn't the system disk, it is re-enabled to improve performance as the blog describes. To make Windows 7 well support SSDs, you'd better upgrade your firmware. 

    For more information, please refer to the following websites as well.

    Solid-state drive

    Best Regards
    Dale


    Respectfully the moderator here is incorrect with answer #1 

    Since the question "Select all drives"  does not indicate any SSD's listed beneath it does infact confirm that the SSD was properly detected and disabled from the schedule of Disk Defragmenter.

     


    Are you saying his second answer is correct? Do you have an SSD? If you do, is Prefetching disabled? It sure isn't on my SSDs.

    There was no comment regarding his second answer.  Merely a note to him to say his 1st answer contradicts his earlier reply to you and figured that on reflection he might like to make the correction since other readers may be confused by this.  This error misled you to believe that your SSD was not properly detected which would not have been the case simply following the described procedure in the moderators earlier post.

    Yes I have many SSD's.   All of them in separate pc's, they have been properly detected and removed form any ability to schedule a defrag, readyboost has also been disabled automatically by Window 7. As for Superfetch and Prefetch (two separate mechanisms) I choose to enable them because I prefer to have performance over administrative overhead.

    Sunday, October 24, 2010 10:56 PM
  • ihjones: I must say, it seams you havent really followed the whole thread, and now are just arguing on choice of words or something.
    I actually agree with ambizytl. He has made some very clear statements earlier, and the moderator has just not responded. Not even just a "Sorry, I'm not able to follow up on this right now" or anything.

    I'm in the same situation, and all proof points in direction of the SSD not being recognized.

    Defrag - Disk is listed, schedule is active. All though, have never run, since it's scheduled at night and wake-up for sched. tasks is disabled.
    Prefetch - Enabled value in reg. Files in perfetch folder. Recent dates.
    Superfetch - Service is running.
    Ready-boost - Is actually disabled "Your drive is fast enough that Ready-boost is unlikely to  provide additional benefit.
    WEI for SSD - 7.6
    System - HP 8440p, Intel SSDSA2M160G2, clean installed Win7 32bit, MS Update enabled, used HP SSM/SDM for driver/firmware updates.

    To sum up some basics:

    1.) The functions mentioned here, are functions to speed up the SYSTEM DISK. And that is what this is all about. I can not see any reason keeping the services enabled AND running, for "later use or another hdd" that was posted earlier.

    2.) Even though some of the criteria for SSDs are met (ready-boost disabled) i think this is based on the drive speed and not the SSD detection MS says windows 7 should have.

    3.) Even MS, that blog on msdn and all tweak utils I'v seen, says super-fetch is supposed to be of for SSDs, so why you argue otherwise I don't know. BUT if you actually are right on this, maby change of mind or something over at MS, WHY isn't that posted somewhere? Why haven't MS posted any updated comments on this subject?

    4.) I'm left with much of the same feeling ambizytl probably have, almost a year after starting this post: Why is there still no official util. to check for, set options and report SSD tuning parameters i win7?  This is functionality MS says exist, but still I haven't seen a mechanism to 100% verify its correct functioning, that doesn't leave you with just another uncertainty...

     

    Regards.

    Corp.

     

    Wednesday, October 27, 2010 2:20 PM
  • ihjones: I must say, it seams you havent really followed the whole thread, and now are just arguing on choice of words or something.
    I actually agree with ambizytl. He has made some very clear statements earlier, and the moderator has just not responded. Not even just a "Sorry, I'm not able to follow up on this right now" or anything.

    I'm in the same situation, and all proof points in direction of the SSD not being recognized.

    Defrag - Disk is listed, schedule is active. All though, have never run, since it's scheduled at night and wake-up for sched. tasks is disabled.
    Prefetch - Enabled value in reg. Files in perfetch folder. Recent dates.
    Superfetch - Service is running.
    Ready-boost - Is actually disabled "Your drive is fast enough that Ready-boost is unlikely to  provide additional benefit.
    WEI for SSD - 7.6
    System - HP 8440p, Intel SSDSA2M160G2, clean installed Win7 32bit, MS Update enabled, used HP SSM/SDM for driver/firmware updates.

    To sum up some basics:

    1.) The functions mentioned here, are functions to speed up the SYSTEM DISK. And that is what this is all about. I can not see any reason keeping the services enabled AND running, for "later use or another hdd" that was posted earlier.

    2.) Even though some of the criteria for SSDs are met (ready-boost disabled) i think this is based on the drive speed and not the SSD detection MS says windows 7 should have.

    3.) Even MS, that blog on msdn and all tweak utils I'v seen, says super-fetch is supposed to be of for SSDs, so why you argue otherwise I don't know. BUT if you actually are right on this, maby change of mind or something over at MS, WHY isn't that posted somewhere? Why haven't MS posted any updated comments on this subject?

    4.) I'm left with much of the same feeling ambizytl probably have, almost a year after starting this post: Why is there still no official util. to check for, set options and report SSD tuning parameters i win7?  This is functionality MS says exist, but still I haven't seen a mechanism to 100% verify its correct functioning, that doesn't leave you with just another uncertainty...

     

    Regards.

    Corp.

     


    Hello Corp

    It's easy to fall into that trap unfortunately, especially when the blog and a later mod.'s reply is misleading if read out of context.   You appear to have a better understanding of system though, so maybe I can shed some light on the issue for you.

    There are other sources for this information, but like the blog referred to above there has been only definitive statement on what items will be disabled on SSD detection.  I quote from that blog "Windows 7 will disable disk defragmentation on SSD system drives."

    The ONLY method to determine if an SSD has been correctly detected is to check under 'select disks' option of the disk defragmenter scheduling feature and note the lack of any SSD listing.   The scheduling feature itself SHOULD be enabled and functioning to perform defrag operations on  other HDD's attached to the system.  

    This picture below clealy indicates that the SSD's attached to this system have been removed from the defrag scheduler, as they simply are not listed below the item "Select all Disks" AS Explained clearly in the Moderators FIRST REPLY..

    http://db.tt/qGlatTY

     

     

    If you have an SSD listed under (select all disks) then please share a picture.

    An SSD that has NOT been detected will display something like this

    (select all disks)

    SSD 1

    SSD 2

    etc..

     

    If you have something like this please share this evidence.   Everything else like Superfetch, etc..  are effected other factors and are considered conjecture..

    I quote again from the same blog

    Will Superfetch be disabled on SSDs?

    Yes, for most systems with SSDs.  This does not mean ALL !!

     

     

    Wednesday, October 27, 2010 4:35 PM
  • i have a ocz agility 2 drive with the latest firmware. i ran the cmd stated above and got "0" so i assume "trim" is enabled. my drive is listed in defrag. i manually dis-abled the items you are concerned are a "windows 7 defect" so i don't see the issue. if you are skilled enough to want and configure an ssd, use the latest windows os, etc. , just do what you need to do and enjoy your computer. if the light is on and you want it off then turn it off or unplug it. good luck.
    Thursday, October 28, 2010 11:38 PM
  • i have a ocz agility 2 drive with the latest firmware. my drive is listed in defrag.
    You have a picture of this ? if you would be so kind to post a link here.
    Friday, October 29, 2010 12:08 AM
  • OK I have posted a piece on my IT site forum about SSD so go there and read it. It has everything you need to work with the machine no matter if Windows can recognize the disk as SSD or not.

    Elected! Your votes and support have got me my 2010 MVP!

    Developer | Windows IT | Chess | Economics | Hardcore Games | Vegan Advocate | PC Reviews

    Friday, October 29, 2010 2:19 AM
  • It's easy to fall into that trap unfortunately, especially when the blog and a later mod.'s reply is misleading if read out of context.   You appear to have a better understanding of system though, so maybe I can shed some light on the issue for you.

    There are other sources for this information, but like the blog referred to above there has been only definitive statement on what items will be disabled on SSD detection.  I quote from that blog "Windows 7 will disable disk defragmentation on SSD system drives."

    The ONLY method to determine if an SSD has been correctly detected is to check under 'select disks' option of the disk defragmenter scheduling feature and note the lack of any SSD listing.   The scheduling feature itself SHOULD be enabled and functioning to perform defrag operations on  other HDD's attached to the system.  

    This picture below clealy indicates that the SSD's attached to this system have been removed from the defrag scheduler, as they simply are not listed below the item "Select all Disks" AS Explained clearly in the Moderators FIRST REPLY..

    http://db.tt/qGlatTY

     

     

    If you have an SSD listed under (select all disks) then please share a picture.

    An SSD that has NOT been detected will display something like this

    (select all disks)

    SSD 1

    SSD 2

    etc..

     

    If you have something like this please share this evidence.   Everything else like Superfetch, etc..  are effected other factors and are considered conjecture..

    I quote again from the same blog

    Will Superfetch be disabled on SSDs?

    Yes, for most systems with SSDs.  This does not mean ALL !!

     

    Defrag:
    Ok, for the disk-list in the defrag window, I guess it wouldn't list disks already added to the schedule?
    My disk is already listed in the "current status" field and it says , but again, maby I'm mislead by what it appears that windows is doing, what I can do manually and what windows is actually doing? (The fact that this window says: Only disk that can be defragmentet are shown, might have given me the impression that it shouldn't be visible at all.)

     

    Superfetch etc:
    Of cause not, BUT maby it's the choice of words again, but further it says:

    "If the system disk is an SSD,  the and SSD performs adequately on random reads and doesn’t have glaring performance issues with random writes or flushes, then Superfetch, boot prefetching, application launch prefetching, ReadyBoost and ReadDrive will all be disabled.  --/ cut /--   In root causing those regressions, we found that some first generation SSDs had severe enough random write and flush problems that ultimately lead to disk reads being blocked for long periods of time. With Superfetch and other prefetching re-enabled, performance on key scenarios was markedly improved."

    To me this says that it only should NOT be enabled if your SSD performs bad and/or is a first generation SSD. Or am I way of here?

     

    OK, lets say thats two of four down. Defrag and readyboost is deactivated, just a bit hard to spot the first time.

    What about the values for prefetch and superfetch in the reg? And that the prefetch dir keeps updating with recent files? Are there a logic explanation for this to?

     

    BTW: Sorry for the arguing back and forth with my self, but we are about to deploy 150 laptops with win7 within weeks now, and those laptops are mixed with conventional disk for the first 1/2 and SSDs for the other 1/2.

    I would really like to know for certain if the default windows detection is sufficient, or if I have to make a crappy home made routine to detect and apply settings to the SSD computers only... :-)

     

    --

    Corp.

     

    Friday, October 29, 2010 1:25 PM
  • Vegan:

    Do you have a link?(I'm not that familiar with these forums to know where that is)

     

    --
    Corp.

    Friday, October 29, 2010 1:31 PM
  • OK I have posted a piece on my IT site forum about SSD so go there and read it. It has everything you need to work with the machine no matter if Windows can recognize the disk as SSD or not.

    Elected! Your votes and support have got me my 2010 MVP!

    Developer | Windows IT | Chess | Economics | Hardcore Games | Vegan Advocate | PC Reviews


    First of all, I don't need any help, especially from you! Secondly, I have not forgotten you from the other thread--you know, the one where it was suggested to ignore you and why.
    Friday, October 29, 2010 5:28 PM
  • CorPus_no,

    I hope you realize Intel suggests Superfetch be disabled in Windows 7 for SSD, and that would be Generation 2 drives and later. I posted the quote and link above.

    You know what Microsoft said and you should know how he takes bits and pieces to make his puzzle fit.

    When seeking information, the source is as important as the information.

    Friday, October 29, 2010 5:35 PM
  • i have a ocz agility 2 drive with the latest firmware. i ran the cmd stated above and got "0" so i assume "trim" is enabled. my drive is listed in defrag. i manually dis-abled the items you are concerned are a "windows 7 defect" so i don't see the issue. if you are skilled enough to want and configure an ssd, use the latest windows os, etc. , just do what you need to do and enjoy your computer. if the light is on and you want it off then turn it off or unplug it. good luck.


    TRIM is enabled by default in Windows 7, so that command query has no bearing on whether or not an SSD is installed. In other words, querying Windows 7 will always show TRIM enabled even with mechanical drives installed.

    Of course, you could disable TRIM by using the cmd and set it to number 1, which turns TRIM off. But, as long as TRIM was never disabled by using that cmd, then querying will result in 0 (zero) that means TRIM is enabled, even if no SSD is installed.

    Friday, October 29, 2010 5:40 PM
  • I think most of you guys are just reading your results incorrectly...
    I just followed these directions from the above post:

    "1)Open Disk Defragmenter 

    2)Click the Configure schedule button 
    3)Click the Select disks button

    If the disk is missing from the list, then it has been detected as an SSD and will not be automatically defragmented."

     

    First, when you open up disk defrag, it'll list ALL the disks regardless whether it's SSD or HDD.

    Now when you click on "Turn on schedule", check "run on a schedule (recommended)", click on "select disks..."

    In the box, you will see a few options:

    (select all disks)

    (C:)

    (D:)

    etc.

     

    If all your disks were SSD none of the partition letters would show up in the list, BUT I think you would still see the "select all disks" part.

    For me, I have an Intel G1 SSD raid setup as the C: partition and two hard drive storage partitions as D: and E:, so in my list, I see: select all disks, D:, and E:, but no C: since it's an SSD.

    Hope this helps some of you.

    Finally the correct answer, despite the concept reiterated in many posts of this thread already!!  The one and only correct answer, period!!  This method was initially confirmed in the second post of this thread.   It's relatively easy to comprehend but unfortunately the logic can be misinterpreted (as has been in this thread).

    Only scheduling of SSD defragmentation is disabled as verified by exclusion from the list of drives found under (select all disks) option described above.

    Users will always always always have the power to defrag their drives through manual selection, this is precisely the reason why ssd's are listed under current status on the Disk Defragmenter's main page.   On this page users may manually defrag both their HDD's and SSD's if they choose, but not recommended.

    Some third party defragmenter utilities have the ability to perform other useful operations on SSD's like Consolidated free space defragmentation, etc, so it's not all bad.
    Saturday, October 30, 2010 4:58 AM
  • Someone erroneously marked this thread as answered. Apparently someone was too lazy to read the first post and find out why this thread was started. This thread is not only about Windows Defragging. Apart from Defrag and Windows 7, Superfetch and Windows 7 shares the issue--as does the other questions posed. All one has to do is read the first 4 posts and a full understanding of what needs to be answered will shine a light within.

    I post this because I am the one who started this thread, the one with the questions, and the one who should know when it is answered.

    Saturday, October 30, 2010 1:17 PM
  • Someone erroneously marked this thread as answered. Apparently someone was too lazy to read the first post and find out why this thread was started. This thread is not only about Windows Defragging. Apart from Defrag and Windows 7, Superfetch and Windows 7 shares the issue--as does the other questions posed. All one has to do is read the first 4 posts and a full understanding of what needs to be answered will shine a light within.

    I post this because I am the one who started this thread, the one with the questions, and the one who should know when it is answered.


    I see that all the time

     


    Elected! Your votes and support have got me my 2010 MVP!

    Developer | Windows IT | Chess | Economics | Hardcore Games | Vegan Advocate | PC Reviews

    Saturday, October 30, 2010 2:49 PM
  • Someone erroneously marked this thread as answered. Apparently someone was too lazy to read the first post and find out why this thread was started. This thread is not only about Windows Defragging. Apart from Defrag and Windows 7, Superfetch and Windows 7 shares the issue--as does the other questions posed. All one has to do is read the first 4 posts and a full understanding of what needs to be answered will shine a light within.

    I post this because I am the one who started this thread, the one with the questions, and the one who should know when it is answered.


    I see that all the time

     


    Elected! Your votes and support have got me my 2010 MVP!

    Developer | Windows IT | Chess | Economics | Hardcore Games | Vegan Advocate | PC Reviews


    I don't care what you see. Your comment here carries about enough information as you presented in that other thread I started--remember? The last thing needed here is you! The one person who couldn't generate a system health report!!!

    Quoted from cyanna:
    "1. Please ignore Vegan Fanatic, he is only posting to promote his own websites."

    Why isn't MSE recognized by Security Center?

    Source of quote from cyanna: http://social.technet.microsoft.com/Forums/en-US/w7itprosecurity/thread/5d23918f-e76f-44c1-9d77-246f7c3b1116

    Saturday, October 30, 2010 4:38 PM
  • Someone erroneously marked this thread as answered. Apparently someone was too lazy to read the first post and find out why this thread was started. This thread is not only about Windows Defragging. Apart from Defrag and Windows 7, Superfetch and Windows 7 shares the issue--as does the other questions posed. All one has to do is read the first 4 posts and a full understanding of what needs to be answered will shine a light within.

    I post this because I am the one who started this thread, the one with the questions, and the one who should know when it is answered.


    I see that all the time

     


    Elected! Your votes and support have got me my 2010 MVP!

    Developer | Windows IT | Chess | Economics | Hardcore Games | Vegan Advocate | PC Reviews


    I don't care what you see. Your comment here carries about enough information as you presented in that other thread I started--remember? The last thing needed here is you! The one person who couldn't generate a system health report!!!

    Quoted from cyanna:
    "1. Please ignore Vegan Fanatic, he is only posting to promote his own websites."

    Why isn't MSE recognized by Security Center?

    Source of quote from cyanna: http://social.technet.microsoft.com/Forums/en-US/w7itprosecurity/thread/5d23918f-e76f-44c1-9d77-246f7c3b1116


    If MSE is not being recognized, try uninstalling it and reinstalling it fresh and see if that works.

    If its does not, there could be some malware blocking it. In that case you may need to scan the disk off another machine.

     


    Elected! Your votes and support have got me my 2010 MVP!

    Developer | Windows IT | Chess | Economics | Hardcore Games | Vegan Advocate | PC Reviews

    Saturday, October 30, 2010 4:40 PM
  • Someone erroneously marked this thread as answered. Apparently someone was too lazy to read the first post and find out why this thread was started. This thread is not only about Windows Defragging. Apart from Defrag and Windows 7, Superfetch and Windows 7 shares the issue--as does the other questions posed. All one has to do is read the first 4 posts and a full understanding of what needs to be answered will shine a light within.

    I post this because I am the one who started this thread, the one with the questions, and the one who should know when it is answered.


    I see that all the time

     


    Elected! Your votes and support have got me my 2010 MVP!

    Developer | Windows IT | Chess | Economics | Hardcore Games | Vegan Advocate | PC Reviews


    I don't care what you see. Your comment here carries about enough information as you presented in that other thread I started--remember? The last thing needed here is you! The one person who couldn't generate a system health report!!!

    Quoted from cyanna:
    "1. Please ignore Vegan Fanatic, he is only posting to promote his own websites."

    Why isn't MSE recognized by Security Center?

    Source of quote from cyanna: http://social.technet.microsoft.com/Forums/en-US/w7itprosecurity/thread/5d23918f-e76f-44c1-9d77-246f7c3b1116


    If MSE is not being recognized, try uninstalling it and reinstalling it fresh and see if that works.

    If its does not, there could be some malware blocking it. In that case you may need to scan the disk off another machine.

     


    Elected! Your votes and support have got me my 2010 MVP!

    Developer | Windows IT | Chess | Economics | Hardcore Games | Vegan Advocate | PC Reviews


    I suggest people read that thread and find out exactly why cyanna and I want nothing to do with Vegan Fanatic--and why he apparently posts. The thread is Why isn't MSE recognized by Security Center? and it is completely understood by practically everyone to be a Microsoft issue, by everyone except Vegan Fanatic, the Vegan Fanatic who has never acknowledged generating a system health report!

    http://social.technet.microsoft.com/Forums/en-US/w7itprosecurity/thread/5d23918f-e76f-44c1-9d77-246f7c3b1116

    Saturday, October 30, 2010 4:49 PM
  •  

    If you ambizytl  choose not to accept the answer that is your choice, but others have seconded some of these answers already which they have a right to do and is how this forum functions.  A proposal by other members substantiates the answer as the best answer in their opinion. 

    This is the first correct answer to the OP original question.

    Hi,

    As I know, currently there are many drives that don't properly report that they are SSDs when queried, so Windows is not able to properly apply the SSD optimizations to those drives. You can check to see if an SSD has been properly detected by looking in Disk Defragmenter. To do this, please refer to the following steps:

    1)Open Disk Defragmenter
    2)Click the Configure schedule button
    3)Click the Select disks button

    If the disk is missing from the list, then it has been detected as an SSD and will not be automatically defragmented.

    If the disk is an SSD, but has not been detected as such, then it's important to remove the check next to the disk in this list so that Windows does not attempt to defragment the drive, which will reduce the life of the drive.

    Best Regards
    Dale

     

    This post indicates to some degree confirmation that folks have been looking in the wrong place and should be looking instead where the first above answer indicates

    @ambizytl:
    I am wondering the same thing as you. I have an Intel G2 and I recently noticed in the App event viewer that defrag had been successfully completed for my C: (SSD) drive. In the Defrag tool interface, sure enough, it listed the date that it had been run. Interestingly, reading Dale's post above, and looking at the scheduler (Select Disks ), I don't see my C: (SSD) drive listed. I'm wondering if that's what they mean by Defrag being disabled for the SSD. And if so, why did defrag run on my SSD drive?

    Does yours look the same way (i.e. none of the SSDs listed in the Select Disks screen)?

    I would _really_ like Microsoft to describe a good way to tell if Windows 7 is treating my SSD properly. :-)

     

    Ok the Second answer clearly demonstrates the poster having good knowledge of the issue

    Guys defrag Is not turned off in the service. load the disk defragmenter. And click configure shedule and then select disk.
    If you SSD is not listed there then it got detected.
    Its just Microsoft did not put it clear since there is a tick on Select all disk. It mean all disk in the current box. and for me there is none.

    For testing . check on a computer with a nomal HDD. you will see the select all disk and the disk in question. With an SSD you will only see select all disk. And there is none so it ok.
    Wagnard

     

    The Third answer to the OP's question

    No, it really isn't OK since Superfetch and prefetch are enabled.
    Superfetch and prefetch are not disabled for all SSD that are found.
    THey are disable based of their performance with random read or write (cant remember the one exactly)

    Defrag is always disabled for the SSD drive tho. (not the service).


    Wagnard

     

    Ok here is the Forth correct answer to the OP's original question

    I think most of you guys are just reading your results incorrectly...
    I just followed these directions from the above post:

    "1)Open Disk Defragmenter 

    2)Click the Configure schedule button 
    3)Click the Select disks button

    If the disk is missing from the list, then it has been detected as an SSD and will not be automatically defragmented."

     

    First, when you open up disk defrag, it'll list ALL the disks regardless whether it's SSD or HDD.

    Now when you click on "Turn on schedule", check "run on a schedule (recommended)", click on "select disks..."

    In the box, you will see a few options:

    (select all disks)

    (C:)

    (D:)

    etc.

     

    If all your disks were SSD none of the partition letters would show up in the list, BUT I think you would still see the "select all disks" part.

    For me, I have an Intel G1 SSD raid setup as the C: partition and two hard drive storage partitions as D: and E:, so in my list, I see: select all disks, D:, and E:, but no C: since it's an SSD.

    Hope this helps some of you.

     

    Someone else who now understands  and agrees to the above solution

    I think most of you guys are just reading your results incorrectly...
    I just followed these directions from the above post:

    "1)Open Disk Defragmenter 

    2)Click the Configure schedule button 
    3)Click the Select disks button

    If the disk is missing from the list, then it has been detected as an SSD and will not be automatically defragmented."

     

    First, when you open up disk defrag, it'll list ALL the disks regardless whether it's SSD or HDD.

    Now when you click on "Turn on schedule", check "run on a schedule (recommended)", click on "select disks..."

    In the box, you will see a few options:

    (select all disks)

    (C:)

    (D:)

    etc.

     

    If all your disks were SSD none of the partition letters would show up in the list, BUT I think you would still see the "select all disks" part.

    For me, I have an Intel G1 SSD raid setup as the C: partition and two hard drive storage partitions as D: and E:, so in my list, I see: select all disks, D:, and E:, but no C: since it's an SSD.

    Hope this helps some of you.

     


    I believe Mrnoobie's post quoted above is the answer. I had originally thought that my OCZ Vertex SSD's were not being recognized by Windows 7. I was wrong. The inital list of disks that Defrag shows contains all the disks. When you try to select disks from the Defag scheduler, that is when the SSD's are excluded.  I have also verified that my windows prefetch folder is nearly empty which also confims that Windows 7 has recognized my OCZ Vertex boot volume as a SSD.

    This post actually confirms each of these posts providing a resolution for folk who do not know where to look for confirmation that their SSD's have in fact been detected properly
    Worth repeating here is the post from Mr. Pig above:

    @ambizytl:
    I am wondering the same thing as you. I have an Intel G2 and I recently noticed in the App event viewer that defrag had been successfully completed for my C: (SSD) drive. In the Defrag tool interface, sure enough, it listed the date that it had been run. Interestingly, reading Dale's post above, and looking at the scheduler (Select Disks ), I don't see my C: (SSD) drive listed. I'm wondering if that's what they mean by Defrag being disabled for the SSD. And if so, why did defrag run on my SSD drive?

    Does yours look the same way (i.e. none of the SSDs listed in the Select Disks screen)?

    I would _really_ like Microsoft to describe a good way to tell if Windows 7 is treating my SSD properly. :-)

     

    Lastly, my own post indicating clearly where to look to and verify if detection has been successful.

    Both these screenshots indicate and confirm all SSDs on each system have be detected correctly and have been excluded from the Disk Defragmenter schedule.

     

    No System SSD's listed under (Select all Disks) is the indication SSD detection has been successful

    Disk Defragmenter schedule 1

     

    The absence of system SSD's listed under (Select all Disks) is the indication SSD detection has been successful

    Disk Defragmenter schedule 2

     

    Correct SSD detection will not prevent any user from manually initiating a defrag on any SSD volume, users beware!


     

    Until this simple method is clearly understood there is little benefit in discussing functions of Superfetch or any of it's associated utilities.    Microsoft has not and most likely will never create a utility to indicate correct SSD detection.  Who knows maybe there is a bug, we will never be able to inspect the code to determine it's function.  It's clear the issue developed as a misunderstanding on how to check detection has been successful.

    • Edited by ihjones Sunday, October 31, 2010 4:04 AM
    Saturday, October 30, 2010 6:07 PM
  • ihjones,

    I do not want you to use my name on any forum--got it? I repeat, and you do need repeating, I do not want you to use my name in any post you create here. You may espouse your statements without using my name.

    You take bits and pieces and try to make them explain what you desire.


    Superfetch is suposed to be disabled for all SSDs that meet the criteria listed in my first post above. All G2 SSDs should meet that requirement, especially SSDs that score 7.7 on WEI. At least 99% of those replying state Superfetch is not disabled. You have never even stated owning an SSD, so I don't know if you have one.


    As for defrag and Windows 7, the moderator said what he said and never retracted that statement. Regardless of Defrag, Superfetch along with the others mentioned from Microsoft are still the issue.

    I am quite satisfied to let the reader look at this entire thread and make up their own minds what to believe. You, for some reason, probably your benefit, cannot seem to let it go and repeat yourself over and over again when nobody is either talking to you or asking you.

    Saturday, October 30, 2010 10:33 PM
  • You take bits and pieces and try to make them explain what you desire.

    You could have said "Thank you for your input but I respectfully disagree because of this and this"

     


    You have never even stated owning an SSD, so I don't know if you have one.

    Well I suggest you read up. This has in fact been stated above, you asked and I replied..

     

    As for defrag and Windows 7, the moderator said what he said and never retracted that statement. Regardless of Defrag, Superfetch along with the others mentioned from Microsoft are still the issue.

    This is the greatest shame ever.  The moderator may never return considering how rude you were to him.  I hope one day he corrects this error.  Consider that his answer you quote is in direct conflict with his previous statement and guide on how to validate detection, you have to wonder how he was confused by your question and answered incorrectly. However the best way to get a clear answer is to ask a clear question, right? I feel confident that with this error shown most folks will realize the moderators intent.  I understood the misunderstanding and seems like many others in this thread understood the concept as shown in their posts I quoted earlier.

     

    My point is simple.  Highlighted bold below the moderator clearly explains an accepted method to check for successful SSD detection.

    As I know, currently there are many drives that don't properly report that they are SSDs when queried, so Windows is not able to properly apply the SSD optimizations to those drives. You can check to see if an SSD has been properly detected by looking in Disk Defragmenter. To do this, please refer to the following steps:

    1)Open Disk Defragmenter

    2)Click the Configure schedule button

    3)Click the Select disks button

    If the disk is missing from the list, then it has been detected as an SSD and will not be automatically defragmented.

    If the disk is an SSD, but has not been detected as such, then it's important to remove the check next to the disk in this list so that Windows does not attempt to defragment the drive, which will reduce the life of the drive. Best Regards Dale


    Then you ask the question

    All it says next to that box where you can place a check mark is All Disks. I have 3 SSD's installed, no RAID. I unchecked the box for scheduled defragmenting immediately after installing Windows 7.

    Since it says All Disks next to that box, does that mean my SSD's are or are not recognized? Under Current Status it shows the drive letters of my SSD's.

     

    Then the mod's misguided answer

    1. Since it says All Disks next to that box, does that mean my SSD's are or are not recognized?

    Answer : Yes, these disks are not recognized as SSDs on your computer.

    To say that the disks are not recognized when if all that is listed is "All Disks" (which is incorrect by the way as it indicates "Select all disks") with no disks listed beneath as you indicate , is a contradiction of the mod's instructions in which he states clearly "If the disk is missing from the list, then it has been detected as an SSD " It's a simple mistake no one is blaming anybody.   It is also normal for SSD's to be listed  "Under Current Status " page

    So please chill out already!

     

    Sunday, October 31, 2010 3:53 AM
  • You have Superfetch disabled by default? I read you said " As for Superfetch and Prefetch (two separate mechanisms) I choose to enable them because I prefer to have performance over administrative overhead."

    Well, you are one in a thousand who has had Superfetch disabled by default. There must be a whole lot of inferior SSDs out there. :-))

    I noticed you didn't address my statement above: "Superfetch is suposed to be disabled for all SSDs that meet the criteria listed in my first post above. All G2 SSDs should meet that requirement, especially SSDs that score 7.7 on WEI. At least 99% of those replying state Superfetch is not disabled."


    ____________________________________________________________________________________________________

    As I've already said, I am not interested in having a conversation with you. You have not said anything that has helped me in any way, nothing.

    The answers given to me by the moderator can be read above. The moderator you refer to has never retracted his answers:

    1. Since it says All Disks next to that box, does that mean my SSD's are or are not recognized?

    Answer : Yes, these disks are not recognized as SSDs on your computer.

    2. What about boot prefetching, application launch prefetching, ReadyBoost and ReadDrive?

    Answer
    These features are disabled on system disks that are SSDs. If the disk isn't the system disk, it is re-enabled to improve performance as the blog describes. To make Windows 7 well support SSDs, you'd better upgrade your firmware.

    _______________________________________________________________________________________________

    From the Microsoft Blog:

    "If the system disk is an SSD, and the SSD performs adequately on random reads and doesn’t have glaring performance issues with random writes or flushes, then Superfetch, boot prefetching, application launch prefetching, ReadyBoost and ReadDrive will all be disabled."

    ______________________________________________________________________________________

    Now, I am not concerned about defrag, but Superfetch and Prefetch are issues that have never been solved. Defrag is only an issue to me because of what the moderator said, right or wrong, he said it and never corrected himself.

    When I, the person who started this thread, decides a mark of answer is deserving, I will do it.

    Having seen how you communicate, I do not desire to discuss anything further with you; I know what you think and I do not agree.

    I build computers and have enough knowledge to know what is going on.

    I am the one who discovered the MSE bug in Windows 7. I am the one who started this thread, and I will mark an answer when and if that day comes.

    BYE!

     

    Sunday, October 31, 2010 1:27 PM

  • You have Superfetch disabled by default? I read you said " As for Superfetch and Prefetch (two separate mechanisms) I choose to enable them because I prefer to have performance over administrative overhead."

    Well, you are one in a thousand who has had Superfetch disabled by default. There must be a whole lot of inferior SSDs out there. :-))

    @ ambizytl. I don't believe any of my posts indicate that Superfetch was disabled at any time on any of my systems. Have only repeated that the Superfetch service you refer is NEVER to be disabled, and users are cautioned by Microsoft from doing so. On the other hand I set Superfetch to auto on all my SSD equipped desktops and notebooks which benefit tremendously from caching of programs and data based on historical traces performed by Superfetch.

     

    FYI  If Windows 7 determines that administrative overhead of the trace and caching mechanisms are not significantly outweighed by their effectiveness, then Superfetch performs a number of other operations and places itself into manual mode.  Superfetch will never disable itself and it's registry entries will always be enabled.    Furthermore it is an incorrect assumption that this process takes place immediately following install.

    Monday, November 01, 2010 9:52 AM
  • Anyways I found that my perticular problem was related to the drivers that windows installs from boot.

    The solution for myself was while in the windows 7 preinstall enviroment, choosing to load drivers when at the partition managment screen. From there I poped in my driver disk for my motherboard and installed the chipset and AHCI drivers. This I can confirm this worked for my Mushkin 60gb and all the ssd features were enabled after install.

    BTW. I read this entire thread and I was rather annoyed that someone checked it. I was expecting a solution only to find a bunch of evasive answers and more people reiterating the same garbage. The lack of comprehension was rather exausting. It only makes it harder when people fill the forums with a bunch of nonsence and irrelevant information for those like myself who read these forums to find answers opposed to asking the same question asked 20 times already let alone in the same thread.

    Saturday, February 19, 2011 2:00 PM
  • You have a solution to what?  Thats the whole point, there is nothing that requires a solution..
    Sunday, February 20, 2011 4:42 AM