none
Window Text font too big, scrolls out of dialog boxes

    General discussion

  • I hope someone can help with this. Google has not been my friend.

    The Window Text size on my Vista Home Premium machine is big. Too big, in fact, to display correctly in most Windows system dialog boxes. And as we know, these verdammt boxes are not resizable. Up to now, this has been a minor annoyance, but now it's a major one: it's keeping me from completing the Vista x64 SP2 patch install.

    Here are some screenshots so you can see what I'm talking about:

    Photobucket
    Photobucket
    Photobucket

    As you can see in the screenshots, the window text is just too big. It overflows the sides of the dialog. And because the SP2 EULA screen requires that you view all its text, and I can't, I never get an active "NEXT" button to proceed with the installation. Changing screen res does not help.

    I've tried Personalize > Windows Color and Appearance > Open Classic Appearance Properties to reset the Window Text size, but the option to do this is grayed out. Help!

    System:
    Windows Vista Home Premium 64-bit, Version 6.0 (Build 6001), Service Pack 1
    Dell Studio XPS 435 MT, Core i7 920, 6GB RAM
    ATI Radeon HD 3650 running Catalyst 8.49
    Dell Widescreen 2408 WFP in 1920 x 1200 native resolution

    Thursday, May 28, 2009 11:52 PM

All replies

  • Hi,

    Thank you for posting in Microsoft TechNet Forum.

    As I know, This feature is by design. For more information, please visit the following website.

    Save your eyes with DPI Scaling in Windows Vista
    http://blogs.techrepublic.com.com/window-on-windows/?p=740

    How to change the font size in Windows Vista
    http://www.vista4beginners.com/How-to-change-font-size

    Hope this helps. Thanks.

    Friday, May 29, 2009 9:25 AM
  • Thanks for the answer, Dale, but it doesn't help.

    I refuse to accept that there is no solution to this problem. There must be a registry hack somewhere that will allow me to fix this problem!
    Friday, May 29, 2009 10:37 AM
  • Hi,

     

    Unfortunately the above suggestions didn't take effect, anyway thanks for your cooperation.

     

    Based on my further research and test on our test machines. I would like to propose the following suggestions.

     

    1. Make sure that you have the latest video driver installed on your computer, you may need to update it through Device Management.

     

    2. Try to change this behavior in Advanced Appearance, please visit the following website for details.

     

    Advanced Appearance

    http://www.vistax64.com/tutorials/78281-advanced-appearance.html

     

    Note: This response contains a reference to a third party World Wide Web site. Microsoft is providing this information as a convenience to you. Microsoft does not control these sites and has not tested any software or information found on these sites; therefore, Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there.

     

    3. I also found some solutions about modifying registry related to Font Size, you can visit the following websites for references.

     

    Note: Be careful with registry modifications, you'd better back up registry first.

     

    How to change the Default Vista Fonts

    http://www.vistax64.com/tutorials/106279-fonts-change-default.html

     

    Fix Windows Vista’s Fonts

    http://chris.pirillo.com/fix-windows-vistas-fonts/

     

    Note: This response contains a reference to a third party World Wide Web site. Microsoft is providing this information as a convenience to you. Microsoft does not control these sites and has not tested any software or information found on these sites; therefore, Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there.

     

    Hope this helps. Thanks.

     

    Monday, June 01, 2009 3:23 AM
  • Thanks for the information, Dale.

    I had already tried Chris Pirillo's Font Fix, with no success. Advanced Appearance likewise does not work. I also tried the "How to change the default fonts" method in your second link - no go.

    Guess this is just something I'll have to live with?
    Thursday, June 04, 2009 1:52 AM
  • Hi,

     

    Thanks for your prompt reply.

     

    Unfortunately, neither of above works. However, I will keep doing a further investigation.

     

    As I mentioned above, please check that your video driver is up-to-dated. A newer version of the driver might include a resolution to the problem.

     

    Meanwhile, I noticed that this issue occurred in Windows Vista SP2 installation. How did you install Windows Vista SP2, upgrading from the previous Operating System or clean installation with Windows Vista SP2? Did this issue occur in the previous Operating System?

     

    If the previous Operating System didn't own this issue, I may need to suggest that you do System Restore to the previous restore point without any problem, then perform reinstall Windows Vista SP2 following steps in the website as follow:

     

    How to install Windows Vista SP2

    http://windowshelp.microsoft.com/Windows/en-GB/Help/105f7420-6f7f-4fe8-8698-2f40ca5f53711033.mspx

     

    Hope this helps. Thanks.

     

    Thursday, June 04, 2009 10:16 AM
  • Hi Dale,

    I have not yet installed Vista SP2, because of the error noted above. My Dell came from the factory with Vista SP1 installed, so there was no previous OS and nothing to System Restore to.

    Thank you for the link about installing SP2.
    Monday, June 15, 2009 2:18 AM
  • Hello MSFT.
    Why don't You answer on exact question - but try to discuss unrelated solutions??
    Videocard drivers??? - Very funny advice!
    Reinstall OS - no comments....

    Maybe You better open that dialog box("Advanced Appearence" in Vista and "Window Color and Appearence" in Windows 7) and see problem by Yourself?
    Click at "Window Text" or open menu item "Window" there and try to change Font Size or Font - it's inactive!

    We have same exact question - Where And How can we change or add some settings (I believe in registry) - so
    I could change Default Windows FONT - as described above.
    I can change anything text size/fonts but not for Main text - "window text".
    And btw I tryed to change it and in Vista and in Windows 7.
    • Edited by a2000 Wednesday, August 19, 2009 5:58 PM
    Wednesday, August 19, 2009 5:13 PM
  • I am having the same problem as the person above but I am running windows 7.  Is there anyway this can be corrected?

    Thanks,
    jsjs
    Thursday, February 18, 2010 4:03 AM
  • The problem is generally caused by some "repairing" tools, I think even sfc.exe does this. These tools put name of incorrect font file under key "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts"
    "Courier 10,12,15"
    "MS Sans Serif 8,10,12,14,18,24" - this causes the most visible problems in dialogs.
    "MS Serif 8,10,12,14,18,24"

    As the fonts with ".fon" suffix are different for each codepage, the name of correct font is dependent on the locale of your Windows, so the easiest way is to look for a correct name at a computer which uses the same version of Windows and correct fonts in dialogs.

    Otherwise, you have to look at %systemroot%\Fonts directory and list available fonts, e.g. sse*.fon for "MS Sans Serif 8,10,12,14,18,24". These fonts can be marked as hidden (e.g. in Windows XP).

    ssee1255.fon
    ssee1256.fon
    ssee1257.fon
    ssee874.fon
    ssef1255.fon
    ssef1256.fon
    ssef1257.fon
    ssef874.fon
    sserife.fon
    sserifee.fon
    sserifeg.fon
    sserifer.fon
    sserifet.fon
    sseriff.fon
    sseriffe.fon
    sseriffg.fon
    sseriffr.fon
    sserifft.fon

    Those beggining with "sse" having "e" on 4th position are smaller fonts, those having "f" on 4th position are bigger ones.
    The numbers from 5th position equal to ASCII codepage:

    874 - Thai 
    1255 - Hebrew
    1256 - Arabic, Farsi and Urdu
    1257 - Baltic languages such as Estonian, Latvian, Lithuanian

    Those beggining with "sserif" having "e" on 7th position are smaller fonts, those having "f" on 7th position are bigger ones.
    8th position means:

    nothing - Western European script
    e - Eastern European script
    g - Greek script
    r - Russian script
    t - Turkish script.

    You should use the correct script for your locale, otherwise the general font substitution will result in those fonts visible inUsers MedalsUsers MedalsShowbizkid's first picture.

    • Edited by Pavel D. _ Saturday, March 20, 2010 5:45 PM
    Thursday, March 11, 2010 5:48 PM
  • Pavel Thanx!

    I had the same Problem with Windows XP
    i changed SSERIFF2.FON with sserife.fon and everything is working fine now!
    You where a great help thanx again

    Chris
    Wednesday, March 17, 2010 7:54 PM
  • try reinstalling fonts. This helped me.  http://forums.cnet.com/5208-12546_102-0.html?threadID=309320
    Wednesday, May 05, 2010 8:29 PM
  • I am having the same problem as the person above but I am running windows 7.  Is there anyway this can be corrected?

    Thanks,
    jsjs


    i had the same problem in windows 7. this simple registry hack works like a charm.

    http://steve.fsxtreme.com/blogs/2008/01/16/say-no-to-segoe-and-cleartype-on-vista/

    it is originally made for vista, but works in windows 7 as well.

    Monday, May 17, 2010 4:23 PM
  • This is really great information, Pavel. Thank you for posting it.

    Unfortunately, my system has the correct Western Euro sserife.fon file listed in the registry for MS Sans Serif, so I already have the correct value there.

    Friday, June 04, 2010 8:54 PM
  • Problem Fixed!

    I tried the "NoSegoe" fix above, but had no luck. But that started me thinking: What if Segoe itself was the problem?

    So I opened my Fonts folder and found that SegoeUI was not listed. I reasoned that Windows was substituting a FON system font for the missing SegoeUI, and re-installed the Segoe family from a backup font archive. Control Panel told me that SegoeUI was already installed (even though I couldn't see it), and asked if I wanted to overwrite it. I clicked "yes" and did a Log Off / Log On cycle and the problem was fixed!

    So my SegoeUI font family was apparently corrupt, and Windows was using a substitute screen font that was too big. After this, I was finally able to download and install the Vista SP2 service pack.

    Big thanks to everyone who contributed to helping me get my fix! Hope this helps someone else to solve their problem too.

    Friday, June 04, 2010 11:59 PM
  • 'Though this may or may not relate to your specific problem, I leave this note here for others with similar problems who happen to find this article. As stupid as this may sound, a lot of the text that people would assume to be controlled with the option you show above as being greyed-out is actually controlled by the value for the item labeled "Icon". See the drop-down menu which is above the one you show in your screen capture, select icon, change the font characteristics, click "OK", and finally click "Apply".

    Wednesday, November 24, 2010 10:17 AM
  • There is a similar problem, but ocurring in just some dialogs.

    my solution was to copy the files comctl32.dll and comdlg32.dll (located in system32 or syswow64 depending on your flavor of windows 7) from another windows 7 (that its runing just fine, doesnt matter if it has sp1 installed or not).

    you cannot just overwrite the files, so i used hiren's boot disc (use google to get that) to run a live os and erase the bad files from my system and then copy the new files in.


    Friday, June 03, 2011 7:41 PM
  • THANK YOU!!!!! I've been strugling with this for days and this solved it for me :)

     

    I had to change:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts]

    "MS Sans Serif 8,10,12,14,18,24"="SSERIFF.FON"

    to be

    "MS Sans Serif 8,10,12,14,18,24"="SSERIFE.FON"

    Monday, July 04, 2011 9:53 AM
  • I had a similar problem with Windows 7 Pro, 64-bit, SP1 (on an HP EliteBook 8740w, NVIDIA Quadro FX2800M w/ 1GB dedicated RAM, and a WUXGA (1920x1200) display). Many applications and pages had a font that was too large for the screen real estate allotted to that particular window. Here's what I found:

    My system was set to "Medium - 125% (default)" out of the box. Apparently this IS the default. I set mine to "Smaller - 100%" (as shown in the screen shot above) and all applications worked great and scaled correctly based on the screen real estate allotted to that particular window. Hope this helps!


    Wednesday, August 10, 2011 5:37 AM
  • I had a similar problem with Windows 7 Pro, 64-bit, SP1 (on an HP EliteBook 8740w, NVIDIA Quadro FX2800M w/ 1GB dedicated RAM, and a WUXGA (1920x1200) display). Many applications and pages had a font that was too large for the screen real estate allotted to that particular window. Here's what I found:

    My system was set to "Medium - 125% (default)" out of the box. Apparently this IS the default. I set mine to "Smaller - 100%" (as shown in the screen shot above) and all applications worked great and scaled correctly based on the screen real estate allotted to that particular window. Hope this helps!


    Running Windows 7 - This worked for me, Thank you!  Can finally read my entire UDID Identifier.
    Sunday, March 04, 2012 3:20 PM
  • My computer is already set to "Smaller" but is still too large for the screen.
    Saturday, March 31, 2012 8:35 PM
  • Had the same problem on a new DELL Precision M6600 laptop with a resolution of 1920x1080.   For some reason, Windows 7 determined that I should use 125%, and changing the per user setting to 100% still had some dialog boxes displayed with a much bigger font, making it overflow the dialog.

    From Davel's explanation I could understand why my windows was still using a bigger fonts in some dialog boxes and not all of them.  Any application still using the Ms Serif and Sans Serif fonts was using the wrong .FON file.  Changing the name of the fonts in the registry fixed the problem.

    One other thing worth mentionning.  In order to make sure to force a 96 DPI setting as a system default, you might have to search for the "LogPixels" value in the whole registry and wherever you see 120 (or 78 hexa), change it to 96 (or 60 hexa).

    Thanks again!

    Friday, June 15, 2012 9:38 PM
  • i'm struggling with a related issue. 

    On Windows 7 Starter, I reduced my DPI to less than 100% using the steps explained here:

    http://superuser.com/questions/80151/how-to-setup-custom-dpi-below-100-on-windows-7

    This image shows this on my computer. 

    Problem: Immediately after doing this, fonts in dialog boxes are oversized. See image. You can see how the 'Advanced' button is off-screen. 

    I made various attempts to fix this, based on tips in the above thread and other articles. 

    Here are my Advanced settings. What I choose here seems to have no affect on dialog boxes:

     

    This shows my MS Serif setting in the registry. It appears to be correct, according to this and other discussions:

    Here's my Segoe UI entry in the registry. 

    Here are my font substitution entries for MS Shell Dlg:

    Here are my Segoe UI properties from Windows/Fonts folder. It appears to be missing sizes lower than 12, but choosing a size of 12 (or any other size) in Advanced Settings seems to have no effect on dialog boxes. 

    I'm not expert enough to know how to fix it. Can anyone make sense of this? 

    Thanks!


    • Edited by johny w Wednesday, August 01, 2012 7:24 AM
    Wednesday, August 01, 2012 7:23 AM