none
Upgraded from windows vista to windows 7 and now i cannot open the old videos and pictures. Everytime i attempt to access a file i am prompted 'you do not have the correct permissions to acces the file location'.

    Question

  • As i Described in the title, i cannot access any of the videos and pictures i have transfered from my old copy of windows. everytime i try to open the files i am prompted, 'windows photo viewer can't open this picture because you dont have the correct permissions to acces the file location'. 

    I have read a few other posts that say they have gone into the security tab and enabled the 'full control' in permissions. i have done this and i am still unable to open any of the files. i think that i may of selected the 'encrypt data for added protection' box in folder options when the files were on my vista computer but i thought i had unchecked that so i cant be sure if thats adding to the problem or not.

    i dont have any backups of these files and its so frustrating having them all saved but unaccessable as they are very important to me. please can someone help, feel free to ask anything i may of left out and i will be happy to be of assistance. thanks again.

    Monday, July 19, 2010 1:03 AM

All replies

  • I would recommend also changing the Owner of the files.

    Go back into the Security Tab, click Advanced, Owner, then click Edit.

    If your username isn't showing up by default, just click "Other users or groups" and type it in.  Finally, check the box for "Replace owner on subcontainers and objects", which I think means to recursively set the permissions.

    Let us know if that works.

    Monday, July 19, 2010 2:06 AM
  • hi, thanks for the reply, i have just tried that. changed the folder and subfolders to my username but i am still getting the same error message. is there anything else you can suggest?
    Monday, July 19, 2010 2:15 AM
  • Hi,

     

    Please open a command prompt running as Administrator, then type the following command to grant the full control permissions:

     

    Cacls [The folder path] /t /e /g [username]:f

     

    For example, I will change the ACLs on the C:\Test folder to allow the full control for the Administrator account:

     

    Cacls C:\Test /t /e /g Administrator: f

     

    If the issue persists, you can use the following command line to reset all security settings to the default:

     

    secedit /configure /db defltbase.sdb /cfg %windir%\inf\defltbase.inf /verbose

     

    More references:

     

    Cacls

     

    Resetting NTFS files security and permission in Windows 7 RC

     

    Best Regards

    Dale

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Tuesday, July 20, 2010 6:56 AM
    Moderator
  • I have tried both of these methods but nothing has changed. i still recieve the alert, 'windows photo viewer cant open this picture because you do not have the correct permissions to access this file location'. i have tried opening with different programs and it still will not open any of the files within the target folder. please help!
    Wednesday, July 28, 2010 1:03 PM