none
Access Denied to take ownership of files even from command prompt logged in as administrator in Windows 7

    Question

  • I have a PC with 2 additional 1.5 terabyte drives in a hardware mirror that I use as a home file server.  In is NFTS and was initially installed at Vista.  Recently I have upgraded it to Windows 7 however the volume with the data was not touched only the disk I use as a system volume. 

    Now I find that when I go to delete files (mostly video files of TV shows etc) I get can not. Even when logged in as a administrator equivelent or the administrator account itself I get a "access denied" message.  I have tired to take ownership both using GUI and the command prompt logged in as the local administrator and that does not work giving me a "INFO: Access Denied" message using takeown for the files.

    I is odd there is nothing different with the files and other files in the same directory are ok.  I look at the permissions in the GUI and they appear to be ok also.  I am perplexed.  I have run two virus scanners just in case and no luck there.

    Any ideas?

    Thursday, May 20, 2010 5:40 PM

Answers

  • Hi, have you tried booting into Safe Mode and then remove the files since you mentioned that the disk is a system volume now. You can also try take ownership in Safe Mode:

    1. Navigate to the target file/folder.
    2. Right-click on the file/folder and choose Properties.
    3. Click the "Security" tab and see if your current user is listed in the "Group or user names" list. If not, please click the Add button, type the name of your current user in the "Enter the object names to select " box, then click "OK" to add this group.
    4. Select the user from the list and then check the "Allow" checkbox next to "Full Control".
    5. Click the Advanced button and click the "Owner" tab. Then, press "Edit" button.
    6. Select current user from the list and check the "Replace owner on subcontainers and objects" checkbox.
    7. Click "OK" to save changes and wait for Windows Vista to transfer the ownership of all the objects on the partition.
    8. Click OK again to save changes and exit the Properties window. 


    Sean Zhu - MSFT
    Tuesday, May 25, 2010 6:49 AM
    Moderator

All replies

  • Hi, have you tried booting into Safe Mode and then remove the files since you mentioned that the disk is a system volume now. You can also try take ownership in Safe Mode:

    1. Navigate to the target file/folder.
    2. Right-click on the file/folder and choose Properties.
    3. Click the "Security" tab and see if your current user is listed in the "Group or user names" list. If not, please click the Add button, type the name of your current user in the "Enter the object names to select " box, then click "OK" to add this group.
    4. Select the user from the list and then check the "Allow" checkbox next to "Full Control".
    5. Click the Advanced button and click the "Owner" tab. Then, press "Edit" button.
    6. Select current user from the list and check the "Replace owner on subcontainers and objects" checkbox.
    7. Click "OK" to save changes and wait for Windows Vista to transfer the ownership of all the objects on the partition.
    8. Click OK again to save changes and exit the Properties window. 


    Sean Zhu - MSFT
    Tuesday, May 25, 2010 6:49 AM
    Moderator
  • Access denied? I have a same problem of you, but long path tool help me in this situation. So you can download a latest version of “Long Path Tool" for solve this problem.

    Sunday, October 14, 2012 4:07 PM