none
Win7 Pro: Impossible to connect on any wireless network with a domain account

    Question

  • Hi,
    I have a weird issue with some laptops (Dell Latitude different models). On all of them Win7 pro 64bits is installed
    They are all on our domain and everything works fine but not the wireless
    If I use a local account (administrator or not), I can see all available wireless networks and I can connect o them and put my credentials
    If I use a domain account (administrator or not), I can see all available wireless networks but if I try to connect to one of them, it says that windows was unable to connect to this network and I don't understand why. I don't even have the credential window to put my login and password
    Any help will be great
    Thanks in advance
    Monday, April 16, 2012 12:39 AM

Answers

  • Ok guys,

    Sorry for the late reply but all your comments helped me to find a solution

    Here it is:
    - I setup the connection manually
    - I went to my wireless network properties and then in Security tab I clicked on "Settings"
    - Ticked "Validate server certificate" and in Trusted Root... area, i ticked "AddTrust External CA Root"
    - On the same window, I clicked on "Configure" and unselected the option "Automatically use my Windows logon name..."
    - Click on OK

    - Still in secutiry tab, I click on "Advanced Settings"
    - Selected "Specify authentication code" and selected "User authentication"
    - Clicked on "Saved Credential" and I put my network login detail
    - Clicked on OK to save all my settings

    And now the connection works perfectly even after a reboot

    Thanks a lot for your help

    • Marked as answer by Ben Genest Tuesday, May 15, 2012 6:47 AM
    Tuesday, May 15, 2012 6:47 AM

All replies

  • Do you guys have any GPO set which might disable wireless networks?

    Blog: rorymon.com Twitter: @Rorymon

    • Proposed as answer by RorymonMVP Monday, April 16, 2012 5:52 AM
    Monday, April 16, 2012 5:38 AM
  • Very often in domains certificates are used to manage computers.

    However if the computer or user account is not in the proper OU it may never get the certificates.

    I would start with verifying that the computer is not in default container "Computers". Then find out from your domain admin where the computer needs to be.  Move the computer to the proper OU. Run "gpupdate /force" and reboot.

    Monday, April 16, 2012 5:51 AM
  • Check related policies. You may refer to:

    Configuring Wireless settings via Group Policy
    http://www.techrepublic.com/blog/networking/configuring-wireless-settings-via-group-policy/1093


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    Tuesday, April 17, 2012 7:29 AM
  • Ok guys,

    Sorry for the late reply but all your comments helped me to find a solution

    Here it is:
    - I setup the connection manually
    - I went to my wireless network properties and then in Security tab I clicked on "Settings"
    - Ticked "Validate server certificate" and in Trusted Root... area, i ticked "AddTrust External CA Root"
    - On the same window, I clicked on "Configure" and unselected the option "Automatically use my Windows logon name..."
    - Click on OK

    - Still in secutiry tab, I click on "Advanced Settings"
    - Selected "Specify authentication code" and selected "User authentication"
    - Clicked on "Saved Credential" and I put my network login detail
    - Clicked on OK to save all my settings

    And now the connection works perfectly even after a reboot

    Thanks a lot for your help

    • Marked as answer by Ben Genest Tuesday, May 15, 2012 6:47 AM
    Tuesday, May 15, 2012 6:47 AM
  • I salute you for coming back and posting the solution! You saved me, a poor linux soul, hours in battling my girlfriends e v i l windows machine, and made me look fantastic. Merci beaucoup!

    Tuesday, March 04, 2014 11:02 AM