none
Display cropped on 1080p TV using HDMI cable?

    Question

  • I have a problem that when I use either of my HD 1080p TVs,

    the desktop seems to be cropped by about 40 pixels on all four sides of the screen.

    It happens on both my Sony Bravia LCD TV and my Sharp Aquos TV.

    I do not think it is a driver or Windows problem per se, as if I plug the HDMI into

    my 1080p ASUS monitor, all is fine (all pixels are shown). On the Sony, I can also

    adjust Horizontal Center up to 5 pixels but of coarse I lose a pixel on the right for

    every pixel I gain on the left.

    Therefore, I think the display is actually something like 1880 x 1040

    instead of 1920 x 1080. While this is not a problem with pictures, it is a big

    problem with a Windows Desktop, as the Start Menu is hard to use.

    Is there any simple way in Windows 7 to tell it not to use the edges of the screen?


    • Edited by davel.wiki Sunday, March 04, 2012 11:19 PM Better understand of problem
    Sunday, January 08, 2012 12:59 PM

Answers

  • This is the answer I found using

    "Intel Graphics and Media Control Panel" Other graphic

    drivers will probably have a completely different terminology.

     

    OK. I finally found the setting you were talking about under
    <Right-click the desktop> / Graphic Properties ... / Advanced Mode - OK
    Under "Custom Resolution" and answering yes to the very scary
    warning about how this could cause your computer to blow up.
    I set width 1920  height 1080 refresh rate 59 color depth 32
    Underscan percentage 20% (I left interlace off and Timing GTF)
    I think (hope) "Timing Standard" is ignored using HDMI.
    I then added the Custom resolution 1862 x 1048, 32 bit, 59 Hz
    I then switched to "General Settings", Select the "Resolution" as
    the custom one of 1862x1048 AND set "Scaling" to "Center Image".
    The last bit is very important as none of the other settings seem to have
    an affect unless "Center Image" is chosen. It still Chops off
    some pixels around the edged but Underscan percentage 20% was the
    highest I could set when I apparently needed 30-40%. But at least
    now I can see the speaker control and the time.

    Thanks everyone for their help.

    PS. Some more official info can be found at

    http://www.intel.com/support/graphics/sb/CS-029478.htm

     

    • Marked as answer by davel.wiki Tuesday, January 31, 2012 11:47 AM
    Tuesday, January 31, 2012 11:47 AM
  • I think I have found a simpler solution. From the default settings, during which the cropping problem is evident, follow these steps: Under the same Intel Graphics and Media control panel interface, go to General settings under the display tab, then switch to the TV display in the display section. Change scaling to "Customize aspect ratio", then adjust the horizontal and vertical scaling as needed. For me, it was just about perfect at 50 horizontal scaling and 45 vertical scaling.
    • Edited by CamJM Wednesday, February 29, 2012 11:18 PM
    • Marked as answer by davel.wiki Sunday, March 04, 2012 11:03 PM
    Wednesday, February 29, 2012 11:14 PM

All replies

  • Televisions are not monitors.  They have different specifications than monitors.  What gets displayed on yous televisions is controlled by exactly what the video driver detects is the capability of the TV.

    Comparing what is displayed on your monitor and what is displayed on you TV is like comparing apples to oranges.  They are not the same.

    For more information about what is happening, you need to talk to the Technical Support for your video card and for the driver.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Sunday, January 08, 2012 8:31 PM
  • I know TVs are different then monitors. That is why I listed them seperately.

    Although, I think it is more like comparing a red delicious apple to a yellow

    delicious apple then apples and oranges ;-)

     

    My point was: I believe the TV is reporting the signal size it expects 1920 x 1080 (I.E. 1080p)

    not the display area the TV actually shows. Therefore, the driver can not easily do the right thing.

    That being said: There is no reason Windows could not have an easy way not to use part of

    the screen, kind of like setting borders on a printed page.

     

    Thanks for responding to my message. While it did not help me much, maybe it will help

    clarify the problem for others.

    Sunday, January 08, 2012 10:02 PM
  • Your video card manufacturer may have tools that will allow you to resize the output image to a given physical dimension. ATI Catalyst and Nvidia Vision have tools that does that. You could check your manufacturer website for these software.
    Friday, January 13, 2012 1:07 AM
  • I am using the built in video on the Intel i7-2600 "Intel(R) HD Graphics Family"

    which I am assuming uses a Windows 7 device drive but I do not know how to check.

    I believe the image output needs to be 1920 x 1080, for the TV to recieve the signal.

    It seems the software just needs to know not to display anything needed on the edges.

    It sounds like there is no easy solution, thanks anyway.

     

    Tuesday, January 17, 2012 10:31 PM
  • Which type of connection have you made between the pc and the tv?

    Many work better using the blue VGA, as that port is designed to receive the pc signal. Others will work ok using an HDMI to HDMI.

    The "cropped" desktop is usually fixed(as mentioned by Krupa) using a scaling adjustment.

    Right-click the desktop and look for the Intel display settings and perhaps find the scaling adjustment. The Windows settings in control panel do not provide a scaling adjustment. ATI CCC and Nvidia control center do.

     

    Wednesday, January 18, 2012 9:20 PM
  • This is the answer I found using

    "Intel Graphics and Media Control Panel" Other graphic

    drivers will probably have a completely different terminology.

     

    OK. I finally found the setting you were talking about under
    <Right-click the desktop> / Graphic Properties ... / Advanced Mode - OK
    Under "Custom Resolution" and answering yes to the very scary
    warning about how this could cause your computer to blow up.
    I set width 1920  height 1080 refresh rate 59 color depth 32
    Underscan percentage 20% (I left interlace off and Timing GTF)
    I think (hope) "Timing Standard" is ignored using HDMI.
    I then added the Custom resolution 1862 x 1048, 32 bit, 59 Hz
    I then switched to "General Settings", Select the "Resolution" as
    the custom one of 1862x1048 AND set "Scaling" to "Center Image".
    The last bit is very important as none of the other settings seem to have
    an affect unless "Center Image" is chosen. It still Chops off
    some pixels around the edged but Underscan percentage 20% was the
    highest I could set when I apparently needed 30-40%. But at least
    now I can see the speaker control and the time.

    Thanks everyone for their help.

    PS. Some more official info can be found at

    http://www.intel.com/support/graphics/sb/CS-029478.htm

     

    • Marked as answer by davel.wiki Tuesday, January 31, 2012 11:47 AM
    Tuesday, January 31, 2012 11:47 AM
  • I think I have found a simpler solution. From the default settings, during which the cropping problem is evident, follow these steps: Under the same Intel Graphics and Media control panel interface, go to General settings under the display tab, then switch to the TV display in the display section. Change scaling to "Customize aspect ratio", then adjust the horizontal and vertical scaling as needed. For me, it was just about perfect at 50 horizontal scaling and 45 vertical scaling.
    • Edited by CamJM Wednesday, February 29, 2012 11:18 PM
    • Marked as answer by davel.wiki Sunday, March 04, 2012 11:03 PM
    Wednesday, February 29, 2012 11:14 PM
  • I think when I tried this, I was think it was in percent so I only tried 95 which had no apparent affect.  I also "knew" it was a bad idea to scale text by a small amount as it tends to make vertical and horizontal lines an irregular thickness.  After trying your setting, the results seem better than mine. I am not sure what scaling means/does in this context but it does not seem to be a simple scaling. In any case, I set it to 60 vertical and 60 horizontal and will test it for a while and check for artifacts. So far so good.

    Thanks.


    • Edited by davel.wiki Sunday, March 04, 2012 11:18 PM typo
    Sunday, March 04, 2012 11:16 PM
  • I just had the same thing with a new Windows HTPC connected to a SONY Bravia TV via HDMI - the screen seemed to be very slightly zoomed but the normal TV zoom setting was definitely set to "full" (no zoom). After reading quite a few suggestions around software to adjust various settings on the video card, I found that the problem in my case at least was with another TV setting. The "Display Area" option (press HOME, scroll across to "settings", down to "screen") was set to "auto". There are various other options several of which make it worse (more zoom) but setting to "full pixel" completely fixed the problem for me and now I have the whole Windows desktop displayed.

    • Proposed as answer by nicknz1 Friday, April 13, 2012 7:39 PM
    Friday, April 13, 2012 7:39 PM