none
Opening files over network takes long time

    Question

  • When I open files on network share with double click, it takes about 30 sec to open. With File -> Open method files open instantly. It affects Excel 2003 files, Word 2003 and Autocad 2010 files, on the other hand .txt and .pdf files are not affected with any delays.

    Other operations on this network disk work in normal way (to search, or copy takes 1-2 sec).

    Already tried disabling antivirus software - didnt help.

    Any clues what could be wrong?


    • Edited by Lukas2 Saturday, February 25, 2012 8:53 AM
    Saturday, February 25, 2012 8:49 AM

Answers

  • Hi,

    Since the office and AutoCAD files are opened with more components, it will take some time. And the antivirus would take time on scanning.
    I suggest you upgradte Office product first. If the files are large, please download to the local disks first.

    If you would like to speed up, try to disable SMBv2. Please use the following commands.
    sc config lanmanworkstation depend= bowser/mrxsmb10/nsi
    sc config mrxsmb20 start= disabled

    Please note: there's an extra " " (space) after the "=" sign.

    Network performance issues can also be caused by auto-tuning, because not all network devices support auto-tuning well. To disable auto-tuning, use the following command.
    netsh interface tcp set global autotuninglevel=disabled

    Please note that all the commands need to be run in cmd window that with high privilege.


    The following article introduces the advantages of SMB2.

    SMB2, a complete redesign of the main remote file protocol for Windows
    http://blogs.technet.com/b/josebda/archive/2008/12/05/smb2-a-complete-redesign-of-the-main-remote-file-protocol-for-windows.aspx


    Hope that helps.

    Tuesday, February 28, 2012 1:32 AM
  • Hello Lukas

    Most Anti Virus have their filter drivers that sit at the Kernel level , just disabling the AV is not a proper test to rule out AV from the picture.

    If you completely rule that out then uninstall the AV software and then try.

    Also please let me know the server OS.

    Do you have teaming enabled on the server ?

    Tuesday, February 28, 2012 3:46 AM

All replies

  • Hi,

    Since the office and AutoCAD files are opened with more components, it will take some time. And the antivirus would take time on scanning.
    I suggest you upgradte Office product first. If the files are large, please download to the local disks first.

    If you would like to speed up, try to disable SMBv2. Please use the following commands.
    sc config lanmanworkstation depend= bowser/mrxsmb10/nsi
    sc config mrxsmb20 start= disabled

    Please note: there's an extra " " (space) after the "=" sign.

    Network performance issues can also be caused by auto-tuning, because not all network devices support auto-tuning well. To disable auto-tuning, use the following command.
    netsh interface tcp set global autotuninglevel=disabled

    Please note that all the commands need to be run in cmd window that with high privilege.


    The following article introduces the advantages of SMB2.

    SMB2, a complete redesign of the main remote file protocol for Windows
    http://blogs.technet.com/b/josebda/archive/2008/12/05/smb2-a-complete-redesign-of-the-main-remote-file-protocol-for-windows.aspx


    Hope that helps.

    Tuesday, February 28, 2012 1:32 AM
  • Hello Lukas

    Most Anti Virus have their filter drivers that sit at the Kernel level , just disabling the AV is not a proper test to rule out AV from the picture.

    If you completely rule that out then uninstall the AV software and then try.

    Also please let me know the server OS.

    Do you have teaming enabled on the server ?

    Tuesday, February 28, 2012 3:46 AM