none
How to set up a usb to serial converter in Windows 7 to Windows XP in Virtual Mode

    Question

  • I have purchased a new laptop with Windows 7 installed. I had to load my old XP software into the virtual XP mode to get it to work. But the communications from my old software will not work using the usb to serial converter. I am not really sure how is the best way to set this up. I have installed the drivers in XP mode and Windows 7.

    Can anyone help? The max.number of serial ports my software will look at is Com 4.

    Thursday, January 27, 2011 6:12 PM

Answers

All replies

  • Hi,

    First, I would like to advise that not all the USB devices can work under XP Mode.

    Have you already installed integration features in the XP Mode? If you have not, please install it and try again.

    Also, Check it in Device Manager.

    You may refer to the following link.

    http://blogs.technet.com/b/windows_vpc/archive/2009/09/26/networking-and-using-windows-xp-mode.aspx

    If the issue persists, I suggest to post at http://social.technet.microsoft.com/Forums/en-US/w7itprovirt/threads for better help.

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Tuesday, February 01, 2011 8:44 AM
  • Hello,

    I have found a similar problem in my laptop. I have one with Windows 7 and I really need to use a serial port for communication purposes. After installing XP mode in my laptop, I may use a usb-serial adapter (in fact, I have tested several ones...) but I can't establish any communitacion between my laptop and the device to control although XP mode detects de USB-serial adapter perfectly (I have installed the drivers and integration tools are enabled, too). I would like to know what I must configure to get it. The same usb-serial adpater works fine in VMware but I must use XP Mode, so I'm looking for a solution.

    Thank you very much.

    Wednesday, October 26, 2011 3:25 PM