none
Chinese Handwriting Using Writing Pad on Windows 7

    Question

  • Hi, Recently, I bought a desktop computer which has Windows 7 Ultimate pre-installed with the understanding (as I was told) that it would allow me to write Traditional Chinese (Big 5) characters using IME Pad.

    However, after downloading and installing the Traditional Chinese language pack and experimenting by using various keyboard(s), I have finally decided that probably the Chinese (Traditional) - New Phonetic keyboard is the closest which can generate the characters with phonetic in the IME Pad. Yet, I have not been able to get the handwriting recognition part of IME pad to work with the right phonetic. There seem to be just 2 phonetics available which can enable the handwriting applet: either the Japanese version, or, the Korean version. So, I am wondering why there is no Chinese phonetic (such as zh-tw) available to work with the handwriting recognition? Neither the Japanese nor the Korean version generates the right phonetic. They only produce phonetic in Japanese or Korean neither of which I could understand or pronounce. So, you either get handwriting recognition in wrong phonetic or no handwriting recognition at all.

    In contrast, my Windows XP Professional has a "Microsoft New Phonetic IME 2002a" which generates IME pad that has "Hand Writing (zh-tw)" available. As a result, it enables handwriting in the Traditional Chinese character set (BIG 5) and has right phonetic associated with the words it finds. Why can Windows 7 do likewise?

    Could someone help please?

    Tong
    Saturday, February 13, 2010 1:39 AM

Answers

  • Right click the "Directory" icon on the IME Pad, choose "User settings",enable "Show Applets for all IME", highlight "Hand Writting(CH)" and click Add. Then the Hand Writing (zh-tw) will show up as input methods under "Directory".
    Wednesday, February 17, 2010 5:12 AM
  • I did as suggested. Now, it works!

    Thank you for your help.


    • Marked as answer by tonglu1 Friday, February 19, 2010 5:16 AM
    Friday, February 19, 2010 5:15 AM

All replies

  • Hi,

    For Chinese characters, only the “Chinese(Simpifies)-MicrosoftPinyinNewexperence Input Style” will bring out the IME Pad. Add this from Text Services and Input Languages, you will see the IME item from the language bar. In addition, Windows 7 Ultimate should have the Traditional Chinese language pack  build-in.
    Monday, February 15, 2010 9:35 AM
  • Thanks for taking time to reply my question.

    Following the suggestion of adding “Chinese(Simpifies)-MicrosoftPinyinNewexperence Input Style”, I do see IME as an item on the language bar.

    But I still have difficulty in getting the correct handwriting recognition option with right kind of phonetic in IME. What I do see are 3 options in my IME pad: Strokes (CH), Radicals (CH), and Symbols (CH). If I click the symbol on the upper left corner of the IME Pad, and move the cursor on the item "Input Method Selections", and select "Set Up", I do see Hand Writing (JA) and Hand Writing (KO) as 2 choices (and the only choices) with HandWriting recognition input methods. However, if I add them to the input options, they result in phonetic either in Japanese or in Korean pronouciation. Unfortunately, I can't read them because I don't know either of these languages. I can only pronounce in traditional Chinese phonetic (e.g. ㄅㄆㄇㄈ etc). Besides, it doesn't seem to make sense to recognize traditional Chinese characters but only allow pronouncing in Japanese or Korean. Why not pronounce it in Traditional Chinese as well?

    As a matter of fact, I have seen these same choices before, using only Chinese (traditional) - New Phonetic keyboard as the only alternative input language besides English. The difference between this and the one with “Chinese(Simpifies)-MicrosoftPinyinNewexperence Input Style” is IME Pad comes as part of the Tool Menu in the former while it is a separate item on the language bar for the latter. Once IME pad is brought up, the functionalities are the same. Neither of them has the correct combination of handwriting recognition and traditional Chinese phonetic.

    In contrast, in Windows XP Professional (which I run on my other desktop computer), I see 4 input method choices: Hand Writing (zh-tw), Strokes (CH), Radicals (CH), and Symbols (CH).

    Can you help me in get the "hand writing (zh-tw)" as one of the input methods?

    Thanks.

    Tong
    Tuesday, February 16, 2010 7:12 AM
  • Right click the "Directory" icon on the IME Pad, choose "User settings",enable "Show Applets for all IME", highlight "Hand Writting(CH)" and click Add. Then the Hand Writing (zh-tw) will show up as input methods under "Directory".
    Wednesday, February 17, 2010 5:12 AM
  • I did as suggested. Now, it works!

    Thank you for your help.


    • Marked as answer by tonglu1 Friday, February 19, 2010 5:16 AM
    Friday, February 19, 2010 5:15 AM
  • Hi,

    I have the same problem and still can't get it resolved:

    I have a 64 bit Windows 7 Ultimate desktop, and want to have "Traditional Chinese handwriting pad(CH). I added Traditional Chinese Keyboard-Phonetic. I see there are 3 options in my IME pad: Strokes (CH), Radicals (CH), and Symbols (CH). Then I went to  "User settings" and checked "Show Applets for all IME". There are only HandWriting(JA) and Hand Writing(KO) shown, no "Hand Writting(CH)".

    Does anybody know why?

    Many many thanks!


    Tim
    Friday, February 19, 2010 9:35 PM
  • Sorry, I do not know why. Like yourself, I had struggled with the same problem: no "Hand Writing (CH)" on the IME pad.

    The only difference I had was that I did not add the "Traditional Chinese Keyboard-Phonetic" keyboard. Instead, I have other traditional Chinese keyboards such as "Chinese (Traditional) - New Phonetic" and “Chinese(Simpifies)-MicrosoftPinyinNewexperence Input Style”. I ran into exactly the same problem, i.e. only "Hand Writing (KO)" (for Korean) and "Hand Writing (JA)" (for Japanese).

    Then, after seeing the last post from Magon_67, I tried what he (or she) wrote, then all of sudden it worked - "Hand Writing (CH)" appeared on the list of "Show Applets for all IME".

    Today, I added your keyboard ("Traditional Chinese Keyboard-Phonetic") to my list to see what happens. Well, not only it did not have the (CH) hand writing option, Hand Writing (CH) disappeared from the other keyboards as well!

    After that, I deleted the "Traditional Chinese Keyboard-Phonetic" keyboard, rebooted my computer. Surprisingly, I got mine back.

    So, I am not doing any more experimenting with any other Traditional Chinese Keyboards.

    I would suggest replacing your "Traditional Chinese Keyboard-Phonetic" with "Chinese (Traditional) - New Phonetic". Reboot might help.

    Tong


    Sunday, February 21, 2010 7:47 PM
  • Hi there,

    I'm also running into this problem, I had read somewhere online that the problem is because of the fact that my/our Windows7 Ultimate is 64-bit. I'm not sure why this would mean the IME pad wouldn't be available but this is very frustrating as my Win7 professional x86 on my laptop works perfectly fine!

    I wonder if there's anything that could be done, please advise!

    Allen

    Tuesday, March 23, 2010 4:05 PM
  • I have the same problem on Windows 7 x64.
    Thursday, June 10, 2010 5:33 AM
  • Share the same problems/symptoms as described above - "Hand Writting(CH)" does not appear, or disappears after a change in selection etc.

    However, if I reboot, and then use MS Word with the IME Pad, and use the methods described above - "Hand Writting(CH)" becomes available

    for selection and use.

     

    Unfortunately, this method is not permanent. The "Hand Writting(CH)" selection will once again disappear after a change in language configuration...

     

    Monday, June 14, 2010 7:48 AM
  • Many thanks, you are my life saver.
    Tuesday, June 22, 2010 4:07 AM
  • magon_67,

    I have exactly the same problem (and see the same symptoms) except I have 64-bit Windows 7 Professional as opposed to Windows 7 Ultimate. A few questions:

    1. I don't see any "Directory" icon on the IME Pad (withe the same "Chinese (Traditional, Taiwan)" Language and "Chinese (Traditional) - New Phonetic " Keyboard as tonglu1). Is the "Directory" icon available on Windows 7 Ultimate only and not on Windows 7 Professional?

    2. Or, is the "Directory" icon available after the Traditional Chinese Language Pack is installed?  As stated above, I have a 64-bit Windows 7 Professional and Languages Packs are not available to me.

    3. I do not need the Display Language of my Windows 7 to be non-English hence decided against Windows 7 Ultimate and purchased Windows 7 Professional. Shouldn't all aspects of inputing a different language be the same on both versions of Windows 7?

    I actually have posted my problem on Microsoft Answers forum but have not gotten an answer yet and was referred to this posting as a "proposed answer." Upon suggestion by Microsoft Answers's Moderator as a "possible bug," I also provided input on Windows 7 Feedback but do not believe I would hear anything back. See all details on: http://social.answers.microsoft.com/Forums/en-US/w7desktop/thread/b9e09160-a5ee-40c4-ae95-b3f921361295

    Reading this posting, there seems to be other users of both Windows 7 Professional and Ultimate having the same problem. And I had read on the internet about other users experiencing the same problem without any resolution. Any suggestion(s) on the next step to get this looked at and hopefully resolved?

    Thanks in advance!

    Thursday, February 24, 2011 5:58 AM
  • Wow, I am so glad that I found this page. I have the exact same problem as everyone else. Yesterday I could open the IMEPad and draw Chinese characters to enter them, but today all of a sudden it doesn't work properly. I have not changed any settings. These bugs are extremely irritating and driving me mad.

    If I want to change the options, I also only get three options in the IMEPad -- 劃、部、符

    Then if I try to go into the options I finally see handwriting but ONLY FOR JP/KO. What the hek is going on! Why would there be options for Korean and Japanese when I only have the Chinese keyboard installed? This is so infuriating. I reiterate that no changes have been made. I was able to use the hand-writing entry method YESTERDAY and now all of a sudden the entire IMEPad has altered itself... why is Windows so buggy?!!!!

    Tuesday, April 05, 2011 5:00 AM
  • found the same issue - Hand Writing (CH) keeps disappearing from the IME.

    What seems to be happening is that the DLL is being unregistered by something - not 100% sure what it is, but it is happening at the registry level. (Look in the registry under HKEY_CLASSES_ROOT\CLSID\{C0AA878E-97A5-44DF-B7EF-2E732F7B2FEC}  - this is the "MS CHTIJME Handwriting Applet)

    If you have the traditional chinese (Taiwan) IME installed, you can restore it via the command

    regsvr32 c:\Windows\System32\IME\IMETC10\applets\IMTCCAC.dll

    (ps: IMTCCAC.dll is the actual chinese handwriting applet).

    I noticed that installing other software sometimes resets this. Just running the above command restored it each time.

    chris wong

     

    • Proposed as answer by warper Wednesday, June 26, 2013 11:04 AM
    Tuesday, April 26, 2011 9:58 AM
  • but where is that directory i do not see it at all on my language bar
    Thursday, June 16, 2011 7:30 PM
  • ok so this time i installed this regsvr32 c:\Windows\System32\IME\IMETC10\applets\IMTCCAC.dll but it still does not work so where to go from there????thx
    Thursday, June 16, 2011 8:14 PM
  • This I do the following, now I have the Hand Writting IME Pad shows up again.

     

    Right click the "Directory" icon on the IME Pad, choose "User settings",enable "Show Applets for all IME", highlight "Hand Writting(CH)" and click Add. Then the Hand Writing (zh-tw) will show up as input methods under "Directory".

    Sunday, June 19, 2011 9:45 AM
  • Kenrickw, do you have a 32-bit Windows 7 or a 64-bit Windows 7?  Thanks.

    Tuesday, July 12, 2011 3:20 AM
  • Hey Tonglu1,

    It works! Many thanks to internet users.

    Rebooting was the key.

    Here's what happened.

    Prior I had Chinese (Simplified, PRC) Microsoft Pinyin new experience installed. Following Magon_67 i tried to add Hand Writing (CH), but that option simply wasn't available.

    Then I add Chinese (Traditional, Taiwan) as a new input language with keyboard input Cangjie, New Cangjie, New Phonetic, Phonetic, New Quick and Quick, but no success, still no Hand Writing (CH) option at the IME pad.

    So, I deinstalled all of Chinese (Traditional, Taiwan).

    I rebooted.

    And voila, when starting the Chinese (Simplified, PRC) IME pad, there was Hand Writing (CH) option to be added.

    Still not sure where the error lies, but rebooting might indeed help.

    Good luck my fellow internet users. You were much more a help than the Window Help option.

     

    Sunday, August 28, 2011 12:10 PM
  • Thanks. This article is great help.

    Remark:

    Location of Directory icon:

    Saturday, March 17, 2012 5:30 AM
  • wow, this is some serious bug!!!  After testing on several machines I was able to identify the root cause of why it work for some machines and not others.  On a test machine, I logged in a local "administrator" of my win7-64 box and did the followings:

    1-  ran the reg fix cmd:  regsvr32 c:\windows\system32\IME\IMETC10\applets\IMTCCAC.dll

    2- go to control panel and add the traditional-chinese taiwan, choose Phonetic

    3- in the language bar, choose tool menu Chinese Tradition -->Tool Menu--IME pad

    4- at the top left corner click on the little icon -->applet menu --> user setting, there you will see it!

    Now, I tried these same steps on my own desktop logging as myself with domain admin rights and local administrator group right.  However, after many reboot, it still would not work.  Then I logged off, and log back in but this time I login as the windows built-in administrator/password.  So basically I login to the local computer and not as a domain.  Next, I follow the steps above and it worked!  Finally I logged off as local adminstrator and log back in as a domain admin role and it showed up. 

    There must be a bug somewhere because I am a domain admin and that group belongs to the administrator group on my windows 7 machine.  As far as permission it is there, but for some reason logging in the local builtin administrator work.

    I hope this help.

    Friday, October 05, 2012 6:31 PM
  • This is a very noisy bug with random chinese handwriting applet missing in IME Pad under Windows 7. None of suggested solutions works for me. Just wondering when Microsoft can provide a fix to this serious bug.      

    Thursday, November 08, 2012 3:36 AM
  • The real issue after getting IMEPad to show up with handwriting recognition, is how to get the mouse pad to be used in absolute coordinate mode, so you don't have to use the buttons, and simply actually write the character.  My HP Pavilion dv4 has the Synaptics driver but has not way to get it to toggle between absolute and relative modes.  Anyone has a solution to this?
    Tuesday, January 01, 2013 12:33 PM
  • Is there a way using hotkey to call out the IME writing pad?  Thanks
    Tuesday, March 05, 2013 4:29 AM
  • can't post a link!!

    may be you can search the text below in youtube to see the solution for this, it works for me!!

    教您啟用64 bit Windows7手寫板 (How to enable Windows 7 x64 IMEpad for Chinese input) - YouTube

    Saturday, May 18, 2013 4:24 AM
  • I ran regsvr in CMD administrator mode, soon as I did that. The Handwriting (CH) IME comes right up! Thank you!!
    Wednesday, June 26, 2013 11:06 AM
  • Thanks so much for the tips.  It solve my problem for many years.  Wonderful. 
    Saturday, September 07, 2013 6:38 PM
  • Late reply but this works great for me. Once it's registered, go back to the settings to make sure Hand Writing (CH) is selected and it starts to work for me.
    Tuesday, September 10, 2013 6:47 AM
  • TongLu1's procedure hit right on the nail.

    I was struggle on unable to find the Hand Writing (CH) to add  ---- read : unable to find, not exist !,  it's only when you remove everything but those two AND reboot, then you can see it to add.  I did repeat his experiment add the Phonetic back, and hand written disappeared !

    Don't know why Microsoft design this,  people would most likely be able to hand writing either simplified or traditional, not both.  And people that can write traditional characters very likely can pronouncing BPMF  !!

    Wesley

    ==================

    " ......had struggled with the same problem: no "Hand Writing (CH)" on the IME pad.

    I would suggest replacing your "Traditional Chinese Keyboard-Phonetic" with "Chinese (Traditional) - New Phonetic". Reboot might help.

    Tong "



    Friday, August 08, 2014 11:30 PM