none
Disable administrator share

    Question

  • hi . i disable administrator share but when i restart or shutdown my computer again administrator share enable .
    please help me .
    Thursday, July 02, 2009 9:08 AM

Answers

  • For Workstations (Vista/Windows7)

    Click Start—>Run type regedit click ok

    For vista users Enter your UAC credentials to continue.

    Open the HKEY_LOCAL_MACHINE branch.

    Open the SYSTEM branch.

    Open the CurrentControlSet branch.

    Open the Services branch.

    Open the LanmanServer branch.

    Select the Parameters branch.

    Select Edit, New, DWORD (32-bit) Value. Vista & Windows 7 adds a new value to the Parameters key (If you have the key just check for correct value).

    Type AutoShareWks and press Enter. (You can leave this setting with its default value of 0.)

    Restart Windows  to put the new setting into effect.

    I hope this work out for you this time.

    Good Luck.


    Microsoft Certified: MCP, MCSA, MCSA Security, MCSE, MCSE Security.
    Saturday, July 04, 2009 9:54 PM
  • Hi,

    We suggest customers do not disable Administrative Share. There will be several potential issues. Please read the following KB article.

    Overview of problems that may occur when administrative shares are missing


    Arthur Xie - MSFT
    Monday, July 06, 2009 9:08 AM
    Moderator

All replies

  • How did you disable the administrative shares?

    Did you notice these shares are not accessible over the network unless you configure Windows Firewall to allow file sharing?
    Ray
    Thursday, July 02, 2009 11:06 AM
  • yes i know . but i want disable this from my computer . like xp or vista .
    Thursday, July 02, 2009 1:43 PM
  • I understand, but what did you do to disable the Adminsitrative shares?


    Ray
    Thursday, July 02, 2009 2:07 PM
  • Disable the workstation and server services.
    Thursday, July 02, 2009 2:59 PM
  • because if this enable another user can remote my computer with software . and when i don't need this why i disable this ?

    Thursday, July 02, 2009 7:52 PM
  • There are a few workstation applications that need server service running, in particular, some SNA emulation packages.

    i recommend you the following:

    In order to disable these shares permanently, a registry edit will be necessary.

    Servers

    For NT 4.0/W2K/Windows Server 2003s, the change is:

    Hive: HKEY_LOCAL_MACHINE Key: SYSTEM\CurrentControlSet\Services\LanManServer\
    Parameters Name: AutoShareServer
    Data Type: REG_DWORD
    Value: 0

    Note: A reboot is necessary for this to take effect.

    Workstations

    For NT 4.0 Workstation/W2K Pro/XP Pro, the change is:

    Hive: HKEY_LOCAL_MACHINE Key: SYSTEM\CurrentControlSet\Services\LanManServer\
    Parameters Name: AutoShareWks
    Data Type: REG_DWORD
    Value: 0

    Note: Again, a reboot is necessary for this to take effect. If you want the administrative shares to be re-created, you can change the value back to 1.

    Note: Some applications depend on the presence of these shares. If things stop working you'll know to re-enable the shares.

    Security note: Unfortunately this registry hack does NOT stop the IPC$ share and this is a share that is often used by hackers to enumerate systems before attack since it can yield a wealth of information about your system names, your user names, and more. If your ACL permissions are not correct or you haven't disabled anonymous user access or you haven't disabled the guest account then this port can lead to total system compromise within.


    good luck.

    Friday, July 03, 2009 1:04 AM
  • tnx dear . but i work with windows 7 . and this don't work for windows 7.
    Saturday, July 04, 2009 9:16 AM
  • For Workstations (Vista/Windows7)

    Click Start—>Run type regedit click ok

    For vista users Enter your UAC credentials to continue.

    Open the HKEY_LOCAL_MACHINE branch.

    Open the SYSTEM branch.

    Open the CurrentControlSet branch.

    Open the Services branch.

    Open the LanmanServer branch.

    Select the Parameters branch.

    Select Edit, New, DWORD (32-bit) Value. Vista & Windows 7 adds a new value to the Parameters key (If you have the key just check for correct value).

    Type AutoShareWks and press Enter. (You can leave this setting with its default value of 0.)

    Restart Windows  to put the new setting into effect.

    I hope this work out for you this time.

    Good Luck.


    Microsoft Certified: MCP, MCSA, MCSA Security, MCSE, MCSE Security.
    Saturday, July 04, 2009 9:54 PM
  • Hi,

    We suggest customers do not disable Administrative Share. There will be several potential issues. Please read the following KB article.

    Overview of problems that may occur when administrative shares are missing


    Arthur Xie - MSFT
    Monday, July 06, 2009 9:08 AM
    Moderator
  • Tnx . it's work
    Wednesday, July 15, 2009 2:43 PM
  • Sorry, but this does not work for me....

    It works fine on Vista but not Win 7. I still see a bunch of $ shared.

    I have used the AutoShareWks and AutoShareServer on Vista, 2000 in the past many times, works fine, again, it still shows on Win 7.


    Any ideas, let me know...

    Cheers
    Wednesday, July 22, 2009 6:55 PM
  • are you sure ??? i work with 7 . and it's work perfect . my administrator share disabled . please try agein .
    Wednesday, July 22, 2009 7:15 PM
  • This article details

    if
      your shares are missing and you didn't disable them
    then
      you might have a virus

    If you disable them yourself, I think a lot of the listed consequences don't apply, as several would be the result of viruses/trojans, not a result of turning off the shares.
    Also, a lot of the listed consequences are for disabled shares on a domain controller.  These seem more credible, but I wouldn't worry about turning off the shares on your workstation.
    Friday, January 29, 2010 12:33 AM
  • Hi Shady,

    I am a late bloomer, however the resolution works Perfect! Works like a charm! C=

    Julius

    Thursday, July 05, 2012 1:50 PM