none
WIndows 7 RTM Solid Color backgroud causes login to take almost 45 seconds....

    Question

  • Just wondering if anyone came across this.  I was racking my brain over the weekend until I figured it out.  I installed Win 7 RTM on two machines.  After installing all my apps, I had set my desktop background to a solid color (Dark Blue).  After logging off and back on later I noticed that it was taking upwards of 45 seconds to login.  Another account on the system, one I had created but still had the default Win 7 background logged in, in under 3 seconds.  Again this time from hitting enter on the password prompt, until desktop appears.

    Setting a background picture on the profile again restored login time back to under 3 seconds. 

    I also noticed that during the 45 second login time that if I hit CTRL-ALT-DEL and selected "Start Task Manager" I would go immediately to the desktop.

    Strange bug!!!
    Compbl
    Monday, August 10, 2009 10:04 PM

Answers

  • A Hotfix is out:

    KB977346 - The Welcome screen may be displayed for 30 seconds during the logon process after you set a solid color as the desktop background in Windows 7 or in Windows Server 2008 R2

    Go to http://support.microsoft.com/kb/977346 and follow the link under the yellow image to request the hotfix per Mail.

    I hope this helps you.

    André

    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Tuesday, December 15, 2009 9:42 PM

All replies

  • Hi Compbl, i tested on my Win 7 RTM computer and it works fine, not sure if there are startup items cause the slow log in. Please try following methods to have a check.

    How to perform a clean boot procedure to determine whether background programs are interfering with a game or a program that you currently use

    http://support.microsoft.com/kb/331796

    Please disable all startup items and non-Microsoft Services to have a check.

    Thanks,
    Michael
    • Proposed as answer by Robinson Zhang Tuesday, August 18, 2009 2:06 AM
    • Unproposed as answer by Compbl Saturday, October 03, 2009 12:24 PM
    Wednesday, August 12, 2009 3:33 AM
  • I can confirm this behavior on 2 machines. One is a Core-i7 920-based system and the other is an Intel Atom 330 ION-based system. Using a jpg image as the background does not cause the login delay, but if I select a solid color as a background the login will hang with no hard disk activity for ~20 seconds.
    Saturday, August 29, 2009 2:48 AM
  • i can confirm i have the same issues on two computers.  a hp6010b laptop and a shuttle pc.  however it took me bloody hours to work out what was causing such a slow logon! - please sort it out MS!
    Thursday, September 10, 2009 9:19 PM
  • I too can confirm this issue. Setting a solid color background to an aero theme causes logon to hang for 20 -30 seconds. Took me bloody ages to work this out.
    Wednesday, September 30, 2009 11:18 AM
  • Sorry Mike but I did all that.. (e.g. set all startup programs to disabled etc...) 



    I also did this on two different computers.  An MSI Netbook running Win 7 Home Basic RTM and my Quad Core desktop running Win 7 Ultimate RTM x64.  If you just set your background to a solid color, with out changing anything else (e.g leave all other default aero functions) the login process takes almost 1 minute.

    There definately is a problem.

    Compbl
    Saturday, October 03, 2009 12:28 PM
  • FYI, I'm not running Aero in my Windows 7 Virtual Machine and with a solid background it comes up right away.  It must have to do with both Aero being enabled together with the use of a solid background.

    Has Microsoft laid off their entire testing team?  How does something this basically wrong make it into the RTM version?

    -Noel
    Saturday, October 03, 2009 4:51 PM
  • Not only a problem for Win 7!
    I can confirm excact same behaviour for a danish Vista 64 SP2, Aero enabled ,  slow login with Solid Color background but CTRL-ALT-DEL and then just ESC (no need to start task manager) shows desktop immediately. Choosing a Windows Wallpaper gives no delay .

    btw. Using a 1x1 one color bitmap created in Paint and tile it don't seem to create the delay so that could be a temporary solution for a solid color background.
    Thursday, October 22, 2009 4:51 AM
  • I can confirm this behavior in Windows 7 Enterprise 64-bit running on an Intel Core2 Quad Dell Optiplex 760.  Thirty-second delay between typing the credentials and appearance of desktop. Switching to a Windows (graphical) wallpaper removes the delay--time to desktop drops to two seconds.
    Thursday, October 29, 2009 7:52 PM
  • I have the same issue with Windows 7 Professional x64 Retail Upgrade edition (clean install though).

    I was not having this problem with win 7 RC on same computer. I just installed the OS and except for graphics and intel chipset drivers, i did not have anything else installed. Backing out the normal changes(drivers, turn off sync, restore points, hibernate, pagefile,...) eventually led to simple enabling of Solid Color desktop background. It adds a 30 second delay from pressing enter after password to desktop with that glowing circle busy indicator instead of normal like 1-2 seconds.

    Was using default background instead until this thread. So i created a full native resolution solid colored BMP file for my background and its back to 1-2 to desktop from password when computer boots up.
    Friday, October 30, 2009 5:02 AM
  • TooMuch --

    Now you have a computer that starts quickly when the computer screen background is one color (whatever you picked), and starts slowly with any other color.
    Friday, October 30, 2009 5:28 AM
  • I have the same issue on my two Win7 Home Preimium laptops (one AMD, one Intel). Solid color background, ~30secs of Welcome screen. Any image as a background, 2-3secs of Welcome screen.
    Wednesday, November 18, 2009 2:35 PM
  • I have just upgraded to VMware 7 and am now running Aero with Windows 7 Ultimate retail in my test virtual machine.  This was a fresh, clean install with NOTHING else installed.  No apps or tools whatsoever, just a clean install updated with Windows Update to current status with Important Updates as of today.

    With Aero off (Windows 7 Basic theme with Harmony background image), it took 9 seconds to log in to where I could see the main desktop.
    With Aero off and a solid color background, it took 6 seconds to log in.

    With Aero on and the out-of-the-box Windows logo image background, it took 11 seconds to log in.
    With Aero on and a solid color background, it took 34 seconds to log in.

    With Aero on and a .bmp image I created which contains only a solid color selected as the background, it took (not surprisingly) 11 seconds to log in.

    NO OTHER CHANGES in this test but enabling / disabling Aero via theme choice, and the choice of a background image vs. a solid color were made.  All tests were timed with a stopwatch and done several times on an otherwise quiet system, with measurements coming out within a second of one another.

    Clearly if you want to have a solid background and get the best performance out of Windows 7, you need to set your background to an image that's just a solid color.

    Microsoft, there can be no justification for this kind of performance hit.  Please fix it soon in an upcoming update.  Thank you.

    -Noel

    Thursday, November 19, 2009 4:17 AM
  • I can confirm this as well on Windows 7 Ultimate German.

    Solid color background - login about 30 seconds
    JPEG background - login about 3 seconds

    Please Microsoft - fix this!
    Monday, December 14, 2009 8:27 AM
  • A Hotfix is out:

    KB977346 - The Welcome screen may be displayed for 30 seconds during the logon process after you set a solid color as the desktop background in Windows 7 or in Windows Server 2008 R2

    Go to http://support.microsoft.com/kb/977346 and follow the link under the yellow image to request the hotfix per Mail.

    I hope this helps you.

    André

    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Tuesday, December 15, 2009 9:42 PM
  • It's nice to hear they've fixed it but Holy Karp. One has to agree to give away one's first-born male child just so one can download a patch/fix to use a solid background? I don't think we're asking for an industry changing enhancement, just fix their product.

    I hope it comes out as an update soon.
    Tuesday, December 15, 2009 10:06 PM
  • What's so difficult? Just follow the link, type in your mail and the captcha. After 1 min, you have the link and the password in your mailbox.

    This is very easy.

    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Tuesday, December 15, 2009 10:58 PM
  • Hmmm... wonder what I'm doing wrong then. On http://support.microsoft.com/kb/977346 at the top of the page is:

    Hotfix Download Available
    View and request hotfix downloads

    I click on the View and request hotfix downloads link and am taken to a page were I have to agree to an extraordinarily long Terms and Conditions page that I must accept before proceeding.  Others don't see that?
    Thursday, December 17, 2009 1:32 PM
  • We have to assume if we just wait we'll get this fix in a Windows Update sooner or later.

    Hotfixes are by nature more risky because they've had limited testing.

    -Noel
    Thursday, December 17, 2009 6:15 PM
  • Don't know why I didn't figure that one out. Makes sense they'd want to do a Pontius Pilate on HotFixes.
    Thursday, December 17, 2009 7:31 PM
  • Yeah, accept that agreement, you you'll be redirected a new page, where you have to fill in your mail adress and answer a captcha. After 1 min you have the link and the password you need to extract the hotfix. Install the fix and reboot and the issue is gone.

    André

    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Friday, December 18, 2009 12:41 PM
  • FYI, I'm not running Aero in my Windows 7 Virtual Machine and with a solid background it comes up right away.  It must have to do with both Aero being enabled together with the use of a solid background.

    Has Microsoft laid off their entire testing team?  How does something this basically wrong make it into the RTM version?

    -Noel

    LOL!!! Its still beta d a m i t lol. As of december 25 I have some 140 updates installed sence windows 7 was given to the gen pub in oct 22. Thats crazzy lololl
    Funny most the updates have nothing to do with what people are saying they have problems with in using windows 7. Just really odd..
    Friday, December 25, 2009 2:47 PM
  • I missed that link but saw it after reading this post.  Might have found it myself but was busy scrolling the page assuming near the bottom looking for the fix...

    Have noticed this issue for a while but have been too lazy to debug it.  I don't restart all that often.  Still, appreciate that someone else figured this out and even better that there is a patch for it.  I've applied it and it seems to be working well, but add me to the list of those wondering why it hasn't been included in the ton of other updates to date.  Ah well.

    Friday, January 22, 2010 1:54 PM
  • I can also confirm this in win 7 x64. I timed it with a pic, it took just under 35 secs. Changed it to a solid color, it took just under a minute.


    Sunday, January 24, 2010 11:18 PM
  • Hmm think, I'll leave a pic on the background. The hotfix only made it 13s faster (47s instead of 59s-1 min). Whereas a pic only takes 35s.
    Monday, January 25, 2010 12:50 AM
  • I went back to a solid background (even tho the patch didnt do a lot). Then disabled aeropeek. That took it back to 34-35 secs.
    Monday, January 25, 2010 9:58 PM
  • I don't know if this has been brought up as a possible solution, as I haven't read all the posts related to this, but why not do as I did, and just create a properly sized all-black (or whatever color you want) JPG graphic, and use that as the background image?  Looks the same, and one-color JPG images are pretty small, so not too memory-intensive.  Works for me.
    • Proposed as answer by p__v__s Monday, February 01, 2010 2:58 PM
    • Edited by p__v__s Thursday, February 04, 2010 6:14 PM
    Monday, January 25, 2010 10:24 PM
  • After spending at least 5 or 6 hours reinstalling windows, messing with profile settings, troubleshooting hardware, and scouring event logs I finally figured out it was the solid color background causing the SLOOOW logon times and stumbled across this page. PLEASE microsoft push this update out to every windows 7 machine via windows update, your customers hair will thank you!!!
    Wednesday, February 03, 2010 3:42 AM
  • See Update KB980408 which fixes this problem.
    Tuesday, May 11, 2010 9:24 PM
  • i have found the solution its funny but it works on all pc and try it it will work dnt woory the big solution isssssssss change the default volour to black.tada enjoy
    Tuesday, August 28, 2012 7:58 PM