none
Sony Ericsson Software Update Suite

    Question

  • It appears that the Sony Ericsson Software Update Suite is not working on Windows 7.

    It installs fine (which I believe they've released a new version, as I was unable to successfully install this on Vista), and once you launch it for the first time, it appears to update fine. It will not launch the actual application, however. It will open a blank white window that just appears to freeze. The only option available is Help, and About under that, and even trying that took over 30 seconds for the About window to come up.

    I left this open and left for my break (15 minutes) and still no change when I returned.

    Compatibility modes seem to have no effect, nor does running as administrator.
    Saturday, February 07, 2009 7:54 PM

All replies

  • Hello,

     

    If the problem still persists, please understand that Windows 7 is a new operating system (only the beta version) and not all the previous software is not compatible with new OS. I suggest that you should wait for another period of time till the retail version is released and push the sony manufacturer to upgrade their device driver. Thanks for your time and understanding!

     

    Good Luck!

    • Marked as answer by Andy Song Thursday, February 12, 2009 4:25 AM
    • Unmarked as answer by Captain Canaduh Thursday, February 12, 2009 12:56 PM
    • Marked as answer by Andy Song Friday, March 06, 2009 7:49 AM
    • Unmarked as answer by Captain Canaduh Thursday, July 30, 2009 4:40 PM
    Monday, February 09, 2009 10:00 AM
  • Woah! Hold up! I thought this was the Beta, the place we work out all the bugs etc. Are you telling me to wait until Windows 7 is released before trying to find a fix for this software?

    If so, I think I've lost all hope in Microsoft.
    Monday, February 09, 2009 5:02 PM
  • Don't ignore my reply and mark yours as an answer, please.
    Thursday, February 12, 2009 12:57 PM
  • I try installing the Sony Ericsson Software, even in Compatibility mode with no success. i suppose that you should contact Sony Ericsson vendor for the solution to your problem. Thanks!
    Friday, February 13, 2009 7:36 AM
  • Heh I guess I misunderstood the purpose of these beta forums. I'll stop posting then.
    Thursday, February 19, 2009 9:36 PM