none
The following boot-start or system-start driver(s) failed to load: i8042prt

    Question



  • Hi all,

    I have a problem with Vista Business.Naimly, every time I start the computer and look up into the computer menadgement/event viewer/administrative events it has an error msg:

    The following boot-start or system-start driver(s) failed to load: i8042prt

    - System
    - Provider
    [ Name] Service Control Manager
    [ Guid] {555908D1-A6D7-4695-8E1E-26931D2012F4}
    [ EventSourceName] Service Control Manager
    - EventID 7026
    [ Qualifiers] 49152
    Version 0
    Level 2
    Task 0
    Opcode 0
    Keywords 0x80000000000000
    - TimeCreated
    [ SystemTime] 2007-08-27T15:56:02.000Z
    EventRecordID 26753
    Correlation
    - Execution
    [ ProcessID] 0
    [ ThreadID] 0
    - EventData
    param1 i8042prt
    I think this is regarding my video card (Gygabyte Nvidia 8600GTS) drivers?!But the card works pretty normally and the drivers are up to date.
    Anyway there are also a lot of other error & warninig msgs regarding the volsnap and security update installation files.Maybe this due to the situation that I have installed both Vista and XP and there is a common problem with Vista working with XP/other and that is NO RESTORE POINTS after the rebooting the PC into the XP/other OP sys.
    So, is anybody familiar with this and what is to be done?
     
    Thanks,
     
    Regads

     

    Monday, September 03, 2007 12:06 PM

All replies

  • Problem Solution The following boot-start or system-start driver(s) failed to load: i8042prt

    1.Go to Start > Run and put regedit.exe  and click  Ok
    2.Navigator to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\i8042prt\Parameters in Registry Editor
    3.Add a new REG_DWORD "Headless " and set the value to 1
    4.Reboot the server.

    Regards,
    • Proposed as answer by Fred B Wednesday, March 14, 2012 1:43 PM
    Monday, January 04, 2010 10:11 PM
  • I too had this exact error on a Vista x64 system. This cleared up the problem immediately. Thanks Ramis!!

    Wednesday, January 27, 2010 2:33 PM
  • Same problem with an old HP ML310 G3 server.  It was causing me no end of problems with my KVM switch - now I know why.  Many thanks Ramis.

    Friday, May 28, 2010 1:08 AM
  • Hi 

    Thanks ...... really it works. 

    Tuesday, June 22, 2010 7:40 AM
  • Hi Ramis and a big thanks for the solution, however, i have a question ...

    I have (2) up to date WS'03 domain controllers that are of the same hardware generation (but not identical).  Neither machine had this problem until i had to restore DC0 from backup (due to a disc failure).  After wrestling the restore to a "back into operation with (almost) no boot errors" condition, this (only) error did persist; i.e. SCM 7026 for the subject service.  I suspect your solution will work and i'm going to try it, however, the other DC (DC1) doesn't have such an entry and i'm wondering if u could explain the impact/implication of "headless"?

    Thanks and Best Regards!

    GlennXS


    Glenn of xSyLent
    Wednesday, June 30, 2010 9:36 PM
  •  the impact/implication of "headless"?

    I think "headless" here is referring to the fact that you are running the server without a monitor and/or keyboard and/or input device like a mouse, which is exactly what I did with my server and would explain why I started getting this error in the Event Log, so the registry entry probably prevents the OS from trying to load input drivers or something  like that so that you don't receive an error every time you boot.
    Tuesday, July 06, 2010 2:48 AM
  • Would this fix effect a normal XP workstation in a negitive way? Because I recieved the same error message.
    Wednesday, August 11, 2010 6:22 PM
  • Is it safe to say that this fix needs to be performed on the DNS server, Or on the PC giving off the error?

    Tuesday, January 04, 2011 5:20 PM
  • Just to be clear, I have a Win7 laptop on which i am getting this error when i boot up. Can i run this fix on the pc because it seems most are commenting about this fix on server issues... 
    Tuesday, January 11, 2011 6:38 PM
  • Thank you!!! I have been searching for a solution to this problem for a couple of weeks.  Tried numerous fixes only to get the blank screen.  This one worked!!!  Props to you!!!
    Friday, July 01, 2011 12:39 AM
  • Just wanted to say Thank You!!!

     

    I know your post was from 2007 so you may never see this, but this immediately cleared up an issue that was driving me nuts!

     

    Thanks again!

     

    - Scott

    Tuesday, January 03, 2012 2:05 AM
  • hi.. thanks.. it worked..
    Thursday, February 09, 2012 6:14 AM
  • This worked on a system with Windows 2003 R2 Enterprise x86.

    Thanks Ramis!!

    Wednesday, September 12, 2012 3:51 PM
  • Thanks Ramis! This worked for me on an XP machine.

    Jeff Speirs

    Wednesday, November 21, 2012 4:49 PM