none
Windows 7 - Can't delete files on a external harddrive-Says I need permission when I have administrative rights???

    Question

  • I am using Windows 7 Professional. I have two external hard drives attached to my home PC.  When I attempted to delete a folder or files on the external hard drive I get a pop up box that says that I need permission to perform this action or to make changes to this folder.  I have administrative rights on this computer as I am the only user.  Anyone know how to fix this?  Thanks.
    Saturday, December 12, 2009 11:44 PM

Answers

  • Hi cwale,

     

    You can try take ownership of the files before deleting them. To do so, please refer to this article: Take Ownership of a File or Folder.

     

    In addition, please change the permission of the folder by the steps below:

     

    1.     Open Windows Explorer, and then locate the file or folder you want to take ownership of.

    2.     Right-click the file or folder, click Properties, and then click the Security tab.

    3.     Click Edit button.

    4.     Please check if Administrators and your user account have the full control to the folder. If not, please highlight the user in the list and check "Full control" under Allow section.

    5.     Click Apply and then click OK.

     

    Hope this can resolve the issue.

     

    Regards,

    Linda

     

     

    • Marked as answer by Linda Yan Monday, December 21, 2009 2:13 AM
    Wednesday, December 16, 2009 6:02 AM

All replies

  • I take it you haven't used Vista or Windows 7 before? I think the pop up box is the UAC (User Account Control)
    Disclaimer - Note: Disabling UAC will lead to a less secure system, so be warned.

    Disable UAC on Windows 7

    Windows 7 makes it much easier to deal with UAC settings, and in fact you don’t have to completely disable UAC if you don’t want to. Just type UAC into the start menu or Control Panel search box.

    You can simply drag the slider up or down, depending on how often you want to be alerted.
    Windows 7 UAC Settings
    If you drag it all the way down to the bottom, you’ll have disabled it entirely.

    If that's not the case, then its just a simple matter of taking ownership of the files/folders.

    MCSE, MCSA, MCDST
    Sunday, December 13, 2009 12:50 AM
  • Hi cwale,

     

    You can try take ownership of the files before deleting them. To do so, please refer to this article: Take Ownership of a File or Folder.

     

    In addition, please change the permission of the folder by the steps below:

     

    1.     Open Windows Explorer, and then locate the file or folder you want to take ownership of.

    2.     Right-click the file or folder, click Properties, and then click the Security tab.

    3.     Click Edit button.

    4.     Please check if Administrators and your user account have the full control to the folder. If not, please highlight the user in the list and check "Full control" under Allow section.

    5.     Click Apply and then click OK.

     

    Hope this can resolve the issue.

     

    Regards,

    Linda

     

     

    • Marked as answer by Linda Yan Monday, December 21, 2009 2:13 AM
    Wednesday, December 16, 2009 6:02 AM
  • did the solutions mentioned above solve your problem?
    Thursday, December 17, 2009 3:33 PM
  • I have exactly the same problem except I need to use the files. It does work to take ownership of the files BUT taking ownership of a folder does not give ownership of the files in the folder, so it will take more than a few workdays to be able to get access to all my documents.

    I hope you have a solution.

     

    Sunday, December 19, 2010 3:18 PM
  • i tried the said solution but i got an error saying access denied

    this is my screenshot hope you can help me

    http://i53.tinypic.com/30x78f9.jpg

    Monday, March 21, 2011 10:12 AM
  • Hey all,

    I had very similar issues with Windows 7 Home Premium. I found doing it through the GUI very frustrating. What I did:

    - Right click on Command Prompt in the Start Bar and Selected "Run as Administrator" (this way you don't have to disable UAC system wide from what I understand.... )

    - I then used the command line tool "takeown" to take ownership of all the files on the external disk. My external drive was coming up as I: so I ran:       

     

    takeown I:/* /R

     

    - This took a long time and there were a few prompts during it (basically saying you don't have permission, do you want to modify permissions and then take ownership, to which I said yes),  but it fixed it for me.

     

    Hope this helps someone.

    Cheers,

    JSG


    • Edited by JustaSumGai Sunday, January 08, 2012 12:24 PM
    Sunday, January 08, 2012 12:23 PM
  • Boom goes the dynamite!

    http://www.howtogeek.com/howto/windows-vista/add-take-ownership-to-explorer-right-click-menu-in-vista/

    Tuesday, April 02, 2013 1:48 PM