none
How to change a single adapter's network location to 'private'?

    Question

  • Hello, I have three network adapters in a computer - two LANs and one WiFi adapter.

    LAN1 is domain network (and correctly applies domain firewall profile).
    LAN2 is virtualbox virtual adapter, it is always "public". There weren't (and aren't) any options to change it.
    LAN2 and WiFi are merged in 'Unidentified Networks' public location.


    How do I move LAN2 to "private" location instead?

    My desired configuration -
    LAN1 stays 'domain'
    LAN2 becomes 'private'
    WiFi adapter stays 'public'

    That way I can config adv.firewall by using profiles (that's how it should be used, isn't it?). As of now, I HAVE to use one profile for all locations (public profile), limit all rules by IP scopes and disable all other profiles to avoid confusion. That is kinda time-consuming and ineffective.

    System is Windows 7 Professionsl 64bit

    Thursday, January 20, 2011 11:16 AM

Answers

  • Andy_Scull_2 wrote:

    Hello, I have three network adapters in a computer - two LANs and one
    WiFi adapter.

    LAN1 is domain network (and correctly applies domain firewall
    profile).  LAN2 is virtualbox virtual adapter, it is always "public".

    If this is a virtual adapter (probably only connected to your virtual
    machines) you could redefine the vitual NIC as endpoint - that's my
    preferred solution for virtual adapters.
    See this VMware KB article
    http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd
    =displayKC&externalId=1004813 for further details. Although this
    article is written for Vmware, most of this article applies to all
    types of similar virtual adapters

    There weren't (and aren't) any options to change it.  LAN2 and WiFi
    are merged in 'Unidentified Networks' public location.

    This should not be the case but can be caused by the Apple
    Bonjour-service, which is often installed alongside other software like
    e.g. Adobe C3S, iTunes, several Network software etc. If that's the
    culprit you probably find an entry with strange numbers and signs at
    the top of the services list or an entry named 'Service "Bonjour"'. You
    can disable this service or upgrade to the latest for your Windows
    version, both approaches should help.


    How do I move LAN2 to "private" location instead?

    My desired configuration - LAN1 stays 'domain'
    LAN2 becomes 'private'
    WiFi adapter stays 'public'

    That way I can config adv.firewall by using profiles (that's how it
    should be used, isn't it?). As of now, I HAVE to use one profile for
    all locations (public profile), limit all rules by IP scopes and
    disable all other profiles to avoid confusion. That is kinda
    time-consuming and ineffective.

    System is Windows 7 Professionsl 64bit

    HTH


    Wolfgang
    Friday, January 21, 2011 3:12 PM