none
'ipconfig' is not recognized as an internal or external command, . . .

    Question

  • I am getting the following message when I attempted to execute ipconfig:

    'ipconfig' is not recognized as an internal or external command, operable program or batch file.

    I tried it on another W7 machine but the same message returned.

    Tuesday, December 28, 2010 4:01 PM

Answers

  • For Windows 7...

    Control Panel, click on System, click on Advanced System Settings link, click on Advanced Tab, Environmental Variables button, In the System variables windows, scroll for Path, then edit your settings.

     


    Visit: anITKB.com, an IT Knowledge Base.
    • Marked as answer by churin Wednesday, December 29, 2010 2:40 PM
    Wednesday, December 29, 2010 3:10 AM

All replies

  • It works fine on my computers.  Do you have a Group Policy restricting access to ipconfig?
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Tuesday, December 28, 2010 4:29 PM
  • No, because I do not know how to do that. Could a required service not running, though I do not know what it is?
    Tuesday, December 28, 2010 9:21 PM
  • IPCONFIG is a tool in the TCP/IP suite.  The only instance that I can think of where ipconfig would not be recognized would be on a computer that does not have TCP/IP installed.

    Also, I am wondering if your "Path" variable was changed.  If you open a command prompt and type "path" (no quotes), the output should include, at a minimum, this path... "PATH=C:\WINDOWS\system32;C:\WINDOWS;"


    Visit: anITKB.com, an IT Knowledge Base.
    Tuesday, December 28, 2010 9:39 PM
  • There is no problem for networking so TCP/IP suite must be installed.

    PATH is recognized, though what are returned is not the same as posted by JM.

    It appears any networking related command is not working.

    Tuesday, December 28, 2010 10:39 PM
  • This has occurred because of a mis-configured path environmental variable. Check your computer for spyware/viruses.

     

    Tuesday, December 28, 2010 11:54 PM
  • churin,

    I have already validated (after I posted my response) that "C:\WINDOWS\system32" must be included in the path variable for the TCP/IP command utilities to be recognized.

    You can validate this yourself by typing in the full path to the location of the IPCONFIG executable by opening a command prompt and typing:

    c:\windows\system32\ipconfig [hit enter]

    You should check to see what is being configured for the path by opening the control panel, System applet, Advanced tab, Environmental Variables button (for XP systems, other OSs will vary)

     


    Visit: anITKB.com, an IT Knowledge Base.
    Wednesday, December 29, 2010 2:04 AM
  • churin,

    I have already validated (after I posted my response) that "C:\WINDOWS\system32" must be included in the path variable for the TCP/IP command utilities to be recognized.

    You can validate this yourself by typing in the full path to the location of the IPCONFIG executable by opening a command prompt and typing:

    c:\windows\system32\ipconfig [hit enter]

    You should check to see what is being configured for the path by opening the control panel, System applet, Advanced tab, Environmental Variables button (for XP systems, other OSs will vary)

     


    Visit: anITKB.com , an IT Knowledge Base.


    "C:\windows\system32" is not included in those returned for PATH command.

    If I type in the full path or c:\windows\system32\ipconfig, then it works fine.

    How can I check the configuration on W7? Or, how can I correct the configuration so that "C:\windows\system32" is included in it?

    Wednesday, December 29, 2010 2:57 AM
  • hello,

     

    it's in your system properties->advanced->environment variables when you right click computer and select properties.

     

    miguel


    Miguel Fra / Falcon IT Services
    Computer & Network Support, Miami, FL
    Visit our Knowledgebase and Support Sharepoint Site

    Wednesday, December 29, 2010 3:06 AM
  • For Windows 7...

    Control Panel, click on System, click on Advanced System Settings link, click on Advanced Tab, Environmental Variables button, In the System variables windows, scroll for Path, then edit your settings.

     


    Visit: anITKB.com, an IT Knowledge Base.
    • Marked as answer by churin Wednesday, December 29, 2010 2:40 PM
    Wednesday, December 29, 2010 3:10 AM
  • Thank you very much for your help. The problem has been resolved.
    Wednesday, December 29, 2010 2:41 PM
  • Hi,

    I am getting the same error message when I type ipconfig or ping in my command.

    I checked to see that the ipconfig.exe does exist in C:\Windows\System32. Also, both C:\Windows\System32 and C:\Windows appear when I type path in the command.

    Any ideas on what else I could try?

    Thank you very much

    Wednesday, May 02, 2012 4:56 AM
  • Did you try this:

    Click on start, run, then type "c:\windows\system32\ipconfig" [hit enter].  if that works, then as I mentioned above, its a path problem.  If that doesnt work, then TCP/IP is not installed and running properly.


    Guides and tutorials, visit ITGeared.com.

    itgeared.com facebook twitter youtube

    Saturday, June 09, 2012 5:29 PM
  • thank you this works im use to it just being /ipconfig and not the extended c:\windows\system32\ipconfig.

    for help i shall post a video later. sometime.
    Thursday, January 23, 2014 3:46 AM
  • 100% working solution

    change to the directory

    C:\Windows\System32>

    then type "ipconfig" or "ping" both will work.

    Saturday, July 26, 2014 7:36 AM