none
"No internet access" in wireless connection in Windows 7 - caused by default gateway geting reset?

    Question

  • I have run into this problem, while vacationing in India, on my Windows 7 laptop. Here is what I observed:

    1. I try to connect to Foo, a specfic Wireless network. I get connected right away, with an excellent signal.

    2. However, I am unable to browse to the Internet. I notice the text  The network panel shows that I am "Currently connected to Foo", but also displays the text "No Internet access" under it.

    3. I try disabling/enabling the wireless connection, uninstalling/installing the Wireless network adapter driver, rebotting the laptop, etc but none of thiose fix the problem.

    4. Occassionally, the problem resolves itself magically, but returns as soon as I restart either my laptop, or the router/modem.

    Here is a solution that a local network engineer came up with. This proved to work 100% of the time, at least for me.

    1. Go to Control Panel\Network and Internet\Network and Sharing Center.

    2. Click on "Wireless Connection Foo" to bring up the Wireless Network Connection Status dialog.

    3. Click on the "Properties" button, to bring up the "Wireless Network Connection Properties" dialog.

    4. From the item list in the dialog, click to highlight the item "Internet Protocol Version 4(TCP/IPv4)".

    5. Click the "Properties" button to bring up the "Internet Protocol Version 4(TCP/IPv4) Properties" dialog.

    6. Make sure that following two radio buttons are checked: i) "Use the following IP address", and ii) "Use the following DNS server addresses".

    7. Fill the values for "IP address", "Default gateway", "Preferred DNS server address" and "Alternate DNS server address". These values can be obtained by contacting your local Internet Service P8.rovider. The "Subnet mask" can usually be left set to its default value of 255.255.255.0. 

    8. Ok/Close all the dialogs.

    9. Disconnect from Foo and re-connect to it. The problem should be resolved now.

    Unfortunately, the problem is likely to resurface as soon as you restart the machine or the router. Fortunately, this is easy enough to fix.

    10. Re-execute steps 1 to 5 above to again bring up the "Internet Protocol Version 4(TCP/IPv4) Properties" dialog.

    11. Notice that the all the addresses that you typed in Step 7 above are still intact, excepot for the Default gateway! Simply, re-enter its value.

    12. Ok/close all the dialogs. The connection should be good now!

    Hopefully, this information is useful to other folks. Also, I would love to understand the root cause, especially why the Default gateway address keeps getting cleared upon a restart.

     

    Thanks

    Mohan B

     

     

    3.

     

    Monday, December 13, 2010 3:04 AM

Answers

  • Hi,

    According to your description, I suspect your issue is caused by your corrupt TCP/IP protocol. Please refer the following steps to reinstall the protocol.

    Reinstall and Reset TCP/IP (Internet Protocol)
    1. Click on Start button.
    2. Type Cmd in the Start Search text box.
    3. Press Ctrl-Shift-Enter keyboard shortcut to run Command Prompt as Administrator. Allow elevation request.
    4. Type netsh int ip reset in the Command Prompt shell, and then press the Enter key.
    5. Restart the computer.

    For details information, please refer to the following link:

    http://support.microsoft.com/kb/299357

    Then If the issue persists, I need you to clarify your issue, please advise me whether your subnet have a DHCP server? If so, I suspect this issue may be caused by the DHCP server setting.

    Wednesday, December 15, 2010 9:22 AM
    Moderator

All replies