none
Windows 7 RTM, red X on network connection icon

    Question

  • I installed the RTM version from MSDN two days ago and the network connection icon has had a red x on it.  The kicker is all my network connections work fine.  Is it a bug or how do I check?

    Thanks!
    Shawn
    Saturday, August 08, 2009 2:29 AM

Answers

  • I have a similar issue.  Once your computer is booted up and everything is loaded and settled, try going into device manager, right-clicking your NIC driver, choose 'Disable'...wait 20 seconds and then right-click and choose 'Enable'...X might go away 10-20 seconds after that.
    • Marked as answer by Vivian Xing Friday, September 04, 2009 7:52 AM
    Saturday, August 08, 2009 11:20 PM

All replies

  • Hello Shawn D

    No techie here.  My experience has been that a red X means no connection.  First go to Control Panel>System>Device Manager
    >Network Adapter.  Check to see that there is no " ! " sign there.  If so you probably need to install or update the driver.  If not.
    X out of Device Manager bringing you back to System.  On the right hand side of the window >Change Settings>Change.  Check Workgroup and enter the name of your network.  You then should get a window pop up and say Welcome To (What ever you network name may be). If this all happens you should be ready to go
    Saturday, August 08, 2009 4:41 AM
  • I have tried that and no change.  I made sure I had the latest driver from Intel as well.  Just weird because everything works just fine.  Any other ideas?
    Shawn
    Saturday, August 08, 2009 4:51 PM
  • The only other thing for me to think of is to turn off the computer.  Unplug the network cable.  Turn the computer back on and plug your cable back in.  This will allow your router to give you an IP address.   Other than that you may have to give more specifics.  Someone else will surely help you.  That is all I know without making all of the changes myself.
    Saturday, August 08, 2009 5:12 PM
  • I have a similar issue.  Once your computer is booted up and everything is loaded and settled, try going into device manager, right-clicking your NIC driver, choose 'Disable'...wait 20 seconds and then right-click and choose 'Enable'...X might go away 10-20 seconds after that.
    • Marked as answer by Vivian Xing Friday, September 04, 2009 7:52 AM
    Saturday, August 08, 2009 11:20 PM
  • I have a similar issue.  Once your computer is booted up and everything is loaded and settled, try going into device manager, right-clicking your NIC driver, choose 'Disable'...wait 20 seconds and then right-click and choose 'Enable'...X might go away 10-20 seconds after that.


    To Vivian Xing: This reply has been marked as answer. But why is this happening? Which is the origin of the issue? Drivers?

    Regards.
    If it was helpful, please vote! · · ¡Si te ayudó, por favor vota!
    W7 RTM x64 running along with Office 2010 x64 TP
    Monday, September 21, 2009 11:36 AM
  • Hi All !!
    I am Experiencing the Same issue with Windows 7 ultimate edition downloaded as a RTM Copy from the MS Website earlier this month. Everything works just great I am also connected to the internet as well but the problem is that in order to get that "RED X" out You have to enable the network service which for some unknown reason has disabled itself automatically while I was tryingto reinstall the sound card driver, I was not able to make it work again as when I try to enable it I get the error message" Network Service Failed to start" and due to this reason I am unable to see the NIC properties in the Netowrk and resource center. I have tried starting the service times took the NIC out and replug it, Uninstall and reinstall the NIC driver. Recreate the Hoemgroup have tried reinstalling the following registry files as well to no avail:
    regsvr32 netshell.dll
    regsvr32 netcfgx.dll
    regsvr32 netman.dll

    Any clues ??? Or The Only option is to Reinstall OS as usual.

     

     

     

    Wednesday, October 21, 2009 3:45 AM
  • I have had the same issue for months exactly as yours. Tried everthing sept new install. It causes no problem sept cant see network enviroment. It will magically start working some day, Im tired and will wait for it to go away.
    Sunday, June 13, 2010 12:31 AM
  • Just had the red "X" again.  This time Mine was different than all of the above.  It was caused by an anti- spyware program blocking  internet connection of a program that contained a trojan.  So the red "X" in this case was a good thing.

     

    JB

    • Edited by jjjjbbbb Tuesday, July 27, 2010 6:58 PM spelling
    Tuesday, July 27, 2010 6:55 PM
  • I found a solution that worked for me:

    -At the bottom right of your computer, click on your wireless network icon, which brings up the list of networks your system sees.
    -Right click on your "red X" network icon, drag down to properties & click on it.
    -Select "Connection" tab at the top
    *****uncheck the "Connect automatically when the network is in range" box.*************
    -Click "OK."
    -Go back down to your wireless network icon & click it to get a list of the networks & click on your network....it should now work!!
    -Right click on it, go to properties, click the connect tab & ****now, re-select the "connect automatically box," the click ok.
    It appears that the "connect automatically" retains settings, so if they are now incorrect, no matter home many times you reconfigure, it would automatically use the old settings. I hope this is helpful. Merry Christmas!!

    Saturday, December 18, 2010 1:19 AM