none
Windows 7: "you do not have permission to access..."

    Question

  • Home network of Windows 7 (hard-wired to wireless Actiontec DSL modem) and Windows XP (Actiontec USB adapter).  Both computers assigned to Workgroup.  I have given up trying to use Win 7 networking features so using mapped drives.  Win XP can see and access the Win 7 files.  On Win 7, the XP machine is listed by name and icon under the Network tab but I can not access it.  I get the error message "you do not have permission to access \\NAME."  But if on the Win 7 computer I do Run command \\XPNAME\C drive, I can get to the files on C.  But even then, if I click on the computer name (as listed under Network), I still get the 'No permission' error.  I have, on both machines, the same User name and passwords and checked all the files I want as Shared.  Why can I not access the WinXP machine the "normal" way by clicking on the name/icon?   BTW, I tried mapping the XP on the Win 7 using Map Network Drive, but this causes a different error message, "device name already in use."  Any suggestions?
    Thanks 
    Tuesday, December 22, 2009 4:52 PM

Answers

  • To answer your questions:  Yes, same username/password on both computers.  WinXP Home sp3.  All firewalls (windows, TrendMicro, and the modem) were set to OFF.  Guest account enabled on WinXP but I use my Username account when logging on.  BUT I think I have solved the issue.  On the WinXP machine: Regedit HKEY_LOCAL_Machine/System/CurrentControlSet/Conrol/Lsa. Change value for "restrictanonymous" from 1 to 0.
    • Marked as answer by rokbottom47 Wednesday, December 23, 2009 11:02 PM
    Wednesday, December 23, 2009 5:15 PM

All replies

  • Did you create the same username\password on both computers? What is the version of the Windows XP system? If it is Windows XP Professional, is enable Simple File Sharing enabled? Is the Guest account enabled.

    I suggest you temporary disable the firewall in Windows XP and let us know the result.


    Arthur Xie - MSFT
    Wednesday, December 23, 2009 7:39 AM
  • To answer your questions:  Yes, same username/password on both computers.  WinXP Home sp3.  All firewalls (windows, TrendMicro, and the modem) were set to OFF.  Guest account enabled on WinXP but I use my Username account when logging on.  BUT I think I have solved the issue.  On the WinXP machine: Regedit HKEY_LOCAL_Machine/System/CurrentControlSet/Conrol/Lsa. Change value for "restrictanonymous" from 1 to 0.
    • Marked as answer by rokbottom47 Wednesday, December 23, 2009 11:02 PM
    Wednesday, December 23, 2009 5:15 PM
  • I get this same error when mapping a network drive from windows 7 to a directory/folder on another windows 7 machine in a peer to peer network. In this case the win7 computer doing the mapping (A) does have a different logon name than that of the win7 computer which physically has the directory/folder(B). Under advanced sharing I have turned password protected sharing OFF on both computers. Both machines are Win7 PRO 64bit. I would rather not have to create a userid on the B machine for each logon on each computer (about 20 computers) in the network.

    The client/server software I use (Church Windows v15) requires that the workstation execute from a mapped network drive.

    How can I fix this?

    Saturday, July 13, 2013 3:52 PM