none
Windows 7 SP1 x64 Install Error 0x80070490

    Question

  • Here is my CBS log

     

    2011-03-18 14:12:18, Info                  CBS    SPI: Created path: C:\b94f01b481a83938b73a\c63332f5950a3a47da705509375372\eula\zh-tw\server_license_addendum_1.rtf
    2011-03-18 14:12:18, Info                  CBS    SPI: Root directory being used: C:\b94f01b481a83938b73a\c63332f5950a3a47da705509375372\
    2011-03-18 14:12:18, Info                  CBS    SPI: Self trust verification failed for C:\b94f01b481a83938b73a\c63332f5950a3a47da705509375372\spc.xml.  0x57
    2011-03-18 14:12:18, Info                  CBS    SPI: Succeeded verifying trust on C:\b94f01b481a83938b73a\c63332f5950a3a47da705509375372\spc.cat
    2011-03-18 14:12:18, Info                  CBS    SPI: Succeeded verifying trust on C:\b94f01b481a83938b73a\c63332f5950a3a47da705509375372\spc.xml
    2011-03-18 14:12:18, Info                  CBS    SPI: Self trust verification failed for C:\b94f01b481a83938b73a\c63332f5950a3a47da705509375372\SPWizUI.dll.  0x57
    2011-03-18 14:12:18, Info                  CBS    SPI: Succeeded verifying trust on C:\b94f01b481a83938b73a\c63332f5950a3a47da705509375372\spc.cat
    2011-03-18 14:12:18, Info                  CBS    SPI: Succeeded verifying trust on C:\b94f01b481a83938b73a\c63332f5950a3a47da705509375372\SPWizUI.dll
    2011-03-18 14:12:18, Info                  CBS    SPI: Self trust verification failed for C:\b94f01b481a83938b73a\c63332f5950a3a47da705509375372\SpError.dll.  0x57
    2011-03-18 14:12:18, Info                  CBS    SPI: Succeeded verifying trust on C:\b94f01b481a83938b73a\c63332f5950a3a47da705509375372\spc.cat
    2011-03-18 14:12:18, Info                  CBS    SPI: Succeeded verifying trust on C:\b94f01b481a83938b73a\c63332f5950a3a47da705509375372\SpError.dll
    2011-03-18 14:12:18, Info                  CBS    SPI: Self trust verification failed for C:\windows\System32\SpError.dll.  0x57
    2011-03-18 14:12:18, Info                  CBS    SPI: SPC CAT verification failed for C:\windows\System32\SpError.dll.  0x800b0100
    2011-03-18 14:12:19, Info                  CBS    SPI: Succeeded verifying trust on C:\windows\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\nt5.cat
    2011-03-18 14:12:19, Info                  CBS    SPI: Succeeded verifying trust on C:\windows\System32\SpError.dll
    2011-03-18 14:12:19, Info                  CBS    SPI: Loading SPError.dll contained at C:\b94f01b481a83938b73a\c63332f5950a3a47da705509375372\SpError.dll
    2011-03-18 14:12:19, Info                  CBS    SPI: Self trust verification failed for C:\windows\System32\spinstall.exe.  0x57
    2011-03-18 14:12:19, Info                  CBS    SPI: SPC CAT verification failed for C:\windows\System32\spinstall.exe.  0x800b0100
    2011-03-18 14:12:19, Info                  CBS    SPI: Succeeded verifying trust on C:\windows\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\ntexe.cat
    2011-03-18 14:12:19, Info                  CBS    SPI: Succeeded verifying trust on C:\windows\System32\spinstall.exe
    2011-03-18 14:12:19, Info                  CBS    SPI: Self trust verification failed for C:\windows\System32\SPC_SP1_Wave1.xml.  0x57
    2011-03-18 14:12:19, Error                 CBS    SPI: (SPCVerifyTrust:1664)Failed to CryptCATAdminCalcHashFromFileHandle GLE=0x57
    2011-03-18 14:12:19, Info                  CBS    SPI: Installed SPInstall or XML not trusted.  Continuing with current version.
    2011-03-18 14:12:19, Info                  CBS    SPI: Self trust verification failed for C:\windows\System32\EventProviders\spcmsg.dll.  0x57
    2011-03-18 14:12:19, Info                  CBS    SPI: Succeeded verifying trust on C:\b94f01b481a83938b73a\c63332f5950a3a47da705509375372\spc.cat
    2011-03-18 14:12:19, Info                  CBS    SPI: Succeeded verifying trust on C:\windows\System32\EventProviders\spcmsg.dll
    2011-03-18 14:12:19, Info                  CBS    SPI: No need to update spcmsg.dll event provider
    2011-03-18 14:12:19, Info                  CBS    SPI: Reporting Started event
    2011-03-18 14:12:19, Info                  CBS    SPI: SQM is not opted in
    2011-03-18 14:12:19, Error                 CBS    SPI: (SPIRegQueryDWORDValue:413)Failed to query registry value: UploadDisableFlag er=0x2
    2011-03-18 14:12:19, Info                  CBS    SPI: Running in SPCLite mode
    2011-03-18 14:12:19, Info                  CBS    SPI: Starting SP Compatibility\Applicability scan
    2011-03-18 14:12:19, Error                 CBS    SPI: (SPIRegQueryDWORDValue:400)Failed to open the registry root: n/a, key: SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\ServicePack\SP1. er=0x2
    2011-03-18 14:12:19, Error                 CBS    SPI: (SPIRegQueryDWORDValue:400)Failed to open the registry root: n/a, key: SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\ServicePack\SP1. er=0x2
    2011-03-18 14:12:19, Error                 CBS    SPI: (SPIRegQueryDWORDValue:400)Failed to open the registry root: n/a, key: SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\ServicePack\SP1. er=0x2
    2011-03-18 14:12:19, Error                 CBS    SPI: (SPIRegQueryDWORDValue:400)Failed to open the registry root: n/a, key: SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\ServicePack\SP1. er=0x2
    2011-03-18 14:12:19, Info                  CBS    Session: 30139766_2111484221 initialized by client SP Coordinater Engine.
    2011-03-18 14:12:19, Info                  CBS    Failed to open package file: \\?\C:\windows\Servicing\Packages\Microsoft-Windows-InternetExplorer-Optional-Package~31bf3856ad364e35~amd64~~8.0.7600.16385.mum [HRESULT = 0x80070002 - ERROR_FILE_NOT_FOUND]
    2011-03-18 14:12:19, Info                  CBS    Failed to read in xml content [HRESULT = 0x80070002 - ERROR_FILE_NOT_FOUND]
    2011-03-18 14:12:19, Error                 CBS    Failed to parse package manifest: \\?\C:\windows\Servicing\Packages\Microsoft-Windows-InternetExplorer-Optional-Package~31bf3856ad364e35~amd64~~8.0.7600.16385.mum [HRESULT = 0x80070002 - ERROR_FILE_NOT_FOUND]
    2011-03-18 14:12:19, Error                 CBS    Failed to resolve package 'Microsoft-Windows-InternetExplorer-Optional-Package~31bf3856ad364e35~amd64~~8.0.7600.16385' [HRESULT = 0x80070490 - ERROR_NOT_FOUND]
    2011-03-18 14:12:19, Info                  CBS    Failed to resolve package [HRESULT = 0x80070490 - ERROR_NOT_FOUND]
    2011-03-18 14:12:19, Info                  CBS    Failed to populate children. [HRESULT = 0x80070490 - ERROR_NOT_FOUND]
    2011-03-18 14:12:19, Info                  CBS    Failed to initialize internal package [HRESULT = 0x80070490 - ERROR_NOT_FOUND]
    2011-03-18 14:12:19, Info                  CBS    Failed to create package. [HRESULT = 0x80070490 - ERROR_NOT_FOUND]
    2011-03-18 14:12:19, Error                 CBS    Failed to internally open package. [HRESULT = 0x80070490 - ERROR_NOT_FOUND]
    2011-03-18 14:12:19, Error                 CBS    SPI: (CSPICbsClient::EnumPackages:156)Failed to open package hr=0x80070490
    2011-03-18 14:12:19, Error                 CBS    SPI: (CSystem::EnumerateCbsPackages:360)Failed to populate CBS package list hr=0x80070490
    2011-03-18 14:12:19, Info                  CBS    Session: 30139766_2111484221 finalized. Reboot required: no [HRESULT = 0x00000000 - S_OK]
    2011-03-18 14:12:19, Info                  CBS    SPI: Failed enumerating CBS packages
    2011-03-18 14:12:19, Error                 CBS    SPI: (CSPInstall::CompatibilityApplicabilityScan:1482)ATL exception hr=0x80070490
    2011-03-18 14:12:19, Info                  CBS    SPI: Ending Compatibility\Applicability scan
    2011-03-18 14:12:19, Info                  CBS    SPI: DiskFreeSpace for volume \\?\C:\.  Sectors per cluster: 8, Bytes per sector: 512, Free clusters: 110187519
    2011-03-18 14:12:19, Info                  CBS    SPI: Getting CopyFreeSpace for volume: \\?\C:

    2011-03-18 14:12:20, Info                  CBS    SPI: systemVolumeSize (430419 MB 440750076 KB)
    2011-03-18 14:12:20, Info                  CBS    SPI: systemFreeSpace (333284 MB 341283476 KB)
    2011-03-18 14:12:20, Info                  CBS    SPI: copyFreeSpace (329520 MB 337428800 KB)

    Friday, March 18, 2011 2:16 PM

All replies

  • Have you removed the Internet Explorer 8?

    Please start the command prompt (cmd.exe) with admin rights [1] and run sfc [2]:

    sfc.exe /scannow

    Is it able to find and repair/restore broken/missing files (create the txt file shown under [2] and look if all files are restored)?

    Also run the System Update Readiness Tool for Windows7 [3] and check the chechSUR.log if everything was restored.


    best regards
    André

    [1] http://windows.microsoft.com/en-US/windows7/How-do-I-run-an-application-once-with-a-full-administrator-access-token
    [2] http://support.microsoft.com/kb/929833
    [3] http://support.microsoft.com/kb/947821


    "A programmer is just a tool which converts caffeine into code"

    Want to install RSAT on Windows 7 Sp1? Check my HowTo: http://www.msfn.org/board/index.php?showtopic=150221
    Friday, March 18, 2011 2:24 PM
  • I just downloaded IE9 and installed it

    I  run the System Update Readiness Tool and it ask me if I want to install Hotfix for windows(KB947821)

    Friday, March 18, 2011 3:24 PM
  • And I've run sfc.exe /scannow it said Window Resource Protection did not find any integrity violation

    Friday, March 18, 2011 3:38 PM
  • I managed to install SP1 now, but I encountered another problem which is the referenced assembly could not be found

    " ERROR_SXS_ASSEMBLY_MISSING(0x80073701)

    Friday, March 18, 2011 4:30 PM
  • Please run the Windows Explorer and go to the folder "C:\Windows\Logs\CBS\" and copy all files to your document folder, also copy the setupapi.dev.log from the folder C:\Windows\Inf, the "C:\Windows\WindowsUpdate.log" and the file "C:\Windows\winsxs\poqexec.log" to your document folder (otherwise you can't upload it), zip all files into 1 ZIP and upload the zip to your SkyDrive [1] and post a link here.

    André

    [1] http://social.technet.microsoft.com/Forums/en-US/w7itproui/thread/4fc10639-02db-4665-993a-08d865088d65
    "A programmer is just a tool which converts caffeine into code"

    Want to install RSAT on Windows 7 Sp1? Check my HowTo: http://www.msfn.org/board/index.php?showtopic=150221
    Friday, March 18, 2011 9:11 PM
  • 2011-03-19 10:11:30, Info                  CBS    Failed to resolve item[0] in Package: Microsoft-Windows-InternetExplorer-Optional-Package~31bf3856ad364e35~amd64~en-US~8.0.7600.16385, Update: Internet-Explorer-Optional-amd64 [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING]
    2011-03-19 10:11:30, Info                  CBS    Failed to resolve execution update. [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING]
    2011-03-19 10:11:30, Error                 CBS    Failed to resolve execution package: Microsoft-Windows-InternetExplorer-Optional-Package~31bf3856ad364e35~amd64~en-US~8.0.7600.16385 [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING]


    You miss english MUI files for the IE8. Have you tried to delete the IE8?
    "A programmer is just a tool which converts caffeine into code"

    Want to install RSAT on Windows 7 Sp1? Check my HowTo: http://www.msfn.org/board/index.php?showtopic=150221
    Saturday, March 19, 2011 2:32 PM
  • No, as i said before I just installed IE9 to replace IE8
    Saturday, March 19, 2011 4:09 PM
  • Currently I have no real idea why sfc says everything is fine, the setup fails with a missing file and the readiness tool was not able to fix it.

    Run an InPlace Upgrade [1][2] to repair your windows. Your programs are still usable after doing the InPlace upgrade. This repairs all missing/damaged files.

    Now install the Windows 7 Service Pack 1.

    André

    [1] http://support.microsoft.com/kb/2255099
    [2] http://www.sevenforums.com/tutorials/3413-repair-install.html


    "A programmer is just a tool which converts caffeine into code"

    Want to install RSAT on Windows 7 Sp1? Check my HowTo: http://www.msfn.org/board/index.php?showtopic=150221
    Saturday, March 19, 2011 8:19 PM
  • I tried everything to fix my SP1 issue. I will not go into all of the steps that it took to make it function.

    In the end I found a post that suggested using this:


    2. Click: Reset Windows Update Components and run the FixIt? in both default and aggressive modes. http://support.microsoft.com/kb/971058

    This worked and from what I can tell, it will reset missing items like this automatically.

    The original post is available here:

    http://answers.microsoft.com/en-us/windows/forum/windows_7-windows_update/error-8e5e0147-while-installing-windows-7-service/985420be-0d48-e011-90b6-1cc1de79d2e2

    Saturday, March 19, 2011 10:05 PM
  • Did you face the same problem I had?
    Sunday, March 20, 2011 8:16 PM
  • I can't run InPlace Upgrade

     

    [url]http://www.sendspace.com/file/pz1wlj[/url]

    Sunday, March 27, 2011 11:16 PM
  • Which Windows Edtion have you installed? Have you used AnyTime upgrade to upgrade from Home Premium to Ultimate ?
    "A programmer is just a tool which converts caffeine into code"

    Want to install RSAT on Windows 7 Sp1? Check my HowTo: http://www.msfn.org/board/index.php?showtopic=150221
    Monday, March 28, 2011 2:13 PM
  • 1. I think I am using Window 7 Home Premium

    2.No

    Monday, March 28, 2011 6:03 PM
  • The ERROR_SXS_ASSEMBLY_MISSING(0x80073701) means its missing an associated .manifest from C:\Windows\winsxs\manifest and folder (there won't always be a needed folder) from the C:\Windows\winsxs ... Copy those from another machine then run the system readiness tool.

    From your log:

    2011-03-19 10:11:29, Info                  CBS    Exec: Resolving Package: Microsoft-Windows-InternetExplorer-Optional-Package~31bf3856ad364e35~amd64~en-US~8.0.7600.16385, Update: Internet-Explorer-Optional-amd64, PinDeployment: amd64_microsoft-windows-i..oyment-languagepack_31bf3856ad364e35_8.0.7600.16385_en-us_ed66154d5f1d25e1

    The name in bold is the folder or manifest file that's looking for. There may be a alot of manifest/folders missing (too many to count) from the winsxs folder so fixing one may not fix the whole thing. And adding those files doesn't mean the problem is fixed yet.  If the readiness tool doesn't fix everything at that point, you may need some missing registry keys in the HKLM\COMPONENTS and rerun the tool afterwards.

    I was able to fix this per the instructions I put together in this thread. http://social.technet.microsoft.com/Forums/en/w7itproinstall/thread/742c11df-2af9-4b1d-aed0-2ee1fb9cb5e5

    Monday, March 28, 2011 6:57 PM
  • Just wanted to post this as this thread is coming up as a big hit on Google for this issue.

    The blog post Danma links above is poor attempt at explaining the solution I posted here:

    http://social.technet.microsoft.com/Forums/en-US/w7itproinstall/thread/bfb3e5b5-a3bd-4124-b4d6-7fb437ac7b74

    This has seemed to work for many people, so I recommend you take a look at that thread.

    Good luck!

    • Proposed as answer by Uguess977 Tuesday, March 13, 2012 8:16 AM
    Tuesday, December 27, 2011 9:36 PM